Dell コンピュータのアップグレード後に、ライセンス確認の問題を示す "エラー コード: 0x80070002" というエラー メッセージが表示される

文書翻訳 文書翻訳
文書番号: 310794 - 対象製品
重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、レジストリの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986 Microsoft Windows レジストリの説明
すべて展開する | すべて折りたたむ

目次

現象

Microsoft Windows XP の起動時に、次のエラー メッセージが表示されることがあります。
問題が発生したため、このコンピュータのライセンスを正しく確認することができません。エラー コード: 0x80070002。

原因

この問題は、以下の状況のいずれかに該当する場合に発生することがあります。
  • Microsoft Windows XP のデフォルトのセキュリティ プロバイダが変更されている場合
  • システム ドライブのドライブ文字が変更されている場合
セキュリティ プロバイダの問題は、Dell Assistant ソフトウェアがインストールされている Dell コンピュータで報告されています。

: この問題は、デフォルト セキュリティ プロバイダを変更するソフトウェアが原因で発生する可能性があります。この問題は、Dell コンピュータや Dell Assistant ソフトウェアに限定されるわけではありません。

回避策

警告 : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリ エディタの誤用により発生した問題に関しては、一切責任を負わないものとします。レジストリ エディタは、自己の責任においてご使用ください。

この問題を回避するには、以下のうち該当する方法を実行します。

Microsoft Windows XP のデフォルト セキュリティ プロバイダをリセットする

Windows XP のデフォルト セキュリティ プロバイダをリセットするには、Windows レジストリ内の関連するレジストリ キーを削除します。この操作を行うには、以下の手順を実行します。
  1. コンピュータを起動します。起動中に F8 キーを押し、セーフ モードでコンピュータを起動します。
  2. レジストリ エディタ (Regedt32.exe) を起動します。
  3. Windows レジストリの以下のレジストリ キーを削除します。
    HKEY_USERS\.DEFAULT\Software\Microsoft\Cryptography\Providers
    HKEY_USERS\S-1-5-20\Software\Microsoft\Cryptography\Providers
  4. レジストリ エディタを終了します。
  5. コンピュータを再起動します。

システム ドライブのドライブ文字をリセットする

レジストリ エディタを使用して、システム ドライブのドライブ文字を元の値に戻します。以下のレジストリ キーを編集して、システム ドライブの値を変更します。
HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices
関連情報およびシステム ドライブのドライブ文字を変更するための詳細な手順を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
223188 Windows のシステム ドライブまたはブート ドライブのドライブ文字の復元方法

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

詳細

この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。明示または黙示にかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

プロパティ

文書番号: 310794 - 最終更新日: 2007年12月1日 - リビジョン: 3.2
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional x64 Edition
キーワード:?
kberrmsg kbnofix kbregistry kbenv kbprb kb3rdparty KB310794
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com