Τρόπος επίλυσης ζητημάτων που αφορούν τη χρήση των αναφορών σε βάση δεδομένων της Access

Μεταφράσεις άρθρων Μεταφράσεις άρθρων
Αναγν. άρθρου: 310803 - Δείτε τα προϊόντα στα οποία αναφέρεται το συγκεκριμένο άρθρο.
Ανάπτυξη όλων | Σύμπτυξη όλων

Σε αυτήν τη σελίδα

Περίληψη

Το άρθρο αυτό περιγράφει ζητήματα που αφορούν τη χρήση των αναφορών σε μια βάση δεδομένων της Access.

Η κατανόηση των σφαλμάτων που αφορούν τις αναφορές προϋποθέτει την κατανόηση τόσο του τρόπου με τον οποίο γίνονται οι αναφορές σε βιβλιοθήκες σε μια βάση δεδομένων της Access όσο και των απαιτήσεων, για να γίνει η εγκατάσταση μιας βάσης δεδομένων σε έναν υπολογιστή προορισμού χωρίς να παραβιαστούν αυτές οι αναφορές. Αυτό το άρθρο συνοψίζει τα ακόλουθα θέματα:
  • Προβολή των αναφορών μιας βάσης δεδομένων της Access
  • Επίλυση ζητημάτων που αφορούν αναφορές της Microsoft Visual Basic for Applications (VBA) στην Access
  • Κατανόηση μηνυμάτων σφάλματος αναφοράς
  • Επίλυση ζητημάτων που αφορούν τη χρήση αναφορών στον υπολογιστή ανάπτυξης
  • Κατανομή αρχείων βάσης δεδομένων
  • Ενημέρωση της λίστας αναφορών
  • Κατανομή αρχείων βάσης δεδομένων που έχουν στοιχεία ελέγχου ActiveX
  • Επανακαταχώρηση αρχείου

Περισσότερες πληροφορίες

Προβολή των αναφορών μιας βάσης δεδομένων της Access

Για να προβάλετε τις τρέχουσες αναφορές μιας βάσης δεδομένων:
  1. Ανοίξτε τη βάση δεδομένων.
  2. Πιέστε το συνδυασμό πλήκτρων ALT+F11, για να ξεκινήσει η Επεξεργασία Visual Basic (Visual Basic Editor).
  3. Από το μενού Εργαλεία (Tools), κάντε κλικ στην εντολή Αναφορές (References).

Επίλυση ζητημάτων που αφορούν αναφορές της Visual Basic στην Access

Η Access φορτώνει το σχετικό αρχείο (για παράδειγμα, μια βιβλιοθήκη τύπων, μια βιβλιοθήκη αντικειμένων ή μια βιβλιοθήκη στοιχείων ελέγχου) για κάθε αναφορά, σύμφωνα με τις πληροφορίες που εμφανίζονται στο πλαίσιο Αναφορές (References). Εάν η Access δεν μπορεί να βρει το αρχείο, εκτελεί τις ακόλουθες διαδικασίες για τον εντοπισμό του αρχείου:
  1. Η Access ελέγχει μήπως το αρχείο που αναφέρεται φορτώνεται εκείνη τη στιγμή στη μνήμη.
  2. Εάν το αρχείο δεν φορτώνεται στη μνήμη, η Access προσπαθεί να επιβεβαιώσει την ύπαρξη του κλειδιού μητρώου RefLibPaths. Εάν υπάρχει το κλειδί, η Access αναζητά μια επώνυμη τιμή που έχει το ίδιο όνομα με την αναφορά. Εάν βρεθεί μια τέτοια τιμή, η Access φορτώνει την αναφορά από τη διαδρομή προς την οποία οδηγεί η επώνυμη τιμή.
  3. Στη συνέχεια, η Access αναζητά το αρχείο στο οποίο γίνεται αναφορά στις ακόλουθες θέσεις και με την εξής σειρά:
    • Στο φάκελο "Εφαρμογές" (Application) (η θέση του αρχείου Msaccess.exe).
    • Στον τρέχοντα φάκελο που εμφανίζεται κάνοντας κλικ στην εντολή Άνοιγμα (Open) από το μενού Αρχείο (File).
    • Στα Windows ή στο φάκελο Winnt, όπου εκτελούνται τα αρχεία του λειτουργικού συστήματος.
    • Στο φάκελο "Σύστημα" (System) κάτω από το φάκελο των Windows ή το φάκελο Winnt.
    • Στους φακέλους της μεταβλητής περιβάλλοντος PATH, στους οποίους υπάρχει δυνατότητα άμεσης πρόσβασης από το λειτουργικό σύστημα.
  4. Εάν δεν είναι δυνατή εύρεση του αρχείου από την Access, προκύπτει σφάλμα αναφοράς.Για περισσότερες πληροφορίες σχετικά με τον τρόπο που χρησιμοποιεί η Access για την επίλυση ζητημάτων που αφορούν αναφορές της Visual Basic, κάντε κλικ στον αριθμό του άρθρου παρακάτω, για να προβάλετε το άρθρο της Γνωσιακής Βάσης της Microsoft (Knowledge Base):
    248941 ACC2000: Τρόπος με τον οποίο η Access 2000 επιλύει ζητήματα που αφορούν στη χρήση αναφορών της Visual Basic for Applications (VBA)

Κατανόηση μηνυμάτων λάθους αναφοράς

Υπάρχουν πολλά μηνύματα λάθους που σχετίζονται με ένα αρχείο που λείπει ή με ένα αρχείο που έχει διαφορετική έκδοση από την έκδοση που χρησιμοποιείται στη βάση δεδομένων. Στις περισσότερες περιπτώσεις, μπορείτε να ψάξετε στη Γνωσιακή Βάση της Microsoft (Knowledge Base) για κάποιο αρχείο σχετικά με το συγκεκριμένο μήνυμα λάθους και, στη συνέχεια, να επιλύσετε το ζήτημα ακολουθώντας τα βήματα που αναφέρονται στο άρθρο. Σε ορισμένες περιπτώσεις, ένα αρχείο εξάρτησης δεν ταιριάζει ακριβώς με το αρχικό αρχείο.

Η παρακάτω λίστα περιγράφει ορισμένα από τα μηνύματα λάθους αναφοράς που ενδέχεται να εμφανιστούν. Ωστόσο, σημειώστε ότι η λίστα δεν περιλαμβάνει όλα τα πιθανά μηνύματα λάθους αναφοράς.
  • "Η μέθοδος Όνομα_μεθόδου του αντικειμένου Όνομα_αντικειμένου απέτυχε" (Method MethodName of Object ObjectName Failed)

    Συνήθως, αυτό το μήνυμα λάθους μπορεί να εμφανιστεί, εάν έχει προκύψει κάποιο ζήτημα με μια βιβλιοθήκη τύπων προγραμματισμού, για παράδειγμα, ένα μη έγκυρο αρχείο βιβλιοθήκης δυναμικής σύνδεσης (dynamic-link library - DLL) ενός αντικειμένου πρόσβασης δεδομένων (Data Access Object - DAO). Μπορείτε να αναζητήσετε στη Γνωσιακή Βάση της Microsoft (Knowledge Base) άρθρα που περιγράφουν τις διάφορες μορφές αυτού του μηνύματος λάθους.
  • "Η συνάρτηση δεν είναι διαθέσιμη στην έκφραση Χρήσης ". (Function is not available in Usage expression)

    Το μήνυμα αυτό μπορεί να εμφανιστεί εάν έχει προκύψει κάποιο ζήτημα με μια βιβλιοθήκη τύπων προγραμματισμού ή εάν ο κώδικας δεν καλεί τη σωστή βιβλιοθήκη και το αρχείο έχει χαμηλότερη προτεραιότητα στη λίστα αναφορών από ένα αρχείο που περιέχει το ίδιο όνομα συνάρτησης --για παράδειγμα, εάν ο κώδικας DAO χρησιμοποιείται με τη βιβλιοθήκη αντικειμένων ActiveX Data Object (ADO) έχει υψηλότερη προτεραιότητα από τη βιβλιοθήκη αντικειμένων DAO. Αυτό το μήνυμα σφάλματος μπορεί, επίσης, να εμφανιστεί εάν μια φόρμα ή μια αναφορά περιέχει ένα στοιχείο ελέγχου ActiveX.
  • "Δεν είναι δυνατό να βρεθεί το έργο ή η βιβλιοθήκη" (Can't find project or library)

    Ενδέχεται να εμφανιστεί αυτό το μήνυμα λάθους εάν η Access δεν είναι δυνατό να εντοπίσει ένα αρχείο στη λίστα αναφορών. Συχνά, το αρχείο φέρει την επισήμανση Missing στο παράθυρο διαλόγου Αναφορές (References). Μερικές φορές, το αρχείο υπάρχει στον υπολογιστή ανάπτυξης αλλά όχι στον υπολογιστή προορισμού. Για πρόσθετες πληροφορίες σχετικά με αυτό το σφάλμα, κάντε κλικ στον αριθμό του άρθρου παρακάτω, για να προβάλετε το άρθρο στη Γνωσιακή Βάση της Microsoft (Knowledge Base):
    208218 ACC2000: Οι συναρτήσεις VBA διακόπτουν τη βάση δεδομένων με αναφορές που λείπουν
  • "Δεν έχει οριστεί μεταβλητή" (Variable not defined) ή "Δεν έχει οριστεί τύπος ορισμένος από το χρήστη" (User-defined type not defined)

    Ενδέχεται να εμφανιστεί ένα από αυτά τα μηνύματα λάθους εάν χρησιμοποιείτε τον "Οδηγό ασφαλείας σε επίπεδο χρήστη" (User-Level Security Wizard), για να ασφαλίσετε μια βάση δεδομένων με αναφορές σε βιβλιοθήκες διαφορετικές από τις βιβλιοθήκες προεπιλογής. Για παράδειγμα, αναφορές σε βιβλιοθήκες που υπήρχαν στη βάση δεδομένων χωρίς ασφάλεια δεν δημιουργούνται αυτόματα στη νέα, ασφαλή βάση δεδομένων.
  • "Σφάλμα χρόνου εκτέλεσης 5" (Run-time error 5), "Μη έγκυρη κλήση διαδικασίας ή όρισμα" (Invalid procedure call or argument), "Η βιβλιοθήκη που περιέχει αυτό το σύμβολο δεν αναφέρεται από το τρέχον έργο" (The library which contains this symbol is not referenced by the current project) ή "Η βιβλιοθήκη που περιέχει αυτό το σύμβολο δεν αναφέρεται από το τρέχον έργο, με αποτέλεσμα το σύμβολο να είναι απροσδιόριστο" (The library which contains this symbol is not referenced by the current project, so the symbol is undefined)

    Ενδέχεται να εμφανιστεί ένα από τα παραπάνω μηνύματα λάθους, εάν υπάρχει αναφορά σε μια βάση δεδομένων, μια βιβλιοθήκη τύπων ή μια βιβλιοθήκη αντικειμένων που φέρει τη σήμανση Missing. Για περισσότερες πληροφορίες, κάντε κλικ στον αριθμό του άρθρου παρακάτω, για να προβάλετε το άρθρο της Γνωσιακής Βάσης της Microsoft (Knowledge Base):
    231413 ACC2000: Μηνύματα λάθους τα οποία υποδεικνύουν μια αναφορά που λείπει
  • "Δεν είναι δυνατή η δημιουργία αντικειμένου από το στοιχείο ActiveX" (ActiveX component can't create object)

    Αυτό το μήνυμα λάθους δεν σημαίνει απαραιτήτως ότι ενέχεται κάποιο στοιχείο ελέγχου ActiveX. Για παράδειγμα, μια πιθανή αιτία είναι ότι το αντικείμενο DAO, το οποίο είναι ένα στοιχείο ActiveX, δεν μπορεί να δημιουργήσει ένα αντικείμενο, επειδή δεν είναι δυνατή η εκκίνηση του διακομιστή αυτοματοποίησης DAO. Συχνά, η αιτία είναι ότι τα αρχεία DLL που παρέχουν λειτουργικότητα αναφοράς για το πρόγραμμα δεν είναι καταχωρημένα ή δεν είναι καταχωρημένα σωστά.Για πρόσθετες πληροφορίες σχετικά με αυτό το σφάλμα, κάντε κλικ στον αριθμό του άρθρου παρακάτω, για να προβάλετε το άρθρο στη Γνωσιακή Βάση της Microsoft (Knowledge Base):
    244264 ΠΛΗΡΟΦΟΡΙΕΣ: Αντιμετώπιση προβλημάτων σφάλματος 429 κατά την αυτοματοποίηση εφαρμογών του Office
    Αν και αυτό το άρθρο είναι γραμμένο από την οπτική γωνία της Visual Basic, καλύπτει πολλές από τις αιτίες αυτού του σφάλματος.

Επίλυση ζητημάτων που αφορούν τη χρήση αναφορών στον υπολογιστή ανάπτυξης

Η δημιουργία μιας νέας, κενής βάσης δεδομένων και, στη συνέχεια, η εισαγωγή αντικειμένων από ένα αρχείο μιας άλλης βάσης δεδομένων μπορεί να έχουν ως αποτέλεσμα να προκύψουν ζητήματα που αφορούν τη χρήση αναφορών, εάν ο κώδικας ή τα στοιχεία ελέγχου ActiveX βασίζονται σε αναφορές που δεν συμπεριλαμβάνονται σε μια βάση δεδομένων από προεπιλογή. Οι προεπιλεγμένες αναφορές για μια βάση δεδομένων της Access 2000 είναι:
  • Visual Basic for Applications
  • Βιβλιοθήκη αντικειμένων της Microsoft Access 9.0
  • Αυτοματοποίηση OLE
  • Βιβλιοθήκη Microsoft ActiveX Data Objects (ADO) 2.1
Εάν η πηγή είναι μια άλλη βάση δεδομένων της Access 2000, βεβαιωθείτε ότι ταιριάζουν οι αναφορές. Εάν η πηγή είναι μια παλαιότερη έκδοση της Access, τότε ενδέχεται να χρησιμοποιείται η έκδοση DAO 3.5 ή παλαιότερη. Ωστόσο, η Access 2000 δεν παρέχει την έκδοση DAO 3.5 από προεπιλογή. Προσπαθήστε να καταργήσετε την αναφορά στη βιβλιοθήκη αντικειμένων ADO 2.1 (εάν υπάρχει) και να προσθέσετε την αναφορά στη βιβλιοθήκη αντικειμένων DAO 3.6.

Εάν μετατρέψατε τη βάση δεδομένων από μια παλαιότερη έκδοση της Access και η βάση δεδομένων περιέχει μια αναφορά στο αρχείο Utility.mda, στις περισσότερες περιπτώσεις μπορείτε να καταργήσετε αυτήν την αναφορά, επειδή οι λειτουργίες που καλεί αυτή η αναφορά συμπεριλαμβάνονται στις αναφορές προεπιλογής στην Access 2000. Εάν υπάρχουν αναφορές σε παλαιότερες εκδόσεις DAO, μπορείτε να καταργήσετε και αυτές τις αναφορές, επειδή η έκδοση DAO 3.6 μπορεί να αντιμετωπίσει αυτές τις λειτουργίες.

Για να προσθέσετε μια αναφορά σε μια βιβλιοθήκη:
  1. Ανοίξτε τη βάση δεδομένων.
  2. Πιέστε το συνδυασμό πλήκτρων ALT+F11, για να ξεκινήσει η Επεξεργασία Visual Basic (Visual Basic Editor).
  3. Από το μενού Tools, κάντε κλικ στην εντολή References.
  4. Στην περιοχή Available References, κάντε κλικ για να επιλέξετε το πλαίσιο ελέγχου που βρίσκεται δίπλα στο όνομα της βιβλιοθήκης και, στη συνέχεια, κάντε κλικ στο κουμπί OK.
Για να καταργήσετε μια αναφορά από μια βιβλιοθήκη:
  1. Ανοίξτε τη βάση δεδομένων.
  2. Πιέστε το συνδυασμό πλήκτρων ALT+F11, για να ξεκινήσει η Επεξεργασία Visual Basic (Visual Basic Editor).
  3. Από το μενού Tools, κάντε κλικ στην εντολή References.
  4. Στην περιοχή Available References, κάντε κλικ για να καταργήσετε την επιλογή του πλαισίου ελέγχου που βρίσκεται δίπλα στο όνομα της βιβλιοθήκης και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

Κατανομή αρχείων βάσης δεδομένων

Υπάρχουν δύο βασικές μέθοδοι κατανομής των αρχείων μιας βάσης δεδομένων. Μπορείτε να αντιγράψετε το αρχείο από τον υπολογιστή ανάπτυξης στον υπολογιστή προορισμού ή να χρησιμοποιήσετε τον οδηγό Package and Deployment Wizard, για να δημιουργήσετε ένα πακέτο εγκατάστασης.

Εάν αντιγράψετε το αρχείο από τον υπολογιστή ανάπτυξης στον υπολογιστή προορισμού, αντιγράφεται μόνο το αρχείο της βάσης δεδομένων. Πρέπει να βεβαιωθείτε με μη αυτόματο τρόπο ότι τα αρχεία που παρατίθενται στη λίστα αναφορών είναι διαθέσιμα, στη σωστή έκδοση και στην ίδια σχετική θέση τόσο στον υπολογιστή προορισμού όσο και στον υπολογιστή ανάπτυξης.

Εάν χρησιμοποιήσετε τον οδηγό Package and Deployment Wizard, για να δημιουργήσετε ένα πακέτο εγκατάστασης, ανατρέξτε στο άρθρο της Γνωσιακής Βάσης (Knowledge Base) που χρησιμοποιείται ως λίστα ελέγχου για την ανάπτυξη εφαρμογών χρόνου εκτέλεσης στην Access. Για περισσότερες πληροφορίες σχετικά με τη λίστα ελέγχου, κάντε κλικ στον αριθμό του άρθρου παρακάτω, για να προβάλετε το άρθρο στη Γνωσιακή Βάση της Microsoft (Knowledge Base):
247530 MOD2000: Τρόπος αποφυγής συνηθισμένων λαθών κατά τη δημιουργία εφαρμογών χρόνου εκτέλεσης με δυνατότητα διανομής
Όταν αναπτύσσετε εφαρμογές χρόνου εκτέλεσης στην Access, έχετε υπόψη σας ότι ορισμένα αρχεία λειτουργικών συστημάτων πρέπει να διανέμονται μαζί με την εφαρμογή χρόνου εκτέλεσης. Η συσκευασία αυτών των αρχείων πραγματοποιείται αυτόματα από το στοιχείο του οδηγού Package and Deployment Wizard του Microsoft Office 2000 Developer. Μερικές φορές, οι εκδόσεις των αρχείων που συμπεριλαμβάνονται εξαρτώνται από άλλες εφαρμογές που είναι εγκατεστημένες στον υπολογιστή ανάπτυξης και ενδέχεται να έχουν τροποποιήσει τα αρχεία του λειτουργικού συστήματος.

Η εφαρμογή ορισμένων οδηγιών εξασφαλίζει συνήθως ότι οι εκδόσεις των αρχείων που χρησιμοποιείτε δεν θα έρθουν σε διένεξη με αρχεία του υπολογιστή προορισμού, όταν εγκαταστήσετε την εφαρμογή χρόνου εκτέλεσης. Οι οδηγίες είναι ακόλουθες:
  1. Αναπτύξτε τη βάση δεδομένων Access σε οποιονδήποτε υπολογιστή.
  2. Δημιουργήστε ένα περιβάλλον υπολογιστή στο οποίο να έχει γίνει νέα διαμόρφωση του σκληρού δίσκου και να έχει εγκατασταθεί μόνο η παλαιότερη έκδοση του λειτουργικού συστήματος του Office και του Office 2000 Developer. Εκτελέστε τον οδηγό Package and Deployment Wizard σε αυτόν τον υπολογιστή, για να δημιουργήσετε μια έκδοση χρόνου εκτέλεσης της εφαρμογής. Με αυτόν τον τρόπο εξασφαλίζεται ότι τα επίπεδα αναθεώρησης των αρχείων θα λειτουργούν σε οποιονδήποτε υπολογιστή προορισμού.
  3. Δημιουργήστε ένα περιβάλλον υπολογιστή στο οποίο να έχει γίνει νέα διαμόρφωση του σκληρού δίσκου και να έχει εγκατασταθεί μόνο το λειτουργικό σύστημα. Δοκιμάστε την εφαρμογή χρόνου εκτέλεσης σε αυτό το περιβάλλον.
    • Εάν η εφαρμογή δεν εκτελείται με επιτυχία, ξέρετε ότι κάτι δεν πάει καλά με την εφαρμογή. Πρέπει να εντοπίσετε και να επιλύσετε το ζήτημα πριν να διανείμετε την εφαρμογή.
    • Εάν η εφαρμογή λειτουργεί με επιτυχία στον δοκιμαστικό υπολογιστή, αλλά δεν λειτουργεί στον υπολογιστή προορισμού, τότε κάτι συμβαίνει με τον υπολογιστή προορισμού και όχι την εφαρμογή. Πρέπει να εντοπίσετε και να αντιμετωπίσετε την πιθανή αιτία στον υπολογιστή προορισμού, πιθανότατα κάποια ασυμβατότητα ή ένα κατεστραμμένο αρχείο.

Ανανέωση της λίστας αναφορών

Εάν το σχετικό με την αναφορά ζήτημα αφορά κάποιο στοιχείο ελέγχου ActiveX, μπορείτε σε κάποιες περιπτώσεις να επιλύσετε το ζήτημα ανανεώνοντας τη λίστα αναφορών. Για να ανανεώσετε τη λίστα αναφορών:
  1. Στην Επεξεργασία Visual Basic (Visual Basic Editor), κάντε κλικ στην εντολή References από το μενού Tools.
  2. Στο παράθυρο διαλόγου References, κάντε κλικ για να επιλέξετε μια αναφορά που δεν έχει ήδη επιλεγεί, σημειώστε την αναφορά που επιλέξατε και, στη συνέχεια, κάντε κλικ στο κουμπί OK.
  3. Από το μενού Tools, κάντε ξανά κλικ στην εντολή References.
  4. Κάντε κλικ για να καταργήσετε την επιλογή της αναφοράς και, στη συνέχεια, κάντε κλικ στο κουμπί OK.

Κατανομή αρχείων βάσης δεδομένων που έχουν στοιχεία ελέγχου ActiveX

Υπάρχουν δύο τύποι αδειών για στοιχεία ελέγχου ActiveX: μια άδεια χρόνου σχεδίασης και μια άδεια χρόνου εκτέλεσης.
  • Μια άδεια χρόνου σχεδίασης σας επιτρέπει να εισάγετε στοιχεία ελέγχου ActiveX με άδεια χρήσης από τον Office 2000 Developer σε φόρμες και αναφορές σε μια βάση δεδομένων της Access.
  • Μια άδεια χρόνου σχεδίασης σας επιτρέπει να χρησιμοποιείτε στοιχεία ελέγχου ActiveX σε μια βάση δεδομένων της Access σε έναν υπολογιστή που δεν έχει εγκατεστημένο τον Office 2000 Developer, αλλά μια άδεια χρόνου εκτέλεσης δεν σας επιτρέπει να εισάγετε νέα στοιχεία ελέγχου ActiveX με άδεια. Για να εγκαταστήσετε μια άδεια χρόνου εκτέλεσης, διανείμετε τα στοιχεία ελέγχου ActiveX χρησιμοποιώντας τον οδηγό Package and Deployment Wizard, ο οποίος εγγράφει την άδεια από τα στοιχεία ελέγχου στο μητρώο του υπολογιστή προορισμού.
Μια επισήμανση Missing, την οποία ενδέχεται να δείτε αφού ανοίξετε μια λειτουργική μονάδα στην προβολή σχεδίασης και, στη συνέχεια, κάνετε κλικ στην εντολή References από το μενού Tools, δηλώνει ότι η αναφορά στο στοιχείο ελέγχου Κοινό παράθυρο διαλόγου (Common Dialog) στον υπολογιστή προορισμού δεν ταιριάζει με την πηγή στο αρχείο της βάσης δεδομένων από τον υπολογιστή ανάπτυξης.

Εάν διανείμετε ένα αρχείο βάσης δεδομένων χωρίς να εγκαταστήσετε το στοιχείο ελέγχου "Κοινό παράθυρο διαλόγου" (Common Dialog) με δυνατότητα διανομής, η αναφορά του στοιχείου ελέγχου ενδέχεται να φέρει την επισήμανση Missing ή ενδέχεται να εμφανιστεί το μήνυμα λάθους "Δεν έχετε την άδεια που απαιτείται για να χρησιμοποιήσετε αυτό το στοιχείο ελέγχου ActiveX" (You don't have the license required to use this ActiveX control), εάν το στοιχείο ελέγχου που δεν έχει δυνατότητα διανομής έχει ήδη εγκατασταθεί στον υπολογιστή προορισμού.

Ακόμη και όταν το αρχείο βάσης δεδομένων αποτελεί μέρος μιας εφαρμογής χρόνου εκτέλεσης, ενδέχεται να εμφανιστεί το μήνυμα λάθους "Δεν έχετε την άδεια που απαιτείται για να χρησιμοποιήσετε αυτό το στοιχείο ελέγχου ActiveX" (You don't have the license required to use this ActiveX control), εάν το στοιχείο ελέγχου χωρίς δυνατότητα διανομής που έχει ήδη εγκατασταθεί στον υπολογιστή προορισμού είναι παλαιότερης έκδοσης από το στοιχείο ελέγχου που παρέχεται από την εφαρμογή χρόνου εκτέλεσης. Η συμπεριφορά αυτή ενδέχεται να εμφανίζεται επειδή το πρόγραμμα εγκατάστασης δεν αντικαθιστά νεότερες εκδόσεις ενός αρχείου με μια παλαιότερη έκδοση του ίδιου αρχείου.

Επανακαταχώρηση αρχείου

Είναι δυνατό ένα αρχείο να είναι στη λίστα αναφορών χωρίς να είναι σωστά καταχωρημένο στο μητρώο. Εάν υποψιάζεστε ότι μπορεί να συμβαίνει κάτι τέτοιο, ακολουθήστε αυτά τα βήματα για να επανακαταχωρήσετε το αρχείο:
  1. Στο Microsoft Windows NT 4.0, κάντε κλικ στο κουμπί Start, τοποθετήστε το δείκτη του ποντικιού στην επιλογή Find και, στη συνέχεια, κάντε κλικ στην επιλογή Files or Folders ή, στα Windows 2000, κάντε κλικ στο κουμπί Έναρξη (Start), τοποθετήστε το δείκτη του ποντικιού στην επιλογή Αναζήτηση (Search) και, στη συνέχεια, κάντε κλικ Για αρχεία ή φακέλους (For Files and Folders).
  2. Στο πλαίσιο Με όνομα (Named) ή στο πλαίσιο Αναζήτηση αρχείων και φακέλων με το όνομα (Search for files and folders named), πληκτρολογήστε regsvr32.exe.
  3. Στο πλαίσιο Διερεύνηση σε (Look in), κάντε κλικ στη ρίζα του σκληρού δίσκου (συνήθως είναι ο C:).
  4. Κάντε κλικ για να επιλέξετε το πλαίσιο ελέγχου Να συμπεριληφθούν οι υποφάκελοι (Include Subfolders), εάν δεν είναι ήδη επιλεγμένο και, κατόπιν, κάντε κλικ στο κουμπί Εύρεση τώρα (Find Now) ή Αναζήτηση τώρα (Search Now).
  5. Αφού εντοπίσετε το αρχείο, κάντε κλικ στο κουμπί Έναρξη (Start), κάντε κλικ στην επιλογή Εκτέλεση (Run) και, στη συνέχεια, διαγράψτε οτιδήποτε υπάρχει στο πλαίσιο Άνοιγμα (Open).
  6. Σύρετε το αρχείο Regsvr32.exe από το τμήμα παράθυρου των αποτελεσμάτων αναζήτησης στο πλαίσιο Άνοιγμα (Open).
  7. Επαναλάβετε τα βήματα 2 έως 6, αναζητώντας αυτήν τη φορά το αρχείο Όνομα_αρχείου.dll, όπου Όνομα_αρχείου είναι το όνομα του αρχείου που θέλετε να επανακαταχωρήσετε.
  8. Αφού το αρχείο Όνομα_αρχείου.dll τοποθετηθεί στο πλαίσιο Άνοιγμα (Open) με το αρχείο Regsvr32.exe, κάντε κλικ στο κουμπί OK.
  9. Στην Access, ελέγξτε για να διαπιστώσετε εάν επιλύθηκε το ζήτημα.
Εάν δεν έχετε το αρχείο Regsvr32.exe στον υπολογιστή σας, αναζητήστε το σε άλλους υπολογιστές. Εάν το αρχείο δεν είναι διαθέσιμο, μπορείτε να το αποκτήσετε από την τοποθεσία της Microsoft στο Web. Για περισσότερες πληροφορίες, κάντε κλικ στον αριθμό του άρθρου παρακάτω, για να προβάλετε το άρθρο της Γνωσιακής Βάσης της Microsoft (Knowledge Base):
161983 ACC: Το αρχείο Regsvr32a.exe είναι διαθέσιμο από το Κέντρο λήψης
ΣΗΜΕΙΩΣΗ: Θυμηθείτε να μεταγλωττίσετε όλες τις λειτουργικές μονάδες αφού προσαρμόσετε τις αναφορές. Για να μεταγλωττίσετε όλες τις λειτουργικές μονάδες, έχοντας ανοιχτή τη λειτουργική μονάδα, κάντε κλικ στη βάση δεδομένων Μεταγλώττιση (Compile) από το μενού Εντοπισμός σφαλμάτων (Debug). Εάν οι λειτουργικές μονάδες δεν μεταγλωττίζονται, ενδέχεται να υπάρχουν και άλλες ανεπίλυτες αναφορές.

Ιδιότητες

Αναγν. άρθρου: 310803 - Τελευταία αναθεώρηση: Παρασκευή, 18 Νοεμβρίου 2005 - Αναθεώρηση: 2.1
Οι πληροφορίες σε αυτό το άρθρο ισχύουν για:
  • Microsoft Access 2000 Standard Edition
Λέξεις-κλειδιά: 
kbhowto kbenv kbinfo kbinterop kbprogramming KB310803

Αποστολή σχολίων

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com