Poor Performance with File and Print Services for NetWare

Article translations Article translations
Article ID: 311243 - View products that this article applies to.
This article was previously published under Q311243
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

SYMPTOMS

The performance of File and Print Services for NetWare (FPNW) may be impaired if certain client operations are not processed correctly. For example, when you copy files from a client computer that is running Microsoft Windows 95, Microsoft Windows 98, or Microsoft Windows Millennium Edition (Me) to an FPNW server by using the Novell client, each file may take over a second to be copied, and the time and date on the file may not be set to the time and date of the original file. Delays may also occur when you create drive mappings.

CAUSE

This issue occurs because FPNW does not process GetNSLoadedListFromVolNumber and "NCP Set File Date Time" instructions because of a structure size mismatch. The client resends the instruction after approximately one second, but FPNW considers the resent instruction to be a duplicate and returns "success" without processing it.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack
The English version of this fix should have the following file attributes or later:
   Date         Time   Version        Size     File name
   -------------------------------------------------------
   13-Nov-2001  13:03  5.0.2195.4625  213,648  Fpnwsrv.sys
				

WORKAROUND

To work around this problem, use Microsoft Client Service for Netware Networks, if you are running Windows 2000 Professional. If you are running Windows 2000 Server, or Windows 2000 Advanced Server, use Gateway (and Client) Services for Netware.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 3 (SP3).

MORE INFORMATION

For additional information about how to install multiple hotfixes with only one reboot, click the article number below to view the article in the Microsoft Knowledge Base:
296861 Use QChain.exe to Install Multiple Hotfixes with One Reboot
For additional information about how to install Windows 2000 and Windows 2000 hotfixes at the same time, click the article number below to view the article in the Microsoft Knowledge Base:
249149 Installing Microsoft Windows 2000 and Windows 2000 Hotfixes

Properties

Article ID: 311243 - Last Review: October 24, 2013 - Revision: 2.2
APPLIES TO
  • Microsoft Windows 2000 Service Pack 1
  • Microsoft Windows 2000 Service Pack 2
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbnosurvey kbarchive kbbug kbfix kbwin2000presp3fix kbqfe kbsysadmin kbwin2000sp3fix kbdirservices kbwinxpsp1fix kbhotfixserver KB311243

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com