Impossible d'afficher les fichiers d'un disque après le remplacement d'un lecteur de CD-R ou de CR-RW par un lecteur de DVD ou de CD-ROM

Traductions disponibles Traductions disponibles
Numéro d'article: 311455 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F311455
Agrandir tout | Réduire tout

Symptômes

Sur un ordinateur (comme un ordinateur portable) qui autorise le remplacement du lecteur de CD-R ou de CD-RW par un lecteur de DVD ou de CD-ROM, vous risquez de ne pas pouvoir accéder aux fichiers du disque inséré dans le nouveau lecteur, si vous remplacez le lecteur de CD-R ou de CD-RW par un lecteur de DVD ou de CD-ROM alors que l'ordinateur est arrêté, et le démarrez ensuite. Lorsque cela se produit, vous pouvez toujours accéder aux fichiers en utilisant une invite de commandes.

Cause

Ce problème apparaît si vous remplacez le lecteur de CD-R ou de CD-RW par un lecteur de DVD ou de CD-ROM alors que l'ordinateur est arrêté et que la même lettre de lecteur est affectée à un autre lecteur.

Lorsque vous installez un lecteur accessible en écriture, comme un lecteur CD-R ou CD-RW, l'Explorateur Windows inscrit sa lettre de lecteur dans le Registre. Si vous remplacez ce lecteur alors que Windows est exécuté (cette opération est appelée "hot swapping" ou "remplacement à chaud"), les informations du Registre sont mises à jour automatiquement. Toutefois, si vous effectuez ce remplacement alors que l'ordinateur est arrêté, les informations du Registre ne sont pas mises à jour et l'Explorateur Windows tente de traiter le nouveau lecteur comme un périphérique accessible en écriture.

Résolution

Pour résoudre ce problème, procurez-vous le dernier Service Pack de Windows XP. Pour plus d'informations, cliquez sur le numéro ci-après pour afficher l'article correspondant de la Base de connaissances Microsoft :
322389 Procédure pour obtenir le dernier Service Pack de Windows XP
La version anglaise de ce correctif doit avoir les attributs de fichier suivants ou ceux d'une version ultérieure :
   Date        Heure  Version     Taille     Nom du fichier
   --------------------------------------------------------
   20/11/2001  20:59  6.0.2600.2  8 220 720  Shell32.dll

Contournement

Pour contourner ce problème, procédez comme suit :
  1. Si l'Explorateur Windows est exécuté ou si Poste de travail l'exécute, fermez-le.
  2. Cliquez sur Démarrer, puis sur Panneau de configuration.
  3. Cliquez sur Imprimantes et autres périphériques, puis sur Système sous Voir aussi. (Si vous utilisez l'Affichage classique du Panneau de configuration, double-cliquez sur Système.)
  4. Sous l'onglet Matériel, cliquez sur Gestionnaire de périphériques.
  5. Développez DVD/CD-ROM.
  6. Cliquez sur le périphérique approprié, puis cliquez sur Désinstaller dans le menu Action.
  7. Lorsque le système vous invite à confirmer la suppression du périphérique, cliquez sur OK.
  8. Dans le menu Action, cliquez sur Rechercher les modifications sur le matériel. Ceci pousse Windows à reconnaître les nouveaux périphériques.
  9. Fermez le Gestionnaire de périphériques et le Panneau de configuration.

Statut

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section "Liste des produits concernés par cet article". Ce problème a été corrigé dans Windows XP Service Pack 1.

Propriétés

Numéro d'article: 311455 - Dernière mise à jour: mercredi 29 mars 2006 - Version: 3.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows XP Édition familiale
  • Microsoft Windows XP Professionnel
Mots-clés : 
kbqfe kbhotfixserver kbbug kbfix kbshell kbwinxppresp1fix kbwinxpsp1fix KB311455
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com