Jak změnit soubor Boot.ini v systému Windows 2000

Překlady článku Překlady článku
ID článku: 311578 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Souhrn

Článek popisuje postup úpravy souboru Boot.ini v prostředí systému Windows 2000. Soubor NTLDR zobrazuje obrazovku zavaděče, na které můžete vybrat operační systém, který bude spuštěn. Obrazovka je založena na informacích v souboru Boot.ini. Pokud nevyberete položku dříve, než počítadlo dosáhne nuly, soubor NTLDR načte operační systém, který je v souboru Boot.ini určen jako výchozí. Instalační program systému Windows 2000 umisťuje soubor Boot.ini do aktivního oddílu. Soubor NTLDR používá informace v souboru Boot.ini pro zobrazení obrazovky zavaděče, na které můžete vybrat operační systém.

Nezapomeňte soubor Boot.ini před jeho úpravou zálohovat. První kroky popisují změny možností složky, aby bylo možné zobrazit skryté soubory, a dále postup vytvoření záložní kopie souboru Boot.ini.

Změna možností složky

  1. Klepněte pravým tlačítkem myši na tlačítko Start a poté vyberte příkaz Prozkoumat.
  2. V nabídce Nástroje klepněte na příkaz Možnosti složky a pak na kartu Zobrazení.
  3. Ve skupinovém rámečku Upřesnit nastavení zaškrtněte klepnutím políčko Zobrazovat skryté soubory a složky. Klepnutím zrušte zaškrtnutí políčka Skrýt chráněné soubory operačního systému (doporučeno), klepněte na tlačítko OK a potom klepněte na tlačítko OK.
  4. V levém podokně vyberte jednotku %systemroot%, v podokně pro zobrazení klepněte pravým tlačítkem myši na soubor Boot.ini a vyberte příkaz Vlastnosti.
  5. Zrušte zaškrtnutí políčka atributu Jen pro čtení a pak klepněte na tlačítko OK.

Uložení záložní kopie souboru Boot.ini

  1. Klepněte pravým tlačítkem myši na tlačítko Start a poté vyberte příkaz Prozkoumat.
  2. V levém podokně klepněte na jednotku %systemroot%, v pravém podokně klepněte na soubor Boot.ini a potom klepněte na příkaz Kopírovat.
  3. V levém podokně otevřete složku dočasných souborů, klepněte pravým tlačítkem myši v pravém podokně pro zobrazení a potom klepněte na příkaz Vložit. Tím v této složce vytvoříte kopii souboru Boot.ini.

Ukázkový soubor Boot.ini


Jedná se o ukázku výchozího souboru Boot.ini v počítači se systémem Windows 2000 Server:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows 2000 Server" /fastdetect
				
Následuje ukázka výše uvedeného souboru Boot.ini po přidání dalšího oddílu se systémem Windows XP Professional.
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows 2000 Server" /fastdetect
multi(0)disk(1)rdisk(0)partition(2)\WINNT="Windows XP Professional" /fastdetect
				

Úprava souboru Boot.ini

  1. Klepněte na tlačítko Start, přejděte na příkaz Programy, přejděte na příkaz Příslušenství a klepněte na příkaz Poznámkový blok.
  2. V programu Poznámkový blok klepněte v nabídce Soubor na příkaz Otevřít.
  3. V poli Oblast hledání klepněte na jednotku %systemroot% a potom klepněte na soubor Boot.ini. Klepněte na tlačítko Otevřít.

Odebrání operačního systému z nabídky

  1. V programu Poznámkový blok vyberte řádek, který obsahuje informace o operačním systému, který chcete odstranit, a potom stiskněte klávesu DELETE. Příklad řádku, který je vybrán:
    multi(0)disk(1)rdisk(0)partition(2)\Windows="Windows 98" /fastdetect
  2. V nabídce Soubor klepněte na příkaz Uložit.

Změna pořadí operačních systémů v nabídce

  1. V programu Poznámkový blok vyberte řádek, který chcete přesunout, stiskněte kombinaci kláves CTRL+C a potom stiskněte klávesu DELETE. Klepněte na místo, kam chcete řádek přemístit a stiskněte kombinaci kláves CTRL+V.
  2. Podle potřeby opakujte krok 1. Potom klepněte v nabídce Soubor na příkaz Uložit.

Úprava výchozího operačního systému

Hodnota default (výchozí) určuje, který operační systém bude načten v případě, že před vypršením časového limitu nebude vybrána žádná položka.
  1. V programu Poznámkový blok upravte následující řádek tak, aby odkazoval na požadovaný výchozí operační systém:
    default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
    V následujícím příkladu bude výchozí operační systém změněn ze systému Windows 2000 Server na systém Microsoft Windows 95.
    default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
    bude změněn na:
    default=multi(0)disk(0)rdisk(1)partition(2)\Windows
  2. V nabídce Soubor klepněte na příkaz Uložit.

Úprava časového limitu

Časový limit představuje počet sekund, během kterých můžete v nabídce vybrat operační systém. Pokud tak neučiníte, bude po uplynutí časového limitu načten výchozí operační systém.
  1. V programu Poznámkový blok upravte následující řádek tak, aby obsahoval požadovaný počet sekund.
    timeout=30
  2. V nabídce Soubor klepněte na příkaz Uložit.

Odstraňování potíží

  • Pokud nastanou potíže s upraveným souborem, zkopírujte záložní kopii původního souboru Boot.ini do složky %systemroot%.






Vlastnosti

ID článku: 311578 - Poslední aktualizace: 17. května 2006 - Revize: 3.2
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows 2000 Service Pack 1
  • Microsoft Windows 2000 Service Pack 2
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Service Pack 1
  • Microsoft Windows 2000 Service Pack 2
Klíčová slova: 
kbhowto kbhowtomaster kbenv kbui KB311578

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com