Modifica del file Boot.ini in Windows XP

Traduzione articoli Traduzione articoli
Identificativo articolo: 311578 - Visualizza i prodotti a cui si riferisce l?articolo.
Questo articolo è stato precedentemente pubblicato con il codice di riferimento I311578
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

Nelle procedure di questo articolo viene descritto come modificare il file Boot.ini in un ambiente Windows 2000. NTLDR consente di visualizzare la schermata di caricamento bootstrap in cui è possibile selezionare un sistema operativo da avviare. Questa schermata è basata sulle informazioni del file Boot.ini. Se non si seleziona una voce prima che il contatore raggiunga lo zero, in NTLDR viene caricato il sistema operativo specificato dal parametro predefinito nel file Boot.ini. Il programma di installazione di Windows 2000 inserisce il file Boot.ini nella partizione attiva. Le informazioni presenti nel file Boot.ini vengono utilizzate in NTLDR per visualizzare la schermata di caricamento bootstrap in cui selezionare il sistema operativo.

È opportuno eseguire il backup del file Boot.ini prima di modificarlo. Le prime operazioni implicano la modifica delle opzioni della cartella in modo da visualizzare file nascosti, quindi il backup del file Boot.ini.

Modifica delle opzioni della cartella

  1. Fare clic con il pulsante destro del mouse su Start, quindi scegliere Esplora.
  2. Scegliere Opzioni cartella dal menu Strumenti, quindi fare clic sulla scheda Visualizzazione.
  3. Nell'area Impostazioni avanzate selezionare la casella di controllo Visualizza cartelle e file nascosti, deselezionare la casella di controllo Nascondi i file protetti di sistema (consigliato), scegliere OK e di nuovo OK.
  4. Nel riquadro sinistro selezionare la directory %systemroot%, fare clic con il pulsante destro del mouse su Boot.ini nel riquadro di visualizzazione, quindi scegliere Proprietà.
  5. Deselezionare la casella di controllo Sola lettura, quindi scegliere OK.

Salvataggio di una copia di backup del file Boot.ini

  1. Fare clic con il pulsante destro del mouse su Start, quindi scegliere Esplora.
  2. Nel riquadro sinistro fare clic sull'unità %systemroot% e, nel riquadro destro, fare clic sul file Boot.ini, quindi scegliere Copia.
  3. Aprire una cartella temporanea nel riquadro sinistro, fare clic con il pulsante destro del mouse nel riquadro di visualizzazione a destra, quindi scegliere Incolla per creare una copia del file Boot.ini in tale cartella.

File Boot.ini di esempio


Di seguito è riportato un esempio del file Boot.ini predefinito presente in un computer in cui è installato Windows 2000 Server:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows 2000 Server" /fastdetect
				
Il seguente è un esempio del file Boot.ini riportato in precedenza in seguito all'aggiunta di un'altra partizione che esegue Windows XP Professional.
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows 2000 Server" /fastdetect
multi(0)disk(1)rdisk(0)partition(2)\WINNT="Windows XP Professional" /fastdetect
				

Modifica del file Boot.ini

  1. Fare clic sul pulsante Start, scegliere Programmi, Accessori e infine Blocco note.
  2. Nel Blocco note scegliere Apri dal menu File.
  3. Fare clic sull'unità %systemroot% nella casella Cerca in, fare clic sul file Boot.ini, quindi scegliere Apri.

Rimozione di un sistema operativo dal menu

  1. Nel Blocco note selezionare la riga che contiene informazioni sul sistema operativo da rimuovere, quindi premere CANC. Esempio della riga da selezionare:
    multi(0)disk(1)rdisk(0)partition(2)\Windows="Windows 98" /fastdetect
  2. Scegliere Salva dal menu File.

Modifica dell'ordine dei menu del sistema operativo

  1. Nel Blocco note selezionare la riga che deve essere spostata, premere CTRL+C, quindi CANC, posizionare il cursore nel punto in cui inserire la riga, quindi premere CTRL+V.
  2. Ripetere il passaggio 1 se richiesto dalla configurazione, quindi scegliere Salva dal menu File.

Modifica del sistema operativo predefinito

Il sistema operativo predefinito corrisponde a quello che verrà caricato se non si effettua nessuna selezione prima del timeout.
  1. Nel Blocco note modificare la seguente riga in modo che rifletta il sistema operativo da rendere predefinito:
    default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
    Ad esempio in seguito alla modifica del sistema operativo predefinito da Windows 2000 Server a Microsoft Windows 95
    default=multi(0)disk(0)rdisk(0)partition(1)\WINNT
    viene modificato in:
    default=multi(0)disk(0)rdisk(1)partition(2)\Windows
  2. Scegliere Salva dal menu File.

Modifica del valore di timeout

Il valore di timeout rappresenta il numero di secondi in cui è possibile selezionare un sistema operativo dal menu prima del caricamento del sistema operativo predefinito.
  1. Nel Blocco note modificare la seguente riga in modo che rifletta il numero di secondi necessari.
    timeout=30
  2. Scegliere Salva dal menu File.

Risoluzione dei problemi

  • In caso di problemi con il file modificato, copiare il file Boot.ini originale di cui è stato eseguito il backup nella cartella %systemroot%.






Proprietà

Identificativo articolo: 311578 - Ultima modifica: martedì 21 giugno 2005 - Revisione: 3.2
Le informazioni in questo articolo si applicano a
  • Microsoft Windows 2000 Service Pack 1
  • Microsoft Windows 2000 Service Pack 2
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Service Pack 1
  • Microsoft Windows 2000 Service Pack 2
Chiavi: 
kbhowto kbhowtomaster kbenv kbui KB311578
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com