PROBLEMA: Reversão do MDAC pode falhar no Windows 95, Windows 98 e Windows Millennium Edition

Traduções deste artigo Traduções deste artigo
ID do artigo: 311720 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Expandir tudo | Recolher tudo

Sintomas

O programa Dasetup.exe, quando usado com a opção /u, pode não corretamente reverter Microsoft Data Access Components (MDAC) para a versão anterior. Você pode verificar isso usando o utilitário Verificador de componente que está disponível no seguinte site da Microsoft:
http://msdn2.microsoft.com/en-us/data/aa937695.aspx

Causa

Quando a instalação do MDAC encontra erros durante o processo de instalação, o comportamento esperado é reverter quaisquer arquivos e configurações alteradas durante a instalação para sua configuração original. No entanto, um problema conhecido com sistemas Windows 95, Windows 98 e Windows Millennium Edition (Me) impede que essa reversão ocorra corretamente.

Se determinados erros forem encontrados durante a instalação do MDAC (por exemplo, Msxml3.dll não está registrado corretamente), a instalação do MDAC é concluída e relatórios com êxito mesmo que a instalação não foi totalmente bem-sucedida. Porque o MDAC estado em que o computador não é uma instalação limpa, reversões subseqüentes do MDAC podem falhar.

Resolução

No Windows 95 e Windows 98, você pode usar o Component Checker para reconfigurar os componentes do MDAC em um computador como uma alternativa para o método de reversão Dasetup.exe.

Não há nenhuma solução alternativa no Windows Millennium Edition se Dasetup.exe reversão falhar. Nesse caso, contate o Atendimento Microsoft.

Referências

Para obter informações adicionais sobre como reconfigurar os componentes MDAC, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
232060COMO: Instalação do MDAC Troubleshooting Guide

Propriedades

ID do artigo: 311720 - Última revisão: quinta-feira, 24 de outubro de 2013 - Revisão: 3.4
A informação contida neste artigo aplica-se a:
  • Microsoft Data Access Components 2.6 nas seguintes plataformas
    • Microsoft Windows 95
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows Millennium Edition
  • Microsoft Data Access Components 2.6 Service Pack 1 nas seguintes plataformas
    • Microsoft Windows 95
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows Millennium Edition
  • Microsoft Data Access Components 2.7 nas seguintes plataformas
    • Microsoft Windows 95
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows Millennium Edition
  • Microsoft Data Access Components 2.8 nas seguintes plataformas
    • Microsoft Windows 95
    • Microsoft Windows 98 Standard Edition
    • Microsoft Windows 98 Second Edition
    • Microsoft Windows Millennium Edition
Palavras-chave: 
kbnosurvey kbarchive kbmt kbprb KB311720 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 311720

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com