Chybové hlásenia pri pokuse získať prístup k zväzku NTFS

Preklady článku Preklady článku
ID článku: 311724 - Zobraziť produkty, ktorých sa tento článok týka.
Pozn mka
Tento článok sa uplatňuje na systém Windows 2000. Podpora pre Windows 2000 končí 13. júla 2010. V Windows 2000 podpora riešenie Center je východiskovým bodom pre plánovanie vašej stratégie migrácie zo systému Windows 2000. Ďalšie informácie nájdete Microsoft Support Lifecycle politiky.
Rozbaliť všetko | Zbaliť všetko

Na tejto stránke

PRIZNAKY

Pri pokuse získať prístup k zväzku systémom súborov NTFS môže sa zobraziť jedno z nasledujúcich chybových hlásení v príkazovom riadku alebo v Program Microsoft Internet Explorer.
  • Príkazový riadok

    Hlásenie 1
    C:\>F:
    Štruktúra disku je poškodený a nečitateľný.
    Message 2
    C:\>F:
    Nie je dostatok miesta na disku.
  • Internet Explorer

    Hlásenie 1
    F:\is nie sú prístupné.
    Disk štruktúra je poškodený a nečitateľný.
    Message 2
    F:\is nie sú prístupné.
    Nie je dostatok miesta na disku.
Ak zväzok, ktorý je poškodený je tiež systémové alebo zavádzacie objem, môže tiež zobrazí nasledujúce chybové hlásenie pri spustení počítač (ak druhý parameter je 0xC0000032 DISK_CORRUPTION_ERROR):
Stop 0x0000007B (0x00000000, 0xC0000032, 0x00000000, 0x00000000)
Inaccessible_boot_device
Pri pokuse nainštalovať Windows 2000 na zväzku NTFS, môže zobraziť nasledujúce hlásenie:
Windows 2000 rozpoznal vybratú, ale oblasť je poškodená alebo nenaformátovaná. Na inštaláciu systému Windows 2000 na tomto oblasť, Inštalátor ho preformátovať.
Ak spustíte systém Windows 2000 Konzola na obnovenie a skúste použiť dir príkaz na zobrazenie obsahu objemu, môže sa zobraziť nasledujúce chybové hlásenie:
Adresár F:\
Chyba počas adresár enumerácie vyskytla.
Keď spustíte nástroj Chkdsk proti objem postupom dokončí, sú zistené žiadne chyby, a nie sú vykonané opravy. Avšak, nemôžete získať prístup k alebo boot z objem a môžete zobraziť chybové hlásenie. Tiež, ak môžete spustiť príkaz chkdsk volume_drive_letter: /p Konzola na obnovenie príkaz proti zväzku (kde volume_drive_letter je objem písmeno jednotky), no sú zistené chyby.

PRICINA

Tento problém sa vyskytuje, pretože zväzok NTFS má neplatnú alebo poškodené záznamy v súbore $UsnJrnl alebo $LogFile súboru. Obe tieto súbory sú vnútorné súbory, ktoré používajú iba systém súborov NTFS; Príkaz chkdsk nie Skontrolujte integritu týchto dvoch súborov. Príkaz chkdsk zabezpečí iba kapitán Tabuľka súborov (MFT) má položky pre tieto súbory a položky sú platné položky.

RIESENIE

Na vyriešenie tohto problému, ak prijímate, „stop 0x0000007b" chybové hlásenie pri spustení počítača, použite jednu z nasledujúcich metód.

Postup č. 1

Používať systém Microsoft Windows XP alebo Microsoft Windows Server 2003 Nástroj Recovery Console opraviť súbor $UsnJrnl. Systém Windows XP a Windows Server 2003 obsahovať zmeny v Ntfs.sys, že ignorovať poškodené položky v $UsnJrnl súbor a automaticky pripojiť a opraviť súbory prúdu poškodených údajov počas pripájania.
  1. Reštartujte počítač so systémom Windows 2000 na vymáhanie Konzoly pomocou systému Windows XP alebo Windows Server 2003 CD operačného systému. Uistite sa, že načítate ovládač správne tretej strany veľkokapacitného zariadenia.Ďalšie informácie o možnostiach získania inštaláciu systému Windows XP disky s cieľom reštartujte konzolu na obnovenie, kliknite na nasledovné číslo článku databázy Microsoft Knowledge Base:
    310994Ako získať inštaláciu systému Windows XP zavádzacích diskov
  2. Kliknite na položku Štart, kliknite na tlačidlo Spustiť, typ CHKDSK.exe /r , a potom kliknite na tlačidlo ok.
  3. Reštartujte počítač so systémom Windows 2000.

Metóda 2

Použitie nástroja Fsutil.exe z disku CD-ROM systému Windows XP na odstránenie Zmena/čísiel USN:
  1. Skopírujte súbor Fsutil.exe z disku CD-ROM systému Windows XP na počítač, ktorý chcete odstrániť zmeny/čísiel USN na.
  2. Kliknite na položku Štart, kliknite na tlačidlo Spustiť, typ cmd, a potom kliknite na tlačidlo ok.
  3. Zmena adresára, že ste skopírovali Fsutil.exe súboru v kroku 1. Napríklad, ak ste skopírovali Fsutil.exe súboru do koreňového priečinka na jednotke C, zadajte CD c:\, a potom stlačte kláves ZADAJTE.
  4. Do príkazového riadka, zadajte fsutil usn deletejournal /D písmeno_jednotky, a potom stlačte kláves ENTER, kde písmeno_jednotky je jednotka, ktorá obsahuje zmeny/USN denník, ktorý chcete odstrániť.
  5. Ak chcete vytvoriť nové denníka zmeny/USN, spustiťprogram chkdsk/f príkaz na jednotke, ktorú ste odstránili denníka z.

Metóda 3

Presunúť danú jednotku do iného počítača so systémom Windows 2000 aby sa opraví.

Môžete použiť aj program Chkdsk znova inicializovať Súbor $LogFile, ale nie $UsnJrnl súbor, pretože nie všetky zväzky NTFS obsahujú Súbor $UsnJrnl. $UsnJrnl súbor je vytvorený na zväzku len vtedy, keď program, použitie súboru robí prvú žiadosť písať.

Chkdsk bude iba inicializovať súbor $LogFile, keď zmeníte veľkosť súboru denníka v pomocou príkaz chkdsk volume_drive_letter: /f /l:new_size príkaz. Napríklad, ak napíšete príkaz chkdsk f: /f /l:65536.

Ak problém pretrváva aj po zmeníte veľkosť súboru $LogFile, obráťte sa na technickú podporu spoločnosti Microsoft viac Pomocníka pre tento problém. Zoznam telefónnych čísel pre služby technickej podpory spoločnosti Microsoft a informácie o poplatkoch za poskytnutie technickej podpory nájdete na nasledovnej webovej lokalite spoločnosti Microsoft:
http://support.Microsoft.com/default.aspx?scid=FH;[LN];CNTACTMS

STAV

Microsoft potvrdila, že ide o problém v produktoch spoločnosti Microsoft, ktoré sú uvedené v časti „vzťahuje sa na".

DALSIE INFORMACIE

Ak príkaz Chkdsk spustí a nenájde žiadne problémy, ale vy zobrazí chybové hlásenie „prístup odmietnutý"pri pokuse o prístup na objem, existujú nesprávne povolenia NTFS. Môžete použiť nasledujúci príkaz zároveň prihlásení ako správca dať každému "Full Control" root priečinka a podpriečinkov. Toto tiež umožňuje zväzok prístupný.
c:\>cacls volume_drive_letter:\ /g everyone:F /c /t

Vlastnosti

ID článku: 311724 - Posledná kontrola: 1. novembra 2011 - Revízia: 2.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Small Business Server 2000 Standard Edition
  • Microsoft Windows 2000 Server
Kľúčové slová: 
kbbug kberrmsg kbfix kbmt KB311724 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok bol preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft, nie prekladateľom. Spoločnosť Microsoft ponúka články preložené prekladateľmi aj strojovo preložené články, vďaka čomu máte možnosť prístupu ku všetkým článkom databázy Knowledge Base vo svojom jazyku. Strojovo preložený článok však nie je vždy perfektný. Môže obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky, podobne ako cudzinec môže robiť chyby, keď rozpráva vašim jazykom. Spoločnosť Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené akýmkoľvek nepresným prekladom obsahu alebo jeho použitím zo strany zákazníkov. Spoločnosť Microsoft softvér na strojový preklad pravidelne aktualizuje.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem:311724

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com