Windows XP를 설치할 때 "Windows XP Professional CD-ROM의 'Asms' 파일이 필요합니다" 오류 메시지 발생

기술 자료 번역 기술 자료 번역
기술 자료: 311755 - 이 문서가 적용되는 제품 보기.
모두 확대 | 모두 축소

이 페이지에서

현상

Windows XP를 설치할 때 다음과 같은 오류 메시지가 나타날 수 있습니다.
[필요한 파일]

Windows XP Professional CD-ROM의 'Asms' 파일이 필요합니다. 파일이 있는 경로를 입력한 후 [확인]을 클릭하십시오.

원인

설치 프로그램이 CD-ROM 드라이브와 통신할 수 없는 경우 이 문제가 발생할 수 있습니다.

해결 방법

이 문제를 해결하려면 사용하는 컴퓨터에 해당하는 방법을 사용하십시오.

FAT 또는 FAT32 파일 시스템으로 포맷된 하드 디스크

하드 디스크가 FAT 파일 시스템이나 FAT32 파일 시스템으로 포맷된 경우 다음 단계를 수행하십시오.
  1. CD-ROM 드라이버가 있는 Microsoft Windows 98 Second Edition 또는 Microsoft Windows Millennium Edition(Me) 시동 디스크를 사용하여 컴퓨터를 다시 시작합니다.
  2. Windows 98 Second Edition CD-ROM, Windows Millennium Edition(Me) CD-ROM 또는 하드 디스크의 Xcopy.exe 도구를 Windows 시동 디스크로 복사합니다. 이렇게 하려면 적절한 방법을 사용하십시오.

    Windows 98 Second Edition CD-ROM

    Windows 98 Second Edition CD-ROM을 CD-ROM 또는 DVD-ROM 드라이브에 삽입한 다음 명령 프롬프트에 다음 명령을 입력하고 각 줄을 입력한 후 ENTER 키를 누릅니다. 여기서 cd-rom은 CD-ROM이나 DVD-ROM 드라이브의 드라이브 문자입니다.
    c:
    copy cd-rom:\win98\smartdrv.exe
    copy cd-rom:\tools\oldmsdos\xcopy* *

    Windows Millennium Edition(Me) CD-ROM

    Windows Millennium Edition(Me) CD-ROM을 CD-ROM 또는 DVD-ROM 드라이브에 삽입한 다음 명령 프롬프트에 다음 명령을 입력하고 각 줄을 입력한 후 ENTER 키를 누릅니다. 여기서 cd-rom은 CD-ROM 또는 DVD-ROM 드라이브의 드라이브 문자입니다.
    c:
    copy cd-rom:\win9x\smartdrv.exe
    extract cd-rom:\win9x\win_17.cab xcopy.exe /L c:\ xcopy.exe
    extract cd-rom:\win9x\win_17.cab xcopy32.exe /L c:\ xcopy32.exe
    extract cd-rom:\win9x\win_19.cab xcopy32.mod /L c:\ xcopy32.mod

    하드 디스크

    명령 프롬프트에 다음 명령을 입력하고 각 줄을 입력한 후 ENTER 키를 누릅니다. 여기서 드라이브는 Windows가 설치된 하드 디스크의 드라이브 문자입니다.
    c:
    copy drive:\windows\smartdrv.*
    copy drive:\windows\xcopy*.*
  3. Windows 98 또는 Windows Millennium Edition(Me) CD-ROM을 꺼낸 다음 Windows XP Professional CD-ROM을 넣습니다.
  4. I386 폴더 및 모든 하위 폴더를 하드 디스크로 복사합니다. 이렇게 하려면 명령 프롬프트에 다음 명령을 입력하고 각 줄을 입력한 후 ENTER 키를 누릅니다.여기서 cd-rom은 CD-ROM 드라이브의 드라이브 문자이며 드라이브는 하드 디스크의 드라이브 문자입니다.
    smartdrv
    xcopy cd-rom:\i386 drive:\i386 /e
  5. 컴퓨터를 다시 시작한 다음 설치 프로그램을 다시 시작합니다.
  6. 오류 메시지가 나타나면 찾아보기를 누른 다음 하드 디스크에 있는 I386 폴더의 경로를 입력합니다.

    참고 이 폴더의 위치를 묻는 메시지가 여러 번 나타날 수 있습니다. 찾아보기를 사용할 수 없는 경우 이 문서 뒷부분의 "NTFS 파일 시스템으로 포맷된 하드 디스크" 절을 참조하십시오.

NTFS 파일 시스템으로 포맷된 하드 디스크

하드 디스크가 NTFS 파일 시스템으로 포맷되었고 Windows의 이전 버전을 업그레이드하는 경우 다음 방법 중 하나를 사용하십시오.

№ж№э 1:

중요 이 절, 방법 또는 작업에는 레지스트리를 수정하는 방법에 대한 단계가 포함되어 있습니다. 그러나 레지스트리를 잘못 수정하면 심각한 문제가 발생할 수도 있으므로 다음 단계를 주의 깊게 따라야 합니다. 레지스트리를 수정하기 전에 추가 보호 조치로 해당 레지스트리를 백업하는 것이 좋습니다. 이렇게 하면 문제가 발생하는 경우 레지스트리를 복원할 수 있습니다. 레지스트리 백업 및 복원 방법에 대한 자세한 내용은 다음 문서 번호를 클릭하여 Microsoft 기술 자료 문서를 참조하십시오.
322756 Windows에서 레지스트리를 백업 및 복원하는 방법
  1. 오류 메시지가 나타나면 Shift+F10을 눌러 명령 세션을 시작합니다.
  2. regedit.exe를 입력한 다음 Enter 키를 누릅니다.
  3. HKEY_LOCAL_MACHINE을 누릅니다.
  4. 파일 메뉴에서 하이브 로드를 누른 다음 %Windir%\System32\Config\System.sav를 로드합니다.
  5. 이름을 지정할지 묻는 메시지가 나타나면 Test를 입력합니다.
  6. 다음 키를 찾아 누릅니다.
    HKEY_LOCAL_MACHINE\Test\ControlSet1\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}
  7. UPPERFILTERSLOWERFILTERS 레지스트리 키를 삭제합니다.
  8. Test 하이브 아래의 다른 ControlSet# 키에 대해 6단계와 7단계를 반복합니다.
  9. 파일을 누른 다음 끝내기를 눌러 레지스트리 편집기를 종료합니다.
  10. 오류 메시지 대화 상자의 경로가 CD-ROM 드라이브에 대해 올바른 드라이브 문자이면 확인을 눌러 설치 프로그램을 계속합니다.
  11. 오류 메시지가 다시 나타나면 설치 프로그램이 CD-ROM 드라이브에서 올바르게 읽을 수 없거나 경로 정보가 잘못된 것입니다. 이 경우 컴퓨터를 다시 시작하고 설치 프로그램을 다시 시작하십시오.

방법 2

명령 프롬프트에서 Regedit.exe를 시작할 수 없고 하드 디스크에 Windows를 설치할 수 있는 다른 파티션이 있는 경우 다음 단계를 수행하십시오.
  1. 다른 파티션에 Windows를 설치합니다.
  2. Windows의 새 설치를 시작한 다음 Regedit.exe를 시작합니다.
  3. 방법 1의 단계를 수행하되 원래 Windows 폴더에서 System.sav 하이브를 로드합니다.

방법 3

홀로그램이 표시된 정품 Windows XP CD-ROM을 사용하지 않는 경우(예를 들어, 구운 CD-ROM 사용) 홀로그램이 표시된 정품 CD-ROM에서 설치 프로그램을 실행해 보십시오. 이것을 확인하려면 복구 콘솔을 사용하여 컴퓨터를 시작한 다음 C:\$win_nt$.~ls 폴더를 확인합니다. Asms 폴더를 확인합니다. 폴더가 없거나 크기가 0바이트인 파일이 있는 경우 CD-ROM이 올바로 구워진 것이 아닙니다.

복구 콘솔을 사용하는 방법에 대한 자세한 내용은 다음 문서 번호를 클릭하여 Microsoft 기술 자료 문서를 참조하십시오.
307654 HOWTO: Windows XP에서 복구 콘솔을 설치하고 사용하는 방법
참고 이것은 Microsoft 기술 지원 서비스 내에서 직접 작성한 “빠른 게시” 문서입니다. 여기에 포함된 정보는 발생한 문제에 대해 있는 그대로 제공됩니다. 이 문서는 즉시 참조할 수 있도록 빠르게 작성되어서 표기상의 오류가 포함되어 있을 수 있고 언제든지 예고 없이 수정될 수 있습니다. 기타 고려 사항은사용 약관을 참조하십시오. 정보

속성

기술 자료: 311755 - 마지막 검토: 2013년 7월 2일 화요일 - 수정: 1.0
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
키워드:?
kbregistry kberrmsg kbprb kbsetup KB311755

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com