Felmeddelandet "Filen 'Asms' på Windows XP Professional CD-ROM behövs" visas vid installation av Windows XP

Artikelöversättning Artikelöversättning
Artikel-id: 311755 - Visa produkter som artikeln gäller.
Viktigt! Denna artikel innehåller information om hur du redigerar registret. Innan du redigerar registret måste du vara säker på att du kan återställa det om det uppstår något problem. Om du vill veta mer om hur du säkerhetskopierar, återställer och redigerar registret klickar du på följande artikelnummer och läser artikeln i Microsoft Knowledge Base:
256986 Beskrivelse av Microsoft Windows-registret
Visa alla | Dölj alla

På den här sidan

Symptom

När du installerar Microsoft Windows XP visas följande felmeddelande:
[Nödvändiga filer]

Filen 'Asms' på Windows XP Professional CD-ROM behövs. Ange sökvägen till filen och klicka sedan på OK.

Orsak

Det här problemet kan uppstå om installationsprogrammet inte kan kommunicera med CD-ROM-enheten.

Lösning

Lös problemet med någon av följande metoder.

Hårddisken är formaterad med filsystemet FAT eller FAT32

Om hårddisken är formaterad med filsystemet FAT eller FAT32 gör du följande:
  1. Använd en startdiskett för Microsoft Windows 98, andra utgåvan, eller Microsoft Windows Millennium Edition (ME) med CD-ROM-drivrutiner för att starta datorn.
  2. Kopiera Xcopy.exe från CD:n med Windows 98, andra utgåvan, Windows Millennium Edition (ME)-CD:n eller hårddisken till Windows-startdisketten med någon av följande metoder.

    CD:n med Windows 98, andra utgåvan

    Sätt in CD:n med Windows 98, andra utgåvan, i CD-ROM- eller DVD-ROM-enheten. Skriv sedan följande rader vid kommandotolken och tryck på RETUR efter varje rad, där cd-rom är enhetsbeteckningen för CD-ROM- eller DVD-ROM-enheten:
    c:
    copy cd-rom:\win98\smartdrv.exe
    copy cd-rom:\tools\oldmsdos\xcopy*.*

    Windows Millennium Edition (ME)-CD:n

    Sätt in Windows Millennium Edition (ME)-CD:n i CD-ROM- eller DVD-ROM-enheten, skriv följande rader vid kommandotolken, där cd-rom är enhetsbeteckningen för CD-ROM- eller DVD-ROM-enheten, och tryck på RETUR efter varje rad:
    c:
    copy cd-rom:\win9x\smartdrv.exe
    extract cd-rom:\win9x\win_17.cab xcopy.exe /L c:\ xcopy.exe
    extract cd-rom:\win9x\win_17.cab xcopy32.exe /L c:\ xcopy32.exe
    extract cd-rom:\win9x\win_19.cab xcopy32.mod /L c:\ xcopy32.mod

    Hårddisk

    Skriv följande rader vid kommandotolken, där enhet är enhetsbeteckningen för hårddisken där Windows är installerat, och tryck på RETUR efter varje rad:
    c:
    copy enhet:\windows\smartdrv.*
    copy enhet:\windows\xcopy*.*
  3. Mata ut Windows 98- eller Windows Millennium Edition (ME)-CD:n och sätt in Windows XP Professional-CD:n.
  4. Kopiera I386-mappen med alla undermappar till hårddisken genom att skriva följande rader vid kommandotolken, där cd-rom är enhetsbeteckningen för CD-ROM-enheten och enhet är enhetsbeteckningen för hårddisken, och tryck sedan på RETUR efter varje rad:
    smartdrv
    xcopy cd-rom:\i386 enhet:\i386 /e
  5. Starta om datorn och starta installationsprogrammet igen.
  6. När felmeddelandet visas klickar du på Bläddra och skriver sökvägen till I386-mappen på hårddisken.

    Obs! Platsen för mappen kan efterfrågas flera gånger. Om Bläddra inte är tillgängligt läser du avsnittet "Hårddisk formaterad med filsystemet NTFS".

Hårddisk formaterad med filsystemet NTFS

Om hårddisken är formaterad med filsystemet NTFS, och du uppgraderar en tidigare Windows-version, använder du någon av följande metoder.

Metod 1

Varning! Om du använder Registereditorn fel kan det medföra att du måste installera om operativsystemet. Microsoft kan inte garantera att du kan lösa problem som uppstår på grund av felaktig användning av Registereditorn. Använd Registereditorn på egen risk.
  1. När felmeddelandet visas startar du en kommandosession genom att trycka på SKIFT+F10.
  2. Skriv regedit.exe och tryck på RETUR.
  3. Klicka på HKEY_LOCAL_MACHINE.
  4. Klicka på Läs in registreringsdatafilArkiv-menyn, och läs sedan in %Windir%\System32\Config\System.sav.
  5. Skriv Test när du ombeds ange ett namn.
  6. Leta upp och klicka på följande nyckel:
    HKEY_LOCAL_MACHINE\Test\ControlSet1\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}
  7. Ta bort registernycklarna UPPERFILTERS och LOWERFILTERS.
  8. Upprepa steg 6 och 7 för övriga ControlSetnummer-nycklar under Test-registreringsdatafilen.
  9. Klicka på Arkiv, och avsluta sedan Registereditorn genom att klicka på Avsluta.
  10. Om sökvägen i felmeddelandet är rätt enhetsbeteckning för CD-ROM-enheten fortsätter du installationsprogrammet genom att klicka på OK.
  11. Om felmeddelandet visas igen kan installationsprogrammet inte läsa på rätt sätt från CD-ROM-enheten, eller så är sökvägsinformationen felaktig. Starta i så fall om datorn och låt installationsprogrammet starta om.

Metod 2

Om du inte kan starta Regedit.exe vid kommandotolken, och det finns en annan tillgänglig partition där du kan installera Windows på hårddisken, gör du så här:
  1. Installera Windows på den andra partitionen.
  2. Starta den nya Windows-installationen och sedan Regedit.exe.
  3. Följ instruktionerna för metod 1, men läs in registreringsdatafilen System.sav från den ursprungliga Windows-mappen.

Metod 3

Om du inte använder en återförsäljar-CD med Windows XP och ett hologram (du använder till exempel en bränd CD), försöker du köra installationsprogrammet från en återförsäljar-CD med ett hologram. Kontrollera detta genom att starta datorn med hjälp av Återställningskonsolen och sedan kontrollera mappen C:\$win_nt$.~ls. Leta upp Asms-mappen. Om den saknas eller filerna i den är noll byte stora har CD:n inte bränts på rätt sätt.

Om du vill veta mer om hur du använder Återställningskonsolen klickar du på artikelnumret nedan och läser artikeln i Microsoft Knowledge Base:
307654 Slik installerer og bruker du gjenopprettingskonsollen i Windows XP

Egenskaper

Artikel-id: 311755 - Senaste granskning: den 25 juni 2007 - Revision: 5.1
Informationen i denna artikel gäller:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
Nyckelord: 
kbregistry kberrmsg kbprb kbsetup KB311755

Ge feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com