コンピュータがスタンバイ モードのときに PC カード記憶装置を取り外すと応答を停止することがある

文書翻訳 文書翻訳
文書番号: 311822 - 対象製品
この記事は、以前は次の ID で公開されていました: JP311822
すべて展開する | すべて折りたたむ

現象

コンピュータがスタンバイ モードまたは休止状態のときに PC カード記憶装置を取り外すと、[マイ コンピュータ] ウィンドウが黒色または白色のウィンドウで表示され、コンピュータが再開時に応答を停止 (ハング) することがあります。この問題は、CompactFlash、Flash ATA カード、メモリ スティック デバイスなどの PC カード記憶装置で発生する可能性があります。

原因

この問題は、コンピュータがスタンバイ モードまたは休止状態になった際に、[マイ コンピュータ]、または記憶装置を参照するその他のエクスプローラ ベースのツールが実行されており、コンピュータが再開時にデスクトップに直接戻るように設定されている場合に発生することがあります。Windows が 突然の取り外し の処理を完了しないうちに、エクスプローラのディスク確認処理が開始されるために、コンピュータは応答を停止します。

解決方法

マイクロソフトでは、現在この問題を修正する修正プログラムを提供中ですが、修正プログラムはこの資料に記載された問題のみを修正することを目的としており、障害があったコンピュータに対してのみ適用することを推奨します。この修正プログラムは、今後さらにテストを受ける場合があります。この問題で深刻な影響を受けていない場合は、この修正プログラムが含まれる次の Windows XP Service Pack がリリースされるまで待つことを推奨します。

この問題を解決するには、Microsoft Product Support Services にお問い合わせのうえ、修正プログラムを入手してください。Microsoft Product Support Services の電話番号一覧およびサポート料金については、次のマイクロソフト Web ページを参照してください。
http://support.microsoft.com/default.aspx?scid=fh;JA;CNTACTMS
: Microsoft Support Professional が、特定のアップデートを適用することにより問題が解決されると判断した場合、まれに通常サポート依頼にかかる料金が免除されることがあります。ただし、特定のアップデートの対象とならない追加の質問および問題については、通常のサポート料金が適用されます。

修正プログラム (英語版) の属性は次のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。
   日付         時刻   バージョン      サイズ    ファイル名
   --------------------------------------------------
   04-Jan-2002  14:13  5.1.2600.26  86,912  Atapi.sys

回避策

この問題を回避するには、[コントロール パネル] の [電源オプション] ツールで [スタンバイから回復するときにパスワードの入力を求める] チェック ボックスをオンにします。このオプションをオンにすると、[マイ コンピュータ] またはエクスプローラが実行されている場合でも、デスクトップではなくパスワードの画面に戻ります。このオプションを設定するには、以下の手順を実行します。
  1. [スタート] ボタンをクリックし、[コントロール パネル] をクリックします。
  2. [パフォーマンスとメンテナンス] をクリックし、[電源オプション] をクリックします。
  3. [詳細設定] タブをクリックします。
  4. [スタンバイから回復するときにパスワードの入力を求める] チェック ボックスをオンにし、[OK] をクリックします。
パスワードを使用せずに Windows にログオンしている場合、使用しているユーザー アカウントを選択する画面に戻ります。

状況

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。この問題は、Windows XP Service Pack 1 で修正済みです。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 311822 (最終更新日 2002-05-08) をもとに作成したものです。

プロパティ

文書番号: 311822 - 最終更新日: 2006年3月24日 - リビジョン: 1.1
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
キーワード:?
kbhotfixserver kbbug kbfix kbwinxppresp1fix kbwinxpsp1fix KB311822
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com