Chybová zpráva: Spoolsv.exe generoval chyby a bude systémem Windows uzavřen

Překlady článku Překlady článku
ID článku: 312052 - Produkty, které se vztahují k tomuto článku.
DŮLEŽITÉ: Tento článek obsahuje informace o úpravě registru. Před úpravami je nutné registr zálohovat. Seznamte se také s postupem při obnovení registru v případě, že nastanou potíže. Informace o zálohování, obnovení a úpravě registru najdete v následujícím článku znalostní báze Microsoft Knowledge Base:
256986 Popis registru systému Microsoft Windows
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Při otevření okna Tiskárny nebo při pokusu o tisk z libovolného programu se může zobrazit jedna z následujících chybových zpráv:
Spoolsv.exe generoval chyby a bude systémem Windows uzavřen.
nebo
Printer operation cannot continue due to lack of resources. (Operace tisku nemůže pokračovat z důvodu nedostatku prostředků.)
nebo
Subsystem unavailable. (Podsystém není k dispozici.)

Příčina

Tento problém nastane v případě, že je poškozen ovladač tiskárny, který je instalován v počítači.

Řešení

UPOZORNĚNÍ: Použijete-li Editor registru nesprávně, můžete způsobit vážné problémy, které mohou vyžadovat přeinstalování operačního systému. Společnost Microsoft nemůže zaručit, že bude možné vyřešit problémy vzniklé v důsledku nesprávného použití Editoru registru. Editor registru používáte na vlastní nebezpečí.

Problém vyřešte takto: Odeberte tiskárny a ovladače tiskáren a potom odstraňte položky určitých klíčů registru. Postupujte takto:
  1. Pokud je to možné, v okně Tiskárny odeberte všechny tiskárny.

    Chcete-li tiskárnu odebrat, v okně Tiskárny klepněte pravým tlačítkem na tiskárnu, potom klepněte na příkaz Odstranit a odstranění potvrďte klepnutím na tlačítko Ano.
  2. V okně Tiskárny klepněte v nabídce Soubor na příkaz Vlastnosti serveru.
  3. Na kartě Ovladače odeberte všechny nainstalované ovladače tiskárny.

    Chcete-li odebrat ovladač tiskárny, klepněte na ovladač a potom klepněte na tlačítko Odebrat. Potvrďte klepnutím na tlačítko Ano.
  4. Spusťte Editor registru (Regedit.exe).
  5. Exportujte následující klíče registru:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print
  6. Odstraňte všechny položky v následujících klíčích (samotné klíče neodstraňujte):
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers\Version-2
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers\Version-3
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print\Environments\Windows NT x86\Drivers\Version-2
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print\Environments\Windows NT x86\Drivers\Version-3
  7. V následujících klíčích odstraňte všechny položky, které nejsou výchozí:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print\Monitors
    Seznam výchozích monitorů obsahuje:

    • Tisková zařízení s rozhraním AppleTalk (pokud je nainstalována služba Services for Macintosh)
    • BJ Language Monitor
    • Místní port
    • PJL Language Monitor
    • Sledování standardního portu TCP/IP
    • Monitor USB
    • Sledování služby Fax systému Windows NT (pokud je instalován faxmodem)

    Další informace o položkách, které nejsou výchozí, naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
    260142 Odstraňování potíží s tiskem v systému Windows 2000
  8. Odstraňte všechny položky následujících klíčů:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print\Printers
  9. Ukončete Editor registru.
  10. Restartujte počítač a pak znovu nainstalujte potřebné tiskárny.

Vlastnosti

ID článku: 312052 - Poslední aktualizace: 16. června 2006 - Revize: 2.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows 2000 Professional Edition
Klíčová slova: 
kbenv kberrmsg kbprb kbprint KB312052

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com