Messaggio di errore: Spoolsv.exe ha provocato errori e verrà chiuso

Traduzione articoli Traduzione articoli
Identificativo articolo: 312052 - Visualizza i prodotti a cui si riferisce l?articolo.
IMPORTANTE: in questo articolo sono contenute informazioni su come modificare il Registro di sistema. Prima di modificare il Registro di sistema, eseguire una copia di backup e assicurarsi di sapere come ripristinarlo in caso di problemi. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
256986 Description of the Microsoft Windows Registry
Espandi tutto | Chiudi tutto

Sintomi

Se si apre la finestra Stampanti o se si tenta di stampare da un programma, è possibile che venga visualizzato uno dei seguenti messaggi di errore:
Spoolsv.exe ha provocato errori e verrà chiuso.
Oppure
Impossibile proseguire con l'utilizzo della stampante. Risorse insufficienti.
Oppure
Sottosistema non disponibile

Cause

È possibile che si verifichi questo problema se un driver di stampante installato nel computer è danneggiato.

Risoluzione

AVVISO: l'errato utilizzo dell'editor del Registro di sistema può causare seri problemi che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire la risoluzione di problemi causati dall'errato utilizzo dell'editor del Registro di sistema. L'utilizzo dell'editor del Registro di sistema è a rischio e pericolo dell'utente.

Per risolvere il problema, rimuovere stampanti e driver di stampanti dal computer, quindi eliminare gli elementi che si trovano in corrispondenza di specifiche chiavi del Registro di sistema. Attenersi alla seguente procedura:
  1. Se possibile, rimuovere tutte le stampanti elencate nella finestra Stampanti.

    Per rimuovere una stampante, fare clic con il pulsante destro del mouse sulla stampante da eliminare nella finestra Stampanti, scegliere Elimina, quindi per confermare l'eliminazione.
  2. Nella finestra Stampanti scegliere Proprietà server dal menu File.
  3. Nella scheda Driver rimuovere tutti i driver di stampante installati.

    Per rimuovere un driver di stampante, fare clic sul driver, scegliere Rimuovi, quindi per confermare.
  4. Avviare l'editor del Registro di sistema (Regedit.exe).
  5. Esportare le seguenti chiavi del Registro di sistema:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print
  6. Eliminare eventuali elementi elencati in corrispondenza delle seguenti chiavi (non eliminare le chiavi stesse):
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers\Version-2
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers\Version-3
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print\Environments\Windows NT x86\Drivers\Version-2
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print\Environments\Windows NT x86\Drivers\Version-3
  7. Eliminare eventuali elementi non predefiniti elencati in corrispondenza delle seguenti chiavi:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print\Monitors
    L'elenco di monitor predefiniti include:

    • Periferiche di stampa AppleTalk (quando è installato Servizi per Macintosh)
    • BJ Language Monitor
    • Porta locale
    • PJL Language Monitor
    • Porta TCP/IP standard
    • Monitor USB
    • Monitoraggio fax di Windows NT (quando è installato un modem fax)

    Per ulteriori informazioni su quali elementi non sono predefiniti, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
    260142 How to Troubleshoot Windows Printing Problems
  8. Eliminare eventuali elementi elencati in corrispondenza delle seguenti chiavi:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print\Printers
  9. Chiudere l'editor del Registro di sistema.
  10. Riavviare il computer, quindi reinstallare le stampanti necessarie.

Proprietà

Identificativo articolo: 312052 - Ultima modifica: lunedì 10 novembre 2003 - Revisione: 1.0
Le informazioni in questo articolo si applicano a
  • Microsoft Windows 2000 Professional Edition
Chiavi: 
kberrmsg kbprint kbenv kbprb KB312052
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com