Se pueden perder instantáneas al desfragmentar un volumen

Seleccione idioma Seleccione idioma
Id. de artículo: 312067 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Cuando se ejecuta Desfragmentador de disco en un volumen con instantáneas activadas, se copia todo o parte de la sombra copias pueden perderse, comenzando por la sombra más antigua.

Después de que las instantáneas se pierden, sucesos similares al siguiente pueden grabarse en el registro del sistema:

Tipo de suceso: advertencia
Origen del suceso: VolSnap
Categoría del suceso: ninguna
ID. de suceso: 24 usuario: N/d
Equipo: producción
Descripción: Hubo espacio en disco insuficiente en el volumen C: crecer el almacenamiento de instantáneas para instantáneas de unidad. Como resultado de este error todas las instantáneas de volumen C: corren riesgo de que se va a eliminar.
Para obtener más información, consulte Ayuda y Centro de soporte técnico en http://go.Microsoft.com/fwlink/events.ASP.
Datos: 0000: 00000000 00580003 00000000 80060018 0010: 00000002 0000003f c000007f 00000000 0020: 00000000 00000000 puede que tenga varios eventos ID 33 iniciado ambos antes y después se registra el 24 de identificador de suceso.

Tipo de suceso: información
Origen del suceso: VolSnap
Categoría del suceso: ninguna
ID. de suceso: 33 usuario: N/d
Equipo: producción
Descripción: La instantánea más antigua del volumen que c: eliminó para mantener el uso de espacio de disco para instantáneas de volumen C: debajo el usuario define el límite.
Para obtener más información, consulte Ayuda y Centro de soporte técnico en http://go.Microsoft.com/fwlink/events.ASP.
Datos: 0000: 00000000 00580002 00000000 40060021 0010: 00000001 00000040 00000000 00000000 0020: 00000000 00000000

Causa

El proveedor de instantáneas del sistema utiliza un mecanismo de copia por escritura que opera en un nivel de bloque de 16 KB. Esto es independiente del tamaño de unidad de asignación de clúster del sistema de archivos. Si tamaño de clúster del sistema de archivos es menor que 16 KB, el proveedor de instantáneas del sistema no puede determinar fácilmente que E/s la desfragmentación de disco es diferente de E/s de escritura normal y realiza una operación de copia en escritura. Esto puede provocar que el área de almacenamiento de instantáneas para crecer muy rápidamente. Si el área de almacenamiento alcanza su límite definido por el usuario, las instantáneas más antiguas se eliminan primero.

Solución

Si tamaño de clúster del sistema de archivos es de 16 KB o mayor, el proveedor puede reconocer la desfragmentación de disco E/s y controlarlo correctamente. Microsoft recomienda que utilice un tamaño de unidad de asignación de clúster de 16 KB o mayor al dar formato el volumen si piensa desfragmentar volúmenes que se utilizan para instantáneas de carpetas compartidas.

Más información

Para obtener más información acerca de los tamaños de unidad de asignación de clúster, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
140365Tamaño de clúster predeterminado para FAT y NTFS
Para obtener información adicional acerca prácticas recomendadas para utilizar instantáneas de carpetas compartidas, vea el tema "Sombra copias de compartido carpetas: recomendaciones" en el Centro de soporte técnico y Ayuda de Windows Server 2003.

Propiedades

Id. de artículo: 312067 - Última revisión: lunes, 03 de diciembre de 2007 - Versión: 8.2
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Small Business Server 2003 Standard Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
Palabras clave: 
kbmt kbprb KB312067 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 312067

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com