Dataförlust efter ominstallation, reparation eller uppgradering av Windows XP

Artikelöversättning Artikelöversättning
Artikel-id: 312368 - Visa produkter som artikeln gäller.
Obs! Informationen i den här artikeln gäller endast datorer där Windows XP förinstallerats av en datortillverkare.
Visa alla | Dölj alla

Symptom

Du kan förlora data som är lagrade i mappen All Users, samt standardmappar och standardinställningar som är lagrade i mappen Default User, när du installerar om, reparerar eller uppgraderar Windows XP. Dessutom kan följande saknas: genvägar på Start-menyn, objekt i Autostart-gruppen samt dokument, bilder och musikfiler som är lagrade i mappen Delade dokument.

Det här problemet kan uppstå när du gör följande på en dator där Windows XP är förinstallerat av en datortillverkare (även kallad Original Equipment Manufacturer eller OEM):
  • Du installerar om Windows XP i samma mapp genom att klicka på Uppgradering (rekommenderas) när du har kört Winnt32.exe, eller genom att klicka på länken Installera Windows XP på skärmen "Välkommen till Microsoft Windows XP", som visas när du sätter in Windows XP-CD:n. Detta kallas även att utföra en uppgradering eller installation på plats.
  • Du reparerar Windows XP genom att starta datorn från Windows XP-CD:n, trycka på RETUR för att installera Windows XP och sedan trycka på R för att reparera den valda installationen.
  • Du uppgraderar den installation av Windows XP Home Edition som förinstallerats av datortillverkaren till återförsäljarversionen av Windows XP Professional.

Orsak

Det här problemet kan uppstå om filen Undo_guimode.txt finns i mappen Windows\System32 på hårddisken, när du utför någon av de åtgärder som anges i avsnittet "Symptom" på en dator där Windows XP förinstallerats av en datortillverkare. Filen Undo_guimode.txt skapas av en guide som körs när du första gången startar en dator där Windows XP förinstallerats av en datortillverkare.

Obs! Filen Undo_guimode.txt skapas felaktigt av OEM OOBE (Out-of-Box Experience). Den här filen ska bara användas för GUI-lägesinstallation när installationsprogrammet startar. När filen har skapats av OOBE och uppgraderingen genomförs med installationsprogrammet identifieras filen. Därmed förefaller det som om installationsprogrammet startar om och profilerna ovan tas bort.

Lösning

Lös problemet genom att hämta den senaste Service Pack-versionen för Windows XP. Om du vill veta mer klickar du på följande artikelnummer och läser artikeln i Microsoft Knowledge Base:
322389 Skaffa den senaste Service Pack-versionen för Windows XP
Lös problemet genom att återställa data och programgenvägar som saknas från en säkerhetskopia.

I följande artikel i Microsoft Knowledge Base kan du läsa hur du undviker problemet:
312369 Data eller programinställningar kan gå förlorade efter ominstallation, reparation eller uppgradering av Windows XP
En uppdatering av OPK (OEM Preinstall Kit) som löser problemet har distribuerats till datortillverkare.

Uppdateringen kan också fås från Microsoft Support.

Information om snabbkorrigeringen

En snabbkorrigering som stöds är tillgänglig från Microsoft. Den är emellertid endast avsedd att åtgärda det problem som beskrivs i artikeln. Använd den bara på datorer där detta problem uppstår. Snabbkorrigeringen kan komma att testas igen. Om ditt arbete inte störs alltför mycket av detta problem, rekommenderar vi att du väntar på nästa programuppdatering som innehåller den här snabbkorrigeringen.

Om snabbkorrigeringen är tillgänglig för hämtning anges detta högst upp i denna artikel. Annars kontaktar du Microsoft Support för att få snabbkorrigeringen.

Obs! Om det uppstår ytterligare problem eller krävs felsökning, måste du kanske skapa en särskild serviceförfrågan. Normala supportavgifter tas ut för ytterligare supportfrågor och problem som inte gäller den aktuella snabbkorrigeringen. En fullständig lista över telefonnummer till Microsoft Support finns på följande Microsoft-webbplats:
http://support.microsoft.com/contactus/?ws=support
Obs! Samtliga språk som snabbkorrigeringen är tillgänglig för visas i en lista. Om ditt språk inte finns med i listan beror det på att ingen snabbkorrigering är tillgänglig för språket.

Filinformation

Den engelska versionen av denna korrigeringsfil ska ha följande filattribut (eller senare):
   Datum         Tid   Version      Storlek     Filnamn
   -----------------------------------------------------
   11-aug-2001  09:12  5.1.2600.19  927 232  Syssetup.dll
				

Mer Information

För att den här snabbkorrigeringen ska fungera i en OEM-förinstallationsmiljö, måste du lägga in den i installationskällans katalog (i386) innan du installerar operativsystemet. Annars skapas filen \Windows\System32\Undo_GUImode.txt av den ursprungliga versionen av filen Syssetup.dll, och de symptom som beskrivs i början av den här artikeln uppstår.

Så här lägger du in snabbkorrigeringen i installationskällans katalog:
  1. Byt namn på snabbkorrigeringspaketet till ett filnamn med 8.3-formatet.

    Gör så här: skriv följande rad vid en kommandotolk, där q######är Q-numret på den artikel i Knowledge Base som hör till snabbkorrigeringen, och tryck sedan på RETUR:
    ren q######_wxp_spx_x86_enu.exe q######.exe
    Obs!: Du måste byta namn på snabbkorrigeringsfilen eftersom långa filnamn inte identifieras i installationsprogrammet för Windows XP.
  2. Skapa en tillfällig katalog för det extraherade innehållet från snabbkorrigeringspaketet.

    Gör så här: skriv följande rad vid en kommandotolk, där q###### är namnet på snabbkorrigeringspaketet, och tryck sedan på RETUR.
    md c:\q######
  3. Extrahera filerna från snabbkorrigeringspaketet. Gör så här: skriv följande rad vid en kommandotolk, där q###### är namnet på snabbkorrigeringspaketet, och tryck sedan på RETUR.
    q######.exe /x
  4. När du ombeds ange vilken mapp du vill extrahera filerna till skriver du följande rad och trycker på RETUR:
    c:\q######
  5. Öppna filen \Opktools\Lang\ENU\SKU\Pro\x86\i386\Dosnet.inf i en textredigerare som Anteckningar.
  6. Lägg till följande rader i Dosnet.inf samt spara och stäng filen:
    [OptionalSrcDirs]
    svcpack
  7. Ta bort filen Svcpack.in_ i mappen i386, och ta bort alla ursprungliga filer som ersätts av filerna i snabbkorrigeringen.
  8. Kopiera ersättningsfilerna från den tillfälliga snabbkorrigeringsmappen till i386-mappen. Gör så här: skriv följande rad vid en kommandotolk, där q###### är namnet på snabbkorrigeringspaketet, och tryck sedan på RETUR.
    copy c:\q######\syssetup.dll c:\opktools\lang\enu\sku\pro\x86\i386\syssetup.dll
  9. Skapa en Svcpack-mapp i mappen \Opktools\Lang\ENU\SKU\Pro\x86\i386.
  10. I mappen \Opktools\Lang\ENU\SKU\Pro\x86\i386 skapar du en ny Svcpack.inf-fil med följande rader i en textredigerare som Anteckningar:
    [Version]
    Signature="$Windows NT$"
    BuildNumber=2600
    MajorVersion=5
    MinorVersion=1

    [SetupData]
    CatalogSubDir="i386\svcpack"

    [ProductCatalogsToInstall]
    sp1.cat

    [SetupHotfixesToRun]
    q###### -q -n -z
    Här är q###### namnet på snabbkorrigeringspaketet.
  11. Kopiera filen Sp1.cat från mappen c:\q######\Update till mappen C:\Opktools\Lang\ENU\SKU\Pro\x86\i386\Svcpack.

    Gör så här: skriv följande rad vid en kommandotolk, där q###### är namnet på snabbkorrigeringspaketet, och tryck sedan på RETUR.
    copy c:\q######\update\sp1.cat c:\opktools\lang\enu\sku\pro\x86\i386\svcpack\sp1.cat
  12. Kopiera filen Q######.exe till mappen C:\Opktools\Lang\ENU\SKU\Pro\x86\i386\Svcpack.

    Gör så här: skriv följande rad vid en kommandotolk, där q###### är namnet på snabbkorrigeringspaketet, och tryck sedan på RETUR.
    copy q######.exe c:\opktools\lang\enu\sku\pro\x86\i386\svcpack\q######.exe

Status

Microsoft har bekräftat att detta är ett problem i Microsoft-produkterna som nämns i början av denna artikel. Detta problem åtgärdades först i Windows XP Service Pack 1.

Egenskaper

Artikel-id: 312368 - Senaste granskning: den 23 december 2008 - Revision: 2.5
Informationen i denna artikel gäller:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
Nyckelord: 
kbautohotfix kbhotfixserver kbqfe kbenv kbbug kbfix kbsetup kbwinxpsp1fix KB312368

Ge feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com