SK0325:Po preinštalovaní, oprave alebo inovácii operacného systému Windows XP sa môžu stratit údaje alebo nastavenia aplikácií

Preklady článku Preklady článku
ID článku: 312369 - Zobraziť produkty, ktorých sa tento článok týka.
Rozbaliť všetko | Zbaliť všetko

PRIZNAKY

POZNÁMKA: Informácie uvedené v tomto článku sa týkajú len počítačov, ktoré majú od výrobcu predinštalovaný systém Windows XP.

Po preinštalovaní, oprave alebo inovácii operačného systému Windows XP sa môžu stratiť údaje uložené v priečinku All Users a predvolené nastavenia a šablóny programov uložené v priečinku Default User. Môžu chýbať aj odkazy v ponuke Štart, položky v skupine Po spustení a dokumenty, obrázky alebo súbory s hudbou, ktoré sú uložené v priečinku Shared Documents. Tento problém sa môže objaviť vtedy, ak uskutočníte niektorý z nasledovných krokov na počítači s predinštalovaným systémom Windows XP od výrobcu počítača (označovaného aj ako Original Equipment Manufacturer alebo OEM):
• Ak preinštalujete systém Windows XP do toho istého priečinka kliknutím na tlačidlo Upgrade (Recommended) po spustení programu Winnt32.exe alebo ak kliknete na odkaz Inštalovať systém Windows XP v okne „Vitajte v systéme Microsoft Windows XP“, ktoré sa objaví po vložení disku CD-ROM systému Windows XP do počítača. Tento krok je tiež známy ako priama inovácia alebo priama inštalácia.
• Ak opravíte systém Windows XP tak, že spustíte počítač z disku CD-ROM systému Windows XP, stlačením klávesu Enter spustíte inštaláciu systému Windows XP a potom stlačením klávesu R opravíte vybratú inštaláciu.
• Ak inovujete inštaláciu systému Windows XP Home Edition, ktorý bol predinštalovaný výrobcom počítača, na predajnú verziu Windows XP Professional.

PRICINA

Toto správanie sa môže objaviť v prípade, ak na počítači so systémom Windows XP predinštalovaným výrobcom počítača uskutočňujete niektorý z vyššie spomenutých krokov v časti Príznaky, pričom súbor Undo_guimode.txt sa nachádza v priečinku Windows\System32 na pevnom disku počítača. Tento súbor vytvorí sprievodca, ktorý sa spustí po zapnutí počítača so systémom Windows XP predinštalovaným výrobcom počítača.

RIESENIE

Ak chcete odstrániť tento problém, musíte obnoviť údaje a odkazy na programy zo zálohy. Aby ste problému predišli, odstráňte súbor Undo_guimode.txt z priečinka Windows\System32 skôr, než uskutočníte ktorýkoľvek z krokov uvedených v časti Príznaky. Tento postup vykonáte v systéme Windows XP zadaním nasledovného príkazu v príkazovom riadku:
del /a /f %windir%\system32\undo_guimode.txt
POZNÁMKA: Ak používate konzolu na obnovenie, systém MS-DOS alebo zavádzaciu disketu systému Microsoft Windows, postup odstránenia súboru je trocha odlišný.

Viac informácií o odstraňovaní súborov nájdete v dokumentácii k produktom systémov MS-DOS alebo Windows, vyhľadávaním v Centre pomoci a technickej podpory systému Windows XP alebo v nasledovnom článku o konzole na obnovenie: 229716 Description of the Windows Recovery Console

Oprava, ktorá rieši tento problém, bude čoskoro k dispozícii ako kritická aktualizácia vo forme súčasti Dynamickej aktualizácie Inštalátora na stránkach lokality Microsoft Windows Update a bude dostupná pomocou funkcie Automatická aktualizácia. Pre výrobcov počítačov a správcov podnikových sietí bude k dispozícii samostatná aktualizácia. Tento článok bude aktualizovaný po vydaní aktualizácie.
POZNÁMKA: Ak použijete disk CD-ROM na obnovu systému dodaný výrobcom počítača, na zabránenie opätovnému výskytu problému bude pravdepodobne potrebné zopakovať kroky uvedené v tomto článku.

STAV

Spoločnosť Microsoft potvrdzuje, že ide o problém týkajúci sa produktov, ktoré sú uvedené v úvode tohto článku.

Vlastnosti

ID článku: 312369 - Posledná kontrola: 12. apríla 2005 - Revízia: 1.3
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
Kľúčové slová: 
kbenv kbbug kbfix kbsetup kbwinxpsp1fix KB312369

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com