Artigo: 312592 - Última revisão: segunda-feira, 10 de Setembro de 2007 - Revisão: 4.3

PROBLEMA: Aplicação aleatória reinicia com o erro "Aplicação reiniciar" no ASP.NET

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Reduzir tudo

Sintomas

Quando executa o ASP.NET num computador que utiliza software anti-vírus com monitorização em tempo real activado, poderá notar que uma aplicação aleatória é reiniciado e receberá a seguinte mensagem de erro no browser:
Reiniciar aplicação.

Descrição: Ocorreu uma excepção não processada durante a execução da solicitação da web actual. Reveja o rastreio da pilha para mais informações sobre o erro e onde tem origem no código.

Detalhes da excepção: System.InvalidOperationException: aplicação estiver a reiniciar.

Causa

Este problema ocorre devido a algumas informações de back de escrita de aplicações antivírus para os ficheiros digitalizar. Sempre que um utilizador altera o ficheiro de configuração Web.config, o ficheiro global.asax ou o conteúdo da pasta Bin do, deve reiniciar a aplicação para incorporar estas alterações. Uma vez que alterações detecção antivírus não podem ser distinguidas das alterações do ficheiro, a aplicação é reiniciado quando o software antivírus pesquisa destas pastas.

Nota Este problema pode ocorrer mesmo quando é devolvido sem erros. Se os accionadores de software de detecção de vírus Alterar notificações, cada notificação de alteração é duplicada no mínimo: um real alterar notificação e uma notificação de alterações adicionais do software de antivírus algum tempo mais tarde.

Resolução

Utilize um dos seguintes métodos para resolver este problema:
  • Desactive monitorização em tempo real no seu software anti-vírus.
  • Exclua as pastas de aplicação na lista de detecção de vírus.
Consulte a documentação do software antivírus para obter instruções sobre como alterar estas definições.

Com algum software antivírus, poderá aumentar o atributo delayNotificationTimeout a secção de configuração <httpruntime> no ficheiro Web.config para contornar este problema. Este valor é definido com a seguinte entrada no ficheiro Web.config:
<httpRuntime delayNotificationTimeout="5" />
				
o valor predefinido é 5 segundos, que por vezes, não é suficiente para hardware específico. Para resolver o problema no computador, tem de aumentar o valor de limite de tempo para um valor que funciona para a velocidade de hardware e o computador (por exemplo, 60).

Ponto Da Situação

Este comportamento ocorre por predefinição.

Mais Informação

Se a actualização de ficheiros ocorre enquanto o primeiro pedido está a ser processado, o ASP.NET rejeita o pedido e apresenta o erro "Aplicação reiniciar" uma vez que a notificação ocorre antes da aplicação é totalmente compilada.

Referências

Para obter informações adicionais sobre problemas relacionados com o Microsoft Mobile Internet Toolkit, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
310619  (http://support.microsoft.com/kb/310619/ ) PROBLEMA: O estado da sessão é perdido em aplicações de formulário da Web móvel durante o desenvolvimento

A informação contida neste artigo aplica-se a:
  • Microsoft ASP.NET 1.1
  • Microsoft ASP.NET 1.0
  • Microsoft ASP.NET 2.0
Palavras-chave: 
kbmt kbhttpruntime kbprb KB312592 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 312592  (http://support.microsoft.com/kb/312592/en-us/ )