ID do artigo: 312592 - Última revisão: segunda-feira, 10 de setembro de 2007 - Revisão: 4.3

PROBLEMA: Aplicativo aleatório é reiniciado com o erro "O aplicativo está reiniciando" no ASP.NET

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Recolher tudo

Sintomas

Quando você executar o ASP.NET em um computador que está usando software antivírus com monitoramento em tempo real habilitada, você pode observar que um aplicativo aleatório é reiniciado, e você recebe a seguinte mensagem de erro no navegador:
Reiniciando o aplicativo.

Descrição: Ocorreu uma exceção não tratada durante a execução da atual solicitação da web. Examine o rastreamento da pilha para obter mais informações sobre o erro e onde foi originado no código.

Detalhes da exceção: System.InvalidOperationException: aplicativo está reiniciando.

Causa

Esse problema ocorre devido a algumas informações de voltar de gravação de aplicativos antivírus os arquivos que eles digitalizar. Sempre que um usuário altera o arquivo de configuração Web.config, o arquivo global.asax ou o conteúdo da pasta bin, o aplicativo deve reiniciar para incorporar essas alterações. Como as alterações de verificação antivírus não podem ser distintos de alterações de arquivo do usuário, o aplicativo é reiniciado quando o software antivírus examina essas pastas.

Observação Esse problema pode ocorrer mesmo quando nenhum erro será retornado. Se os disparadores de software antivírus notificações de alteração, cada notificação de alteração é duplicada na pior das hipóteses: um real alterar notificação e uma notificação de alteração adicional do software antivírus algum tempo posteriormente.

Resolução

Use um dos seguintes métodos para resolver esse problema:
  • Desabilite o monitoramento em tempo real no seu software antivírus.
  • Exclua as pastas de aplicativo da lista de verificação antivírus.
Consulte a documentação do software antivírus para obter instruções sobre como alterar essas configurações.

Com alguns softwares antivírus, você poderá aumentar o atributo delayNotificationTimeout da seção de configuração <httpruntime> no arquivo Web.config para contornar este problema. Esse valor é definido com a seguinte entrada no arquivo Web.config:
<httpRuntime delayNotificationTimeout="5" />
				
o valor padrão é 5 segundos, que às vezes não é suficiente para hardware específico. Para resolver o problema no seu computador, você deve aumentar o valor tempo limite para um valor que funciona para a velocidade de hardware e de computador (por exemplo, 60).

Situação

Esse comportamento é por design.

Mais Informações

Se a atualização do arquivo ocorrer enquanto a primeira solicitação está sendo processada, o ASP.NET rejeitará a solicitação e exibe o erro "O aplicativo está reiniciando" como a notificação ocorre antes do aplicativo é compilado totalmente.

Referências

Para obter informações adicionais sobre os problemas relacionados com o Microsoft Mobile Internet Toolkit, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
310619  (http://support.microsoft.com/kb/310619/ ) PRB: Estado de sessão é perdido no Mobile Web Form aplicativos durante o desenvolvimento

A informação contida neste artigo aplica-se a:
  • Microsoft ASP.NET 1.1
  • Microsoft ASP.NET 1.0
  • Microsoft ASP.NET 2.0
Palavras-chave: 
kbmt kbhttpruntime kbprb KB312592 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 312592  (http://support.microsoft.com/kb/312592/en-us/ )