Makale numarası: 312592 - Son Gözden Geçirme: 10 Eylül 2007 Pazartesi - Gözden geçirme: 4.3

SORUN: ASP.NET'te "Uygulama yeniden başlatılıyor" hatasıyla rasgele uygulama yeniden başlatılıyor

Sistem İpucuBu makale, kullandığınızdan farklı bir işletim sistemine yöneliktir. Sizinle ilgili olmayabilecek makale içeriği devre dışı bırakıldı.
Hepsini aç | Hepsini kapa

Belirtiler

ASP.NET etkin gerçek zamanlı izleme ile virüsten koruma yazılımını kullanan bir bilgisayarda çalıştırdığınızda, rasgele bir uygulamasını yeniden başlatır ve tarayıcıda aşağıdaki hata iletisini aldığınız görebilirsiniz:
Uygulama yeniden başlatılıyor.

Açıklama:, Geçerli web isteği yürütülürken işlenmeyen bir özel durum oluştu. Lütfen hata ve kod içinde kaynaklandığı yer hakkında daha fazla bilgi almak için yığın izlemesini gözden geçirin.

Özel durum ayrıntıları: İletisi: uygulama yeniden başlatılıyor.

Neden

Bu sorun, bazı virüsten koruma uygulamaları yazma geri bilgileri, tarama, dosyaları nedeniyle oluşur. Bir kullanıcı Web.config yapılandırma dosyasına, Global.asax dosyasını ve bin klasörü içeriği her değiştiğinde, bu değişiklikleri birleştirmek için uygulamayı yeniden başlatmalısınız. Virüsten koruma tarama değişiklikler kullanıcının dosya değişikliklerden ayırt edemiyor çünkü virüsten koruma yazılımı, bu klasörler taramasını uygulama yeniden başlatılıyor.

Not Hata döndüğünde bile bu sorun oluşabilir. Virüs tarama yazılımı Tetikleyicileri bildirimleri değiştirirseniz, her değişikliği bildirimi en azından çift: bir reel değiştirme bildirimi ve bir ek değişiklik bildirimi virüsten koruma yazılımı daha sonra bir süre.

Çözüm

Bu sorunu gidermek için aşağıdaki yöntemlerden birini kullanın:
  • Gerçek zamanlı virüsten korunma yazılımınızı izleme devre dışı bırakın.
  • Uygulama klasörleri, virüsten koruma taraması listeden dışta bırakmalısınız.
Lütfen bu ayarları nasıl değiştirileceği hakkında yönergeler için virüsten koruma yazılımınızın belgelerine bakın.

Bazı virüsten koruma yazılımı Web.config dosyasında bu soruna geçici bir çözüm bulmak için <a1><httpruntime></a1> yapılandırma bölümünün delayNotificationTimeout özniteliği artırmanın mümkün olabilir. Bu değer, Web.config dosyasında aşağıdaki girdi ile belirlenir:
<httpRuntime delayNotificationTimeout="5" />
				
Varsayılan değer 5, bazen belirli donanım yeterli olmadığı saniyedir. Bilgisayarınızda bu sorunu gidermek için <a0></a0>, donanım ve bilgisayar hızınızı için (örneğin, 60) çalışan bir değer için zaman aşımı değerini artırın gerekir.

Durum

Bu davranış tasarım yüzündendir.

Daha fazla bilgi

Dosya güncelleştirmesi, ilk isteğin işlenmesi sırasında oluşursa, ASP.NET isteği reddeder ve uygulama tam olarak derlendiğinden önce bildirim oluşur çünkü "Uygulama yeniden başlatılıyor" hatası görüntüler.

Referanslar

Microsoft Mobile ınternet Toolkit ile ilgili sorunlar hakkında ek bilgi için Microsoft Knowledge Base'deki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
310619  (http://support.microsoft.com/kb/310619/ ) SORUN: Oturum durumu Mobile Web Form uygulamaları geliştirme sırasında kaybolur.

Bu makaledeki bilginin uygulandığı durum:
  • Microsoft ASP.NET 1.1
  • Microsoft ASP.NET 1.0
  • Microsoft ASP.NET 2.0
Anahtar Kelimeler: 
kbmt kbhttpruntime kbprb KB312592 KbMttr
Otomatik TercümeOtomatik Tercüme
ÖNEMLİ: Bu makale, bir kişi tarafından çevrilmek yerine, Microsoft makine-çevirisi yazılımı ile çevrilmiştir. Microsoft size hem kişiler tarafından çevrilmiş, hem de makine-çevrisi ile çevrilmiş makaleler sunar. Böylelikle, bilgi bankamızdaki tüm makalelere, kendi dilinizde ulaşmış olursunuz. Bununla birlikte, makine tarafından çevrilmiş makaleler mükemmel değildir. Bir yabancının sizin dilinizde konuşurken yapabileceği hatalar gibi, makale; kelime dağarcığı, söz dizim kuralları veya dil bilgisi açısından yanlışlar içerebilir. Microsoft, içeriğin yanlış çevrimi veya onun müşteri tarafından kullanımından doğan; kusur, hata veya zarardan sorumlu değildir. Microsoft ayrıca makine çevirisi yazılımını sıkça güncellemektedir.
Makalenin İngilizcesi aşağıdaki gibidir:312592  (http://support.microsoft.com/kb/312592/en-us/ )