FIX: SQL Server fails to bind TCP/IP port at startup

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Article ID: 312935 - View products that this article applies to.
This article was previously published under Q312935
BUG #: 76752 (MDAC Bugs)
BUG #: 76801 (MDAC Bugs)
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SYMPTOMS

SQL Server unsuccessfully binds its server-side TCP/IP port at startup. If this occurs:
  • Clients cannot make TCP/IP connections.
-or-
  • When a client computer tries to make a connection to SQL Server, the connection may fail and you receive this error message:
    SQL Server Does Not Exist or Access Denied.
This article discusses one possible cause of this message. Applying the fix that is referenced in this article only helps if you are experiencing this exact same scenario. For other possible causes, see the following articles in the Microsoft Knowledge Base:
293107 PRB: TCP\IP Port in Use by Another Application
319578 PRB: Error Message:"Bind Failed" Occurs After IP Address Changes on a Cluster

CAUSE

Processes that are started from the SQL Server process space can hold a resource which prevents the server from being able to bind its TCP/IP port at startup. There are two scenarios that are currently known to expose this problem:
  • The execution of database maintenance plans by way of SQLAgent jobs which execute the SQLMaint utility by using the xp_sqlmaint extended stored procedure.

    NOTE: This includes SQLAgent jobs that facilitate log shipping.
  • The execution of commands by way of the xp_cmdshell extended stored procedure.
To encounter this problem, the SQL Server process must terminate after the child process begins execution and must be restarted before the child process terminates.

RESOLUTION

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this fix for SQL Server 2000 SP1 should have the following file attributes or later:
   Date         Time   Version             Size   File name
   --------------------------------------------------------------
   30-Nov-2001  12:45  2000.80.472.0      86,588  Ssnetlib.dll
				
The English version of this fix for SQL Server 2000 SP2 should have the following file attributes or later:
   Date         Time   Version             Size   File name
   --------------------------------------------------------------
   14-Oct-2002  18:27  2000.80.692.0      82,492  Ssnetlib.dll
				
The English version of this fix for SQL Server 7.0 should have the following file attributes or later:
   Date         Version         Size     File name
   --------------------------------------------------

   30-Nov-2001  2001.11.26.0    45,328   Ssmsso70.dll
				
NOTE: Because of file dependencies, the most recent hotfix or feature that contains the files may also contain additional files.


WORKAROUND

If you determine that the SQLMaint utility is preventing SQL Server from binding its TCP/IP listen-on port at startup, the properties of each SQLAgent job that executes the SQLMaint utility can be modified to work around the problem.

The essence of the workaround is to execute the SQLMaint executable in an operating system command shell, as opposed to executing the utility by using a call to the xp_sqlmaint extended stored procedure.

Two changes are required to each job step that executes the SQLMaint utility by using the xp_sqlmaint extended stored procedure.
  1. Modify the job step "Type" from "Transact-SQL Script (TSQL)" to "Operating System Command (CmdExec)".
  2. Change the "Command" associated with the job step from an extended stored procedure call to the direct execution of the SQLMaint executable as described above.
    1. Replace the string "EXECUTE master.dbo.xp_sqlmaint" with "SQLMaint" (without the quotes).
    2. Remove the single quotes which encapsulate the parameter list. You must delete the opening single quote, N', and the closing single quote, ', at the end of the parameter list.
The required changes are most easily demonstrated by way of an example. Note the changes made to the following sample command.

Before Required Changes:
EXECUTE master.dbo.xp_sqlmaint N'-PlanID 917F24D5-D71E-41B2-A2FB-FA538954F33E 
-WriteHistory  -BkUpMedia DISK -BkUpDB  -UseDefDir  -BkExt "BAK"'
				
After Required Changes:
SQLMaint -PlanID 917F24D5-D71E-41B2-A2FB-FA538954F33E
-WriteHistory  -BkUpMedia DISK -BkUpDB  -UseDefDir  -BkExt "BAK"
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Properties

Article ID: 312935 - Last Review: April 7, 2006 - Revision: 7.2
APPLIES TO
  • Microsoft SQL Server 2000 Standard Edition
  • Microsoft SQL Server 7.0 Standard Edition
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbbug kbfix kbsqlserv2000presp2fix kbsqlserv700presp4fix KB312935

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