INFO: Wegweiser für Visual Database Tools und typisiertes DataSets

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 313486 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Dieser Artikel wurde archiviert. Er wird im vorliegenden Zustand bereitgestellt und nicht mehr aktualisiert.
Alles erweitern | Alles schließen

Auf dieser Seite

Zusammenfassung

Dieser Artikel enthält einen Wegweiser dieser Artikel, um zu erhalten, und das Microsoft Visual Basic Studio .NET Visual Database Tools zu beherrschen, und gab DataSet Klassen ein.

Wegweiser-Artikel enthalten Verknüpfungen zu nützlichen Informationen, die Online-Dokumentation, Microsoft Knowledge Base-Artikel und Microsoft-White-Papers umfassen, um Ihnen dabei Sie über ein Microsoft-Produkt oder eine Technologie mehr zu erfahren zu helfen. Erhalten Sie Weitere Informationen zu ADO.NET-Technologie-Wegweiser-Artikel, wenn unten auf Artikelnummer klickt, um den Beitrag in dem Microsoft Knowledge Base anzuzeigen:
313590 INFO: Wegweiser für ADO.NET
Erhalten Sie Weitere Informationen zu DataAdapter ADO.NET-Objekt, wenn unten auf Artikelnummer klickt, um den Beitrag in dem Microsoft Knowledge Base anzuzeigen:
313483 INFO: Wegweiser für ADO.NET DataAdapter Objekte

Visual Database Tools

Zu dem Ausführen der folgenden Aufgaben können Sie das Visual Database Tools verwenden:
  • Verbinden Sie zu alle OLE DB-Kompatibeler Datenbank, und durchsuchen Sie alle OLE DB-Kompatibele Datenbank.
  • Erstellen Sie und ändern Sie Microsoft SQL Server-Datenbank, indem Sie Datenbank-Diagramme verwenden.
  • Entwerfen Sie komplexe Abfragen, führen Sie komplexe Abfragen aus, und speichern Sie komplexe Abfragen.
  • Fügen Sie Daten hinzu, das in Datenbank-Tabellen gespeichert wird, aktualisieren Sie Daten, das in Datenbank-Tabellen gespeichert wird, und löschen Sie Daten, das in Datenbank-Tabellen gespeichert wird.
  • Entwurf object Trigger wie Tabellen und speicherte Prozeduren in Microsoft SQL Server- und Oracle-Datenbanken.
  • Ziehen Sie Datenbank-Objekte auf einer Entwurfsoberfläche wie einem Web Form, und binden Sie dann Steuerelemente an die Objekte.
Das Visual Database Tools wird in zwei Hauptkategorien unterteilt:
  • Server-Explorer
  • Verbleibende Tools
Sie können Server-Explorer verwenden, um zu erstellen, Datenbank-Schema zu bearbeiten, und Daten interaktiv zu aktualisieren. Sie können die verbleibenden Tools verwenden, um Code zu generieren, und Eigenschaften zu bearbeiten. Diese anderen Tools wirken sich direkt auf Ihrem Projekt aus, das enthält, typisierte DataSet Klasse zu erstellen, die auf dem Server-Schema basiert.

Einige Überlappung und Interaktion zwischen diesen zwei Kategorien sind. Beispielsweise verwendet Server-Explorer einige Editoren und aus Server-Explorer können Sie eine Tabelle in einer Entwurfsoberfläche ziehen, um Codegeneratoren aufzurufen.

Wie folgt lauten die Hauptkomponenten von Server-Explorer: Das andere Visual Database Tools lautet wie folgt: Hinweis: Visual Database Tools-Extras unterstützen das SqlClient und den OleDb .NET Data Providers. Andere Anbieter, wie dem ODBC .NET-Datenanbieter und dem .NET-Datenanbieter für Oracle dass nach Visual Studio .NET freigab, werden nur in einer sehr eingeschränkten Weise unterstützt. Sie können jedoch den Code verwenden, die für einen Datenprovider generiert wird und es ändert damit es mit anderem funktionieren.

Server-Explorer

In Server-Explorer können Sie Datenbank-Schema anzeigen, Sie können Schema der SQL Server-Datenbank bearbeiten, Sie können Daten interaktiv abrufen und in der integrierten Entwicklungsumgebung (IDE) von Visual Studio .NET können Sie Daten interaktiv ändern.

Die Verbindungen werden in einer Strukturansicht dargestellt. Sie können dem Knoten Server oder dem Knoten Datenverbindungen Verbindungen hinzufügen.
  • Wenn Sie Verbindungen zu dem Knoten Server hinzufügen, ist einer der unterordneten Knoten SQL Server. Wenn Sie Tabellen von unter dem Knoten von SQL Server ziehen, werden das SqlConnection und die SqlDataAdapter Komponenten Ihrem Projekt so hinzugefügt.
  • Wenn Sie eine OLE DB-Verbindung über den Knoten Datenverbindungen hinzufügen, wird das Dialogfeld Datenverknüpfungseigenschaft angezeigt.

    Hinweis: Das OLE DB-Verbindungsdialogfeld enthält Verbindungen, die ADO.NET wie dem Microsoft OLE DB Provider für ODBC nicht unterstützt.
  • Wenn Sie eine Tabelle von unter dem Knoten Datenverbindungen in Ihrem Projekt ziehen werden das OleDbConnection und die OleDbDataAdapter Objekte erstellt und konfiguriert. Wenn Sie Microsoft SQL Server 7.0 oder höher Version herstellen, werden das SqlConnection und die SqlDataAdapter Komponenten stattdessen hinzugefügt.
Finden Sie Weitere Informationen Sie diese Komponenten zu konfigurieren, unter Verwenden der Anderes Visual Database Tools Abschnitt.

Server-Explorer enthält für das Bearbeiten von SQL Server mehrere Editoren. Sie können in der Strukturansicht mit der rechten Maustaste auf den Knoten Datenverbindungen klicken, um eine neue SQL Server-Datenbank zu erstellen. Mit der rechten Maustaste können Sie das Tabellen, die Ansichten, die gespeicherte Prozedur und die Knoten von Datenbank-Diagramm klicken, um zu erstellen, oder eine Tabelle, eine Ansicht, eine gespeicherte Prozedur oder ein Datenbank-Diagramm jeweils zu ändern. Außerdem können Sie SQL-Skript, das Sie ausführen können, generieren gegen einem anderen die Datenbank neu mit einem Server erstellenden Server. Ebenfalls verfügbar dieser meist Funktionen, wie dem Erstellen und dem Ändern von Tabellen und gespeicherten Prozeduren für Oracle-Versionen ist.

Datenbankdesigner

Sie können den Datenbankdesigner verwenden, um Datenbank-Diagramme zu bearbeiten, und Beziehungen zu erstellen, indem Sie Felder aus Tabelle an anderes ziehen.
Datenbankdesigner
http://msdn.microsoft.com/en-us/library/ms171971.aspx
back to the list of tools

Tabellendesigner

Sie können den Tabellendesigner zu dem Erstellen oder dem Ändern von Tabellen in der Datenbank verwenden. Sie können Feldname, Datentypen, Einschränkungen und Indexe zwischen anderen Elementen angeben oder Sie können ändern.

Findet weitere Informationen zu dem Tabellendesigner auf dem folgenden Website von Microsoft:
Tabellendesigner
http://msdn.microsoft.com/en-us/library/aa290301.aspx
back to the list of tools

Abfrage-Designer

Der Abfrage-Designer wird gemeinsam von anderen Datenkomponenten wie den Komponenten Command und DataAdapter genutzt. Sie können den Abfrage-Designer verwenden, um Abfragen visuell zu entwerfen, und die Ergebnisse der Abfrage anzuzeigen. Wenn Sie eine Ansicht in dem Datenadapter-Konfigurations-Assistenten oder wenn Sie die CommandText Eigenschaft eines Befehls oder einer Komponente DataAdapter bearbeiten, erstellen oder wenn bearbeiten, wird der Abfrage-Designer in Server-Explorer aufgerufen, um die SQL-Anweisung zu erstellen für Sie. Das SQL, das nur Code generiert, zitiert Bezeichner für Microsoft SQL Server, Microsoft Jet und Oracle. Die Bezeichner werden unquoted sein, wenn Sie ein andere Datenbank End Back verwenden. Wenn Ihre Datenbank nicht standardmäßige Tabelle oder Feldname enthält, stellt das ein Problem eventuell dar. Beispielsweise enthalten die Namen ein Leerzeichen oder anderes nicht-alphanumerisches Zeichen. Um dieses Problem zu beheben, müssen Sie Änderungen manuell an das SQL in dem generierten Code vornehmen. Wenn Sie das SQL neu generieren, werden die Änderungen jedoch verlorengehen.

Findet weitere Informationen zu dem Abfrage-Designer auf dem folgenden Website von Microsoft:
Abfrage-Designer
http://msdn.microsoft.com/en-us/library/ms172013.aspx
back to the list of tools

SQL-Editor

Wenn Sie eine gespeicherte Prozedur erstellen, wird das SQL-Editor aufgerufen. Das SQL-Editor ermöglicht Klarheit zu Ihrem T-SQL, zu Ihrer Anweisung von PL/SQL und von Grenzen zu Ihren einzelnen Anweisungen einem Rechteck das SQL-Editor zu farbcodieren. Bei dem Bearbeiten von Multistatement SQL-Skript können Sie mit der rechten Maustaste zudem auf einzelne Anweisungen klicken und den Abfrage-Designer visuell zu dem Verfassen oder dem Bearbeiten dieser Anweisungen verwenden.

Findet weitere Informationen zu dem SQL-Editor auf dem folgenden Website von Microsoft:
SQL-Editor
http://msdn.microsoft.com/en-us/library/ms172018.aspx
back to the list of tools

Anderes Visual Database Tools

Die Tools, die in diesem Abschnitt aufgelistet werden, schreiben Code in Ihrem Projekt. Sie können diesen Code ändern oder Sie können entsprechenden Code schreiben. Einige Tools wie dem Datenformularassistent generieren eine Windows Form-Klasse, die DataAdapter Komponenten, typisiertes DataSet DataAdapter und ein gebundenes Steuerelement DataAdapter umfasst. Wie dem Bearbeiten des -Auflistung eines einzelnen Befehls des Parameter führen andere Dienstprogramme wie dem Parameter - Auflistungs - Editor beschränktere Aufgaben aus.

Datenformularassistent

Der Datenformularassistent ähnelt dem Formularassistent in Microsoft Access. Mit dem Datenformularassistent können Sie eine oder zwei Tabellen auf dem Server angeben und Anzahl der Formate können Sie dann auswählen. Der Assistent konfiguriert anschließend, wie in dem Windows Forms die Elemente angezeigt werden.

Der Datenformularassistent führt die folgenden Aufgaben aus:
  • Sie erstellen ein typisiertes DataSets für die Tabellen, die Sie auswählen.
  • Verbindung, Befehl und DataAdapter erstellen Objekte, um abzurufen, und Daten zu aktualisieren.
  • Erstellt Steuerelemente auf dem Formular, und bindet diese Steuerelemente an das typisierte DataSet.
Besuchen Sie für weitere Information das folgende Websites von Microsoft:
Datenformularassistent
http://msdn2.microsoft.com/en-us/library/aa291437(VS.71).aspx

Dialogfeld Erweiterte SQL - Generierungsoptionen
http://msdn.microsoft.com/en-us/library/2ft8f67x.aspx

Von dem DataForm - Assistenten generierter Code
http://msdn.microsoft.com/en-us/library/aa291843.aspx
back to the list of tools

XSD-Editor

Sie können das XSD Editor verwenden, um zu erstellen, und eine XML Schema Definition Language (XSD) Schemadatei in Ihrem Projekt zu bearbeiten. Sie können die XSD-Datei, wie geradem XML oder in einem grafischen Editor, das dem Tabellendesigner und Database Designer of Server Explorer ähnelt, bearbeiten.

Sie können ein typisiertes DataSet aus einer XSD-Datei generieren, indem Sie die Custom Tool Eigenschaft zu MSDataSetGenerator festlegen. Die DataSet Klassendatei ist ein Teil keines Projekts, wenn Sie diese Eigenschaft leer diese Eigenschaft lassen, und die DataSet Klassendatei wird von dem Datenträger gelöscht.

back to the list of tools

XML-Editor

Um eine XML-Datei in Ihrem Projekt zu bearbeiten, können Sie das XML-Editor verwenden. Sie können das TEXTTAGESXML durch eine Schnittstelle, die die Farbencodierung unterstützt, und Abschluss oder durch ein hierarchisches, tabellarisches Editor bearbeiten.

back to the list of tools

Verbindung, Befehl, DataAdapter, DataSet und DataView-Komponenten

Sie können diese Komponenten aus der Registerkarte Daten der Tool-Box hinzufügen oder um hinzuzufügen, und diese Komponenten zu konfigurieren für Sie können Sie Server-Explorer oder den Datenformularassistenten verwenden.

Für die Datenbindung von Entwurfszeit können Sie die typisierte DataSet Komponente verwenden. Kann sich bei Datenbindung gelegentlich um das Verwechseln handeln. Beispielsweise ermöglicht der Designer Ihnen nur in einem Windows Form, einfache Methodensteuerelemente zu einer Datenquelle zu binden, aber Sie können ein Steuerelement DataGrid oder die List einer ListBox Steuerelement oder eines Boxsteuerelements Combo auf zwei anderen Arten binden. Eine dieser Methoden ist mit der Möglichkeit, mit der einfache Steuerelemente gebunden sind, nicht kompatibel. Unter Verwendung einer DataView Komponente können Sie sicherstellen, dass alle Steuerelemente Ihre konsistent gebunden sind.

Sie können Anzahl der Generatoren aus den Eigenschaften der verschiedenen Komponenten öffnen. Beispiel:
  • Öffnen Sie das Dialogfeld Datenverknüpfungseigenschaft von der Komponente Connection.ConnectString.
  • Öffnen Sie den Abfrage-Generator, der dem Abfrage-Designer von der Komponente Command.CommandText ähnelt.
  • Öffnen Sie das Parameter - Auflistungs - Editor von der Komponente Command.Parameters.
  • Öffnen Sie das Table Mapping Editor und das Column Mapping Editor von der Komponente DataAdapter.TableMappings.
Sie können eine DataAdapter Konfiguration testen, indem Sie auf Datenvorschau in dem Eigenschaftsfenster klicken. Das zeigt die Daten in einem Datenblatt an.

back to the list of tools

Dialogfeld DataSet

Wenn Sie die grafische Entwurfsoberfläche oder eine Komponente DataAdapter auswählen, wird ein Hyper-Link DataSet an dem unteren Rand des Eigenschaftsfensters angezeigt. In dem Dialogfeld DataSet können Sie eine oder mehrere Komponenten DataAdapter auf der Entwurfsoberfläche zu Abfrage der Schemainformationen auswählen. Der Assistent erstellt die XSD-Schemadatei und gab dann für Sie DataSet Klasse ein. Die Option, eine Instanz der DataSet Klasse der Entwurfsoberfläche als eine Komponente Sie hinzuzufügen, wird außerdem in dem Assistent angezeigt.

Findet weitere Informationen zu dem Dialogfeld DataSet auf dem folgenden Website von Microsoft:
Dialogfeld DataSet
http://msdn2.microsoft.com/en-us/library/28xee971(vs.71).aspx
back to the list of tools

Datenadapter-Konfigurations-Assistenten

Mit dem Datenadapter-Konfigurations-Assistenten können Sie ein DataAdapter, das durch Server-Formular-Daten-Tool-Explorer manuell durch den Assistenten oder von der Box hinzugefügt wird, konfigurieren. Dieser Assistent umfasst die folgenden Optionen:
  • Generieren Sie SQL-Anweisungen mit der Überprüfung oder ohne die Überprüfung vollständiger Parallelität.
  • Vorhandene gespeicherte Prozeduren verwenden.
  • Generieren Sie neue gespeicherte Prozeduren.
Um die Abfragen zu bearbeiten, können Sie den Abfrage-Designer verwenden. Die generierte SQL-Anweisung zitiert Bezeichner nur für Microsoft SQL Server, Microsoft Jet und Oracle. Die Bezeichner werden unquoted sein, wenn Sie ein andere Datenbank-Backend verwenden. Wenn Ihre Datenbank nicht standardmäßige Tabelle oder Feldname enthält, kann das ein Problem bereiten. Die Namen enthalten z. B. ein Leerzeichen oder anderes nicht-alphanumerisches Zeichen. Um dieses Problem zu beheben, müssen Sie zu dem SQL in dem generierten Code Änderungen manuell durchführen werden. Wenn Sie das SQL neu generieren, werden die Änderungen jedoch verlorengehen.
Wenn Sie vollständige Parallelität auswählen, wird mit den Werten in der Datenbank der ursprüngliche Wert aller Felder überprüft. Wenn Sie einen TimeStamp oder ein ähnliches Versionsnummernfelder zu Vereinfachung der SQL-Anweisung und dem Reduzieren der Datennutzlast verwenden möchten, müssen Sie in Code oder durch den Abfrage-Designer Sie die Abfragen erstellen.

Findet weitere Informationen zu dem Daten-Adapter-Konfigurations-Assistent auf dem folgenden Website von Microsoft:
Daten-Adapter-Konfigurations-Assistent
http://msdn.microsoft.com/en-us/library/kb6bw5z5.aspx
back to the list of tools

Parameter - Auflistungs - Editor

Zu dem Zuordnen von Befehlsparametern auf Spalten in dem zugeordneten DataTable können Sie das Parameter - Auflistungs - Editor verwenden. Sie können den Parameter auf einer bestimmten Zeilenversion außerdem zuordnen. Wenn Sie eine Spalte aktualisieren, wird der neue Wert beispielsweise aus der aktuellen Version der Zeile abgerufen. Parameter in der WHERE-Klausel, die für die Überprüfung von Parallelität verwandt werden, erhalten ihren Wert aus der ursprünglichen Version der Zeile jedoch.

Findet weitere Informationen zu dem Editor für die Parameters - Auflistung auf dem folgenden Website von Microsoft:
Editor für die Parameters - Auflistung
http://msdn.microsoft.com/en-us/library/5xh44k5s.aspx
back to the list of tools

Tabellenzuordnung und Spalte-Zuordnungseditoren

Mit dem DataAdapter können Sie Tabellen- und Feldname zuordnen, so dass die Namen, die bei einem DataSet verwandt werden, nicht damit übereinstimmen müssen, die in der Datenbank verwandt wird. Zu dem Zuordnen von Tabellen- und Feldname, die in der Datenbank zu unterschiedlicher Tabelle verwandt werden, und von Feldname in einem DataSet können Sie die Tabellenzuordnung und den Column Mapping Editors verwenden.

Findet weitere Informationen zu dem Dialogfeld Table Mappings auf dem folgenden Website von Microsoft:
Dialogfeld Tabellenzuordnungen
http://msdn.microsoft.com/en-us/library/hc615e85.aspx
back to the list of tools

Dialogfeld Datenverknüpfungseigenschaften

Wenn Sie die ConnectString Eigenschaft in einer Komponente Verbindung auswählen, können Sie auf Datenverknüpfungseigenschaft klicken, um Datenverknüpfungseigenschaft zu einer neuen Datenquelle zu verbinden. Die Datenquelle muss eine Datenbank in SQL Server 7.0 oder später sein, wenn Sie eine SqlConnection Komponente verwenden, oder Sie werden einen Fehler erhalten. Das ist dasselbe Dialogfeld, das verwandt wird, um eine neue Verbindung von Server-Explorer hinzuzufügen.

back to the list of tools

Typisiertes DataSets

Eins der end product von dem Visual Database Tools ist DataSet die stark typisierte Klasse. Um die DataSet Klasse zu generieren, können Sie eine der folgenden Methoden verwenden:
  • Klicken Sie auf DataSet in dem Eigenschaftsentwurfsfenster DataAdapter von einer Komponente ( oder auf der Oberfläche).
  • Klicken Sie in dem Menü Datei auf Neues Element hinzufügen, um dem Projekt ein DataSet Element hinzuzufügen.
Beide Methoden legen eine XSD-Schemadatei und eine zu verknüpfte, und eine Klasse sein ausgeblendete Klasse Microsoft Visual Basic .NET oder Microsoft Visual C# .NET in Ihrem Projekt ab. Wenn Sie das DataSet erstellen wird ein DataAdapter Objekt die Schemadatei für Sie abgeschlossen und die DataSet Klasse beschreibt das XSD-Schema, die erstellt wird. Die XSD-Datei ist leer, wenn Sie die Datei hinzufügen, indem Sie auf Neues Element hinzufügen in dem Menü Datei klicken und Sie müssen das Schema erstellen.

Wann immer die Schemadatei Sie bearbeiten, wird die DataSet Klassendatei automatisch umschrieben. Wenden Sie eine der folgenden Methoden an, wenn Sie die DataSet Klasse anpassen möchten:
  • Sie können Unterklasse die DataSet Klasse und Sie ändern die Unterklasse. Ihre Änderungen gehen nicht verloren, wenn die DataSet Klassendatei regeneriert wird.
  • Aus dem Projekt können Sie die XSD-Datei entfernen und Sie können wieder Ihrem Projekt manuell dann die zugehörige Klassendatei hinzufügen. Das entfernt die Verknüpfung zwischen den Designern und der Klasse. Die DataSet Klassendatei wird statisch, damit alle Änderungen, die Sie vornehmen, nicht später überschrieben werden. Falls es alle Schemaänderungen gibt, wird die Klassendatei nicht aktualisiert, um diese Änderungen wiederzugeben. Daher ist ein Risiko an dieser Methode.
Das typisierte DataSet beinhält eine Reihe von Vorteilen über ein Standarddataset -Objekt:
  • Die IntelliSense-Funktion ist für Tabellen- in dem Codeeditor und Feldname in dem Codeeditor verfügbar. Das verhindert Fehler codieren.
  • Da das Schema in der Klassendefinition kompiliert wird, kann Schemafehler der Compiler abfangen. Mit der Standardklasse Dataset werden Schemafehler nur zu Ausführungszeit abgefangen.
  • Sie müssen das Schema zu Ausführungszeitpunkt nicht downloaden, da das Schema in der Klassendefinition kompiliert wird. Das bietet einen Leistungsvorteil.
  • Das typisierte DataSet greift als Eigenschaften als Auflistungselemente auf Tabellen- und Feldname zu. Das bietet Leistungsvorteile außerdem.
  • Sie können Steuerelemente zu Entwurfszeit zu Ausführungszeitpunkt binden.
Das typisierte DataSet beinhält Anzahl der Einschränkungen, da das Schema in der Klassendefinition kompiliert wird:
  • Wenn sich das Server-Schema ändert, müssen Sie Ihr Projekt neu erstellen. Das ist nicht ein Hauptaufwand für die meist Anwendungen, da die meist Anwendungen geändert werden müssen, wenn das Schema ändert. Server-Schema ist normalerweise bereits gut und relativ statisch in Anwendungen von unternehmensweiten.
  • Wenn Sie das Feld direkt lesen, wird eine Fehlermeldung Ihnen angezeigt, wenn Sie versuchen, auf Felder zuzugreifen, die einen Nullwert enthalten können. Sie müssen zuerst die Is<VAR>xxx</VAR>Null Eigenschaft verwenden. Wenn Sie den Feldwert festlegen, müssen Sie die Set<VAR>xxx</VAR>Null Methode verwenden, um einen Nullwert in der Tabelle zu speichern.

    Hinweis: ein gebundenes Steuerelement verarbeitet das automatisch.

Schrittweise Anleitungen, Hilfethemen von Visual Studio .NET und Microsoft Knowledge Base-Artikel

Schrittweise Anleitungen stellen Mini-tutorials bereit, die Sie durch typische Anwendungsentwicklungsszenarios führen. "How To" Microsoft Knowledge Base-Artikel enthalten schrittweise Anleitungen über das Durchführen bestimmter Aufgaben.

Der Hilfethema, die exemplarische Vorgehensweise und die Microsoft Knowledge Base-Artikel in den Abschnitten von Visual Studio .NET zu folgen, beschreiben, wie Visual Database Tools und das typisierte DataSet verwandt werden.

Hinweis: wie Verwendung des Visual Database Tools, um eine bestimmte Aufgabe durchzuführen, demonstrieren die exemplarischen Vorgehensweisen in dem Abschnitt zu folgen; die exemplarischen Vorgehensweisen sind nicht ein allgemeines Lernprogramm zu den Tools.

Schrittweise Anleitunge

Klicken Sie in dem Menü Hilfe in dem Visual Studio .NET auf Index. Geben Sie in dem Feld Suchen nach ein Walkthroughs, data . Der Indexergebnissebereich zeigt eine Liste von exemplarischer Datenzugriffsvorgehensweise an.
Walkthrough: Creating a Master-Detail Windows Form
http://msdn.microsoft.com/en-us/library/aa984462.aspx
This walkthrough uses a DataAdapter component. The DataAdapter Configuration Wizard builds a typed DataSet. The walkthrough uses the XSD Editor to create a DataRelation and then binds controls through the Property window to the typed DataSet.
Adding Tables and Columns to the Windows Forms DataGrid Control
http://msdn.microsoft.com/en-us/library/aa984314.aspx
This article demonstrates how to customize the appearance of a bound Windows Form DataGrid control by adding DataGridTableStyle and DataGridColumnStyle objects through an editor that is opened from the Property window.

Hilfethemen von Visual Studio .NET

Neue Datenfeatures
http://msdn.microsoft.com/en-us/library/87sfaezs.aspx

Visual Database Tools
http://msdn.microsoft.com/en-us/library/y5a4ezk9.aspx

Einführung in den Server - Explorer
http://msdn.microsoft.com/en-us/library/t900cyed.aspx

Datenbanken im Server - Explorer
http://msdn.microsoft.com/en-us/library/byads6a9.aspx

Erstellen von Datenadaptern mit dem Server - Explorer
http://msdn.microsoft.com/en-us/library/aa984315.aspx

Sie unter Erstellen von Datenadaptern mit einem Assistenten
http://msdn.microsoft.com/en-us/library/zc6tc8ew.aspx

Manuelles Erstellen und Konfigurieren von Datenadaptern
http://msdn.microsoft.com/en-us/library/z92w563z.aspx

Erstellen neuer typisierter Datasets mit dem XML - Designer
http://msdn.microsoft.com/en-us/library/1k3xyssf.aspx

Microsoft Knowledge Base-Artike

315678 Wie: ACC2002 erstellt und Sie verwenden ein typisiertes DataSets, indem Sie Visual Basic .NET verwenden
320714 Wie: ACC2002 erstellt und Sie verwenden ein typisiertes DataSets, indem Sie VISUAL C#-.NET verwenden
318039 Welcher VERFAHRENSWEISE: TO: indem ein typisiertes DataSet Return Visual Basic .NET verwendet, treffen einen Standardwert statt DBNull Sie einem typisierten DataSet Return
318048 Welcher VERFAHRENSWEISE: TO: indem ein typisiertes DataSet Return visuelles C#-.NET verwendet, treffen einen Standardwert statt DBNull Sie einem typisierten DataSet Return

Beheben

Wenn Probleme auftreten oder wenn Sie Fragen haben, können Sie in den MSDN-Newsgroups finden, in denen Sie Ihre Erfahrungen für Ihre Peer freigeben können. Sie können das Microsoft Knowledge Base auch wo zu dem Suchen kann nach Artikeln zu bestimmten Problemen verwenden.
MSDN-Newsgroups
http://msdn.microsoft.com/newsgroups/

Durchsuchen der Base
http://support.microsoft.com/search/?adv=1
Die Fremd-Anbieter-Produkte, die in diesem Artikel beschrieben werden, werden von Lieferanten hergestellt, die von Microsoft unabhängig sind. Microsoft gewährt keine implizite oder sonstige Garantie in Bezug auf die Leistung oder Zuverlässigkeit dieser Produkte

Eigenschaften

Artikel-ID: 313486 - Geändert am: Montag, 24. Februar 2014 - Version: 6.10
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft ADO.NET 1.1
  • Microsoft ADO.NET 1.0
  • Microsoft Visual Studio .NET 2003 Enterprise Architect
  • Microsoft Visual Studio .NET 2003 Enterprise Developer
  • Microsoft Visual Studio .NET 2003 Academic Edition
  • Microsoft Visual Studio .NET 2002 Professional Edition
  • Microsoft Visual Studio .NET 2002 Enterprise Architect
  • Microsoft Visual Studio .NET 2002 Enterprise Developer
  • Microsoft Visual Studio .NET 2002 Academic Edition
Keywords: 
kbnosurvey kbarchive kbarttyperoadmap kbinfo kbsystemdata KB313486 KbMtde kbmt
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 313486
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com