INFO: Guía para Visual Database Tools y DataSets con tipo

Seleccione idioma Seleccione idioma
Id. de artículo: 313486 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Expandir todo | Contraer todo

En esta página

Resumen

Este artículo proporciona una guía si desea obtenerse y si domina el Visual Database Tools de .NET de Estudio Visual Basic y escribió clases DataSet.

Los artículos de la guía básica proporcionan vínculos a información útil, que incluyen información en línea, artículos de Microsoft Knowledge Base y notas de productos de Microsoft, que le ayudan a aprender acerca de un producto o tecnología de Microsoft Para información adicional acerca de artículos de guía de tecnología de ADO.NET, haga clic en el número de artículo siguiente para ver el artículo en el Microsoft Knowledge Base:
313590 INFORMACIÓN: Guía ADO.NET Para
Para información adicional acerca de objetos DataAdapter de ADO.NET, haga clic en el número de artículo siguiente para ver el artículo en el Microsoft Knowledge Base:
313483 INFORMACIÓN: Objetos de guía DataAdapter de ADO.NET Para

Visual Database Tools

Puede utilizar el Visual Database Tools para realizar las tareas siguientes:
  • Conecte y explore cualquier base de datos compatibles con OLE DB.
  • Cree y modifique bases de datos de Microsoft SQL Server utilizando diagrama de base de datos.
  • Diseñe, ejecute y guarde consultas complejas.
  • Agregue, actualice y elimine datos que están almacenados en tablas de base de datos.
  • El diseño objeta desencadenadores como tablas y almacenó procedimientos en bases de datos de Microsoft SQL Server y de Oracle.
  • Arrastre objetos de base de datos a una superficie de diseño tal como un formulario Web Forms y pueda enlazar controles luego a aquellos objetos.
El Visual Database Tools se divide en dos categorías principales:
  • Explorador de servidores
  • Herramientas restantes
Puede utilizar Explorador de servidores para crear, modificar esquema de base de datos y actualizar datos de forma interactiva. Puede utilizar las herramientas restantes para generar código y modificar propiedades. Estas otras herramientas afectan directamente a su proyecto que incluye generar clase DataSet con tipo basada en el esquema de servidor.

Hay alguna superposición e interacción entre estas dos categorías. Por ejemplo, Explorador de servidores utiliza algunos editores y puede arrastrar una tabla a una superficie de diseño desde Explorador de servidores para invocar generadores de código.

Los componentes principales de Explorador de servidores son como sigue: El otro Visual Database Tools es como sigue: NOTA: Las Visual Database Tools sólo admite el SqlClient y los Proveedores de Datos de .NET de OleDb. Otros proveedores tales como el proveedor de datos ODBC .NET y el proveedor de datos .NET para Oracle que se liberó después de Visual Studio .NET sólo se pueden usar en un modo muy limitado. Sin embargo, puede utilizar el código que se genera para un proveedor de datos y que lo modifica para funcionarlo con otro.

Explorador de servidores

Con Explorador de servidores, puede ver esquema de base de datos, editar esquema de base de datos de SQL Server, recuperar datos de forma interactiva y modificar datos de forma interactiva en el entorno de desarrollo integrado de Visual Studio . NET (IDE).

Las conexiones se representan en una vista de árbol. Puede agregar conexiones al nodo Servidores o al nodo Conexiones de datos.
  • Si agrega conexiones al nodo Servidores, uno de los nodos secundarios es servidores SQL Server. Si arrastra tablas por debajo del nodo Servidores SQL, el SqlConnection y los componentes SqlDataAdapter se agregan a su proyecto.
  • Si agrega una conexión OLE DB a través del nodo Conexiones de datos, el cuadro de diálogo Propiedades de vínculo de datos aparece.

    NOTA: El cuadro de diálogo de conexión OLE DB incluye conexiones no permitidas por ADO.NET tal como el Microsoft OLE DB Provider for ODBC.
  • Si arrastra una tabla por debajo del nodo Conexiones de datos hasta su proyecto, se crea y están configurados. En su lugar, si conecta a Microsoft SQL Server, versión 7.0 o posterior, se agrega el SqlConnection y los componentes SqlDataAdapter.
Para más información acerca de cómo configurar estos componentes, ve Otro Visual Database Tools sección.

Explorador de servidores incluye varios editores para manipular SQL Server. En la vista de árbol, puede hacer clic con el botón secundario en el nodo Conexiones de datos para crear una base de datos de SQL Server nueva. Puede hacer clic con el botón secundario en la Tablas, en la Vistas, en los procedimientos almacenados y en los nodos Diagramas de base de datos para crear o modificar respectivamente una tabla, una vista, unos procedimientos almacenados o un diagrama de base de datos. También puede generar secuencia de comandos SQL que puede ejecutar contra un servidor diferente que vuelve a crear la base de datos. También estas más muchas funciones como crea y modifica tablas y procedimiento almacenado están disponibles para base de datos de Oracle.

Diseñador de bases de datos

Puede utilizar el Diseñador de bases de datos para modificar diagrama de base de datos y crear relaciones arrastrando campos de tabla a otro.
Diseñador de bases de datos
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vdbt7/html/dvovrDatabaseDesigner.asp
back to the list of tools

Diseñador de tablas

Puede utilizar el Diseñador de tablas para crear o modificar tablas de la base de datos. Puede especificar o modificar nombres de campo, tipos de datos, restricciones e índices entre otros elementos.

Para más información acerca del Diseñador de tablas, visite el sitio Web de Microsoft siguiente:
Diseñador de tablas
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vdbt7/html/dvconTableDesigner.asp
back to the list of tools

Consulta y Diseñador de consultas y vistas

El Query y el Diseñador de consultas y vistas son compartidos por otros componentes de datos como los componentes Command y DataAdapter. Puede utilizar la Consulta y el Diseñador de vistas para diseñar consultas visualmente y ver los resultados de la consulta. En Explorador de servidores, al crear o editar una vista en el Asistente para la configuración del adaptador de datos o cuando edita la propiedad CommandText de Command o un componente DataAdapter, la Consulta y el Diseñador de consultas y vistas se invocan para generar la instrucción SQL para usted. El SQL que genera sólo código entrecomilla identificadores para Microsoft SQL Server, Microsoft Jet y Oracle. Si utiliza una base de datos diferente de servidor, los identificadores serán unquoted. Esto puede suponer un problema si su base de datos contiene tabla no estándar o nombres de campos. Por ejemplo, los nombres contienen un espacio u otro carácter no alfanumérico. Para corregir este problema, debe realizar cambios manualmente en el SQL en el código generado. Sin embargo, si vuelve a generar el SQL, se perderán los cambios.

Para más información acerca de la Consulta y Diseñador de consultas y vistas, visite el sitio Web de Microsoft siguiente:
Consulta y Diseñador de consultas y vistas
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vdbt7/html/dvconQueryDesignerLayout.asp
back to the list of tools

Editor SQL

Se invoca el Editor SQL cuando crea un procedimiento almacenado. El Editor SQL proporciona a claridad su T-SQL, su instrucción de PL/SQL y sus instrucciones individuales de límites con un rectángulo codificado con colores. Además, al editar secuencia de comandos SQL multistatement, puede hacer clic con el botón secundario en instrucciones individuales y utilizar el Query y el Diseñador de vistas para redactar o modificar estas instrucciones visualmente.

Para más información acerca del Editor SQL, visite el sitio Web de Microsoft siguiente:
Editor SQL
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vdbt7/html/dvconSQLEditor.asp
back to the list of tools

Otro Visual Database Tools

Las herramientas enumeradas en esta sección escriben código en su proyecto. Puede modificar este código o escribir código equivalente. Algunas herramientas tal como el Asistente para formularios de datos generan una clase de formularios Windows Forms que incluye componentes, un DataSet con tipo y controles dependientes DataAdapter. Otras herramientas tal como el Editor de la colección Parameter realizan tareas más limitadas tal como editan la colección Parameters de un Command único.

Asistente para formularios de datos

El Asistente para formularios de datos es similar al Asistente para formularios en Microsoft Access. Con el Asistente para formularios de datos, puede especificar una o dos tablas del servidor y elegir entonces un número de estilos. Después, el asistente configura cómo aparecen los elementos en el formulario Windows Forms.

El Asistente para formularios de datos realiza las tareas siguientes:
  • Crea un DataSet con tipo de las tablas que selecciona.
  • Crea objetos Connection, Command y DataAdapter para recuperar y actualizar datos.
  • Crea controles del formulario y enlaza estos controles al DataSet con tipo.
Para obtener más información, visite los siguientes sitios Web de Microsoft (pueden estar en inglés)
Asistente para formularios de datos
http://msdn2.microsoft.com/en-us/library/aa291437(VS.71).aspx

Cuadro avanzado de generación de diálogo SQL Opciones
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vsintro7/html/vxurfAdvancedSQLGenerationOptionsDialogBox.asp

Código Asistente para formularios de datos generado
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vsintro7/html/vxconDataFormWizardGeneratedCode.asp
back to the list of tools

Editor XSD

Puede utilizar el XSD Editor para crear y editar un archivo de esquema acerca de del lenguaje XSD (XSD) de su proyecto. Puede modificar el archivo XSD como Lenguaje de marcado extensible recto o en un editor gráfico que es similar al Diseñador de tablas y Diseñador de bases de datos de Explorador de servidores.

Puede generar un DataSet con tipo de un archivo XSD estableciendo la propiedad Custom Tool en MSDataSetGenerator. Si deja esta propiedad en blanco, el archivo de clase DataSet no forma una parte ya del proyecto y se eliminará del disco.

back to the list of tools

Editor XML

Puede utilizar el Editor XML para modificar un archivo XML en su proyecto. Puede editar el XML a través de un editor jerárquico, tabular, a través de un interfaz de texto que admite la codificación en colores y finalización de etiqueta o.

back to the list of tools

Componentes de conexión, de Comando, de DataAdapter, de DataSet y de DataView

Puede agregar estos componentes en la ficha Datos de la herramienta o utilizar Explorador de servidores o el Asistente para formularios de datos para agregar y configurar estos componentes para usted.

Puede utilizar el componente DataSet con tipo para el enlace de datos en tiempo de diseño. Enlace de datos puede ser confundir ocasionalmente. Por ejemplo, en un formulario Windows Forms, el diseñador sólo permite enlazar controles sencillos de una forma a un origen de datos a él pero puede enlazar un control DataGrid o la lista de un control ListBox o un control ComboBox de dos maneras diferentes. Una de estas formas es incompatible con la forma con la que están enlazados los controles sencillos. Utilizando un componente DataView, se puede asegurar de que todos sus controles se enlazan de forma coherente.

Puede abrir un número de generadores de las propiedades de varios de los componentes. Por ejemplo
  • Abra el cuadro de diálogo Propiedades de vínculo de datos del componente Connection.ConnectString.
  • Abra el Generador de consultas que es similar a la Consulta y Diseñador de consultas y vistas del componente Command.CommandText.
  • Abra el Editor de la colección Parameter del componente Command.Parameters.
  • Abra el Table Mapping Editor y el Column Mapping Editor del componente DataAdapter.TableMappings.
Puede probar una configuración DataAdapter haciendo clic en Vista previa de datos en la ventana Propiedades. Esto muestra los datos en una cuadrícula.

back to the list of tools

Genere cuadro conjunto de datos Cuadro de diálogo

Cuando selecciona la superficie de diseño gráfico o un componente DataAdapter, un hipervínculo Generar conjunto de datos aparece en la parte inferior de la ventana Propiedades. En el cuadro de diálogo Generar conjunto de datos, puede seleccionar uno o más componentes DataAdapter en la superficie de diseño a consulta de información de esquema. El asistente genera el archivo de esquema XSD y escribió a continuación clase DataSet para usted. También el asistente ofrece la opción de que agrega una instancia de la clase DataSet a la superficie de diseño como un componente.

Para más información acerca de los cuadros de diálogo Generar conjunto de datos, visite el sitio Web de Microsoft siguiente:
Genere cuadro conjunto de datos Cuadro de diálogo
http://msdn2.microsoft.com/en-us/library/28xee971(vs.71).aspx
back to the list of tools

Asistente para la configuración del adaptador de datos

Con el Asistente para la configuración del adaptador de datos, puede configurar un DataAdapter que se agrega a través de Explorador de servidores a través del Asistente para formularios de datos o del cuadro de herramientas manualmente. Este asistente incluye las opciones siguientes:
  • Instrucciones Generar SQL con o sin la comprobación de concurrencia optimista.
  • Utilice procedimiento almacenado existentes.
  • Genere procedimientos almacenados nuevos.
Puede utilizar el Query y el Diseñador de vistas para modificar las consultas. La instrucción SQL generada sólo entrecomilla identificadores para Microsoft SQL Server, Microsoft Jet y Oracle. Si está utilizando un servidor de servicios de fondo de base de datos diferente, los identificadores serán unquoted. Esto podría suponer un problema si su base de datos contiene tabla no estándar o nombres de campos. Los nombres contienen un espacio u otro carácter no alfanumérico de por ejemplo. Para corregir este problema, deberá realizar cambios manualmente en el SQL en el código generado. Sin embargo, si vuelve a generar el SQL, se perderán los cambios.
Si selecciona concurrencia optimista, el valor original de todos los campos se comprueba con respecto a los valores de la base de datos. Si desea utilizar TimeStamp o un campo numérico de versión similar para simplificar la instrucción SQL y reducir la carga de datos, debe generar las consultas en código, a través del Query o a través de Diseñador de consultas y vistas usted.

Para más información acerca del Asistente para la configuración del adaptador de datos, visite el sitio Web de Microsoft siguiente:
Asistente para la configuración del adaptador de datos
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vsintro7/html/vburfADODataSetCommandConfigurationWizard.asp
back to the list of tools

Editor de la colección Parameter

Puede usar el Editor de la colección Parameter para asignar parámetros de comando a columnas del DataTable asociado. También puede asignar el parámetro a una versión de fila concreta. Por ejemplo, al actualizar una columna, el valor nuevo se obtiene de la versión actual de la fila. Sin embargo, los parámetros en la cláusula WHERE que se utilizan para comprobar concurrencia obtienen su valor de la versión original de la fila.

Para más información acerca del Editor de la colección de parámetros, visite el sitio Web de Microsoft siguiente:
Editor de la colección de parámetros
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vsintro7/html/vxurfADOParameterCollectionEditor.asp
back to the list of tools

Tabla de asignación y editores de asignación de columna

Con el DataAdapter, puede asignar nombres de tabla y campo para que no tengan que coincidir los nombres que se utilizan en un DataSet con aquéllos que se utilizan en la base de datos. Puede usar las Asignaciones de tablas y las Editores Asignación de Columna para asignar nombres de tabla y campo que se utilizan en la base de datos a tabla diferente y nombres de campo en un DataSet.

Para más información acerca de los cuadros de diálogo Table Mappings, visite el sitio Web de Microsoft siguiente:
Tabla de cuadro de diálogo Asignaciones
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vsintro7/html/vburfMappingsDialogBox.asp
back to the list of tools

Cuadro de diálogo Propiedades de vínculo de datos

Cuando selecciona la propiedad Connectstring en un componente Connection, puede hacer clic en Propiedades de vínculo de datos para conectarselas a un origen de datos nuevo. Si está utilizando un componente SqlConnection, el origen de datos debe ser una base de datos en SQL Server 7.0 o posteriormente o recibirá un error. Esto es los mismos cuadros de diálogo que utilizan para agregar una conexión nueva a Explorador de servidores.

back to the list of tools

Conjunto de datos con tipo

Uno de los fines del Visual Database Tools es la clase muy DataSet con tipo. Para generar la clase DataSet, puede utilizar uno de los métodos siguientes:
  • Haga clic en Generar conjunto de datos en la ventana Propiedades de un componente DataAdapter (o en la superficie de diseño).
  • Haga clic en el menú Archivo en Agregar nuevo elemento para agregar un elemento DataSet al proyecto.
Ambos métodos ponen un archivo de esquema XSD y una clase ocultada asociada de Microsoft Visual Basic .NET Visual Basic o Microsoft Visual C # .NET en su proyecto. Si genera el DataSet, un objeto DataAdapter, el archivo de esquema, se completa para usted y la clase DataSet que se genera refleja el esquema XSD. Si agrega el archivo haciendo clic en el menú Archivo en Agregar nuevo elemento, el archivo XSD está vacío y debe crear el esquema en usted.

Cuando edita el archivo de esquema, el archivo de clase DataSet se vuelve a escribir automáticamente. Si desea personalizar la clase DataSet, utilice uno de los métodos siguientes:
  • La subclase puede la clase DataSet y modifica la subclase. Al volverse a generar el archivo de clase DataSet, no se pierden sus cambios.
  • Puede quitar el archivo XSD en el proyecto y a continuación, agregar manualmente el archivo de clase correspondiente de nuevo a su proyecto. Esto quita el vínculo entre los diseñadores y la clase. El archivo de clase DataSet es estático para que no se sobrescriba posteriormente ningún cambio realizado por usted. Si se produce algunos cambios de esquema, el archivo de clase no se actualiza para reflejar estos cambios. Por tanto, hay un riesgo a este método.
El DataSet con tipo tiene un número de ventajas sobre un objeto DataSet estándar:
  • La característica de IntelliSense está disponible para nombres de tabla y campo en el editor de código. Se evita esto codifica errores.
  • Dado que el esquema se compila en la definición de clase, el compilador puede capturar errores de esquema. Con la clase estándar DataSet, los errores de esquema se detectan sólo en tiempo de ejecución.
  • Dado que el esquema se compila en la definición de clase, no ha de descargar el esquema en tiempo de ejecución. Esto ofrece una ventaja de rendimiento.
  • El DataSet con tipo tiene acceso a nombres de tabla y campo como las propiedades como elementos de colección lo tienen. También esto ofrece ventajas de rendimiento.
  • Puede enlazar controles en tiempo de diseño en tiempo de ejecución.
Dado que el esquema se compila en la definición de clase, el DataSet con tipo tiene un número de limitaciones:
  • Si cambia el esquema de servidor, debe volver a generar su proyecto. Para la mayoría de aplicaciones, esto no es una carga principal porque la mayoría de aplicaciones se debe modificar si cambia el esquema. En aplicaciones empresariales, el esquema de servidor ya normalmente es bien definido y ya normalmente razonablemente estático.
  • Cuando intenta obtener acceso a campos que pueden contener un valor NULO, recibe un mensaje de error si lee el campo directamente. Primero debe utilizar la propiedad Is<VAR>xxx</VAR>Null. Al configurar el valor de campo, debe utilizar el método Set<VAR>xxx</VAR>Null para almacenar un valor NULL de la tabla.

    NOTA: Los controles dependientes controlan esto automáticamente.

Artículos de Tutoriales, de Tema de Ayuda de Visual Studio . NET y de Microsoft Knowledge Base

Tutoriales proporcionan mini-tutorials que recorren escenarios de desarrollo de aplicación típica. Este artículo "How To" de Microsoft Knowledge Base proporcionan instrucciones paso a paso acerca de cómo hacer tareas específicas.

En los tema de Ayuda, en lo tutorial y en el artículo de Microsoft Knowledge Base de Visual Studio . NET en las secciones que sigue se describe cómo utilizar Visual Database Tools y el DataSet con tipo.

NOTA: Cómo los tutoriales en la sección que siguen muestran utilizar el Visual Database Tools para realizar una tarea determinada; estos tutoriales no son una tutoriales general acerca de las herramientas.

Tutoriales

En Visual Studio . NET, haga clic en Índice en el menú Ayuda. En el cuadro Buscar, escriba Walkthroughs, data . El panel de índice muestra una lista de lo tutorial de página de acceso a datos.
Walkthrough: Creating a Master-Detail Windows Form
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbcon/html/vbwlkWalkthroughCreatingMaster-DetailWindowsForm.asp
This walkthrough uses a DataAdapter component. The DataAdapter Configuration Wizard builds a typed DataSet. The walkthrough uses the XSD Editor to create a DataRelation and then binds controls through the Property window to the typed DataSet.
Adding Tables and Columns to the Windows Forms DataGrid Control
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbcon/html/vbtskCreatingCustomColumnTypesInDataGrid.asp
This article demonstrates how to customize the appearance of a bound Windows Form DataGrid control by adding DataGridTableStyle and DataGridColumnStyle objects through an editor that is opened from the Property window.

Tema de Ayuda de Visual Studio . NET

Lo nuevo en datos
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbcon/html/vboriDataAlpha.asp

Visual Database Tools
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vdbt7/html/dvoriVisualDatabaseTools.asp

Introducción a Explorador de servidores
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vsintro7/html/vbconServerResources.asp

Bases de datos en Explorador de servidores
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vsintro7/html/vxurfDatabasesInServerExplorer.asp

Crear adaptadores de datos que utilizan Explorador de servidores
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbcon/html/vbtskCreatingDataAdaptersUsingServerExplorer.asp

Crear adaptadores de datos que utilizan un asistente
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbcon/html/vbtskCreatingDataAdaptersUsingWizard.asp

Crear y configurar adaptador de datos manualmente
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbcon/html/vbtskCreatingConfiguringDataAdaptersManually.asp

Crear Nuevo escribió conjuntos de datos con el Diseñador XML
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbcon/html/vbtskCreatingNewDataSetWithXMLDesigner.asp

Artículo de Microsoft Knowledge Base

315678 CÓMO PARA: Crea y utiliza un DataSet con tipo el utilizar Visual Basic .NET
320714 CÓMO PARA: Crea y utiliza un DataSet con tipo el utilizar Visual C # .NET
318039 Realiza CÓMO PARA: que un DataSet con tipo devuelve un valor predeterminado en vez de DBNull utilizando Visual Basic .NET
318048 Realiza CÓMO PARA: que un DataSet con tipo devuelve un valor predeterminado en vez de DBNull utilizando Visual C # .NET

Solucionar

Si experimenta problemas o si tiene preguntas, puede consultar grupo de las noticias de MSDN donde puede compartir sus experiencias con sus interlocutores. También puede utilizar el Microsoft Knowledge Base para dónde puede buscar artículos acerca de problemas específicos.
Grupo de noticias de MSDN
http://msdn.microsoft.com/newsgroups/

Buscar en el Knowledge Base
http://support.microsoft.com/search/?adv=1
Los productos de terceros mencionados en este artículo son fabricados por compañías independientes de Microsoft. Microsoft no realiza ninguna garantía implícita o de caso contrario con respecto al rendimiento o la fiabilidad de estos productos.

Propiedades

Id. de artículo: 313486 - Última revisión: lunes, 24 de febrero de 2014 - Versión: 6.7
La información de este artículo se refiere a:
  • Microsoft ADO.NET 1.1
  • Microsoft ADO.NET 1.0
  • Microsoft Visual Studio .NET 2003 Enterprise Architect
  • Microsoft Visual Studio .NET 2003 Enterprise Developer
  • Microsoft Visual Studio .NET 2003 Academic Edition
  • Microsoft Visual Studio .NET 2002 Professional Edition
  • Microsoft Visual Studio .NET 2002 Enterprise Architect
  • Microsoft Visual Studio .NET 2002 Enterprise Developer
  • Microsoft Visual Studio .NET 2002 Academic Edition
Palabras clave: 
kbnosurvey kbarchive kbarttyperoadmap kbinfo kbsystemdata KB313486 KbMtes kbmt
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente. Si ve errores y desea ayudar con este esfuerzo, rellene la encuesta en la parte inferior de este artículo.
Haga clic aquí para ver el artículo original (en inglés): 313486

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com