INFO : introduction pour Visual Database Tools et DataSets typé

Traductions disponibles Traductions disponibles
Numéro d'article: 313486 - Voir les produits auxquels s'applique cet article
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Agrandir tout | Réduire tout

Sommaire

Résumé

Cet article fournit une introduction pour savoir et pour maîtriser le Studio .NET Visual Database Tools Microsoft Visual et a tapé des classes DataSet.

Articles introduction fournissent des liens vers les informations relatives utiles l'information comprenant la documentation en ligne, les articles de Base de connaissances Microsoft et les livre blanc Microsoft pour vous aider à vous familiariser sur des produits Microsoft ou une technologie. Pour plus d'informations sur les articles d'introduction à la technologie ADO.NET cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft
313590 INFO : introduction For ADO.NET
Pour des informations supplémentaires sur des objets DataAdapter ADO.NET, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
313483 INFO : objets For ADO.NET DataAdapter introduction

Visual Database Tools

Vous pouvez utiliser le Visual Database Tools pour effectuer les tâches suivantes :
  • Vous connectez à la base de données OLE DB-compliant et explorez.
  • Créez en utilisant des schéma de base de données et modifiez des bases de données Microsoft SQL Server.
  • Concevez, exécutez et enregistrez des requêtes complexes.
  • Ajoutez, mettez à jour et supprimez la donnée qui est stockée dans des tables de base de données.
  • Conception objet des déclencheurs tels que des tables et procédures stockées dans bases de données Microsoft SQL Server et Oracle.
  • Faites glisser des objets de base de données jusqu'à une surface de dessin tel qu'un formulaire Web et liez ensuite des contrôles à objets.
Le Visual Database Tools est divisé en deux catégories principales :
  • Explorateur de serveurs
  • Outils restants
Vous pouvez utiliser Explorateur de serveurs pour créer, pour modifier le schéma de base de données et pour mettre interactivement des données à jour. Les outils restants permettent de générer le code et de modifier des propriétés. Ces autres outils affectent votre projet direct, contenant générer la classe typée DataSet basée sur le schéma de serveur.

Il y a certaine superposition et interaction entre ces deux catégories. Explorateur de serveurs utilise certains éditeurs et vous pouvez faire par exemple dans Explorateur de serveurs pour appeler des générateurs de code glisser une table vers une surface de dessin.

Comme suit est le composant principal les suivants d'Explorateur de serveurs : Tout le Visual Database Tools est comme suit : REMARQUE : Outils The Visual Database prennent qu'en charge le SqlClient et l'OleDb .NET Data Providers. Tous les fournisseurs tel que l'ODBC .NET Data Provider et le fournisseur de données .NET pour Oracle, libéré après Visual Studio .NET sont que pris en charge d'une manière très limitée. Vous pouvez cependant utiliser le code généré pour une fournisseur de données et qui le modifie pour le fonctionner avec autre.

Explorateur de serveurs

Vous pouvez afficher le schéma de base de données avec Explorateur de serveurs, interactivement modifier des données du environnement de développement intégré (IDE) de Visual Studio .NET, interactivement récupérer des données et modifier le schéma de base de données SQL Server.

Les connexions sont représentées dans une vue Arborescence. Vous pouvez ajouter des connexions à noeud Serveurs ou le n?ud Connexions de données.
  • Si vous ajoutez des connexions au n?ud Serveurs, un des n?uds enfants est serveurs SQL Server. Si vous faites glisser des tables de dessous le n?ud Serveurs SQL, le SqlConnection et les composants SqlDataAdapter sont ajoutés à votre projet.
  • Si vous ajoutez une connexion OLE DB via le n?ud Connexions de données, la boîte de dialogue Propriétés des liaisons de données s'affiche.

    REMARQUE : boîte de dialogue The OLE DB de connexion inclut les connexions qu'ADO.NET ne prend pas en charge tel que le Microsoft OLE DB Provider for ODBC.
  • Si vous faites glisser une table de dessous le n?ud Connexions de données vers votre projet, l'OleDbConnection et les objets OleDbDataAdapter sont créés et sont configurés. Si vous vous connectez à Microsoft SQL Server version 7.0 ou ultérieur version, le SqlConnection et les composants SqlDataAdapter sont ajoutés.
Pour plus d'informations quant à la configuration de ces composants, vous consultez the Tout Visual Database Tools section.

Explorateur de serveurs inclut plusieurs éditeurs pour manipuler SQL Server. Dans la vue Arborescence, vous pouvez cliquer avec le bouton droit sur le n?ud Connexions de données pour créer une nouvelle base de données SQL Server. Vous pouvez cliquer avec le bouton droit sur le Tables, le Vues, les procédures stockées et les n?uds Schémas de base de données pour créer ou pour modifier respectivement une table, un affichage, des procédures stockées ou un schéma de base de données. Vous pouvez également générer le script SQL que vous pouvez exécuter contr' un serveur différent recréant la base de données. Ces plus plusieurs fonctions telles que la création de tables et procédures stockées et la modification sont également disponibles pour les bases de données Oracle.

Concepteur de base de données

Vous pouvez utiliser le Concepteur de base de données pour modifier des schéma de base de données et pour créer des relations en faisant d'une table glisser des champs dans autre.
Concepteur de base de données
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vdbt7/html/dvovrDatabaseDesigner.asp
back to the list of tools

Concepteur de table

Vous pouvez utiliser le Concepteur de table pour créer ou pour modifier des tables de la base de données. Vous pouvez spécifier des noms de champ, des types de données, des contraintes et des index parmi d'autres éléments ou modifier.

Pour plus d'informations sur le Concepteur de table, reportez-vous au site Web de Microsoft à l'adresse suivante :
Concepteur de table
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vdbt7/html/dvconTableDesigner.asp
back to the list of tools

Requête et Concepteur de vue

Le Query et le Concepteur de vue sont partagés tous les composants de données tels que les composants Command et DataAdapter. Vous pouvez utiliser le Query et le Concepteur de vue pour concevoir visuellement des requêtes et pour afficher les résultats de la requête. Lorsque vous créez ou modifiez un affichage dans l'assistant configuration d'adaptateur de données ou quand vous modifiez la propriété CommandText d'un Command ou un composant DataAdapter, la Requête et le Concepteur de vue sont appelés dans Explorateur de serveurs pour générer l'instruction SQL pour vous. Le SQL générant seul le code indique des identificateurs pour Microsoft SQL Server, Microsoft Jet et Oracle. Si vous utilisez une base de données principale autre, les identificateurs seront unquoted. Cela peut poser un problème si votre base de données contient la table non standard ou les noms de champ. Par exemple les noms contiennent du espace ou tout caractère non-alphanumérique. Pour corriger ce problème, vous devez apporter manuellement des modifications à SQL dans le code généré. Toutefois si vous régénérez le SQL, les modifications seront perdues.

Pour plus d'informations sur la Requête et Concepteur de vue, reportez-vous au site Web de Microsoft à l'adresse suivante :
Requête et Concepteur de vue
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vdbt7/html/dvconQueryDesignerLayout.asp
back to the list of tools

Éditeur SQL

L'Éditeur SQL est appelé lorsque vous créez une procédure stockée. L'Éditeur SQL fournit à votre T - SQL, instruction PL/SQL et instructions dépendant individuelles avec un rectangle de clarté que colorant. Lorsque vous modifiez le script SQL à plusieurs instruction, vous pouvez en outre cliquer avec le bouton droit sur des instructions individuelles et utiliser le Query et le Concepteur de vue pour composer visuellement ou pour modifier ces instructions.

Pour plus d'informations sur l'Éditeur SQL, reportez-vous au site Web de Microsoft à l'adresse suivante :
Éditeur SQL
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vdbt7/html/dvconSQLEditor.asp
back to the list of tools

Tout Visual Database Tools

Les outils répertoriés dans cette section écrivent code dans votre projet. Vous pouvez modifier ce code ou écrire code équivalent. Certains outils tel que l'Assistant Formulaire de données génèrent une classe Windows Form qui inclut des composants, un DataSet typé et des contrôles liés DataAdapter. Tous les outils tel que l'Éditeur de collection paramètres effectuent des tâches plus limitées tel que modifier la collection d'un seul Command Parameters.

Assistant Formulaire de données

L'Assistant Formulaire de données est similaire au Assistant Formulaire dans Microsoft Access. Vous pouvez spécifier une ou deux tables sur le serveur avec l'Assistant Formulaire de données et alors choisir d'un nombre de styles. L'Assistant configure ensuite les éléments apparaissent comment aux Windows Form.

L'Assistant Formulaire de données effectue les tâches suivantes :
  • Crée un DataSet typé pour les tables que vous sélectionnez.
  • Crée des objets Connection, Command et DataAdapter pour récupérer et pour mettre à jour des données.
  • Crée des contrôles du formulaire et lie ces contrôles à DataSet typé.
Pour plus d'informations reportez-vous aux sites Web de Microsoft aux adresses suivantes
Assistant Formulaire de données
http://msdn2.microsoft.com/en-us/library/aa291437(VS.71).aspx

Boîte de dialogue Options SQL avancée de génération
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vsintro7/html/vxurfAdvancedSQLGenerationOptionsDialogBox.asp

Coder Assistant Formulaire de données généré
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vsintro7/html/vxconDataFormWizardGeneratedCode.asp
back to the list of tools

Éditeur XSD

Vous pouvez utiliser le XSD Editor pour créer et pour modifier un fichier de votre projet de schéma XML Schema Definition Language (XSD). Vous pouvez modifier le fichier XSD comme XML droit qui est similaire au Concepteur de table et Database Designer of Server Explorer ou dans un éditeur graphique.

Vous pouvez générer un DataSet typé à partir d'un fichier XSD en définissant la propriété Custom Tool à MSDataSetGenerator. Si vous laissez à blanc cette propriété, le fichier de classe DataSet n'appartient plus, au projet et sera supprimé à partir du disque.

back to the list of tools

Éditeur XML

Vous pouvez utiliser l'éditeur XML pour modifier un fichier XML dans votre projet. Vous pouvez modifier le XML à travers une interface de texte qui prend en charge le codage en couleurs et achèvement de balise ou à travers un éditeur hiérarchique, tabulaire.

back to the list of tools

Composants de connexion, Commandes, DataAdapter, DataSet et DataView

Vous pouvez ajouter ces composants via l'onglet Données, les Données de la boîte à outils ou utiliser Explorateur de serveurs ou l'Assistant Formulaire de données pour ajouter et pour configurer ces composants pour vous.

Vous pouvez utiliser le composant DataSet typé pendant la liaison de données au moment de design. La liaison de données peut parfois faire confondre. Dans un Windows Form le concepteur vous autorise uniquement à lier des contrôles une de manière à une source de données simples, mais pouvez par exemple lier un contrôle DataGrid ou la liste d'un contrôle ListBox ou un contrôle ComboBox deux manières différentes. L'une de ces manières est incompatible dans la façon dans laquelle des contrôles simples sont liés. Vous pouvez vérifier que tous vos contrôles sont liés de manière cohérente en utilisant un composant DataView.

Vous pouvez ouvrir un nombre de générateurs des propriétés des composants différents. Par exemple
  • Ouvrez la boîte de dialogue Propriétés des liaisons de données du composant Connection.ConnectString.
  • Ouvrez le Générateur de requêtes qui est similaire du composant Command.CommandText à la Requête et Concepteur de vue.
  • Ouvrez l'Éditeur de collection paramètres du composant Command.Parameters.
  • Ouvrez la Table Mapping Editor et le Column Mapping Editor du composant DataAdapter.TableMappings.
Vous pouvez tester une configuration DataAdapter en cliquant sur Aperçu des données, dans la fenêtre Propriétés. Cela affiche les données d'une grille.

back to the list of tools

Boîte de dialogue Générer le groupe de données

Lorsque vous sélectionnez la surface de dessin graphique ou un composant DataAdapter, un lien hypertexte Générer le groupe apparaît en bas de la fenêtre Propriétés. Vous dans la boîte de dialogue Générer le groupe de données, sélectionnez un ou plusieurs composants DataAdapter, dans la surface de dessin à la demande d'information de schéma. L'Assistant génère le fichier de schéma XSD et a puis tapé la classe DataSet pour vous. L'Assistant propose également l'option d'ajouter une instance de la classe DataSet dans la surface de dessin comme un composant.

Pour plus d'informations sur la boîte de dialogue Générer le groupe de données, reportez-vous au site Web de Microsoft à l'adresse suivante :
Boîte de dialogue Générer le groupe de données
http://msdn2.microsoft.com/en-us/library/28xee971(vs.71).aspx
back to the list of tools

Assistant configuration d'adaptateur de données

Avec l'assistant configuration d'adaptateur de données, vous pouvez configurer un DataAdapter qui est ajouté à travers Explorateur de serveurs manuellement à travers l'Assistant Formulaire de données ou de la boîte. Cet Assistant inclut les options suivantes :
  • Générez des instructions SQL avec contrôler ou sans contrôler l'accès concurrentiel optimiste.
  • Utilisez des procédure stockée existantes.
  • Générez des nouvelles procédures stockées.
Vous pouvez utiliser le Query et le Concepteur de vue pour modifier les requêtes. L'instruction SQL générée indique que des identificateurs pour Microsoft SQL Server, Microsoft Jet et Oracle. Si vous utilisez un serveur principal de base de données, les identificateurs seront unquoted. Cela peut poser un problème si votre base de données contient la table non standard ou les noms de champ. par exemple les noms contiennent du espace ou tout caractère non-alphanumérique. Pour corriger ce problème, vous devrez apporter manuellement des modifications à SQL dans le code généré. Toutefois si vous régénérez le SQL, les modifications seront perdues.
Si vous sélectionnez l'accès concurrentiel optimiste, la valeur d'origine de tous les champs est vérifiée par rapport aux valeurs de la base de données. Si vous souhaitez utiliser un TimeStamp ou un champ version similaire numérique pour simplifier l'instruction SQL et pour réduire la charge de données, vous devez vous générer les requêtes dans le code ou à travers le Query et à travers Concepteur de vues.

Pour plus d'informations sur l'Assistant Configuration d'adaptateur de données, reportez-vous au site Web de Microsoft à l'adresse suivante :
Assistant Configuration d'adaptateur de données
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vsintro7/html/vburfADODataSetCommandConfigurationWizard.asp
back to the list of tools

Éditeur de collection paramètres

Vous pouvez utiliser l'Éditeur de collection paramètres pour mapper des paramètres de commande à des colonnes de DataTable associé. Vous pouvez également mapper le paramètre vers une version de ligne particulière. Par exemple lorsque vous mettez à jour une colonne, la valeur nouvelle est obtenue de la version récente de la ligne. Cependant paramètres dans la clause WHERE utilisés pour concurrence vérifier la présence obtiennent leur valeur de la version d'origine de la ligne.

Pour plus d'informations sur l'Éditeur de collection Parameters, reportez-vous au site Web de Microsoft à l'adresse suivante :
Éditeur de collection Parameters
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vsintro7/html/vxurfADOParameterCollectionEditor.asp
back to the list of tools

Tableau mappage et éditeurs de mappage de colonne

Vous pouvez mapper des noms de table et champ afin que les noms qui sont utilisés dans un DataSet ne doivent pas à qui qui sont utilisés dans la base de données, correspondre obligatoirement avec le DataAdapter. Vous pouvez utiliser le Mappage des tables et le Column Mapping Editors pour mapper les noms de table et champ qui sont utilisés dans la base de données à table différente et les noms de champ dans un DataSet.

Pour plus d'informations sur la boîte de dialogue Mappages de table, reportez-vous au site Web de Microsoft à l'adresse suivante :
Boîte de dialogue Mappages de table
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vsintro7/html/vburfMappingsDialogBox.asp
back to the list of tools

Boîte de dialogue Propriétés des liaisons de données

Lorsque vous sélectionnez la propriété ConnectString dans un composant Connexion, vous pouvez cliquer sur Propriétés des liaisons de données pour connecter à une nouvelle source de données. Ou si vous utilisez un composant SqlConnection, vous recevrez une erreur, la source de données doit est une base de données dans SQL Server 7.0 ou plus tard. Cela est les mêmes boîtes de dialogue utilisées pour ajouter une nouvelle connexion à Explorateur de serveurs.

back to the list of tools

DataSet typé

Est la classe fortement typée DataSet une des produits final de Visual Database Tools. Pour générer la classe DataSet, vous pouvez appliquer une des méthodes suivantes :
  • Cliquez sur Générer le groupe de données, dans la fenêtre Propriétés d'un composant DataAdapter ( ou sur la surface de dessin).
  • Cliquez sur Ajouter un nouvel élément dans le menu Fichier pour ajouter un élément DataSet au projet.
Deux méthodes placent un fichier de schéma XSD et une classe masquée associée Microsoft Visual Basic .NET ou Microsoft Visual C# .NET dans votre projet. Si vous générez le DataSet, un objet DataAdapter, le fichier de schéma est terminé pour vous et la classe DataSet qui est générée reflète le schéma XSD. Si vous ajoutez le fichier en cliquant sur Ajouter un nouvel élément dans le menu Fichier, le fichier XSD est vide et vous devez vous créer le schéma.

Chaque fois que vous modifiez le fichier de schéma, le fichier de classe DataSet est réécrit automatiquement. Que vous voulez personnaliser la classe DataSet, utilisez une des méthodes suivantes :
  • Vous pouvez sous-classe la classe DataSet et modifiez la sous-classe. Quand le fichier de classe DataSet est régénéré, vos modifications ne sont pas perdues.
  • Vous pouvez supprimer le fichier XSD du projet et puis manuellement ajouter le fichier correspondant de classe en arrière dans votre projet. Cela supprime le lien entre les concepteurs et la classe. Le fichier de classe DataSet devient statique afin qu'aucune modification apportée ne soit écrasée ultérieurement. Si toutes les modifications de schéma appartiennent, le fichier de classe n'est pas mis à jour pour refléter ces modifications. Par conséquent il y a un risque à cette méthode.
Le DataSet typé a un nombre d'avantages sur un objet DataSet standard :
  • La fonctionnalité IntelliSense est disponible pour des noms de table et champ dans l'éditeur de code. Cela vise à empêcher erreurs de codage.
  • Comme le schéma est compilé dans la définition de classe, le compilateur peut intercepter des erreurs de schéma. Des erreurs de schéma sont interceptées à l'aide de la classe standard DataSet en seulement mode exécution.
  • Vous ne devez pas télécharger le schéma en mode exécution comme le schéma est compilé dans la définition de classe. Cela offre un avantage de performance.
  • Le DataSet typé accède en tant que propriétés en tant qu'éléments de collection à des noms de table et champ. Cela propose également des performances.
  • Vous pouvez lier des contrôles au moment de design en mode exécution.
Comme le schéma est compilé dans la définition de classe, le DataSet typé a un nombre de limitations :
  • Si le schéma de serveur est changé, vous devez recréer votre projet. Pour plus plusieurs applications, cela n'est pas une principale charge parce que plus plusieurs applications doivent être modifiées si le schéma est modifié. Le schéma de serveur est généralement dans des applications au niveau de l'entreprise, déjà bien précis et raisonnablement statique.
  • Lorsque vous essayez d'accéder aux champs qui peuvent contenir une valeur NULL, un message d'erreur s'affiche si vous lisez directement le champ. Vous devez en premier lieu utiliser la propriété Is<VAR>xxx</VAR>Null. Lorsque vous définissez la valeur de champ, vous devez utiliser la méthode Set<VAR>xxx</VAR>Null pour stocker une valeur NULL de la table.

    REMARQUE : les contrôles liés gèrent automatiquement cela.

Articles de visite, Rubrique d'aide Visual Studio .NET et Base de connaissances Microsoft

Les mini-didacticiels des procédures pas à pas vous font découvrir des scénarios courants de développement d'application Articles "procédure" de Base de connaissances Microsoft fournissent des instructions étape par étape comment sur effectuer des tâches spécifiques.

Les rubrique d'aide, la procédure et les articles de Base de connaissances Microsoft Visual Studio .NET des sections à suivre expliquent comment utiliser Visual Database Tools et le DataSet typé.

REMARQUE : les procédures dans la section à suivre montrent comment utiliser le Visual Database Tools pour exécuter une tâche particulière; ces procédures ne sont pas un didacticiel général sur les outils.

Visite

Dans Visual Studio .NET, cliquez sur Index dans le menu Aide. Dans la zone Rechercher, tapez Walkthroughs, data . Le volet des résultats d'index répertorie les procédures pas à pas permettant d'accéder à des données
Walkthrough: Creating a Master-Detail Windows Form
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbcon/html/vbwlkWalkthroughCreatingMaster-DetailWindowsForm.asp
This walkthrough uses a DataAdapter component. The DataAdapter Configuration Wizard builds a typed DataSet. The walkthrough uses the XSD Editor to create a DataRelation and then binds controls through the Property window to the typed DataSet.
Adding Tables and Columns to the Windows Forms DataGrid Control
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbcon/html/vbtskCreatingCustomColumnTypesInDataGrid.asp
This article demonstrates how to customize the appearance of a bound Windows Form DataGrid control by adding DataGridTableStyle and DataGridColumnStyle objects through an editor that is opened from the Property window.

Rubrique d'aide Visual Studio .NET

Nouveauté dans des données
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbcon/html/vboriDataAlpha.asp

Visual Database Tools
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vdbt7/html/dvoriVisualDatabaseTools.asp

Introduction à Explorateur de serveurs
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vsintro7/html/vbconServerResources.asp

Bases de données dans Explorateur de serveurs
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vsintro7/html/vxurfDatabasesInServerExplorer.asp

Créer les cartes de données utilisant Explorateur de serveurs
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbcon/html/vbtskCreatingDataAdaptersUsingServerExplorer.asp

Créer les cartes de données utilisant un Assistant
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbcon/html/vbtskCreatingDataAdaptersUsingWizard.asp

Créez et configurer manuellement des adaptateurs de données
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbcon/html/vbtskCreatingConfiguringDataAdaptersManually.asp

La création de Nouveau a tapé un groupe de données à l'aide du Concepteur XML
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbcon/html/vbtskCreatingNewDataSetWithXMLDesigner.asp

Articles de la Base de connaissances Microsoft

315678 COMMENT À : vous créez en utilisant et à l'aide de Visual Basic .NET utilisez un DataSet typé
320714 COMMENT À : vous créez en utilisant et à l'aide de Visual C# .NET utilisez un DataSet typé
318039 COMMENT À : vous effectuez de renvoyer une valeur par défaut au lieu de DBNull, un DataSet typé en utilisant Visual Basic .NET
318048 COMMENT À : vous effectuez de renvoyer une valeur par défaut au lieu de DBNull, un DataSet typé en utilisant Visual C# .NET

Résoudre

Si vous rencontrez des problèmes ou avez des questions, vous pouvez faire référence aux groupes de discussion MSDN lequel vous pouvez partager vos expériences avec vos homologues. Vous pouvez également utiliser la Base de connaissances Microsoft où vous pouvez rechercher des articles sur des problèmes spécifiques.
Groupes de discussion MSD
http://msdn.microsoft.com/newsgroups/

Rechercher la base de connaissances
http://support.microsoft.com/search/?adv=1
Les produits tiers mentionnés dans cet article sont fabriqués par des sociétés indépendantes de Microsoft Microsoft n'offre aucune garantie implicite ou exprès à la performance ou la fiabilité de ces produits.

Propriétés

Numéro d'article: 313486 - Dernière mise à jour: lundi 24 février 2014 - Version: 6.7
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft ADO.NET 1.1
  • Microsoft ADO.NET 1.0
  • Microsoft Visual Studio .NET 2003 Enterprise Architect
  • Microsoft Visual Studio .NET 2003 Enterprise Developer
  • Microsoft Visual Studio .NET 2003 Academic Edition
  • Microsoft Visual Studio .NET 2002 Professional Edition
  • Microsoft Visual Studio .NET 2002 Enterprise Architect
  • Microsoft Visual Studio .NET 2002 Enterprise Developer
  • Microsoft Visual Studio .NET 2002 Academic Edition
Mots-clés : 
kbnosurvey kbarchive kbarttyperoadmap kbinfo kbsystemdata KB313486 KbMtfr kbmt
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que feraient une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique. Si vous relevez des erreurs graves et souhaitez contribuer à l?amélioration du système, vous pouvez compléter l?enquête à votre disposition dans le bas des articles.
La version anglaise de cet article est la suivante: 313486
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com