INFORMAZIONI: Orientamento per Visual Database Tools e per DataSet tipizzato

Traduzione articoli Traduzione articoli
Identificativo articolo: 313486 - Visualizza i prodotti a cui si riferisce l?articolo.
Questo articolo Ŕ stato archiviato. L?articolo, quindi, viene offerto ?cosý come Ŕ? e non verrÓ pi¨ aggiornato.
Espandi tutto | Chiudi tutto

In questa pagina

Sommario

In questo articolo, si fornisce un orientamento per conoscere e mastering lo Visual Database Tools .NET Studio Microsoft Visual J++ e si sono digitato le classi DataSet.

Gli articoli di orientamento contengono collegamenti a informazioni utili, tra cui documentazione in linea, articoli della Microsoft Knowledge Base e white paper di Microsoft, che facilitano l'apprendimento di un prodotto o di una tecnologia Microsoft Per ulteriori informazioni sugli articoli tecnologici di orientamento ADO.NET, fare clic sul seguito sul numero di articolo per visualizzare l'articolo del Microsoft Knowledge Base:
313590 INFORMAZIONI: Orientamento per ADO.NET
Per ulteriori informazioni sugli oggetti DataAdapter ADO.NET, fare clic sul seguito sul numero di articolo per visualizzare l'articolo del Microsoft Knowledge Base:
313483 INFORMAZIONI: Orientamento per gli oggetti ADO.NET DataAdapter

Visual Database Tools

╚ possibile utilizzare il Visual Database Tools per eseguire le seguenti operazioni:
  • Connettersi ed esplorare qualsiasi database OLE DB-compliant.
  • Creare e modificare i database di Microsoft SQL Server utilizzando i diagrammi di database.
  • Progettare, eseguire e salvare le query complesse.
  • Aggiungere, aggiornare ed eliminare il dato che si memorizza nelle tabelle di database.
  • Il la progettazione oggetto dei trigger come tabelle e ha memorizzato le routine nei database Microsoft SQL Server e Oracle.
  • Gli oggetti di database in un'area di progettazione come un Web Form trascinare e quindi associare i controlli a quegli oggetti.
Il Visual Database Tools Ŕ suddiviso in due categorie principali:
  • Esplora server
  • Strumenti rimanenti
Utilizzare Esplora server Ŕ possibile per creare, modificare lo schema di database e aggiornare i dati nel modo interattivo. Utilizzare gli strumenti rimanenti Ŕ possibile per che il codice generi e per modificare le proprietÓ. Questi altri strumenti influiscono direttamente sul progetto incluso che genera la classe tipizzata DataSet basata sullo schema di server.

Sono alcuna sovrapposizione e interazione tra queste due categorie. Ad esempio, Esplora server utilizza alcuni editor ed Ŕ possibile che una tabella ad esempio trascini in un'area di progettazione da Esplora server per richiamare i generatori di codice.

Il principale componente di Esplora server Ŕ la seguente: L'altro Visual Database Tools Ŕ la seguente: NOTA: Visual Database Tools Il solo supporta lo SqlClient e gli Provider Dato .NET OleDb. Altri provider come il provider di dati ODBC .NET e il provider di dati .NET per Oracle che ha rilasciato dopo Visual Studio .NET solo sono supportati in un modo molto limitato. Tuttavia Ŕ possibile utilizzare il codice che genera per il provider di un dato e che lo modifica affinchÚ lo funzioni con altra.

Esplora server

Di Esplora server, Ŕ possibile visualizzare lo schema di database, modificare lo schema di database di SQL Server, recuperare i dati nel modo interattivo e i dati si possono modificare nell'ambiente di sviluppo (IDE) integrato di Visual Studio . NET nel modo interattivo.

Le connessioni si rappresentano in una visualizzazione di struttura. ╚ possibile aggiungere le connessioni al nodo Server o al nodo Connessioni dati.
  • Se si aggiungono le connessioni al nodo Server, uno dei nodi di figlio Ŕ SQL Server. Se le tabelle il nodo SQL Server trascinano, lo SqlConnection e i componenti SqlDataAdapter si aggiungono al progetto.
  • Se si aggiunge una connessione OLE DB attraverso il nodo Connessioni dati, si visualizza la finestra di dialogo di proprietÓ Data Link.

    NOTA: La finestra di dialogo di connessione OLE DB include le connessioni non supportate come il Microsoft OLE DB Provider for ODBC da ADO.NET.
  • Se una tabella il nodo Connessioni dati trascina al progetto, l' OleDbConnection e gli oggetti OleDbDataAdapter si creano e si configurano. Se si connette a Microsoft SQL Server versione 7.0 o successiva, lo SqlConnection e i componenti SqlDataAdapter si aggiungono invece.
Per ulteriori informazioni su modalitÓ di configurazione di questi componenti, vede Un altro Visual Database Tools sezione.

Esplora server include diversi editor per manipolare SQL Server. Nella visualizzazione di struttura, Ŕ possibile fare clic con il pulsante destro del nodo Connessioni dati per creare un nuovo database SQL Server. ╚ possibile fare clic con il pulsante destro della Tabelle, della Visualizzazioni, dello stored procedure e dei nodi Diagrammi di database per creare o modificare rispettivamente una tabella, una vista, uno stored procedure o un diagramma di database. ╚ anche possibile generare lo script SQL che Ŕ possibile eseguire contro un diverso server che ricrea il database. Queste pi¨ molte funzioni come la creazione e la modifica di tabelle e stored procedure sono anche disponibili per i database Oracle.

Progettazione database

Utilizzare la Progettazione database Ŕ possibile per modificare i diagrammi di database e creare le relazioni trascinando i campi da una tabella a altra.
Progettazione database
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vdbt7/html/dvovrDatabaseDesigner.asp
back to the list of tools

Progettazione tabelle

Utilizzare la Progettazione tabelle Ŕ possibile per creare o modificare le tabelle del database. ╚ possibile specificare o modificare i nomi di campo, i tipi di dati, i vincoli e gli indici tra altri elementi.

Per ulteriori informazioni sulla Progettazione tabelle, visitare il seguente sito Web Microsoft:
Progettazione tabelle
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vdbt7/html/dvconTableDesigner.asp
back to the list of tools

Query e Progettazione viste

La Query e la Progettazione viste sono condivisi da altri componenti di dati i componenti Command e DataAdapter. Utilizzare la Query e la Progettazione viste Ŕ possibile per progettare le query visivamente e visualizzare i risultati della query. Quando si crea o si modifica una visualizzazione nella Configurazione guidata adattatore dati o quando si modifica la proprietÓ CommandText di Comando o un componente DataAdapter, in Esplora server, la Query e la Progettazione viste si richiamano per generare l'istruzione SQL. Lo SQL che genera solo il codice cita identificatore per Microsoft SQL Server, per Microsoft Jet e per Oracle. Se si utilizza un diverso database back-end, le identificatori saranno unquoted. Ci˛ pu˛ porre un problema se il database contiene la tabella non standard o i nomi di campi. Ad esempio, i nomi contengono uno spazio o un altro carattere non alfanumerico. Per correggere questo problema, Ŕ necessario apportare le modifiche manualmente allo SQL nel codice generato. Se si rigenera lo SQL, tuttavia si perderanno le modifiche.

Per ulteriori informazioni sulla Query e Progettazione viste, visitare il seguente sito Web Microsoft:
Query e Progettazione viste
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vdbt7/html/dvconQueryDesignerLayout.asp
back to the list of tools

Editor SQL

L'Editor SQL si richiama quando si crea uno stored procedure. L'Editor SQL consente la chiarezza colorato al T-SQL, all'istruzione PL/SQL e alle singole istruzioni di limiti con un rettangolo. Quando si modifica script SQL con pi¨ istruzione, Ŕ inoltre possibile fare clic con il pulsante destro di singole istruzioni e utilizzare inoltre la Query e la Progettazione viste Ŕ possibile per comporre o modificare queste istruzioni visivamente.

Per ulteriori informazioni sull'Editor SQL, visitare il seguente sito Web Microsoft:
Editor SQL
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vdbt7/html/dvconSQLEditor.asp
back to the list of tools

Un altro Visual Database Tools

Gli strumenti elencati in questa sezione scrivono il codice nel progetto. ╚ possibile modificare questo codice o Ŕ possibile scrivere il codice equivaluto. Generano una classe Windows Form che include i componenti, un DataSet tipizzato e i controlli associati DataAdapter alcuni strumenti come la Creazione guidata form dati. Altri strumenti come l'editor dell' insieme di parametri eseguono le attivitÓ pi¨ limitate come modificano l'insieme Parameters di un singolo Comando.

Creazione guidata form dati

La Creazione guidata form dati Ŕ il simile alla Creazione guidata Maschera in Microsoft Access. Con la Creazione guidata form dati, Ŕ possibile specificare una o due tabelle sul server e quindi scegliere numerosi stili. Che modalitÓ di visualizzazione degli elementi nel Windows Form quindi la procedura guidata configura.

La Creazione guidata form dati esegue le seguenti operazioni:
  • Crea un DataSet tipizzato per le tabelle selezionate.
  • Crea gli oggetti Connection, Command e DataAdapter per recuperare e aggiornare i dati.
  • Crea i controlli nella maschera e associa questi controlli al DataSet tipizzato.
Per ulteriori informazioni, visitare i seguenti siti Web Microsoft:
Creazione guidata form dati
http://msdn2.microsoft.com/en-us/library/aa291437(VS.71).aspx

Si passava la finestra di generazione di dialogo Opzione SQL
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vsintro7/html/vxurfAdvancedSQLGenerationOptionsDialogBox.asp

Creazione guidata form dati ha generato il codice
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vsintro7/html/vxconDataFormWizardGeneratedCode.asp
back to the list of tools

Editor XSD

Utilizzare il XSD Editor Ŕ possibile per creare e modificare un file di schema XML Schema Definition Language (XSD) del progetto. ╚ possibile modificare il file XSD come linguaggio retto XML o in un editor grafico che Ŕ il simile alla Progettazione tabelle e Esplora server di Progettazione database.

╚ possibile generare un DataSet tipizzato da un file XSD impostando la proprietÓ Custom Tool a MSDataSetGenerator. Se si lascia questa proprietÓ vuota, il file di classe DataSet fa una parte pi¨ non del progetto e verrÓ eliminato dal disco.

back to the list of tools

Editor XML

Utilizzare l'editor XML Ŕ possibile per modificare un file XML nel progetto. ╚ possibile modificare il XML tramite un editor gerarchico, tabulare, tramite un'interfaccia di testo che supporta il codice di colore e tramite il completamento di tag o.

back to the list of tools

Connessione, il comando, DataAdapter, DataSet e i componenti DataView

╚ possibile aggiungere questi componenti dalla scheda Dati della Casella degli strumenti o utilizzare Esplora server o la Creazione guidata form dati Ŕ possibile per aggiungere e configurare questi componenti.

╚ possibile utilizzare il componente tipizzato DataSet per l'associazione di dati in fase della progettazione. L'associazione di dati pu˛ essere occasionalmente che confonda. Ad esempio, in un Windows Form, la finestra di progettazione solo si consente di associare i controlli semplici in un modo a un'origine dati ma in un Windows Form, ad esempio, Ŕ possibile associare un controllo DataGrid o l'elenco di un controllo ListBox o un controllo ComboBox in due modi diversi. Uno di questi modi non Ŕ compatibile alla modalitÓ a cui si associano i controlli semplici. Utilizzando un componente DataView, si Ŕ possibile assicurare che tutti i controlli si associno costantemente.

╚ possibile aprire numerosi generatori dalle proprietÓ dei vari componenti. Ad esempio
  • Aprire la finestra di dialogo ProprietÓ di Data Link dal componente Connection.ConnectString.
  • Aprire il Generatore di query che Ŕ il simile alla Query e Progettazione viste dal componente Command.CommandText.
  • Aprire l'editor dell' insieme di parametri dal componente Command.Parameters.
  • Aprire il Table Mapping Editor e il Column Mapping Editor dal componente DataAdapter.TableMappings.
╚ possibile verificare una configurazione DataAdapter facendo clic su Anteprima dati nella finestra ProprietÓ. Ci˛ visualizza i dati in una griglia.

back to the list of tools

Generare la casella Finestra di dialogo

Quando si seleziona l'area di progettazione grafica o un componente DataAdapter, un collegamento ipertestuale Genera DataSet si visualizza della finestra ProprietÓ. Nella finestra di dialogo Genera DataSet, Ŕ possibile selezionare un o pi¨ componenti DataAdapter nell'area di progettazione alla query per informazioni sullo schema. Quindi la procedura guidata crea il file di schema XSD e ha digitato la classe DataSet. La procedura guidata offre inoltre l'opzione per aggiungere un'istanza della classe DataSet all'area di progettazione come un componente.

Per ulteriori informazioni sulla finestra di dialogo Genera DataSet, visitare il seguente sito Web Microsoft:
Generare la casella Finestra di dialogo
http://msdn2.microsoft.com/en-us/library/28xee971(vs.71).aspx
back to the list of tools

Configurazione guidata adattatore dati

Con la Configurazione guidata adattatore dati, Ŕ possibile configurare un DataAdapter aggiunto tramite Esplora server tramite la Creazione guidata form dati o dalla Casella degli strumenti manualmente. Questa procedura guidata include le seguenti opzioni:
  • Generare istruzioni SQL con controllare o senza controllare concorrenza ottimistica.
  • Esistere utilizzo ha memorizzato le routine.
  • Generare lo stored nuove procedure.
Utilizzare la Query e la Progettazione viste Ŕ possibile per modificare le query. L'istruzione SQL generata solo cita identificatore per Microsoft SQL Server, per Microsoft Jet e per Oracle. Se si utilizza un back-end di diverso database, le identificatori saranno unquoted. Ci˛ potrebbe porre un problema se il database contiene la tabella non standard o i nomi di campi. ad esempio, i nomi contengono uno spazio o un altro carattere non alfanumerico. Per correggere questo problema, si dovrÓ apportare le modifiche manualmente allo SQL nel codice generato. Se si rigenera lo SQL, tuttavia si perderanno le modifiche.
Se si seleziona la concorrenza ottimistica, il valore originale di tutti i campi viene controllato in base ai valori nel database. Se si desidera utilizzare TimeStamp o un campo di numero di versione simile per semplificare l'istruzione SQL e ridurre il payload di dati, va generare le query nel codice, tramite la Query o tramite Progettazione viste.

Per ulteriori informazioni sulla Configurazione guidata adattatore dati, visitare il seguente sito Web Microsoft:
Configurazione guidata adattatore dati
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vsintro7/html/vburfADODataSetCommandConfigurationWizard.asp
back to the list of tools

Editor dell' insieme di parametri

Mappare i parametri di comando alle colonne nel DataTable associato Ŕ possibile utilizzando l'editor dell' insieme di parametri. ╚ possibile associare inoltre il parametro a una versione di riga particolare. Ad esempio, quando si aggiorna una colonna, il nuovo valore si ottiene dalla versione corrente della riga. I parametri utilizzati per il controllo di concorrenza nella clausola WHERE tuttavia ottengono il loro valore dalla versione originale della riga.

Per ulteriori informazioni sull'editor dell' insieme Parameters, visitare il seguente sito Web Microsoft:
Editor dell' insieme Parameters
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vsintro7/html/vxurfADOParameterCollectionEditor.asp
back to the list of tools

Mapping di tabelle e gli editor di colonna di mapping

Con il DataAdapter, Ŕ possibile associare i nomi di tabella e campo in modo che non dovere corrispondere i nomi che sono utilizzati in un DataSet a quelli utilizzati nel database. Associare i nomi di tabella e campo che sono utilizzati nel database alla tabella diverse e i nomi di campo in un DataSet Ŕ possibile utilizzando il Mapping di tabelle e i Editor Mapping Colonna.

Per ulteriori informazioni sulla finestra di dialogo Mapping tabelle, visitare il seguente sito Web Microsoft:
Finestra di dialogo Mapping tabelle
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vsintro7/html/vburfMappingsDialogBox.asp
back to the list of tools

Finestra di dialogo ProprietÓ di Data Link

Dopo aver selezionato la proprietÓ ConnectString in un componente Connection, Ŕ possibile scegliere ProprietÓ di Data Link per connetterla a una nuova origine dati. Se si utilizza un componente SqlConnection, l'origine dati deve essere un database in SQL Server 7.0 o successivo o visualizzerÓ un errore. Ci˛ Ŕ la stessa finestra di dialogo che si utilizza per aggiungere una nuova connessione a Esplora server.

back to the list of tools

DataSet tipizzato

Uno dei Fine del Visual Database Tools Ŕ la classe DataSet tipizzata nel modo sicuro. Per che la classe DataSet generi, si utilizza uno dei seguenti metodi:
  • Scegliere Genera Dataset nella finestra ProprietÓ di un componente DataAdapter (o sopra l'area di progettazione).
  • Scegliere Aggiungi nuovo elemento dal menu File per aggiungere un elemento DataSet al progetto.
Entrambi metodi posizionano un file di schema XSD e una classe nascosta associata Microsoft Visual Basic . NET Microsoft Visual J++ o di Microsoft Visual C # . NET nel progetto. Se si genera il DataSet, un oggetto DataAdapter, il file di schema, si completa e la classe DataSet incorporata riflette lo schema XSD. Se si aggiunge il file scegliendo Aggiungi nuovo elemento dal menu File, il file XSD Ŕ vuoto ed Ŕ necessario creare lo schema.

Ogniqualvolta si modifica il file di schema, viene automaticamente riscritto il file di classe DataSet. Se si desidera personalizzare la classe DataSet, utilizzare uno dei seguenti metodi:
  • La classe DataSet Ŕ possibile alla sottoclasse e si modifica la sottoclasse. Quando si rigenera il file di classe DataSet, non si vanno perdere le modifiche.
  • Il progetto pu˛ rimuovere il file XSD e quindi Ŕ possibile aggiungere manualmente il file di classe corrispondente indietro al progetto. Ci˛ rimuove il collegamento tra la finestra di progettazione e tra la classe. Diventa statico il file di classe DataSet in modo che tutte le modifiche apportate non si sovrascrivano in seguito. Se le eventuali modifiche di schema vengono rilevate, il file di classe non si aggiorna per riflettere queste modifiche. Pertanto esiste un rischio a questo metodo.
Il DataSet tipizzato presenta numerosi vantaggi su un oggetto DataSet standard:
  • La funzionalitÓ IntelliSense Ŕ disponibile per i nomi di tabella e campo nell'editor di codice. Si impedisce ci˛ codifica di errori.
  • PoichÚ lo schema si compila nella definizione di classe, il compilatore pu˛ rilevare gli errori di schema. Con la classe standard DataSet, gli errori di schema vengono rilevati solo in fase di run-time.
  • PoichÚ lo schema si compila nella definizione di classe, non si deve scaricare lo schema in fase di run-time. Ci˛ offre un vantaggio di prestazione.
  • Il DataSet tipizzato accede ai nomi di tabella e campo come proprietÓ come elementi di insieme. Ci˛ offre anche i vantaggi di prestazione.
  • ╚ possibile associare i controlli in fase della progettazione in fase di run-time.
PoichÚ lo schema si compila nella definizione di classe, il DataSet tipizzato presenta numerose limitazioni:
  • Se si modifica lo schema di server, si deve rigenerare il progetto. Per pi¨ molte applicazioni, ci˛ non Ŕ un carico principale perchÚ la maggior parte delle applicazioni deve essere modificata se si modifica lo schema. Nelle applicazioni aziendali, lo schema di server Ŕ giÓ in genere ben e giÓ ragionevolmente statico in genere.
  • Quando si tenta di accedere ai campi che possono contenere un valore NULL, si visualizza un messaggio di errore se legge il campo direttamente. ╚ necessario utilizzare la proprietÓ Is<VAR>xxx</VAR>Null per il primo. Quando imposta il valore di campo, Ŕ necessario utilizzare il metodo Set<VAR>xxx</VAR>Null per archiviare un valore NULL nella tabella.

    NOTA: I controlli associati gestiscono ci˛ automaticamente.

Il la procedura dettagliata, gli argomenti di Visual Studio . NET della Guida e gli articoli di Microsoft Knowledge Base

La procedura dettagliata fornisce mini-tutorials che camminano tramite gli scenari di sviluppo di applicazioni tipiche. Gli articoli "Procedura" di Microsoft Knowledge Base includono le istruzioni dettagliate a proposito di come eseguire le attivitÓ specifiche.

Nell'argomento della Guida, in dettagliare e negli articoli di Visual Studio . NET di Microsoft Knowledge Base nelle sezioni per seguire si descrive come utilizzare Visual Database Tools e il DataSet tipizzato.

NOTA: Come dettagliare nella sezione per seguirsi illustra utilizzare il Visual Database Tools per eseguire un'operazione particolare; dettagliare non Ŕ un'esercitazione generale sugli strumenti.

La procedura dettagliata

In Visual Studio . NET, fare clic su Indice nel menu Help. Nella casella Cerca, digitare Walkthroughs, data . Nel riquadro Risultati ricerca nell' indice si visualizza un elenco che dettaglia di accesso di dati.
Walkthrough: Creating a Master-Detail Windows Form
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbcon/html/vbwlkWalkthroughCreatingMaster-DetailWindowsForm.asp
This walkthrough uses a DataAdapter component. The DataAdapter Configuration Wizard builds a typed DataSet. The walkthrough uses the XSD Editor to create a DataRelation and then binds controls through the Property window to the typed DataSet.
Adding Tables and Columns to the Windows Forms DataGrid Control
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbcon/html/vbtskCreatingCustomColumnTypesInDataGrid.asp
This article demonstrates how to customize the appearance of a bound Windows Form DataGrid control by adding DataGridTableStyle and DataGridColumnStyle objects through an editor that is opened from the Property window.

Argomenti di Visual Studio . NET della Guida

NovitÓ nei dati
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbcon/html/vboriDataAlpha.asp

Visual Database Tools
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vdbt7/html/dvoriVisualDatabaseTools.asp

Introduzione a Esplora server
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vsintro7/html/vbconServerResources.asp

Database in Esplora server
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vsintro7/html/vxurfDatabasesInServerExplorer.asp

Creare gli adattatori di dati che utilizzano Esplora server
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbcon/html/vbtskCreatingDataAdaptersUsingServerExplorer.asp

Creare gli adattatori di dati utilizzando una procedura guidata
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbcon/html/vbtskCreatingDataAdaptersUsingWizard.asp

Creare e configurare manualmente gli adattatori di dati
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbcon/html/vbtskCreatingConfiguringDataAdaptersManually.asp

Creazione di nuovi DataSet tipizzato tramite la Progettazione XML
http://msdn.microsoft.com/library/default.asp?url=/library/en-us/vbcon/html/vbtskCreatingNewDataSetWithXMLDesigner.asp

Articoli di Microsoft Knowledge Base

315678 COME: si crea e si utilizza un DataSet tipizzato dall'utilizzo .NET di Visual Basic
320714 COME: si crea e si utilizza un DataSet tipizzato utilizzando Visual C# .NET
318039 COME: Effettua un Valore predefinito invece che DBNull dall'utilizzo .NET di Visual Basic a un DataSet Return tipizzato
318048 COME: Crea un Valore predefinito invece che DBNull a un DataSet Return tipizzato utilizzando Visual C# .NET

Il relativo problema risolve

Se i problemi si verificano o se si dispone di domande, si pu˛ riferire ai newsgroup MSDN a cui Ŕ possibile condividere le esperienze con i peer. Utilizzare il Microsoft Knowledge Base dove Ŕ possibile cercare gli articoli sui problemi specifici Ŕ inoltre possibile.
Newsgroup di MSDN
http://msdn.microsoft.com/newsgroups/

Ricercare del knowledge base
http://support.microsoft.com/search/?adv=1
I prodotti di terze parti citati in questo articolo sono forniti da produttori indipendenti Microsoft esclude ogni garanzia implicita o contraria a proposito della prestazione o l'affidabilitÓ di questi prodotti.

ProprietÓ

Identificativo articolo: 313486 - Ultima modifica: lunedý 24 febbraio 2014 - Revisione: 6.7
Le informazioni in questo articolo si applicano a
  • Microsoft ADO.NET 1.1
  • Microsoft ADO.NET 1.0
  • Microsoft Visual Studio .NET 2003 Enterprise Architect
  • Microsoft Visual Studio .NET 2003 Enterprise Developer
  • Microsoft Visual Studio .NET 2003 Academic Edition
  • Microsoft Visual Studio .NET 2002 Professional Edition
  • Microsoft Visual Studio .NET 2002 Enterprise Architect
  • Microsoft Visual Studio .NET 2002 Enterprise Developer
  • Microsoft Visual Studio .NET 2002 Academic Edition
Chiavi:á
kbnosurvey kbarchive kbarttyperoadmap kbinfo kbsystemdata KB313486 KbMtit kbmt
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica. Nel caso in cui si riscontrino degli errori e si desideri inviare dei suggerimenti, Ŕ possibile completare il questionario riportato alla fine del presente articolo.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 313486
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com