Article ID: 313492 - Last Review: May 15, 2007 - Revision: 1.6

You may receive a "Remote Assistance failed" error message on a Windows XP-based Internet Connection Sharing client computer that uses the Internet Connection Firewall feature

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This article was previously published under Q313492

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SYMPTOMS

Consider this scenario: You send a Remote Assistance invitation to a Windows XP-based Internet Connection Sharing host computer from a Windows XP-based Internet Connection Sharing client computer. The client computer has the Internet Connection Firewall (ICF) feature enabled. You receive an error message that is similar to the following:
Remote Assistance failed. Please try again.

CAUSE

This problem may occur if all the following conditions are true:
  • The Internet Connection Sharing client computer uses the Dpnhpast.dll file to establish communication with the Internet Connection Sharing host computer.
  • The Internet Connection Sharing host computer does not start all services correctly.
  • The Internet Connection Sharing client computer believes that the Internet Connection Sharing host computer is running Microsoft Windows Millennium Edition.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/ ) How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time   Version            Size    File name
--------------------------------------------------------------
28-Nov-2001  10:42  5.1.2600.21        30,208  Dpnhpast.dll 

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows XP Service Pack 1.

APPLIES TO
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Keywords: 
kbautohotfix kbhotfixserver kbqfe kbqfe kbbug kbfix kbmm kbwinxpsp1fix KB313492
 

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