Microsoft Office for Mac プログラムのフォントに関する問題のトラブルシューティング方法

文書翻訳 文書翻訳
文書番号: 313535 - 対象製品
この記事は、以前は次の ID で公開されていました: JP313535
すべて展開する | すべて折りたたむ

目次

現象

Microsoft Office for Mac プログラムの起動時、または Microsoft Office for Mac プログラムのドキュメントを開くときに、プログラムの起動画面が表示されることがありますが、プログラムは予期せず終了します。

原因

この問題は、破損したフォントまたはサポートされていないフォントがコンピュータのフォント フォルダにある場合に発生することがあります。

Microsoft Office X for Mac プログラムまたは Microsoft Office 2004 for Mac プログラムは、起動時に、オペレーティング システムで使用可能なフォントを読み込んで最適化された一覧を作成します。破損したフォントが検出されると、プログラムが突然終了することがあります。以下の条件に該当する場合に、この問題が発生する可能性があります。
  • フォント ファイルの重複
  • フォント キャッシュ ファイルの破損
  • フォント ファイルの破損
原因が異なる同様の現象の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
312209 [MacWDX] Word を起動すると "アプリケーション Microsoft Word は予期しない理由で終了しました" というエラー メッセージが表示される
313488 [MacOFFX] プロジェクト ギャラリで OK をクリックするとプログラムが予期せず終了する

解決方法

重複したフォントまたは破損したフォントを特定して削除する

この問題を解決するには、破損したフォントを見つけて無効にします。この操作を行うには、以下の方法を記載されている順に実行します。

注意 : Mac OS X のシステム フォルダにあるフォント フォルダはいずれも変更しないでください。

破損したフォント キャッシュ

  1. 次のフォルダを開きます。
    Hard disk:ユーザ:User_name:ライブラリ:Preferences:Microsoft
  2. Microsoft Office X の場合は、Office Font Cache (10) ファイルをゴミ箱にドラッグします。Microsoft Office 2004 の場合は、Office Font Cache (11) をゴミ箱にドラッグします。
Microsoft Word for Mac (以下 Word) を起動し、問題が解決しているかどうかを確認します。

重複したフォント ファイル

  1. デスクトップで、[ファイル] メニューをクリックし、[新規フォルダ] をクリックします。
  2. 新しいフォルダに Old Fonts という名前を付けます。
  3. Finder で、以下のフォント フォルダを開きます。
    • Hard disk:Mac OS 9 System_folder:フォント
      通常、このフォルダは Hard disk:システムフォルダ:フォントです。
    • Hard disk:ライブラリ:Fonts
    • Hard disk:ユーザ:User_name:ライブラリ:Fonts
  4. 重複したフォント ファイルがある場合はそのファイルを、手順 2. で作成した Old Fonts フォルダにドラッグします。
  5. コンピュータを再起動します。
Word を起動し、問題が解決しているかどうかを確認します。

破損したフォント ファイル

  1. Finder で、Mac OS 9 フォントを含むフォルダを開きます。通常、Mac OS 9 フォントを含むフォルダは以下のとおりです。
    Hard disk:システムフォルダ:フォント
  2. Fonts フォルダにあるフォント ファイルを、この資料の「重複するフォント ファイル」で作成した、デスクトップの Old Fonts フォルダにドラッグします。
  3. コンピュータを再起動します。
  4. Word を起動し、問題が解決しているかどうかを確認します。
  5. 問題が依然として発生する場合は、Old Fonts フォルダにあるフォント ファイルを、手順 1. で使用したフォント フォルダに戻します。
  6. それでもなお問題が発生する場合は、手順 1. で使用したフォルダとは異なるフォント フォルダを使用して、手順 1. 〜 4. を繰り返します。以下のいずれかのフォント フォルダを使用します。
    • Hard disk:ライブラリ:Fonts
    • Hard disk:ユーザー:User_name:ライブラリ:Fonts
問題が発生しない場合は、手順 1. で使用したフォント フォルダに破損したフォントがあると考えられます。

問題の原因となったフォントを特定するには、消去法を使用します。フォントの半分を一度にフォント フォルダに戻し、問題が発生するかどうかを確認します。破損したフォントを見つけるには、以下の手順を実行します。
  1. フォントを削除したフォント フォルダを開きます。
  2. Old Fonts フォルダを開き、[表示] メニューの [リスト] をクリックします。
  3. 一覧の最初に表示されたフォント ファイルをクリックします。
  4. 一覧の中程までスクロールします。
  5. Shift キーを押しながら、一覧の中程にあるフォントをクリックします。これで、一覧の約半分のフォントを選択することができます。
  6. 選択したフォントを、手順 1. で開いたフォント フォルダにドラッグします。
  7. Word を起動し、問題が解決しているかどうかを確認します。
  8. 問題が発生する場合は、フォント フォルダにコピーした半分のフォントの中に破損したフォントがあります。破損したフォントを見つけるには、以下の手順を実行します。
    1. フォント フォルダにコピーした半分のフォントを選択します。
    2. これらのフォントを Old Fonts フォルダにドラッグします。
    3. Word を起動し、問題が解決しているかどうかを確認します。
    4. 問題が依然として発生する場合は、手順 a. 〜 c. を繰り返します。
  9. 手順 7. で問題が発生しない場合は、Old Fonts フォルダに残っているフォントの半分を選択し、手順 3. 〜 8. を繰り返します。

Mac OS X オペレーティング システムに関する問題

この問題は、コンピュータにインストールした Mac OS X オペレーティング システムのバージョンに問題がある場合にも発生することがあります。Mac OS X オペレーティング システムに関する問題のトラブルシューティング方法の詳細については、以下のアップル コンピュータ株式会社の Web サイトを参照してください。
http://www.apple.co.jp/support/

その他の考えられる原因について

フォント管理ソフトウェア

フォントを管理するためのソフトウェアがコンピュータで実行されている場合、そのソフトウェアを無効にして、エラーの原因となっているかどうかを確認します。

複数の Mac OS 9 システム フォルダ

追加の Mac OS 9 システム フォルダの名前を変更することや削除することができます。ハード ディスクのルートにあるフォルダは、プライマリ OS 9 システム フォルダのみです。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 313535 (最終更新日 2005-08-18) を基に作成したものです。

プロパティ

文書番号: 313535 - 最終更新日: 2012年10月1日 - リビジョン: 7.0
この資料は以下の製品について記述したものです。
  • Microsoft Entourage 2004 for Mac
  • Microsoft Excel 2004 for Mac
  • Microsoft Excel X for Mac
  • Microsoft Office 2004 for Mac Standard Edition
  • Microsoft Office v.X for Mac Standard Edition
  • Microsoft PowerPoint 2004 for Mac
  • Microsoft PowerPoint X for Mac
  • Microsoft Word 2004 for Mac
  • Microsoft Word X for Mac
キーワード:?
kbprb KB313535
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com