BUG: PC 카드 Type 병렬 중 입출력 리소스 얻는 있지 않음

기술 자료 번역 기술 자료 번역
기술 자료: 313580 - 이 문서가 적용되는 제품 보기.
모두 확대 | 모두 축소

현상

병렬 함수 코드 사용하여 PC 카드 드라이버가 Windows XP에서 해당 IRP_MN_START_DEVICE 있는 모든 리소스를 받지 않습니다. 일반적으로 IRP_MN_START_DEVICE 실패할 PnP (PNP) 입/출력 요청 패킷 (IRP) 처리기를 발생합니다. 장치 관리자에 노란색 느낌표가 및 오류 코드 10 장치와 표시합니다 결과입니다.

하지만 드라이버가 IRP_MN_START_DEVICE 그래도 성공하면 장치가 장치 관리자에 같은 성공적으로 시작될 있지만 그 연결된 리소스 없거나 완전하지 나타날 수 있습니다.

원인

Windows XP PCMCIA 버스 드라이버 경우에만 두 I/O 포트 범위, 권한이 없는 경우 또는 메모리 범위를 구성 튜플 요청하는 경우 장치에 함수 ID (21) 튜플 코드로 3 (병렬) 속하는 구성 튜플이 잘못된 것으로 표시합니다.

예를 들어, 일반적인 I/O 포트를 요청하는 있는 PC 카드로 구현된 병렬 포트 LPT1, LPT2 또는 LPT3 찾아 모든 구성 튜플 유효하지 않은 것으로 범위는. 이로 인해 시스템이 장치에 리소스를 할당할 수 있습니다. IRP_MN_START_DEVICE 빈 리소스 목록에 있고 드라이버가 이 IRP 일반적으로 실패하는 드라이버를 찾습니다.

해결 방법

이 문제를 해결하려면 Windows XP용 최신 서비스 팩을 구하십시오. 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하십시오.
322389최신 Windows XP 서비스 팩을 구하는 방법


이 문제를 해결하려면 위해 IOConfig 지시문을 통해 장치에 INF LogConfig 구역으로 잘못된 것으로 표시된 구성을 무시하십시오. 이렇게 후에 더미 I/O 포트 범위가 경우에만 두 I/O 포트 범위를 갖는 요구 사항을 충족하는 재정의된 구성 추가할 수 있습니다.

다음 샘플 코드에서는 LogConfig 섹션입니다 LPT1 범위 필요한 및 0778-077F 때 더미 I/O 포트 범위가 포함하도록 수정되었습니다 카드의:

[MyDeviceInstallSection]
...

[MyDeviceInstallSection.LogConfigOverride]
LogConfig=MyLogConfig
...

[MyLogConfig]
ConfigPriority=NORMAL
IOConfig=378-37F(3ff::)
IOConfig=778-77F(ffff::)

				
참고: 이 예제는 병렬 포트 10-비트 디코더 최악의 경우 속해 있다고 가정합니다. 16비트 디코더가 설정되어 있지만 더미 범위 없음 디코더가 존재합니다.

현재 상태

Microsoft는 이 문서의 시작 부분에 나열한 제품에서 문제를 확인했습니다. 이 문제는 Windows XP 서비스 팩 1에서 처음 수정되었습니다.

추가 정보

다음은 문제를 겪을 수 있는 튜플 일반적인 예입니다. PC 카드 장치를 병렬 있으므로 3으로 계산할 함수 ID 튜플 (21 h) 있습니다. 다른 튜플 중에서 함수 ID가 다음과 같이 됩니다:
21h TPL_CODE=CISTPL_FUNCID
02h TPL_LINK
03h TPLFID_FUNCTION
00h 

속성

기술 자료: 313580 - 마지막 검토: 2004년 7월 22일 목요일 - 수정: 1.1
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
키워드:?
kbmt kbbug kbfix kboswin2000fix kbwinxpsp1fix KB313580 KbMtko
기계 번역된 문서
중요: 본 문서는 전문 번역가가 번역한 것이 아니라 Microsoft 기계 번역 소프트웨어로 번역한 것입니다. Microsoft는 번역가가 번역한 문서 및 기계 번역된 문서를 모두 제공하므로 Microsoft 기술 자료에 있는 모든 문서를 한글로 접할 수 있습니다. 그러나 기계 번역 문서가 항상 완벽한 것은 아닙니다. 따라서 기계 번역 문서에는 마치 외국인이 한국어로 말할 때 실수를 하는 것처럼 어휘, 구문 또는 문법에 오류가 있을 수 있습니다. Microsoft는 내용상의 오역 또는 Microsoft 고객이 이러한 오역을 사용함으로써 발생하는 부 정확성, 오류 또는 손해에 대해 책임을 지지 않습니다. Microsoft는 이러한 문제를 해결하기 위해 기계 번역 소프트웨어를 자주 업데이트하고 있습니다.

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com