How to automatically convert many documents to Word 2002 format

Article translations Article translations
Article ID: 313714 - View products that this article applies to.
This article was previously published under Q313714
For a Microsoft Word 2003 version of this article, see 826174.
Expand all | Collapse all

On This Page

SUMMARY

This step-by-step procedure describes the following:
  • What the Batch Conversion Wizard is.
  • How to install the Batch Conversion Wizard.
  • How to use the Batch Conversion Wizard.
  • How advanced users can view the Batch Conversion Wizard macro code.


What is the Batch Conversion Wizard?

The Batch Conversion Wizard is a template that has a .wiz file name extension. It contains macros to perform a batch conversion of selected files to or from Word format. It contains the following macros:

Macro Name Description
AutoNew.Main This macro runs automatically when you click Batch Conversion Wizard on the New Document task pane, or when you click OK after selecting the Batch Conversion Wizard on the Other Documents tab (on the New Documents task pane, click General Templates).
StartConversionWizard This is the main macro that runs when you start the Batch Conversion Wizard.
AutoOpen.Main Not Used




Installing the Batch Conversion Wizard

The Batch Conversion Wizard is installed with the Word 2002 Setup program. If the Batch Conversion Wizard is not installed, install it by following these steps.

NOTE: The Batch Conversion Wizard is typically installed on first use, unless you specifically changed the Setup to make the component Not available, or unless you selected Run all from my computer.
  1. Quit all Office programs.
  2. Click Start, point to Settings, and then click Control Panel. (In Microsoft Windows XP, click Start, and then click Control Panel.)
  3. Double-click Add/Remove Programs.
  4. Do one of the following:
    • In Microsoft Windows 98, Windows Millennium Edition (Me), or Windows NT 4.0, click to select Microsoft Office XP or Microsoft Word 2002 on the Install/Unistall tab, and then click Add/Remove.

      -or-
    • In Microsoft Windows 2000 or Windows XP, click to select Change or Remove Programs, click to select Microsoft Office XP or Microsoft Word 2002 in the Currently installed programs list, and then click Change.
  5. Click to select Add or Remove Features, and then click Next.
  6. In the Features to install list, follow these steps.NOTE: Click the plus sign (+) to the left of the feature to expand it.

    1. Expand the Microsoft Word for Windows option.
    2. Expand the Wizards and Templates option.
    3. Click the More Wizards icon, and then click Run all from my computer on the shortcut menu.
  7. : Click the plus sign (+) to the left of the feature to expand it. Click Update to install the Batch Conversion Wizard.


Using the Batch Conversion Wizard

To use the Batch Conversion Wizard, follow these steps:
  1. On the File menu, click New to open the New Document task pane.
  2. In the New Document task pane, click General Templates.
  3. Click the Other Documents tab. Click the Batch Conversion Wizard icon, and then click OK.
For more information about the Batch Conversion Wizard, click Microsoft Word Help on the Help menu, type Batch Conversion Wizard in the Office Assistant or the Answer Wizard, and then click Search to view the topics returned.



ADDITIONAL INFORMATION

If you are an advanced user and you want to view the macro code of the Batch Conversion Wizard, use the procedure in this section. Note that this additional information is optional. It is not needed to convert multiple documents to or from Word format.



Viewing the Batch Conversion Wizard Macro Code


Microsoft provides programming examples for illustration only, without warranty either expressed or implied. This includes, but is not limited to, the implied warranties of merchantability or fitness for a particular purpose. This article assumes that you are familiar with the programming language that is being demonstrated and with the tools that are used to create and to debug procedures. Microsoft support engineers can help explain the functionality of a particular procedure, but they will not modify these examples to provide added functionality or construct procedures to meet your specific requirements. To view the macro code in the Batch Conversion Wizard, follow these steps:
  1. On the File menu, click Open.
  2. In the Look in list, select the folder that contains the sample macro template, change the Files of type box to All Files (*.*), and then click the appropriate sample macro template.
  3. Press and hold SHIFT and click Open.
  4. On the Tools menu, point to Macro, and then click Macros to open the Macros dialog box.
  5. In the Macros in list, select the sample macro template that you just opened.
  6. Select the appropriate macro, and then click Edit.

Properties

Article ID: 313714 - Last Review: September 27, 2006 - Revision: 2.1
APPLIES TO
  • Microsoft Word 2002 Standard Edition
Keywords: 
kbconversion kbhowtomaster kbhowto KB313714

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com