Microsoft Office deja de responder cuando intenta abrir o guardar un archivo

Síntomas

Si realiza uno de los procedimientos siguientes en uno de los programas de Microsoft Office que aparecen al final de este artículo, el programa puede dejar de responder (bloquear) durante mucho tiempo:

  • Haga clic en la lista Guardar en en el cuadro de diálogo Guardar como .
  • Haga clic en la lista Buscar en en el cuadro de diálogo Abrir .

Si hace clic en Cancelar o intenta cerrar el cuadro de diálogo, el programa sigue sin responder.

Causa

Este problema puede producirse si se cumple alguna de las condiciones siguientes:

  • Cuando el equipo está conectado a uno o varios recursos compartidos de red asignados que son inexistentes o que están actualmente sin conexión.
  • Cuando una o varias unidades asignadas son persistentes y la unidad está en un dominio que no es de confianza.
  • Cuando la unidad asignada se encuentra en un equipo lento o de nivel inferior. Un equipo de nivel inferior es cuando el sistema operativo del equipo tiene una versión anterior de Microsoft Windows que el equipo que está usando).
  • Cuando una unidad asignada está conectada a través de una red de área extensa (WAN).
  • Cuando una unidad es una unidad extraíble inaccesible.

Solución

Para resolver este problema, debe desconectar todas las unidades de red que tengan cualquiera de las condiciones que se indican en la sección "Causa". Para ello, siga estos pasos.

Nota Dado que hay varias versiones de Microsoft Windows, los pasos siguientes pueden ser diferentes en el equipo. Si es así, consulte la documentación del producto para completar estos pasos.

  1. Haga clic con el botón derecho en Mi equipo y, a continuación, haga clic en Desconectar unidad de red.
  2. En el cuadro de diálogo Desconectar unidad de red , haga clic en la letra de la unidad que desea desconectar y, a continuación, haga clic en Aceptar.
  3. Repita los pasos 1 y 2 hasta que todas las unidades de red sin conexión estén desconectadas. Si no está seguro de una unidad determinada, siga estos pasos:
    1. Haga clic en Inicio y luego en Ejecutar.

    2. En el cuadro Abrir, escriba lo siguiente y, a continuación, presione ENTRAR\nombre del equipo\nombre del recurso compartido.

      Donde nombre del equipo es el nombre del servidor que comparte el recurso y nombre del recurso compartido es el nombre del recurso compartido que desea usar.

      Si el recurso no está disponible, recibirá un mensaje de error similar al siguiente:

      No se encuentra el nombre de red.

Como alternativa, puede intentar ver el contenido de la unidad en el Explorador de Windows.

Solución alternativa

Para solucionar este comportamiento, use uno de los métodos siguientes.

Método 1: No usar conexiones persistentes

Al conectar una unidad asignada, haga clic para desactivar la casilla Volver a conectar al inicio de sesión . Al desactivar esta casilla, la unidad asignada no se conectará la próxima vez que inicie sesión en el equipo. Consulte la sección "Más información" para obtener más información sobre cómo asignar una unidad de red.

Método 2: Usar un script de inicio de sesión de usuario

Si puede, use un script de inicio de sesión para conectar un usuario a los servidores adecuados cada vez que el usuario inicie sesión. Asegúrese de que el script asigna la unidad en un estado no persistente. Si la unidad no está disponible a medida que se ejecuta el script de inicio de sesión, la unidad no se asigna. Este comportamiento evita el problema.

Método 3: Uso de la creación de reflejo del servidor

Si la conexión se realiza a través de una red de área extensa (WAN), considere la posibilidad de implementar la creación de reflejo del servidor. La creación de reflejo del servidor duplica localmente un servidor lejano. A continuación, asigne la unidad al servidor local duplicado. Esto puede reducir el tiempo de espera si se conecta a un servidor local.

Método 4: Usar un acceso directo a la ubicación de red

Use un acceso directo en el escritorio de Microsoft Windows o en Mi red Places para conectarse a la ubicación de red que desee.

Más información

Cada ubicación de una lista se comprueba para asegurarse de que está disponible y de que tiene permisos de acceso al realizar ambos procedimientos en los programas de Microsoft Office:

  • Intenta abrir o guardar un archivo.
  • Puede acceder a la lista Buscar en o Guardar en .

Si alguna unidad asignada está en un estado documentado en la sección "Causa", el programa de Office tarda algún tiempo en detectar y resolver la condición. Para evitar este comportamiento, debe desconectar esa unidad asignada. Puede buscar la disponibilidad de la unidad en cualquier momento en el Explorador de Windows. Si la unidad está disponible, vuelva a asignar la unidad de red más adelante.

Para asignar una unidad a un recurso que está en línea de nuevo, siga estos pasos:

  1. Haga clic con el botón derecho en Mi equipo y, a continuación, haga clic en Asignar unidad de red.

  2. En el cuadro Unidad, haga clic en la letra de unidad que desea usar para la unidad de red.

  3. En el cuadro Carpeta, escriba el siguiente \nombre del equipo\nombre del recurso compartido.

    Donde nombre del equipo es el nombre del servidor que comparte el recurso y nombre del recurso compartido es el nombre del recurso compartido que desea usar.

  4. Para que la unidad asignada no sea persistente, haga clic para desactivar la casilla Volver a conectar al inicio de sesión .

  5. Haga clic en Finalizar.

Si está intentando conectarse a recursos en otras redes, póngase en contacto con el administrador de red. Las unidades de red que ya no existen, que ya no se comparten o las unidades extraíbles inaccesibles deben desconectarse permanentemente para evitar afectar al rendimiento de los productos de Office.