PRB: El error "no puede abrir el archivo .pst" se produce cuando se utiliza un perfil de servidor POP3 con SQL Mail

Seleccione idioma Seleccione idioma
Id. de artículo: 313969 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Cuando utilizas para iniciar sesión en un equipo cliente de servicios de Terminal Server, recibirá el siguiente mensaje de error:
No se puede abrir el PST porque está en uso.
Puede recibir este mensaje de error en cualquiera de los dos escenarios siguientes:
  • Si el Agente SQL Server o SQL Mail (o ambas) está configurados para utilizar un perfil de correo de protocolo de oficina de correo 3 (POP3) e intenta abrir Microsoft Outlook utilizando el mismo perfil.
  • Si intenta iniciar el Agente SQL Server al mismo tiempo que un cliente de Outlook que está utilizando un perfil de correo POP3 está abierto y SQL Mail está configurado para utilizar el mismo perfil como el cliente de Outlook.
En una situación diferente donde uno de los procesos (Outlook o Agente SQL Server o SQL Mail) realmente modifica el archivo .pst (como enviar un mensaje de correo electrónico o creando una nueva carpeta), puede recibir el siguiente mensaje de error cuando el otro proceso está intentando obtener acceso a ese archivo .pst:
"El archivo 'ruta de acceso y nombre de archivo'.pst no se tiene acceso al porque otra estación de trabajo lo ha modificado. Cierre y reinicie todas las aplicaciones de correo".

Causa

Aplicación de sólo un usuario a la vez puede tener acceso a un archivo .pst.

Solución

Para solucionar este comportamiento, siga cualquiera de los métodos siguientes:
  • Para obtener correctamente acceso al archivo .pst cuando se conecta a través de cliente de servicios de Terminal Server para que utilice Outlook:
    1. Detener el servicio MSSQLServer.
    2. Inicie Outlook, compruebe su correo y, a continuación, salga de Outlook.
    3. Reinicie el servicio MSSQLSERVER.
  • También puede tener acceso al archivo .pst sin detener el servicio MSSQLSERVER. En lugar de servicios de Terminal Server, (que se abre una segunda sesión con la misma cuenta) utiliza Escritorio remoto compartido (de sólo en Microsoft Windows XP), Microsoft NetMeeting o productos de administración del equipo remoto de otros fabricantes. Al hacerlo, puede iniciar sesión en el equipo en el mismo contexto de usuario que está ejecutando en el propio equipo.
  • Para evitar el problema completamente, utilice perfiles independientes para Outlook y SQL Mail o Agente SQL Server, que a su vez utilizan archivos .pst independiente.
  • También puede utilizar Microsoft Exchange Server como servidor de correo, en cuyo caso no se utiliza un archivo .pst y varios contextos de usuario pueden tener acceso a un buzón al mismo tiempo.

Estado

Este comportamiento es por diseño.

Propiedades

Id. de artículo: 313969 - Última revisión: viernes, 17 de octubre de 2003 - Versión: 3.2
La información de este artículo se refiere a:
  • Microsoft SQL Server 2000 Standard Edition
  • Microsoft SQL Server 7.0 Standard Edition
Palabras clave: 
kbmt kbprb KB313969 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 313969

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com