"NTLDR is missing" ข้อความแสดงข้อผิดพลาดที่ปรากฏขึ้นเมื่อคุณติดตั้งหรืออัปเกรด Windows XP แทนที่ Windows 95, Windows 98 หรือ Windows Millennium Edition

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 314057 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
สำหรับ Microsoft Windows 2000 ในบทความนี้ โปรดดู 255220 (ลิงค์นี้อาจเชื่อมโยงไปยังเนื้อหาที่เป็นภาษาอังกฤษบางส่วน หรือทั้งหมด).
ขยายทั้งหมด | ยุบทั้งหมด

อาการ

หัวข้อนี้มีไว้สำหรับผู้ใช้คอมพิวเตอร์ขั้นสูง หากคุณกังวลกับวิธีการแก้ไขปัญหาขั้นสูง คุณอาจต้องการความช่วยเหลือจากบุคคลอื่นหรือติดต่อฝ่ายสนับสนุน สำหรับข้อมูลเกี่ยวกับวิธีการติดต่อ โปรดเยี่ยมชมที่เว็บไซต์ต่อไปนี้ของ Microsoft:
http://support.microsoft.com/contactus
เมื่อคุณพยายามติดตั้ง Windows XP หรือปรับรุ่นเป็น Windows XP ในคอมพิวเตอร์ที่ใช้ Microsoft Windows 95, Windows 98 หรือ Windows Millennium Edition คุณอาจได้รับข้อความแสดงข้อผิดพลาดต่อไปนี้หลังจากเริ่มระบบของคอมพิวเตอร์ใหม่ครั้งแรกระหว่างการติดตั้ง:
NTLDR is missing
Press any key to restart

สาเหตุ

ปัญหานี้อาจเกิดขึ้นหากการติดตั้ง Windows 95, Windows 98 หรือ Windows Millennium Edition เดิมใช้การโคลนและมีการกำหนดให้ไดรฟ์ที่แตกต่างไปจากต้นทางของการโคลนไดรฟ์

ตัวอย่างเช่น คุณรัน Windows 98 ในไดรฟ์ขนาด 4 กิกะไบต์ (GB) หลังจากนั้น คุณอัปเกรดฮาร์ดดิสก์เป็น 30 กิกะไบต์ โดยใช้ยูทิติลีจัดการดิสก์อื่นๆ ในการสร้างอิมเมจของการติดตั้ง Windows 98 แล้วนำอิมเมจนี้ไปใช้กับไดรฟ์ใหม่ ต่อมา คุณอัปเกรดเป็น Windows XP โดยคุณติดตั้ง Window XP แทนที่อิมเมจที่โคลนมาของ Windows 98

หากเกิดปัญหานี้ขึ้น สภาวะต่อไปนี้จะต้องเป็นจริงทั้งหมด:
  • พาร์ทิชัน system/startup ได้รับการฟอร์แมตด้วยระบบแฟ้ม FAT32
  • คอมพิวเตอร์เริ่มทำงานโดยใช้ INT-13 (คือพาร์ทิชันที่มีขนาดใหญ่กว่า 7.8 กิกะไบต์ พร้อมด้วยประเภท ID ระบบ 0C ในตารางพาร์ทิชัน)
  • เนื่องจากการทำโคลนนิ่ง ค่า Heads (sides) ใน FAT32 BIOS Parameter Block (BPB) จึงไม่ตรงกับรูปแบบทางกายภาพของไดรฟ์
รหัสเริ่มต้นของ Windows 95, Windows 98 หรือ Windows Millennium Edition ปฏิเสธค่า Heads ใน BPB แล้วเริ่มการทำงานของโปรแกรม ถึงแม้ว่าค่าจะไม่ถูกต้องก็ตาม อย่างไรก็ตาม โค้ดการเริ่มต้นระบบใน Microsoft Windows 2000 และ Windows XP ต้องใช้ค่านี้ และการเริ่มระบบจะไม่สำเร็จหากค่านี้ไม่ถูกต้อง

การแก้ไข

เมื่อต้องการแก้ไขปัญหานี้ ให้แก้ไขค่า Heads (sides) ใน FAT32 BPB เพื่อให้การเริ่มระบบของ Windows XP ทำงานต่อไปได้ การอัปเดทค่านี้ แก้ไขรหัสเริ่มต้นของ Windows 95, Windows 98 หรือ Windows Millennium Edition โดยให้ทำตามขั้นตอนต่อไปนี้:
  1. รีสตาร์ทเครื่องคอมพิวเตอร์โดยใช้ startup disk ของ Windows 95, Windows 98 หรือ Windows Millennium Edition ที่มีแฟ้ม Sys.com (โดยค่าเริ่มต้น จะมีแฟ้มนี้ให้มาด้วย)
  2. ทำสำเนาสำรองของแฟ้ม Msdos.sys ในไดเรกทอรีรากของไดรฟ์ระบบ โดยพิมพ์คำสั่งต่อไปนี้ที่พรอมต์คำสั่ง:
    attrib -h -r -s c:\msdos.sys
    rename msdos.sys *.ysy
  3. ที่พรอมต์คำสั่ง พิมพ์ sys c: การแทนที่รหัสเริ่มต้นของ Windows 95, Windows 98 หรือ Windows Millennium Edition ด้วยข้อมูล BPB ที่ถูกต้อง หากรันคำสั่งนี้ได้สำเร็จ ให้ไปที่ขั้นที่ 4

    หากคุณใช้ startup disk ของ Windows Millennium Edition และได้รับข้อความแสดงข้อผิดพลาดต่อไปนี้ แสดงว่ามีแฟ้มสำหรับติดตั้ง Windows Millennium Edition อย่างน้อยหนึ่งแฟ้มถูกลบไป
    ไม่พบแฟ้มระบบในตำแหน่งมาตรฐานในไดรฟ์ C:
    ทำตามขั้นตอนต่อไปนี้เพื่อวางแฟ้มที่ถูกต้องลงในไดรฟ์เพื่อให้คำสั่งsys สามารถระบุได้:
    1. พิมพ์คำสั่งต่อไปนี้ กด ENTER หลังจากแต่ละคำสั่ง:
      c:
      cd\windows
      หากติดตั้ง Windows ไว้ในโฟลเดอร์อื่นๆ นอกจากโฟลเดอร์ Windows ให้แก้ไขคำสั่งตามนั้น
    2. พยายามสลับไปยังโฟลเดอร์ Command โดยพิมพ์คำสั่งต่อไปนี้:
      cd command
      หากคุณได้รับข้อความแสดงข้อผิดพลาดที่แจ้งว่าไม่พบพาธ ให้พิมพ์คำสั่งต่อไปนี้เพื่อสร้างโฟลเดอร์ Command แล้วรันคำสั่งcd command อีกครั้ง:
      md command
    3. สลับไปยังโฟลเดอร์ EBD โดยการพิมพ์คำสั่งต่อไปนี้:
      cd ebd
      หากคุณได้รับข้อความแสดงข้อผิดพลาดที่แจ้งว่าไม่พบพาธ ให้พิมพ์คำสั่งต่อไปนี้เพื่อสร้างโฟลเดอร์ EBD แล้วรันคำสั่งcd ebd อีกครั้ง:
      md ebd
    4. ในโฟลเดอร์ EBD ใช้คำสั่งต่อไปนี้เพื่อคัดลอกแฟ้ม Io.sys จากรากของฮาร์ดดิสก์และเพื่อเปลี่ยนชื่อแฟ้ม Io.sys เป็น Winboot.sys:
      attrib -s -h -r c:\io.sys
      copy c:\io.sys winboot.sys
      Winboot.sys คือแฟ้มที่ Sys.com ต้องการ
    5. สลับกลับไปยังไดรฟ์ A แล้วพิมพ์คำสั่งต่อไปนี้:
      a:
      sys c:
    พิมพ์คำสั่งต่อไปนี้เพื่อเรียกคืนแฟ้ม Msdos.sys เดิม กด ENTER หลังจากแต่ละคำสั่ง:
    attrib -s -h -r c:\msdos.sys
    copy c:\msdos.ysy c:\msdos.sys
    กด Y เพื่อแทนที่แฟ้ม Msdos.sys ที่มีอยู่ คุณจะได้รับข้อความยืนยัน "1 FILE(S) COPIED" ว่าแฟ้มถูกแทนที่แล้ว
  4. รีสตาร์ทคอมพิวเตอร์เป็น Windows 95, Windows 98 หรือ Windows Millennium Edition แล้วลองติดตั้งหรืออัปเกรดเป็น Windows XP อีกครั้ง

    หมายเหตุ หรือหลังจากที่คุณเรียกใช้คำสั่ง sys c: คุณสามารถเริ่มการทำงานของ 'คอนโซลการกู้คืน' แล้วใช้คำสั่ง fixboot เพื่อเขียนโค้ดการเริ่มต้นระบบของ Windows XP ใหม่ ด้วยการทำงานนี้ การติดตั้งเดิมจะทำต่อไปได้ตามปกติ

สถานะ

Microsoft ยืนยันว่าปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ซึ่งมีการระบุไว้ในส่วน "การใช้งาน"

ข้อมูลเพิ่มเติม

หากต้องการทราบข้อมูลเพิ่มเติม โปรดคลิกที่หมายเลขบทความต่อไปนี้เพื่อดูบทความใน Microsoft Knowledge Base:
178947 ไม่พบแฟ้มรีจิสตรี เซอร์วิสรีจิสตรีอาจ... (ลิงค์นี้อาจเชื่อมโยงไปยังเนื้อหาที่เป็นภาษาอังกฤษบางส่วน หรือทั้งหมด)
318948 "NTLDR is missing or corrupt" ข้อความแสดงข้อผิดพลาดระหว่างปรับรุ่น Windows 2000 หรือ Windows NT 4.0 (ลิงค์นี้อาจเชื่อมโยงไปยังเนื้อหาที่เป็นภาษาอังกฤษบางส่วน หรือทั้งหมด)
320397 Windows อาจไม่เริ่มทำงานและคุณอาจได้รับข้อความแสดงข้อผิดพลาด "NTLDR is missing" หาก Windows ยังไม่ได้รับการปรับปรุงและมีแฟ้มจำนวนมากในโฟลเดอร์ราก
883275 คุณไม่สามารถเริ่มการทำงานของคอมพิวเตอร์ได้หลังจากที่คุณแก้ไขสิทธิ์ต่างๆ ใน Windows Server 2003, Windows XP หรือ Windows 2000 (ลิงค์นี้อาจเชื่อมโยงไปยังเนื้อหาที่เป็นภาษาอังกฤษบางส่วน หรือทั้งหมด)
812492 ข้อความแสดงข้อผิดพลาดเมื่อคุณเริ่มการทำงานของคอมพิวเตอร์โดยใช้ดิสก์ที่ไม่มีระบบปฏิบัติการ (ลิงค์นี้อาจเชื่อมโยงไปยังเนื้อหาที่เป็นภาษาอังกฤษบางส่วน หรือทั้งหมด)
315261 คอมพิวเตอร์จะไม่เริ่มการทำงานหลังจากที่คุณเปลี่ยนพาร์ติชันที่ใช้งานอยู่โดยใช้เครื่องมือการจัดการดิสก์ (ลิงค์นี้อาจเชื่อมโยงไปยังเนื้อหาที่เป็นภาษาอังกฤษบางส่วน หรือทั้งหมด)
หากบทความที่แสดงในรายการในที่นี้ไม่สามารถช่วยคุณแก้ไขปัญหาได้หรือหากคุณพบอาการที่แตกต่างจากที่อธิบายไว้ในบทความนี้ ให้ค้นหาข้อมูลในฐานความรู้ของ Microsoft เมื่อต้องการค้นหาฐานความรู้ของ Microsoft โปรดเยี่ยมชมเว็บไซต์ต่อไปนี้ของ Microsoft:
http://support.microsoft.com/?ln=th
แล้วพิมพ์ข้อความแสดงข้อผิดพลาดที่คุณได้รับ หรือพิมพ์คำอธิบายปัญหาไว้ในเขตข้อมูล ค้นหาฝ่ายสนับสนุน (KB)

คุณสมบัติ

หมายเลขบทความ (Article ID): 314057 - รีวิวครั้งสุดท้าย: 5 กุมภาพันธ์ 2551 - Revision: 4.0
ใช้กับ
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
Keywords: 
kberrmsg kbfilesystems kbenv kbsetup kbprb kbresolve KB314057

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com