Код статьи: 314063 - Vizualiza?i produsele pentru care se aplic? acest articol.
Данная статья была ранее опубликована под номером RU314063
Развернуть все | Свернуть все

В этой статье

ВВЕДЕНИЕ

В статье описываются некоторые причины и способы решения проблемы, связанной с сообщением об ошибке "Stop-ошибка: 0x0000000A", возникающей во время установки Windows XP, либо после ее завершения. Эта статья предназначена для опытных пользователей.

Проблема

Во время установки Windows XP, а также после нее может появиться следующее сообщение о критической ошибке:
Stop: 0x0000000A (параметр_1, параметр_2, параметр_3, параметр_4)
IRQL_NOT_LESS_OR_EQUAL
*** Адрес x имеет базу в xимя_файла
В этом сообщении о критической ошибке каждый параметр представляет собой шестнадцатеричное число, указывающее на определенную проблему.
  • Параметр 1: адрес в памяти, по которому выполнено некорректное обращение.
  • Параметр 2: прерывание, затребованное для доступа к памяти.
  • Параметр 3: тип доступа, где "0" — это операция чтения, а "1" — операция записи.
  • Параметр 4: адрес инструкции, обращающейся к участку памяти, указанному в параметре 1.
Например:
STOP 0x0000000A (0xBFD14AAC, 0x000000FF, 0x00000000, 0x8000F67C)
IRQL_NOT_LESS_OR_EQUAL
***Адрес 8000f67c имеет базу в 80001000 — hal.dll

Причина

Эта Stop-ошибка указывает на то, что в режиме ядра была предпринята попытка обратиться к файлу подкачки на слишком высоком уровне прерываний (IRQL) процесса. Обычно эта ошибка возникает при использовании драйвером неправильного адреса памяти. Другой причиной может являться несовместимый драйвер устройства, проблема с оборудованием или несовместимое программное обеспечение.

Решение

При возникновении этой ошибки используйте средство отчета об ошибках Windows, которое автоматически появляется на экране при возникновении любой ошибки. Средство отчета об ошибках позволяет отправлять отчет об ошибке напрямую в корпорацию Майкрософт и получать ответ о доступном исправлении или временном решении. Если исправление или временное решение проблемы недоступно, попытайтесь решить проблему с помощью раздела "Дополнительные способы устранения неполадок".

ДОПОЛНИТЕЛЬНЫЕ СПОСОБЫ УСТРАНЕНИЯ НЕПОЛАДОК

Данный раздел включает два подраздела.
  • Если сообщение об ошибке появляется во время установки, обратитесь к подразделу "Ошибка возникает во время установки Windows XP".
  • Если сообщение об ошибке появляется после установки Windows, обратитесь к подразделу "Ошибка возникает после установки Windows XP".
Приведенные в статье указания будет проще выполнять, если предварительно распечатать статью.

Ошибка возникает во время установки Windows XP

Если сообщение об ошибке "Stop-ошибка: 0x0000000A" появляется во время установки Windows XP, наиболее вероятной причиной ошибки является проблема с аппаратными компонентами компьютера. В первую очередь необходимо убедиться в совместимости используемого оборудования с Windows XP. Для получения инструкций обратитесь к разделу "Проверка совместимости оборудования". Если оборудование совместимо с Windows XP, для выявления причин возникновения ошибки воспользуйтесь инструкциями из раздела "Поиск прочих проблем с оборудованием".

Проверка совместимости оборудования

Сведения о возможной несовместимости программного обеспечения и оборудования можно получить в статье "Проверка совместимости системы" на установочном компакт-диске или DVD-диске Windows XP.

Поиск прочих проблем с оборудованием

В данном разделе описаны семь способов, которые можно использовать для устранения неполадок и выделения проблемы путем проверки оборудования.

Внимание! Данная статья содержит инструкции, связанные с изменением настроек BIOS, CMOS или физической конфигурации оборудования компьютера. Неправильная настройка BIOS может вызвать серьезные неполадки. Корпорация Майкрософт не гарантирует успешного решения проблем, возникших вследствие установки неправильных параметров BIOS. Ответственность за результаты выполненных действий несет пользователь. Для получения инструкций по выполнению этих действий обращайтесь к производителю оборудования. Помните, что изменение аппаратной конфигурации компьютера или параметров BIOS может привести к аннулированию гарантии производителя. Если вы не хотите самостоятельно выполнять физические изменения конфигурации компьютера, обратитесь за помощью в сервисный центр.

Необходимые условия

Необходимо убедиться в наличии установочного диска Windows XP. Для того чтобы воспользоваться одним из описанных ниже способов решения проблемы, необходимо выполнить загрузку компьютера с установочного диска Windows XP.

Рекомендуемые материалы

Перед выполнением действий по устранению проблемы убедитесь в доступности следующих материалов:
  • руководства по использованию установленного оборудования, адаптеров и устройств;
  • контактные данные производителей установленного оборудования, адаптеров и устройств.

Способ 1. Принудительное указание слоя абстрагирования оборудования (HAL)

Попробуйте использовать данный способ в первую очередь.
  1. В начале установки нажмите клавишу F5 при появлении сообщения "Программа установки проверяет аппаратную конфигурацию вашего компьютера".
  2. При появлении запроса укажите тип компьютера и слой абстрагирования оборудования (HAL). Например, для компьютера с одним процессором выберите тип "Стандартный компьютер".
  3. Попробуйте переустановить Windows XP.
    • Если удалось установить Windows XP без сообщений о критической ошибке, никаких дальнейших действий не требуется.
    • Если решить проблему не удалось, воспользуйтесь способом 2.

Способ 2. Отключение параметров в настройках CMOS

Используйте этот способ, если способом 1 решить проблему не удалось.
  1. Отключите указанные ниже параметры в настройках CMOS. Дополнительные указания можно получить в документации на оборудование или у его изготовителя.
    • Все виды кэширования, включая кэширование кэш-памяти второго уровня и BIOS, внутреннее и внешнее кэширование, а также обратную запись на контроллерах дисков.
    • Использование "теневой" памяти.
    • Plug and Play.
    • Все средства защиты от вирусов, встроенные в BIOS.
  2. Попробуйте переустановить Windows XP.
    • Если проблема решена, перейдите к действию c.
    • Если решить проблему не удалось, воспользуйтесь способом 3.
  3. Попробуйте установить, какой из параметров вызывает ошибку. Для этого включайте параметры по одному, выполняя перезагрузку после включения каждого из параметров.
  4. Если таким образом удалось определить проблемный параметр, отключите его и свяжитесь с производителем компьютера для решения проблемы.

    Если определить проблемный параметр не удалось, но компьютер загружается нормально, без появления сообщений об ошибках, то вероятнее всего именно параметры настроек CMOS препятствовали выполнению установки. В этом случае включите параметры после установки Windows XP. Никаких дальнейших действий не требуется.

Способ 3. Проверка ОЗУ

Используйте этот способ, если способом 2 решить проблему не удалось. Если для выполнения описанных ниже действий требуются дополнительные сведения, см. документацию на оборудование.
  1. Удалите непарные модули памяти SIMM; все модули должны иметь одинаковую скорость. Например, 60 нс или 70 нс.
  2. Запустите системный тест памяти и удалите все недействующие модули памяти SIMM.
  3. Протестируйте различные модули SIMM, если они доступны.
  4. Попробуйте переустановить Windows XP.
    • Если удалось установить Windows XP без сообщений о критической ошибке, никаких дальнейших действий не требуется.
    • Если решить проблему не удалось, воспользуйтесь способом 4.

Способ 4. Удаление адаптеров и отключение устройств

Используйте этот способ, если способом 3 решить проблему не удалось.
  1. Удалите все платы адаптеров, отключите все устройства, которые не являются необходимыми для запуска компьютера и установки Windows. К ним относятся следующие адаптеры и устройства:
    • SCSI-устройства;
    • IDE-устройства;
    • сетевой адаптер;
    • Внутренний модем
    • звуковая плата;
    • дополнительные жесткие диски (для завершения установки требуется не менее одного жесткого диска);
    • дисковод компакт-дисков или DVD-дисков (при установке с локального жесткого диска).
  2. Попробуйте переустановить Windows XP.
    • Если проблема решена, перейдите к действию c.
    • Если решить проблему не удалось, воспользуйтесь способом 5.
  3. Попробуйте установить, какое из устройств вызывает ошибку. После завершения установки Windows XP по одному подключайте адаптеры и устройства. После каждого подключения выполняйте перезагрузку компьютера.
  4. Если таким образом удалось определить проблемное оборудование, отключите его и свяжитесь с поставщиком для решения проблемы.

    Если выявить оборудование, вызывающее проблему, не удалось, но компьютер загружается нормально, без появления сообщений об ошибках, то вероятнее всего какое-либо из устройств препятствовало выполнению установки. В этом случае после установки Windows XP подключите ранее отключенное оборудование. Никаких дальнейших действий не требуется.

Способ 5. Обновление драйверов SCSI-устройств и отключение SCSI-устройств

Используйте этот способ, если способом 4 решить проблему не удалось. Если для выполнения описанных ниже действий требуются дополнительные сведения, см. документацию на оборудование.
  1. Получите у поставщика оборудования последнюю версию драйвера для Windows.
  2. Отключите синхронное согласование на контроллере SCSI.
  3. Проверьте правильность терминирования и распределения идентификаторов устройств SCSI
  4. Отключите все SCSI-устройства, кроме одного жесткого диска (при загрузке с этого диска или установке на него).
  5. Попробуйте переустановить Windows XP.
    • Если проблема решена, перейдите к действию f.
    • Если решить проблему не удалось, воспользуйтесь способом 6.
  6. Попробуйте установить, какое из SCSI-устройств вызывает ошибку. После завершения установки Windows XP подключайте SCSI-устройства по одному. После каждого подключения выполняйте перезагрузку компьютера.
  7. Если таким образом удалось определить проблемное устройство, отключите его и свяжитесь с поставщиком для решения проблемы.

    Если определить устройство, вызывающее проблему, не удалось, но компьютер загружается нормально, без появления сообщений об ошибках, то вероятнее всего какое-либо из SCSI-устройств препятствовало выполнению установки. В этом случае после установки Windows XP подключите ранее отключенные устройства. Никаких дальнейших действий не требуется.

Способ 6. Изменение параметров IDE и отключение IDE-устройств

Используйте этот способ, если способом 5 решить проблему не удалось. Если для выполнения описанных ниже действий требуются дополнительные сведения, см. документацию на оборудование.
  1. Определите встроенный IDE-порт только как "Только основной".
  2. Проверьте правильность установленных параметров IDE-устройств (основное, подчиненное либо единственное устройство).
  3. Отключите все устройства IDE, кроме жесткого диска.
  4. Попробуйте переустановить Windows XP.
    • Если проблема решена, перейдите к действию e.
    • Если решить проблему не удалось, воспользуйтесь способом 7.
  5. Попробуйте установить, какой из параметров или устройств IDE вызывает ошибку. После завершения установки Windows XP подключайте IDE-устройства по одному. После каждого подключения выполняйте перезагрузку компьютера.
  6. Если таким образом удалось определить проблемное устройство, отключите его и свяжитесь с поставщиком для решения проблемы.

    Если определить устройство, вызывающее проблему, не удалось, но компьютер загружается нормально, без появления сообщений об ошибках, то вероятнее всего какое-либо из IDE-устройств препятствовало выполнению установки. В этом случае после установки Windows XP подключите ранее отключенные устройства. Никаких дальнейших действий не требуется.

Способ 7. Обращение к производителю за сведениями о типичных проблемах

Это последний из возможных способов решения данной проблемы. Используйте его, если другими способами решить проблему не удалось.
  1. Обратитесь к изготовителю компьютера или материнской платы за сведениями о наличии типичных проблем, связанных с работой или установкой Windows XP. Изготовитель может предоставить следующие виды помощи:
    • выполнение на компьютере диагностического теста;
    • обновление BIOS, если это возможно.
  2. Попробуйте переустановить Windows XP.

    Если решить проблему не удалось, обратитесь в службу технической поддержки корпорации Майкрософт. Сведения об обращении в службу технической поддержки см. на веб-сайте Майкрософт по следующему адресу:
    http://support.microsoft.com/contactus/?ln=ru#tab0

Ошибка возникает после установки Windows XP

Если сообщение об ошибке "Stop-ошибка: 0x0000000A" появляется после установки Windows, наиболее вероятной причиной ошибки является установка нового оборудования или программного обеспечения сторонних поставщиков. В этом случае проверку компонентов сторонних производителей начните со способов, описанных в разделе "Проверка программного обеспечения и оборудования сторонних производителей". Для выполнения инструкций может потребоваться документация на недавно установленное оборудование или программное обеспечение. Если этими способами решить проблему не удается, попробуйте воспользоваться одним из способов, описанных в разделе "Восстановление Windows".

Рекомендация

Перед применением указанных способов устранения проблемы создайте резервную копию системы, включая личные папки и файлы.

Проверка программного обеспечения и оборудования сторонних производителей

Способ 1. Проверка недавно установленного программного обеспечения сторонних производителей

Если после установки Windows было установлено какое-либо программное обеспечение сторонних производителей, удалите его, либо отключите его загрузку при запуске Windows. После этого перезагрузите компьютер и проверьте, устранена ли проблема.
  • Если установлено несколько программ сторонних производителей, удаляйте или отключайте их по одной, перезагружая компьютер после каждого действия, чтобы определить какая из программ вызывает ошибку.
  • Если после удаления одной из программ сообщение об ошибке перестанет появляться, причиной возникновения ошибки является эта программа. Сообщите об этом ее разработчикам для устранения проблемы.
  • Если после удаления программного обеспечения сообщения об ошибке продолжают появляться, причина возникновения ошибки не связана с программным обеспечением. Перейдите к разделу "Способ 2. Проверка недавно установленного оборудования".

Способ 2. Проверка недавно установленного оборудования

Если после установки Windows было добавлено новое оборудование, удалите его, чтобы проверить, прекратится ли появление сообщения об ошибке.
  • Если было установлено более одного устройства, удаляйте их по одному, перезагружая компьютер после каждого удаления, чтобы определить какое из устройств вызывает ошибку.
  • Если удаление нового оборудования позволяет решить проблему, выполните одно из перечисленных ниже действий.
    1. Найдите обновленные драйверы для устройства (если это возможно).
    2. Попробуйте выяснить у производителя, возникала ли подобная проблема ранее.
    3. Чтобы определить, работает ли устройство должным образом, запустите программу диагностики.
    Если проблема решена, никаких дальнейших действий не требуется.
  • Если удаление нового оборудования не решает проблему, попробуйте восстановить Windows с помощью средства восстановления системы. Сведения об этом см. в разделе "Восстановление Windows".

Восстановление Windows

Если удаление недавно установленного оборудования и программного обеспечения не решает проблему, попробуйте восстановить Windows. Для этого воспользуйтесь одним из описанных ниже способов.

Способ 1. Использование последней удачной конфигурации

Функция "Последняя удачная конфигурация" помогает в случае, когда после внесения каких-либо изменений в конфигурацию компьютера не удается загрузить Windows XP. При этом восстанавливаются значения элементов реестра и параметры драйверов, действовавшие в последней конфигурации, в которой загрузка была выполнена успешно. Дополнительные сведения об использовании команды "Загрузка последней удачной конфигурации" см. в следующей статье базы знаний Майкрософт:
307852 Как загрузить компьютер с Microsoft Windows XP, используя последнюю удачную конфигурацию
  • Если таким способом удается восстановить Windows и сообщение об ошибке больше не появляется, никаких дальнейших действий не требуется.
  • Если этот способ не помог, воспользуйтесь способом 2.

Способ 2. Восстановление установленного экземпляра Windows XP

Если использование последней удачной конфигурации не позволяет решить проблему, попробуйте восстановить установленный экземпляр Windows XP.
Необходимые условия
Убедитесь в наличии установочного диска Windows XP.
Рекомендуемые материалы
Перед выполнением действий по устранению проблемы убедитесь в доступности следующих материалов:
  • документация на антивирусное программное обеспечение и программное обеспечение уровня BIOS;
  • документация на компьютер с информацией по установке дисковода оптических дисков в качестве приоритетного загрузочного устройства.
Для восстановления экземпляра Windows XP выполните перечисленные ниже действия.
  1. Отключите все антивирусные программы, а также антивирусную защиту на уровне BIOS. Дополнительные сведения см. в соответствующем руководстве по программному обеспечении или справке в Интернете.
  2. Убедитесь в том, что загрузка в первую очередь выполняется с компакт- или DVD-диска. Для получения указаний по выполнению этой задачи см. документацию к компьютеру.
  3. Вставьте в дисковод компакт- или DVD-дисков компакт-диск Windows XP и перезагрузите компьютер.
  4. После появления приглашения "Press any key to boot from CD" нажмите любую клавишу. Компьютер будет загружен с компакт-диска Windows XP.
  5. При загрузке с компакт-диска система проверяет оборудование, а затем предлагает выбрать один из следующих вариантов.
    • Чтобы приступить к установке Windows XP, нажмите клавишу ВВОД.
    • Чтобы восстановить Windows ХР с помощью консоли восстановления, нажмите R.
    • Чтобы выйти из программы, не устанавливая Windows ХР, нажмите клавишу F3.
  6. Нажмите клавишу ВВОД.
  7. Для принятия условий лицензионного соглашения нажмите клавишу F8.
  8. В списке будет указан текущий экземпляр Windows XP. Выберите из следующих вариантов.
    • Чтобы попытаться восстановить выделенную копию Windows XP, нажмите R.
    • Чтобы установить новую копию Windows XP без восстановления, нажмите ESC.
  9. Нажмите клавишу R. После восстановления Windows XP в том случае, если были внесены изменения в оборудование, возможно, потребуется выполнить повторную активацию Windows.
    • Если таким способом удается восстановить Windows и сообщение об ошибке больше не появляется, никаких дальнейших действий не требуется.
    • Если этот способ не помог, воспользуйтесь способом 3.

Способ 3. Использование средства отката драйверов устройств

Используйте этот способ, если удается выполнить загрузку компьютера в безопасном режиме, а способ 2 не помогает решить проблему.

Средство отката драйверов устройств позволяет восстановить предыдущую версию драйвера устройства. Это средство можно использовать в том случае, если после обновления драйвера компьютер начинает работать нестабильно. Используя функцию отката драйверов, можно восстановить предыдущую версию драйвера и продолжать пользоваться компьютером. Для получения дополнительных сведений о средстве отката драйверов устройств щелкните следующий номер статьи базы знаний Майкрософт:
283657 Возврат к использованию предыдущего драйвера устройства в Microsoft Windows XP
  • Если таким способом удается восстановить Windows и сообщение об ошибке больше не появляется, никаких дальнейших действий не требуется.
  • Если этот способ не помог, воспользуйтесь способом 4.

Способ 4. Использование функции "Восстановление системы" Windows XP

Используйте этот способ, если удается выполнить загрузку компьютера в безопасном режиме, а способ 3 не помогает решить проблему. Функция "Восстановление системы" делает "снимок" конфигурации некоторых файлов программ и важных системных файлов и хранит эти сведения в виде точек восстановления, которые служат для восстановления предыдущего состояния Windows XP. Дополнительные сведения об использовании функции восстановления системы см. в следующей статье базы знаний Майкрософт:
306084 Восстановление ОС Microsoft Windows XP до предыдущего состояния
  • Если таким способом удается восстановить Windows и сообщение об ошибке больше не появляется, никаких дальнейших действий не требуется.
  • Если этот способ не помог, воспользуйтесь способом 5.

Способ 5. Использование агента восстановления

Корпорация Майкрософт рекомендует пользоваться агентом восстановления только в том случае, если не удается загрузить компьютер в безопасном режиме и другими доступными способами. Если не удается загрузить компьютер, можно запустить агент восстановления, используя набор установочных дискет или компакт-диск Windows XP.

Агент восстановления позволяет включать и отключать службы, форматировать диски, читать и записывать данные на локальный диск (включая диски с файловой системой NTFS), а также выполнять многие другие административные задачи. Он особенно полезен в тех случаях, когда необходимо восстановить работоспособность системы путем копирования определенного файла на жесткий диск с дискеты или компакт-диска или изменения параметров службы, препятствующей правильному запуску компьютера.
Необходимые условия
Убедитесь в наличии установочного компакт-диска или DVD-диска Windows XP. Дополнительные сведения об использовании консоли восстановления см. в следующей статье базы знаний Майкрософт:
307654 Установка и использование консоли восстановления в Windows XP
  • Если таким способом удается восстановить Windows и сообщение об ошибке больше не появляется, никаких дальнейших действий не требуется.
  • Если этот способ не помог, воспользуйтесь способом 6.

Способ 6. Изменение имени программы или драйвера

Корпорация Майкрософт рекомендует использовать данный способ только в крайнем случае, если другими способами восстановить работоспособность Windows не удается. При этом компьютер должен загружаться в безопасном режиме или в режиме MS-DOS.
  • Если Windows установлена в разделе FAT, загрузите MS-DOS и измените имя программы или драйвера, вызывающего проблему.
  • Если Windows установлена в разделе NTFS, загрузите компьютер в безопасном режиме и измените имя программы или драйвера, вызывающего проблему.

    Дополнительные сведения о вариантах безопасного режима загрузки см. на веб-сайте справки и поддержи Майкрософт в статье "Описание возможных вариантов безопасного режима загрузки Windows XP".
    • Если таким способом удается восстановить Windows и сообщение об ошибке больше не появляется, никаких дальнейших действий не требуется.
    • Если это не так, обратитесь в службу технической поддержки корпорации Майкрософт. Сведения об обращении в службу технической поддержки см. на веб-сайте Майкрософт по следующему адресу:
      http://support.microsoft.com/contactus/?ln=ru#tab0

Дополнительная информация

Если описанные в данной статье действия не привели к устранению ошибки "Stop-ошибка: 0x0000000A" и все оборудование компьютера входит в список совместимого оборудования, см. следующую статью базы знаний Майкрософт:
314103 Предварительные процедуры перед обращением в службу технической поддержки Майкрософт после появления сообщения об ошибке STOP на синем экране

Свойства

Код статьи: 314063 - Последний отзыв: 7 июня 2013 г. - Revision: 4.1
Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Ключевые слова: 
kbresolve kbenv kberrmsg kbhardware kbinfo kbsetup kbtshoot KB314063

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com