คุณได้รับข้อความแสดงข้อผิดพลาด "Stop error code 0x0000000A (IRQL_NOT_LESS_OR_EQUAL)" ใน Windows XP

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 314063 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

บทนำ

บทความนี้จะอธิบายสาเหตุและวิธีแก้ปัญหาต่างๆ ของข้อความแสดงข้อผิดพลาด "Stop: 0x0000000A" ที่คุณได้รับในระหว่างหรือหลังจากการติดตั้ง Windows XP บทความนี้มีจุดมุ่งหมายสำหรับผู้ใช้ขั้นสูง

อาการ

คุณได้รับข้อความแสดงข้อผิดพลาด Stop ในรูปแบบต่อไปนี้ ในระหว่างหรือหลังจากการติดตั้ง Windows XP
Stop: 0x0000000A (parameter1, parameter2, parameter3, parameter4)
IRQL_NOT_LESS_OR_EQUAL
*** แอดเดรส x อยู่ที่ x - ชื่อแฟ้ม
ในข้อความแสดงข้อผิดพลาด Stop นี้ พารามิเตอร์แต่ละตัวเป็นตัวเลขฐานสิบหกที่อ้างถึงแต่ละปัญหา
  • Parameter 1 - แอดเดรสที่อ้างถึงไม่ถูกต้อง
  • Parameter 2 - IRQL ที่ต้องการเพื่อเข้าใช้งานหน่วยความจำ
  • Parameter 3 - ชนิดของการเข้าใช้งาน โดยที่ 0 คือการอ่านและ 1 คือการเขียน
  • Parameter 4 - แอดเดรสของคำแนะนำที่อ้างถึงหน่วยความจำในพารามิเตอร์ 1
ตัวอย่างเช่น:
STOP 0x0000000A (0xBFD14AAC, 0x000000FF, 0x00000000, 0x8000F67C)
IRQL_NOT_LESS_OR_EQUAL
***แอดเดรส 8000f67c อยู่ที่ 80001000 - hal.dll

สาเหตุ

ข้อความแสดงข้อผิดพลาด Stop นี้ มักจะเกิดขึ้นในระหว่างการติดตั้ง เมื่อมีการพยายามใช้งานหน่วยความจำเพจที่มีระดับการร้องขอสัญญาณขัดจังหวะ (IRQL) สูงเกินไปในโหมดเคอร์เนล โดยปกติ ข้อผิดพลาดนี้จะเกิดขึ้นเมื่อไดรเวอร์ใช้แอดเดรสหน่วยความจำไม่ถูกต้อง สาเหตุอื่นๆ ที่อาจเป็นไปได้ของข้อผิดพลาดนี้ ได้แก่ ไดรเวอร์ของอุปกรณ์ที่ไม่สามารถใช้งานได้ ปัญหาฮาร์ดแวร์ทั่วไป หรือปัญหาซอฟต์แวร์ใช้งานร่วมกันไม่ได้

การแก้ไข

เมื่อข้อความแสดงข้อผิดพลาด Stop นี้เกิดขึ้น ก่อนอื่น ให้ลองแก้ไขปัญหาด้วยการใช้เครื่องมือรายงานข้อผิดพลาดของ Windows ที่แสดงขึ้นโดยอัตโนมัติ เมื่อมีข้อผิดพลาดใดๆ เกิดขึ้น เครื่องมือรายงานนี้จะส่งรายงานข้อผิดพลาดไปที่ Microsoft และแจ้งวิธีแก้ไขปัญหาหรือวิธีชั่วคราวให้กับคุณในทันที ถ้าไม่มีวิธีแก้ไขปัญหาหรือวิธีชั่วคราว หรือวิธีแก้ไขปัญหาหรือวิธีชั่วคราวที่เครื่องมือแจ้งมา ไม่สามารถแก้ไขข้อผิดพลาดได้ ให้ทำตามวิธีการในหัวข้อ "การแก้ไขปัญหาขั้นสูง"

การแก้ไขปัญหาขั้นสูง

หัวข้อนี้ประกอบด้วยสองส่วนสำหรับการแก้ไขปัญหาขั้นสูง
  • ถ้าข้อผิดพลาดเกิดขึ้นในระหว่างการติดตั้ง ไปที่หัวข้อ "ข้อผิดพลาดขณะติดตั้ง Windows XP"
  • ถ้าข้อผิดพลาดเกิดขึ้นหลังจากที่ติดตั้ง Windows XP เรียบร้อยแล้ว ไปที่หัวข้อ "ข้อผิดพลาดหลังจากที่ติดตั้ง Windows XP เรียบร้อยแล้ว"
คุณสามารถทำตามวิธีการต่างๆ ได้ง่ายขึ้น หากคุณพิมพ์บทความนี้ออกมาก่อน

ข้อผิดพลาดขณะติดตั้ง Windows XP

ถ้าคุณได้รับข้อความแจ้งข้อผิดพลาด "Stop: 0x0000000A" ในระหว่างการติดตั้ง Windows XP แสดงว่าส่วนประกอบฮาร์ดแวร์ที่ติดตั้งในคอมพิวเตอร์ของคุณอาจมีปัญหา ก่อนอื่น ตรวจสอบว่าฮาร์ดแวร์ของคุณเข้ากันได้กับ Windows XP หรือไม่ โดยการทำตามการเชื่อมโยงในหัวข้อ "ตรวจสอบว่าฮาร์ดแวร์ของคุณเข้ากันได้" ถ้าฮาร์ดแวร์ของคุณเข้ากันได้ ให้ทำตามขั้นตอนในการแก้ไขปัญหาส่วนประกอบฮาร์ดแวร์ในหัวข้อ "ถ้าฮาร์ดแวร์ของคุณเข้ากันได้ ค้นหาปัญหาฮาร์ดแวร์อื่นๆ"

ตรวจสอบว่าฮาร์ดแวร์ของคุณเข้ากันได้

สำหรับข้อมูลเพิ่มเติม ดูหัวข้อ "ตรวจสอบความเข้ากันได้ของระบบ" ในแผ่นซีดีหรือดีวีดีการติดตั้ง Windows XP เพื่อเรียนรู้การเข้ากันไม่ได้ของซอฟต์แวร์และฮาร์ดแวร์ที่อาจเกิดขึ้นได้

ถ้าฮาร์ดแวร์ของคุณเข้ากันได้ ค้นหาปัญหาฮาร์ดแวร์อื่น

หัวข้อนี้จะแสดงวิธีเจ็ดวิธีในการแก้ไขปัญหาและแยกแต่ละปัญหาโดยการตรวจสอบฮาร์ดแวร์เพื่อดูปัญหาที่อาจเกิดขึ้น

คำเตือน บทความนี้ประกอบด้วยขั้นตอนต่างๆ ที่อาจมีการแก้ไขการตั้งค่า BIOS หรือ CMOS หรืออาจต้องทำการแก้ไขฮาร์ดแวร์คอมพิวเตอร์ การแก้ไข BIOS ของคอมพิวเตอร์ไม่ถูกต้องอาจทำให้เกิดปัญหาร้ายแรงได้ Microsoft ไม่สามารถรับประกันว่าปัญหาที่เกิดจากการแก้ไข BIOS จะสามารถแก้ไขได้ การเปลี่ยนการตั้งค่า BIOS ถือเป็นความรับผิดชอบของคุณเอง หากคุณต้องการความช่วยเหลือในขั้นตอนเหล่านี้ ให้ติดต่อบริษัทผู้ผลิตฮาร์ดแวร์ การทำการเปลี่ยนแปลงฮาร์ดแวร์ หรือ BIOS ของคอมพิวเตอร์อาจทำให้การรับประกันสิ้นสุด หากคุณไม่ต้องการแก้ไขฮาร์ดแวร์ของคอมพิวเตอร์ ให้นำเครื่องคอมพิวเตอร์ไปยังศูนย์ซ่อม

ข้อกำหนดเบื้องต้น

ตรวจดูให้แน่ใจว่าคุณมีแผ่นซีดีหรือดีวีดีติดตั้ง Windows XP วิธีการต่อไปนี้จะต้องใช้แผ่นซีดีหรือดีวีดีติดตั้ง Windows XP เพื่อเริ่มคอมพิวเตอร์

ข้อมูลแนะนำ

ก่อนเริ่มขั้นตอนแก้ไขปัญหา คุณควรจะมีรายการต่อไปนี้
  • เอกสารประกอบสำหรับฮาร์ดแวร์ อะแดปเตอร์ หรืออุปกรณ์ที่เพิ่มเติม
  • ข้อมูลติดต่อสำหรับผู้ผลิตฮาร์ดแวร์ อะแดปเตอร์ หรืออุปกรณ์ที่เพิ่มเติม

วิธีที่ 1: ระบุ Hardware Abstraction Layer (HAL)

ใช้วิธีนี้ก่อนในการพยายามแก้ไขข้อความแสดงข้อผิดพลาด Stop
  1. ระหว่างเริ่มการติดตั้ง ให้กดปุ่ม F5 เมื่อข้อความ "Setup is inspecting your computer's hardware configuration" แสดงขึ้น
  2. เมื่อได้รับการแจ้ง ขอให้ระบุประเภทของคอมพิวเตอร์และ Hardware Abstraction Layer (HAL) ที่ถูกต้อง ตัวอย่างเช่น หากคุณมีหน่วยประมวลผลตัวเดียว ให้ระบุ HAL เป็น "Standard PC"
  3. ลองติดตั้ง Windows XP ดูใหม่
    • ถ้าสามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop และติดตั้ง Windows XP สำเร็จ ถือว่าจบการทำงาน
    • ถ้าไม่สามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop ไปที่วิธีที่ 2

วิธีที่ 2: ปิดคุณลักษณะในการตั้งค่า CMOS

ใช้วิธีนี้ ถ้าวิธีที่ 1 ไม่สามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop ได้
  1. ปิดคุณลักษณะต่อไปนี้ทั้งหมดในการตั้งค่า CMOS สำหรับคอมพิวเตอร์ของคุณ สำหรับคำแนะนำ โปรดดูเอกสารประกอบฮาร์ดแวร์หรือติดต่อผู้ผลิต
    • การแคชทั้งหมด รวมทั้ง L2, BIOS ภายใน/ภายนอก และการแคชแบบไรท์แบ็คในดิสก์คอนโทรลเลอร์
    • การทำแชโดว์ทั้งหมด
    • Plug and Play
    • คุณลักษณะของ BIOS ในการช่วยป้องกันไวรัส
  2. ลองติดตั้ง Windows XP ดูใหม่
    • ถ้าสามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop ไปที่ขั้นตอน c
    • ถ้าไม่สามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop ไปที่วิธีที่ 3
  3. พยายามแยกให้ได้ว่าคุณลักษณะใดที่ทำให้เกิดข้อผิดพลาด โดยการเปิดใช้งานคุณลักษณะทีละรายการ แล้วเริ่มคอมพิวเตอร์หลังจากที่เปิดใช้งานแต่ละคุณลักษณะ
  4. ถ้าคุณสามารถระบุคุณลักษณะที่เกิดปัญหาได้แล้ว ให้ปิดคุณลักษณะนั้นหรือถอดออก และติดต่อผู้ผลิตเพื่อให้แก้ไขปัญหานั้น

    ถ้าไม่สามารถแยกปัญหาการตั้งค่า CMOS ออกได้ แต่สามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop และสามารถเริ่มต้นคอมพิวเตอร์ได้ตามปกติ อาจเป็นเพราะว่ามีการตั้งค่าอย่างใดอย่างหนึ่งป้องกันไม่ให้ติดตั้งได้ ถ้าเป็นเช่นนี้ ให้เปิดใช้การตั้งค่า หลังจากที่คุณติดตั้ง Windows XPแล้วจึงจบการทำงาน

วิธีที่ 3: ตรวจสอบ RAM ของคอมพิวเตอร์

ใช้วิธีนี้ ถ้าวิธีที่ 2 ไม่สามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop ได้ ถ้าคุณต้องการความช่วยเหลือขณะทำขั้นตอนต่อไปนี้ โปรดดูเอกสารประกอบฮาร์ดแวร์
  1. ถอด SIMM (RAM) หน่วยความจำที่ไม่ตรงออก เพื่อให้ SIMM ทั้งหมดทำงานได้ด้วยความเร็วเท่ากัน เช่น 60 นาโนวินาที (ns) หรือ 70 ns
  2. รันทดสอบระบบในหน่วยความจำ แล้วลบ SIMMs ที่เสียออก
  3. ทดสอบโดยการใช้ SIMMs อื่นๆ หากมี
  4. ลองติดตั้ง Windows XP ดูใหม่
    • ถ้าสามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop และติดตั้ง Windows XP สำเร็จ ถือว่าจบการทำงาน
    • ถ้าไม่สามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop ไปที่วิธีที่ 4

วิธีที่ 4: ถอดอะแดปเตอร์ออกและถอดการเชื่อมต่ออุปกรณ์ใดๆ

ใช้วิธีนี้ ถ้าวิธีที่ 3 ไม่สามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop ได้
  1. ถอดอะแดปเตอร์ทั้งหมดและถอดการเชื่อมต่ออุปกรณ์ฮาร์ดแวร์ที่ไม่จำเป็นในการเริ่มคอมพิวเตอร์หรือในการติดตั้ง Windows ซึ่งรวมทั้งอะแดปเตอร์และอุปกรณ์ต่อไปนี้
    • อุปกรณ์ SCSI
    • อุปกรณ์ IDE
    • อะแดปเตอร์เครือข่าย
    • โมเด็มติดตั้งภายใน
    • การ์ดเสียง
    • ฮาร์ดดิสก์เพิ่มเติม (ต้องมีฮาร์ดดิสก์อย่างน้อยหนึ่งตัวเพื่อทำการติดตั้งนี้ให้เสร็จสมบูรณ์)
    • ไดรฟ์ซีดีหรือไดรฟ์ดีวีดี (หากคุณติดตั้งจากฮาร์ดดิสก์ในเครื่อง)
  2. ลองติดตั้ง Windows XP ดูใหม่
    • ถ้าสามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop ทำต่อที่ขั้นตอน c
    • ถ้าไม่สามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop ไปที่วิธีที่ 5
  3. พยายามแยกอะแดปเตอร์หรืออุปกรณ์ฮาร์ดแวร์ที่เป็นต้นเหตุของข้อผิดพลาด หลังจากที่ได้ติดตั้ง Windows XP ใหม่แล้ว ให้เชื่อมต่ออะแดปเตอร์หรืออุปกรณ์ฮาร์ดแวร์ใหม่ทีละตัว เริ่มระบบคอมพิวเตอร์ของคุณใหม่ หลังจากที่ได้เชื่อมต่อใหม่แล้ว
  4. ถ้าสามารถแยกปัญหาฮาร์ดแวร์ออกได้ ให้ถอดการเชื่อมต่ออะแดปเตอร์หรืออุปกรณ์ และติดต่อผู้ขายเพื่อแก้ไขปัญหา

    ถ้าไม่สามารถแยกปัญหาฮาร์ดแวร์ออกได้ แต่สามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop และสามารถเริ่มต้นคอมพิวเตอร์ได้ตามปกติ อาจเป็นเพราะว่าฮาร์ดแวร์บางตัวป้องกันไม่ให้ติดตั้งได้ ถ้าเป็นเช่นนี้ ให้เชื่อมต่อฮาร์ดแวร์ใหม่ หลังจากที่คุณติดตั้ง Windows XPแล้วจึงจบการทำงาน

วิธีที่ 5: ปรับปรุงไดรเวอร์ SCSI และถอดอุปกรณ์ SCSI ทั้งหมดออก

ใช้วิธีนี้ ถ้าวิธีที่ 4 ไม่สามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop ได้ ถ้าคุณต้องการความช่วยเหลือขณะทำขั้นตอนต่อไปนี้ โปรดดูเอกสารประกอบฮาร์ดแวร์
  1. ดาวน์โหลดไดรเวอร์ล่าสุดสำหรับ Windows จากผู้ผลิตอะแดปเตอร์
  2. ปิดการทำการซิงค์ในคอนโทรลเลอร์ SCSI
  3. ตรวจดูให้แน่ใจว่าการจบและ ID ของอุปกรณ์ SCSI ถูกต้อง
  4. ถอดอุปกรณ์ SCSI ทั้งหมดออกจากการเชื่อมต่อ SCSI (ยกเว้นฮาร์ดดิสก์ที่คุณจะใช้เริ่มระบบหรือติดตั้งไปยังไดรฟ์ที่อยู่ในดิสก์นั้นๆ)
  5. ลองติดตั้ง Windows XP ดูใหม่
    • ถ้าสามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop ทำต่อที่ขั้นตอน f
    • ถ้าไม่สามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop ไปที่วิธีที่ 6
  6. พยายามแยกให้ได้ว่าอุปกรณ์ SCSI ใดที่ทำให้เกิดข้อผิดพลาด หลังจากที่ได้ติดตั้ง Windows XP ใหม่แล้ว ให้เชื่อมต่ออุปกรณ์ SCSI ใหม่ทีละตัว เริ่มระบบคอมพิวเตอร์ของคุณใหม่ หลังจากที่ได้เชื่อมต่อใหม่แล้ว
  7. ถ้าสามารถแยกปัญหาอุปกรณ์ออกได้ ให้ถอดการเชื่อมต่ออุปกรณ์ SCSI และติดต่อผู้ขายเพื่อแก้ไขปัญหา

    ถ้าไม่สามารถแยกปัญหาอุปกรณ์ SCSI ออกได้ แต่สามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop และสามารถเริ่มต้นคอมพิวเตอร์ได้ตามปกติ อาจเป็นเพราะว่ามีอุปกรณ์ที่ป้องกันไม่ให้ติดตั้งได้ ถ้าเป็นเช่นนี้ ให้เชื่อมต่ออุปกรณ์ใหม่ หลังจากที่คุณติดตั้ง Windows XPแล้วจึงจบการทำงาน

วิธีที่ 6: กำหนดการตั้งค่า IDE ใหม่และถอดอุปกรณ์ IDE ทั้งหมดออก

ใช้วิธีนี้ ถ้าวิธีที่ 5 ไม่สามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop ได้ ถ้าคุณต้องการความช่วยเหลือขณะทำขั้นตอนต่อไปนี้ โปรดดูเอกสารประกอบฮาร์ดแวร์
  1. กำหนดพอร์ต IDE ในบอร์ดให้เป็น Primary Only
  2. ตรวจดูให้แน่ใจว่าการตั้งค่า Master/Subordinate/Only สำหรับอุปกรณ์ IDE ถูกต้อง
  3. ถอดอุปกรณ์ IDE ทั้งหมดออก ยกเว้นฮาร์ดดิสก์
  4. ลองติดตั้ง Windows XP ดูใหม่
    • ถ้าสามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop ทำต่อที่ขั้นตอน e
    • ถ้าไม่สามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop ไปที่วิธีที่ 7
  5. พยายามแยกให้ได้ว่าการตั้งค่าหรืออุปกรณ์ IDE ใดที่ทำให้เกิดข้อผิดพลาด หลังจากที่ได้ติดตั้ง Windows XP ใหม่แล้ว ให้เชื่อมต่ออุปกรณ์ IDE ใหม่ทีละตัว เริ่มระบบคอมพิวเตอร์ของคุณใหม่ หลังจากที่ได้เชื่อมต่อใหม่แล้ว
  6. ถ้าสามารถแยกการตั้งค่าหรืออุปกรณ์ที่มีปัญหาออกได้ ให้ปิดการตั้งค่านั้น หรือถอดการเชื่อมต่ออุปกรณ์ IDE และติดต่อผู้ขายเพื่อแก้ไขปัญหา

    ถ้าไม่สามารถแยกปัญหาการตั้งค่าหรืออุปกรณ์ IDE ออกได้ แต่สามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop และสามารถเริ่มต้นคอมพิวเตอร์ได้ตามปกติ อาจเป็นเพราะว่ามีการตั้งค่าหรืออุปกรณ์ที่ป้องกันไม่ให้ติดตั้งได้ ถ้าเป็นเช่นนี้ ให้เปิดใช้การตั้งค่าใหม่หรือเชื่อมต่ออุปกรณ์ใหม่ หลังจากที่คุณติดตั้ง Windows XPแล้วจึงจบการทำงาน

วิธีที่ 7: ตรวจสอบกับผู้ผลิตสำหรับปัญหาที่ทราบอยู่แล้ว

ใช้วิธีนี้เป็นทางเลือกสุดท้าย เมื่อวิธีอื่นทั้งหมดในการแยกและแก้ไขปัญหาไม่สามารถใช้ได้
  1. ติดต่อบริษัทผู้ผลิตคอมพิวเตอร์หรือเมนบอร์ด เพื่อดูว่ามีปัญหาที่ทราบอยู่แล้วในการเรียกใช้หรือติดตั้ง Windows XP หรือไม่ บริษัทผู้ผลิตอาจช่วยเหลือได้ในขั้นตอนต่อไปนี้
    • เรียกใช้โปรแกรมวิเคราะห์ในคอมพิวเตอร์
    • ปรับรุ่น BIOS ของคอมพิวเตอร์ หากสามารถทำได้
  2. ลองติดตั้ง Windows XP ดูใหม่

    ถ้ายังไม่ได้ผล โปรดดูเว็บไซต์ของ Microsoft ต่อไปนี้ สำหรับวิธีการติดต่อฝ่ายสนับสนุน
    http://support.microsoft.com/contactus/?ln=th

ข้อผิดพลาดหลังจากที่ติดตั้ง Windows XP เรียบร้อยแล้ว

ถ้าคุณได้รับข้อความแจ้งข้อผิดพลาด "Stop: 0x0000000A" หลังจากที่ติดตั้ง Windows XP เรียบร้อยแล้ว ซอฟต์แวร์หรือฮาร์ดแวร์จากบุคคลที่สามที่เพิ่มใหม่อาจเป็นต้นเหตุของข้อผิดพลาดนั้น ก่อนอื่น ให้ลองวิธีการในหัวข้อ "แก้ไขปัญหาซอฟต์แวร์หรือฮาร์ดแวร์จากบุคคลที่สาม" เพื่อแก้ไขปัญหาส่วนประกอบอื่น คุณควรจะมีเอกสารประกอบสำหรับซอฟต์แวร์หรือฮาร์ดแวร์ที่เพิ่มใหม่ หากวิธีการเหล่านี้ไม่สามารถแก้ไขปัญหาได้ ให้ลองวิธีการในหัวข้อ "คืนค่า Windows"

ขั้นตอนที่แนะนำ

เราขอแนะนำให้คุณสำรองข้อมูลระบบของคุณ รวมทั้งแฟ้มข้อมูลและโฟลเดอร์ส่วนตัว ก่อนเริ่มวิธีการแก้ไขปัญหาต่อไปนี้

แก้ไขปัญหาซอฟต์แวร์หรือฮาร์ดแวร์จากบุคคลที่สาม

วิธีที่ 1: ตรวจสอบซอฟต์แวร์จากบุคคลที่สามที่เพิ่มใหม่

ถ้าคุณติดตั้งซอฟต์แวร์จากบุคคลที่สามแล้ว ให้ลองถอดหรือปิดการใช้งาน เพื่อไม่ให้โหลด หลังจากนั้น ให้เริ่มต้นคอมพิวเตอร์ใหม่ เพื่อดูว่าซอฟต์แวร์หรือไดรเวอร์เป็นต้นเหตุของข้อผิดพลาดหรือไม่
  • ถ้ามีซอฟต์แวร์จากบุคคลที่สามมากกว่าหนึ่งรายการ ถอดออกหรือปิดการใช้งานทีละรายการ แล้วจึงเริ่มต้นคอมพิวเตอร์ใหม่หลังจากที่ถอดหรือปิดการใช้งานแต่ละรายการแล้ว เพื่อลองแยกดูว่าซอฟต์แวร์จากบุคคลที่สามใดที่เป็นต้นเหตุของข้อผิดพลาด
  • ถ้าการถอดซอฟต์แวร์จากบุคคลที่สามสามารถแก้ไขข้อความแสดงข้อผิดพลาด Stop ได้ แสดงว่ามีปัญหากับซอฟต์แวร์ที่ทำให้เกิดข้อผิดพลาด รายงานปัญหานี้ให้กับผู้ขายเพื่อแก้ไขปัญหา
  • ถ้าการถอดซอฟต์แวร์จากบุคคลที่สามไม่สามารถแก้ไขข้อความแสดงข้อผิดพลาด Stop แสดงว่าซอฟต์แวร์ไม่ได้เป็นปัญหา ไปที่หัวข้อ "วิธีที่ 2: ตรวจสอบฮาร์ดแวร์จากบุคคลที่สามที่เพิ่มใหม่"

วิธีที่ 2: ตรวจสอบฮาร์ดแวร์จากบุคคลที่สามที่เพิ่มใหม่

ถ้าคุณเพิ่มอุปกรณ์ฮาร์ดแวร์หรือไดรเวอร์หลังจากที่ได้ติดตั้ง Windows ไปแล้ว ให้ถอดฮาร์ดแวร์ที่เพิ่มใหม่ออก แล้วเริ่มต้นคอมพิวเตอร์ใหม่ เพื่อดูว่าฮาร์ดแวร์เป็นต้นเหตุของข้อผิดพลาดหรือไม่
  • ถ้ามีฮาร์ดแวร์เพิ่มใหม่มากกว่าหนึ่งรายการ ให้ถอดอุปกรณ์หรือไดรเวอร์ออกทีละรายการ แล้วจึงเริ่มต้นคอมพิวเตอร์ใหม่หลังจากที่ถอดแต่ละรายการแล้ว เพื่อลองแยกดูว่าฮาร์ดแวร์ใดเป็นต้นเหตุของข้อผิดพลาด
  • ถ้าการถอดฮาร์ดแวร์ที่เพิ่มใหม่สามารถแก้ไขข้อความแสดงข้อผิดพลาด Stop ได้ ให้ใช้วิธีการต่อไปนี้ในการแก้ไขปัญหา
    1. รับไดรเวอร์อุปกรณ์ที่ปรับปรุงแล้ว ถ้ามี
    2. ติดต่อผู้จำหน่ายอุปกรณ์หรือไดรเวอร์ เพื่อตรวจสอบว่าบริษัทนั้นๆ ทราบอะไรบ้างเกี่ยวกับปัญหาของฮาร์ดแวร์ดังกล่าว
    3. เรียกใช้โปรแกรมวินิจฉัย เพื่อยืนยันว่าฮาร์ดแวร์ทำงานได้อย่างถูกต้อง
    ถ้าสามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop ได้ ถือว่าจบการทำงาน
  • ถ้าการถอดฮาร์ดแวร์ที่เพิ่มใหม่ไม่สามารถแก้ไขข้อความแสดงข้อผิดพลาด Stop ให้ลองคืนค่า Windows ด้วยโปรแกรมการคืนค่าระบบ โดยไปที่หัวข้อ "คืนค่า Windows"

คืนค่า Windows

ถ้าการแก้ไขปัญหาซอฟต์แวร์และฮาร์ดแวร์จากบุคคลที่สามที่เพิ่มใหม่ไม่สามารถแก้ไขข้อความแสดงข้อผิดพลาด Stop ได้ ให้ลองคืนค่า Windows ก่อนอื่น ให้ลองทำตามวิธีที่ 1

วิธีที่ 1: ใช้คุณลักษณะ Last Known Good configuration

คุณลักษณะ Last Known Good configuration เป็นตัวเลือกการคืนค่าที่สามารถใช้ได้ ถ้าคุณไม่สามารถเริ่มต้น Windows XP ได้ หลังจากที่มีการเปลี่ยนแปลงในคอมพิวเตอร์ของคุณ หรือเมื่อคุณสงสัยว่าการเปลี่ยนแปลงที่คุณทำอาจทำให้เกิดปัญหา คุณลักษณะนี้จะคืนค่าข้อมูลรีจิสทรีและการตั้งค่าไดรเวอร์ที่มีผลบังคับใช้ครั้งสุดท้ายที่คอมพิวเตอร์เริ่มต้นได้อย่างเรียบร้อย สำหรับข้อมูลเพิ่มเติมเกี่ยวกับการใช้คุณลักษณะ Last Known Good Configuration โปรดคลิกที่หมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
307852 วิธีการเริ่มเครื่องคอมพิวเตอร์โดยการใช้คุณลักษณะ Last Known Good Configuration ใน Windows XP
  • ถ้าวิธีนี้คืนค่า Windows และแก้ไขข้อความแจ้งข้อผิดพลาด Stop ได้ ถือว่าจบการทำงาน
  • ถ้าวิธีนี้ไม่คืนค่า Windows และไม่สามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop ได้ ไปที่วิธีที่ 2

วิธีที่ 2: แก้ไขการติดตั้ง Windows XP

หากคุณไม่สามารถคืนค่า Windows โดยใช้คุณลักษณะ Last Known Good Configuration ให้ลองคืนค่า Windows โดยการแก้ไขการติดตั้ง Windows XP
ข้อกำหนดเบื้องต้น
ตรวจดูให้แน่ใจว่าคุณมีแผ่นซีดีหรือดีวีดีติดตั้ง Windows XP
ข้อมูลแนะนำ
ก่อนเริ่มขั้นตอนแก้ไขปัญหา คุณควรจะมีรายการต่อไปนี้
  • เอกสารประกอบของซอฟต์แวร์ป้องกันไวรัสหรือการป้องกันในระดับ BIOS
  • เอกสารประกอบคอมพิวเตอร์เกี่ยวกับการติดตั้งไดรฟ์ซีดีหรือดีวีดีให้เป็นอุปกรณ์เริ่มต้นระบบลำดับแรก
ในการแก้ไขการติดตั้ง Windows XP ให้ทำตามขั้นตอนดังนี้
  1. ปิดโปรแกรมป้องกันไวรัสและการป้องกันไวรัสในระดับ BIOS สำหรับวิธีใช้ ดูคู่มือของซอฟต์แวร์หรือวิธีใช้ออนไลน์ที่เกี่ยวข้อง
  2. ตรวจดูให้แน่ใจว่าได้กำหนดให้ไดรฟ์ซีดีหรือดีวีดีเป็นอุปกรณ์สำหรับเริ่มต้นระบบอันดับแรก ดูคู่มือคอมพิวเตอร์ของคุณเพื่อดูวิธีการทำงานนี้
  3. ใส่แผ่นซีดี Windows XP ลงในไดรฟ์ซีดีหรือดีวีดี แล้วเริ่มคอมพิวเตอร์ใหม่
  4. เมื่อปรากฏคำแนะนำ "Press any key to boot from CD" ขึ้น ให้กดปุ่มใดๆ คอมพิวเตอร์ของคุณจะเริ่มจากซีดี Windows XP
  5. เมื่อคอมพิวเตอร์เริ่มต้นจากซีดี ระบบจะตรวจสอบฮาร์ดแวร์ แล้วแจ้งให้คุณเลือกตัวเลือกใดตัวเลือกหนึ่งต่อไปนี้:
    • To set up Windows XP now, press ENTER.
    • To repair a Windows XP installation using Recovery Console, press R.
    • เมื่อต้องการออกจากการตั้งค่าโดยไม่ติดตั้ง Windows XP ให้กด F3
  6. กด ENTER
  7. กด F8 เพื่อยินยอมในข้อตกลงการใช้งาน
  8. ช่องจะแสดงการติดตั้ง Windows XP ปัจจุบัน จากนั้นคอมพิวเตอร์จะแจ้งให้คุณเลือกตัวเลือกใดตัวเลือกหนึ่งต่อไปนี้:
    • To repair the selected Windows XP installation, press R.
    • To continue installing a fresh copy of Windows XP without repairing, press ESC.
  9. กด R หลังจากแก้ไข Windows XP แล้ว คุณอาจต้องลงทะเบียน Windows XP หากมีการเปลี่ยนแปลงฮาร์ดแวร์
    • ถ้าวิธีนี้คืนค่า Windows และแก้ไขข้อความแจ้งข้อผิดพลาด Stop ได้ ถือว่าจบการทำงาน
    • ถ้าวิธีนี้ไม่คืนค่า Windows และไม่สามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop ได้ ไปที่วิธีที่ 3

วิธีที่ 3: ใช้คุณลักษณะ Rollback Driver

หากคุณสามารถเริ่มต้นคอมพิวเตอร์ในเซฟโหมด ใช้วิธีนี้เพื่อคืนค่า Windows ถ้าวิธีที่ 2 ใช้ไม่ได้ผล

คุณลักษณะ Rollback Driver ช่วยให้คุณแทนที่ไดรเวอร์ของอุปกรณ์ได้ด้วยเวอร์ชันก่อนหน้าที่ได้ติดตั้งไว้ คุณสามารถใช้คุณลักษณะนี้ได้ ถ้าคุณติดตั้งไดรเวอร์ใหม่ของอุปกรณ์ที่ทำให้คอมพิวเตอร์ไม่เสถียร เมื่อใช้คุณลักษณะ Rollback Driver คุณสามารถเรียกคืน (หรือโรลแบ็ค) ไดรเวอร์ก่อนหน้าของอุปกรณ์ แล้วใช้งานคอมพิวเตอร์ต่อไปได้ สำหรับข้อมูลเพิ่มเติมเกี่ยวกับการใช้คุณลักษณะ Roll Back Driver โปรดคลิกที่หมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
283657 วิธีการใช้คุณลักษณะ Roll Back Driver ใน Windows XP
  • ถ้าวิธีนี้คืนค่า Windows และแก้ไขข้อความแจ้งข้อผิดพลาด Stop ได้ ถือว่าจบการทำงาน
  • ถ้าวิธีนี้ไม่คืนค่า Windows และไม่สามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop ได้ ไปที่วิธีที่ 4

วิธีที่ 4: ใช้คุณลักษณะการคืนค่าระบบ Windows XP

หากคุณสามารถเริ่มต้นคอมพิวเตอร์ในเซฟโหมด ใช้วิธีนี้เพื่อคืนค่า Windows ถ้าวิธีที่ 3 ใช้ไม่ได้ผล การคืนค่าระบบ Windows XP จะมีการ "สแนปช็อต" แฟ้มระบบที่สำคัญและแฟ้มโปรแกรมบางส่วนไว้ และเก็บข้อมูลเหล่านี้ไว้เป็นจุดคืนค่า คุณสามารถใช้จุดคืนค่าเหล่านี้ เพื่อเรียกคืนสภาวะก่อนหน้าให้ Windows XP ได้ สำหรับข้อมูลเพิ่มเติมเกี่ยวกับการใช้คุณลักษณะ System Restore โปรดคลิกที่หมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
306084 วิธีการคืนค่าระบบปฏิบัติการไปเป็นสภาวะก่อนหน้าใน Windows XP
  • ถ้าวิธีนี้คืนค่า Windows และแก้ไขข้อความแจ้งข้อผิดพลาด Stop ได้ ถือว่าจบการทำงาน
  • ถ้าวิธีนี้ไม่คืนค่า Windows และไม่สามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop ได้ ไปที่วิธีที่ 5

วิธีที่ 5: ใช้คอนโซลการกู้คืน

เราขอแนะนำให้ใช้คอนโซลการกู้คืนเพื่อคืนค่า Windows ก็ต่อเมื่อเซฟโหมดและตัวเลือกอื่นๆ ในการเริ่มต้นระบบใช้ไม่ได้ผลเท่านั้น ถ้าคุณไม่สามารถเริ่มต้นคอมพิวเตอร์ คุณสามารถเรียกใช้คอนโซลการกู้คืนได้จากดิสก์หรือซีดีรอมสำหรับเริ่มต้นระบบ Windows XP

คุณสามารถใช้คอนโซลการกู้คืนเพื่อเปิดและปิดการให้บริการต่างๆ ฟอร์แมตไดรฟ์ อ่านและเขียนข้อมูลลงในไดรฟ์ในระบบ (รวมทั้งไดรฟ์ที่จะต้องฟอร์แมตเพื่อใช้ระบบแฟ้ม NTFS) และทำงานดูแลระบบอื่นๆ ได้ คอนโซลการกู้คืนมีประโยชน์โดยเฉพาะในกรณีที่คุณจะต้องซ่อมแซมเครื่องคอมพิวเตอร์โดยการคัดลอกแฟ้มข้อมูลจากดิสก์หรือซีดีรอมมายังฮาร์ดดิสก์ของคุณ หรือหากคุณต้องกำหนดค่าใหม่สำหรับบริการที่ป้องกันไม่ให้คอมพิวเตอร์ของคุณเริ่มต้นได้อย่างถูกต้อง
ข้อกำหนดเบื้องต้น
ตรวจดูให้แน่ใจว่าคุณมีแผ่นซีดีหรือดีวีดีติดตั้ง Windows XP สำหรับข้อมูลเพิ่มเติมเกี่ยวกับการใช้ Recovery Console คลิกที่หมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
307654 วิธีการติดตั้งและใช้งาน Recovery Console ใน Windows XP
  • ถ้าวิธีนี้คืนค่า Windows และแก้ไขข้อความแจ้งข้อผิดพลาด Stop ได้ ถือว่าจบการทำงาน
  • ถ้าวิธีนี้ไม่คืนค่า Windows และไม่สามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop ได้ ไปที่วิธีที่ 6

วิธีที่ 6: เปลี่ยนชื่อซอฟต์แวร์หรือไดรเวอร์ที่มีปัญหา

หากคุณสามารถเริ่มต้นคอมพิวเตอร์ใน DOS หรือเซฟโหมด ให้ใช้วิธีนี้เป็นทางเลือกสุดท้าย ถ้าวิธีอื่นๆ ทั้งหมดในการคืนค่า Windows ใช้ไม่ได้ผล
  • ถ้า Windows อยู่ในพาร์ติชัน FAT ให้เริ่มต้นคอมพิวเตอร์โดยใช้ MS-DOS แล้วเปลี่ยนชื่อซอฟต์แวร์หรือไดรเวอร์ที่มีปัญหา
  • หรือไม่ก็ใช้เซฟโหมดที่มีพร้อมท์คำสั่งเพื่อเริ่มต้นคอมพิวเตอร์ แล้วจึงเปลี่ยนชื่อซอฟต์แวร์หรือไดรเวอร์ที่มีปัญหา

    สำหรับข้อมูลเพิ่มเติมเกี่ยวกับตัวเลือกการเริ่มระบบในเซฟโหมด โปรดดูเว็บไซต์บริการช่วยเหลือและวิธีใช้ของ Microsoft และดู "คำอธิบายของตัวเลือกการเริ่มระบบด้วยเซฟโหมดใน Windows XP"
    • ถ้าวิธีนี้คืนค่า Windows และแก้ไขข้อความแจ้งข้อผิดพลาด Stop ได้ ถือว่าจบการทำงาน
    • ถ้าวิธีนี้ไม่คืนค่า Windows และไม่สามารถแก้ไขข้อความแจ้งข้อผิดพลาด Stop ได้ โปรดดูเว็บไซต์ของ Microsoft ต่อไปนี้ สำหรับวิธีการติดต่อฝ่ายสนับสนุน
      http://support.microsoft.com/contactus/?ln=th

ข้อมูลเพิ่มเติม

หากวิธีในบทความนี้ไม่สามารถแก้ไขข้อความแจ้งข้อผิดพลาด "Stop: 0x0000000A" และหากคุณกำลังเรียกใช้ Windows ด้วยฮาร์ดแวร์ที่อยู่ในรายชื่อ HCL แล้ว โปรดดูบทความต่อไปนี้ในฐานความรู้ของ Microsoft
314103 การเตรียมพร้อมก่อนติดต่อ Microsoft หลังจากได้รับข้อความแสดงข้อผิดพลาด STOP ในหน้าจอสีน้ำเงิน

คุณสมบัติ

หมายเลขบทความ (Article ID): 314063 - รีวิวครั้งสุดท้าย: 25 กรกฎาคม 2556 - Revision: 4.0
ใช้กับ
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
Keywords: 
kbresolve kbenv kberrmsg kbhardware kbinfo kbsetup kbtshoot KB314063

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com