Artigo: 314357 - Última revisão: sexta-feira, 3 de Fevereiro de 2006 - Revisão: 1.2

Mensagem de erro 'ID do evento: 7000' ou 'ID do evento: 7013' quando tenta iniciar um serviço

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
IMPORTANTE: este artigo contém informações sobre como modificar o registo. Antes de modificar o registo, certifique-se de que efectua uma cópia de segurança e de que compreende como o pode restaurar se ocorrer um problema. Para obter informações sobre como efectuar uma cópia de segurança, restaurar e editar o registo, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
256986  (http://support.microsoft.com/kb/256986/PT/ ) Descrição do registo do Microsoft Windows


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Sintomas

Quando um serviço não é iniciado devido a uma falha de início de sessão, poderá receber uma das seguintes mensagens de erro no registo de eventos do sistema depois de reiniciar o computador (em que Nome_do_serviço é o nome do serviço em questão):
Origem: Service Control Manager
ID do evento: 7000
Descrição:
O serviço Nome_do_serviço falhou o arranque devido ao seguinte erro:
O serviço não foi iniciado devido a um erro de início de sessão.

Sem dados disponíveis.
- ou -
Origem: Service Control Manager
ID do evento: 7013
Descrição:
A tentativa de início de sessão com a palavra-passe actual falhou com o seguinte erro:
Erro de início de sessão: nome de utilizador desconhecido ou palavra-passe incorrecta.

Sem dados disponíveis.
Quanto tenta iniciar manualmente o serviço, poderá receber a seguinte mensagem de erro:
Consola de gestão da Microsoft
Não foi possível iniciar o serviço Nome_do_serviço em Computador local
Erro 1069: O serviço não foi iniciado devido a um erro de início de sessão.
NOTA: poderá receber estas mensagens de erro mesmo que a conta de utilizador seja válida.

Causa

Este comportamento pode ocorrer se configurar o serviço para iniciar sessão numa conta de utilizador e se se verificar alguma das seguintes condições:
  • O direito de iniciar sessão como serviço foi revogado para a conta de utilizador especificada.
  • A palavra-passe é alterada na conta de utilizador que o serviço utiliza para iniciar sessão.
  • Os dados de palavra-passe no registo estão danificados.

Resolução

Para resolver este problema, utilize os seguintes métodos, conforme as circunstâncias.

Método 1: Configurar os direitos de utilizador

NOTA: este método destina-se apenas ao Windows XP Professional, e não ao Windows XP Home Edition.

Se o direito para iniciar sessão como um serviço for revogado para a conta de utilizador especificada, restaure o direito utilizando um dos seguintes métodos, conforme a situação.

Num controlador de domínio

Se o utilizador estiver num domínio do Active Directory, siga estes passos:
  1. Inicie sessão no controlador de domínio como administrador.
  2. Inicie o snap-in Utilizadores e computadores do Active Directory.
  3. Clique com o botão direito na unidade organizacional (OU, organizational unit) onde o direito de utilizador para iniciar sessão como um serviço é concedido e clique em Propriedades.

    Por predefinição, esta é a OU Controladores de domínio.
  4. Clique no separador Política de grupo.
  5. Clique em Política predefinida de controladores de domínio e clique em Editar.
  6. Expanda Configuração do computador, expanda Definições do Windows e expanda Definições de segurança.
  7. Expanda Políticas locais e clique em Atribuição de direitos de utilizadores.
  8. No painel da direita, clique com o botão direito do rato em Iniciar sessão como um serviço e clique em Segurança.
  9. Adicione o utilizador que pretende à política e clique em OK.
  10. Saia do Editor de políticas de grupos, clique em OK e feche o snap-in Utilizadores e computadores do Active Directory.

Num computador local

Se o utilizador estiver num computador baseado no Windows XP autónomo, siga estes passos:
  1. Inicie sessão no computador como administrador ou como membro do grupo de administradores.
  2. Inicie o snap-in Política Computador local.
  3. Expanda Política Computador local, expanda Configuração do computador, expanda Definições do Windows e expanda Definições de segurança.
  4. Expanda Políticas locais e clique em Atribuição de direitos de utilizadores.
  5. No painel da direita, clique com o botão direito do rato em Iniciar sessão como um serviço e clique em Propriedades.
  6. Clique em Adicionar utilizador ou grupo, adicione o utilizador que pretende à política e clique em OK duas vezes.
  7. Feche a snap-in Política Computador local.

Método 2: Configurar informações de início de sessão para o serviço

Se a palavra-passe for alterada na conta de utilizador que o serviço utiliza para iniciar sessão, configure a palavra-passe para corresponder à palavra-passe actual para esse utilizador. Para o fazer, siga estes passos:
  1. Clique em Iniciar, clique em Painel de controlo, clique em Desempenho e manutenção e clique em Ferramentas administrativas.
  2. Faça duplo clique em Serviços.
  3. No painel da direita, clique com o botão direito do rato no serviço apropriado e clique em Propriedades.
  4. Clique no separador Iniciar sessão, escreva a palavra-passe correcta nas caixas Palavra-passe e Confirmar palavra-passe e clique em OK.
  5. Clique com o botão direito do rato no serviço e clique em Reiniciar.
  6. Saia da ferramenta Serviços.

Método 3: Configurar o serviço para utilizar a conta de sistema incorporada

Se o serviço continuar a não funcionar com a conta de utilizador especificada, configure o serviço para iniciar sessão na conta de sistema incorporada. Para o fazer, siga estes passos:
  1. Clique em Iniciar, clique em Painel de controlo, clique em Desempenho e manutenção e clique em Ferramentas administrativas.
  2. Faça duplo clique em Serviços.
  3. No painel da direita, clique com o botão direito do rato no serviço apropriado e clique em Propriedades.
  4. Clique no separador Iniciar sessão, clique em Conta do sistema local e clique em OK.

    NOTA: na maior parte das situações, não é necessário configurar um serviço para interagir com o ambiente de trabalho. Não precisa de seleccionar a caixa de verificação Permitir a interacção entre o serviço e o ambiente de trabalho.
  5. Clique com o botão direito do rato no serviço e clique em Reiniciar.
  6. Saia da ferramenta Serviços.
Quando tenta abrir as propriedades de um serviço utilizando a ferramenta Serviços no Painel de controlo, o computador pode parar de responder (pode suspender) e/ou pode receber a seguinte mensagem de erro:
O servidor de RPC não está disponível.
Pode receber esta mensagem de erro se o serviço de chamada de procedimento remoto (RPC, remote procedure call) não for iniciado devido a uma falha de início de sessão com esse serviço ou um serviço dependente. Alguns serviços têm serviços dependentes e estes serviços só são iniciados quando os respectivos serviços dependentes são iniciados em primeiro lugar (por exemplo, o serviço Estação de trabalho).

Se não puder iniciar a ferramenta Serviços, utilize o Editor de registo para configurar o serviço para utilizar a conta de sistema incorporada. Para o fazer, siga estes passos:
  1. Clique em Iniciar e clique em Executar.AVISO: a utilização incorrecta do Editor de registo poderá provocar problemas graves que poderão forçar a reinstalação do sistema operativo. A Microsoft não garante que os problemas resultantes da utilização incorrecta do Editor de registo possam ser resolvidos. Todo e qualquer risco decorrente da utilização do Editor de registo é da responsabilidade do utilizador.

  2. Na caixa Abrir, escreva regedt32 e clique em OK.
  3. Localize a seguinte chave de registo, em que Nome_do_serviço é o serviço que pretende configurar:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Nome_do_serviço
  4. No painel da direita, faça duplo clique em Nome de objecto.
  5. Na caixa de diálogo Editar cadeia que aparece, escreva localsystem e clique em OK.
  6. No menu Ficheiro, clique em Sair para sair do Editor de registo.
  7. Clique em Iniciar, clique em Painel de controlo, clique em Desempenho e manutenção e clique em Ferramentas administrativas.
  8. Faça duplo clique em Serviços.
  9. Clique com o botão direito do rato no serviço e clique em Reiniciar.

    Poderá ter de reiniciar o computador para que alguns serviços sejam reiniciados correctamente.

Mais Informação

Embora a maior parte dos serviços de sistema iniciem sessão na conta de sistema local por predefinição, pode configurar serviços para que utilizem uma conta de utilizador e palavra-passe específica. Se optar por especificar uma conta de utilizador e palavra-passe, é importante que o nome de conta e palavra-passe permaneçam constantes. Quando a palavra-passe de um utilizador é alterada, as informações da palavra-passe não são actualizadas automaticamente para o serviço.

Por exemplo, a conta de utilizador que o serviço utiliza não terá de alterar a respectiva palavra-passe nem o respectivo nome terá de ser mudado. Se estes dois eventos (ou outros eventos semelhantes) ocorrerem, também terá de actualizar as credenciais de início de sessão para o serviço.

Para obter informações adicionais sobre como visualizar e gerir os registos de eventos no Visualizador de eventos, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
308427  (http://support.microsoft.com/kb/308427/PT/ ) COMO: Visualizar e gerir registos de eventos no 'Visualizador de eventos'

A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
Palavras-chave: 
kbregistry kbenv kberrmsg kbprb KB314357