"Код события: 7000" или "Код события 7013" при попытке запуска службы

Переводы статьи Переводы статьи
Код статьи: 314357 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Проблема

Если служба не запускается из-за ошибки при входе или если вы удаляете пакет обновления 3 (SP3) для Windows XP, в журнале системных событий после перезагрузки компьютера может появиться одно из указанных ниже сообщений об ошибке (где ServiceName — это имя службы, о которой идет речь).
Источник: диспетчер служб
Код события: 7000
Описание:
Ошибка запуска службы ServiceName:
служба не запущена из-за ошибки входа в систему.

Данные будут недоступны.
-или-
Источник: диспетчер служб
Код события: 7013
Описание:
Сбой при попытке входа с текущим паролем из-за такой ошибки:
вход в систему не произведен: имя пользователя или пароль не опознаны.

Данные будут недоступны.
При попытке запустить службу вручную может появиться следующее сообщение об ошибке:
Консоль управления (MMC)
Не удалось запустить службу ServiceName на локальном компьютере
Ошибка 1069: служба не запущена из-за ошибки входа в систему.
Примечание. Подобное сообщение об ошибке можно получить даже при допустимой учетной записи пользователя.

Причина

Подобная ситуация может сложиться, если служба настроена на вход в систему с учетной записью пользователя, при любом из следующих условий.
  • Указанной учетной записи пользователя не предоставлено право "Вход в качестве службы".
  • Изменен пароль учетной записи пользователя, используемой службой для входа в систему.
  • Повреждены данные о пароле в реестре.

Решение

Для решения проблемы выберите подходящий способ.

Способ 1. Настройка прав пользователя

Примечание. Этот метод подходит для Windows XP Professional, но не для Windows XP Home Edition.

Если указанной учетной записи пользователя не предоставлено право на вход в качестве службы, восстановите это право, используя одну из указанных ниже процедур в зависимости от ситуации.

В контроллере домена

Если пользователь находится в домене Active Directory, выполните следующие действия.
  1. Войдите в контроллер домена в качестве администратора.
  2. Запустите оснастку "Active Directory — пользователи и компьютеры".
  3. Правой кнопкой мыши щелкните подразделение, в котором пользователю предоставляется право входа в качестве службы, и щелкните элемент Свойства.

    По умолчанию это подразделение "Контроллеры домена".
  4. Перейдите на вкладку Групповая политика.
  5. Выберите объект Политика контроллеров домена по умолчанию и нажмите кнопку Изменить.
  6. Разверните элементы Конфигурация компьютера, Конфигурация Windows и Параметры безопасности.
  7. Разверните элемент Локальные политики и выберите раздел Назначение прав пользователя.
  8. На правой панели щелкните правой кнопкой мыши элемент Вход в качестве службы, а затем — элемент Безопасность.
  9. Добавьте нужного пользователя в политику и нажмите кнопку ОК.
  10. Закройте редактор групповой политики, нажмите кнопку OK и закройте оснастку "Active Directory — пользователи и компьютеры".

На локальном компьютере

Если пользователь имеет учетную запись на компьютере Windows XP, не входящем в домен, выполните следующие действия.
  1. Войдите в систему с учетной записью "Администратор" или члена группы "Администраторы".
  2. Запустите оснастку "Политика локального компьютера".
  3. Разверните элементы Политика локального компьютера, Конфигурация компьютера, Конфигурация Windows и Параметры безопасности.
  4. Разверните элемент Локальные политики и выберите раздел Назначение прав пользователя.
  5. На правой панели щелкните правой кнопкой мыши элемент Вход в качестве службы, а затем — элемент Свойства.
  6. Нажмите кнопку Добавить пользователя или группу, добавьте в политику нужного пользователя и нажмите кнопку OK два раза.
  7. Закройте оснастку "Политика локального компьютера".

Способ 2. Настройка сведений о входе для службы

Если был изменен пароль учетной записи пользователя, которая использовалась службой для входа в систему, приведите пароль в соответствие текущему паролю пользователя. Для этого выполните следующее действия:
  1. В меню Пуск выберите элемент Панель управления, щелкните ссылку Производительность и обслуживание, а затем — Администрирование.
  2. Дважды щелкните значок Службы.
  3. На правой панели щелкните правой кнопкой мыши соответствующую службу и выберите элемент Свойства.
  4. На вкладке Вход в систему введите правильный пароль в полях Пароль и Подтверждение пароля и нажмите кнопку OK.
  5. Щелкните службу правой кнопкой мыши и выберите команду Перезапустить.
  6. Закройте компонент "Службы".

Способ 3. Настройте службу на использование встроенной системной учетной записи

Если служба по-прежнему не работает с заданной учетной записью пользователя, настройте службу на вход со встроенной системной учетной записью. Если после удаления пакета обновления 3 (SP3) для Windows XP служба диспетчера отгрузки не работает, настройте ее. Для этого выполните следующее действия:
  1. В меню Пуск выберите элемент Панель управления, щелкните ссылку Производительность и обслуживание, а затем — Администрирование.
  2. Дважды щелкните значок Службы.
  3. На правой панели щелкните правой кнопкой мыши соответствующую службу и выберите элемент Свойства.
  4. Откройте вкладку Вход в систему, выберите параметр С системной учетной записью и нажмите кнопку OK.

    Примечание. В большинстве случаев нет необходимости настраивать службу на взаимодействие с рабочим столом. Поэтому не нужно устанавливать флажок Разрешить взаимодействие с рабочим столом.
  5. Щелкните службу правой кнопкой мыши и выберите команду Перезапустить.
  6. Закройте компонент "Службы".
При попытке открыть свойства службы в средстве "Службы" панели управления компьютер может перестать реагировать на действия пользователя ("зависнуть") или отобразить следующее сообщение об ошибке:
сервер RPC недоступен.
Это сообщение об ошибке может быть получено, если служба удаленного вызова процедур (RPC) не запущена из-за ошибки входа в систему этой службы или дочерних служб. У некоторых служб есть дочерние службы, которые должны быть запущены для запуска основных служб (например служба "Рабочая станция").

Если компонент "Службы" не открывается, следует воспользоваться редактором реестра и настроить службу на использование встроенной системной учетной записи. Для этого выполните следующие действия:
  1. В меню Пуск выберите команду Выполнить.Важно! В данный раздел, метод или задачу включены действия по изменению параметров реестра. Однако их неправильное изменение может привести к возникновению серьезных проблем. Поэтому такие действия необходимо выполнять очень внимательно. Чтобы обеспечить дополнительную защиту, создайте резервную копию реестра. При возникновении неполадок реестр можно восстановить. Дополнительные сведения о создании резервной копии и восстановлении реестра см. в следующей статье базы знаний Майкрософт:
    322756 Создание резервной копии и восстановление реестра Windows

  2. В поле Открыть введите команду regedt32 и нажмите кнопку ОК.
  3. Найдите следующий раздел реестра (где ServiceName — это имя службы, которую нужно настроить):
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ServiceName
  4. На правой панели дважды щелкните элемент ObjectName.
  5. В окне Изменение строкового параметра введите значение localsystem и нажмите кнопку OK.
  6. В меню Файл выберите команду Выход, чтобы закрыть редактор реестра.
  7. В меню Пуск выберите элемент Панель управления, щелкните ссылку Производительность и обслуживание, а затем — Администрирование.
  8. Дважды щелкните значок Службы.
  9. Щелкните службу правой кнопкой мыши и выберите команду Перезапустить.

    Для правильного перезапуска некоторых служб необходимо перезагрузить компьютер.

Дополнительная информация

Хотя большинство системных служб входят в систему по умолчанию с локальной системной учетной записью, можно настроить их так, чтобы они использовали учетную запись и пароль определенного пользователя. Если решено воспользоваться учетной записью и паролем определенного пользователя, важно, чтобы имя и пароль этой учетной записи оставались неизменными. При изменении пароля пользователя информация о пароле не обновляется в службе автоматически.

Например, не должно появляться требование переименовать или изменить пароль учетной записи пользователя, которую использует служба. В таких случаях необходимо также обновить учетные данные службы, используемые для входа в систему.

Дополнительные сведения о просмотре журналов событий и управлении ими в программе "Просмотр событий" см. в следующей статье базы знаний Майкрософт:
308427 ИНСТРУКЦИИ Просмотр и управление журналами событий с помощью окна просмотра событий
Примечание. Это ЭКСПРЕСС-ПУБЛИКАЦИЯ, подготовленная непосредственно службой технической поддержки Майкрософт . Сведения, содержащиеся в данном документе, предоставлены в качестве отклика на возникшие проблемы. Из-за срочности в материалах могут быть опечатки, и в любое время и без уведомления в них могут быть внесены изменения. Чтобы получить дополнительные сведения, см. Условия использования.

Свойства

Код статьи: 314357 - Последний отзыв: 26 февраля 2014 г. - Revision: 1.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Ключевые слова: 
kbregistry kbenv kberrmsg kbprb KB314357

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com