FP2002 : Un formulaire de confirmation apparaît mais aucune information n'est écrite dans la base de données

Traductions disponibles Traductions disponibles
Numéro d'article: 314440 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F314440
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Agrandir tout | Réduire tout

Symptômes

Lorsque vous soumettez un formulaire, une page de confirmation apparaît (ce qui vous mène à croire que la soumission a réussi) mais aucune information n'est écrite dans la base de données.

Cause

Ce problème se produit si vous marquez un champ dans la base de données comme clé primaire, puis soumettez un formulaire qui duplique des données précédemment soumises dans un champ marqué comme champ clé primaire.

Pour plus d'informations, consultez la section "Informations supplémentaires" plus bas dans cet article.

Contournement

Microsoft fournit des exemples de programmation à des fins d'illustration uniquement, sans garantie explicite ou implicite, y compris, de manière non limitative, les garanties implicites de qualité marchande et/ou d'adéquation à un usage particulier. Cet article suppose que vous connaissez le langage de programmation présenté et les outils utilisés pour créer et déboguer des procédures. Les techniciens du Support technique Microsoft peuvent vous expliquer les fonctionnalités d'une procédure particulière, mais ils ne peuvent pas modifier les exemples en vue de vous fournir des fonctionnalités supplémentaires ou de créer des procédures répondant à vos besoins spécifiques. Si vous ne maîtrisez que partiellement la programmation, vous pouvez contacter un fournisseur de logiciels agréé Microsoft ou l'assistance téléphonique (payante) de Microsoft au (800) 936-5200 (États-Unis). Pour plus d'informations sur les fournisseurs de logiciels agréés Microsoft, veuillez consulter la page suivante sur le Web :
https://partner.microsoft.com/global/30000104
Pour plus d'informations sur les options de support technique proposées par Microsoft, veuillez consulter la page Web suivante :
http://support.microsoft.com/directory/overview.asp
Pour contourner ce problème, procédez comme suit :
  1. Ouvrez le fichier Fpdbform.inc qui se trouve dans le dossier _fpclass.
  2. Localisez la fonction FP_DumpError(strErrorUrl, strMsg).
  3. Supprimez la ligne qui ressemble à ceci :
    On Error Resume Next
  4. Enregistrez et fermez le fichier.

Statut

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section "Liste des produits concernés par cet article".

Plus d'informations

Lorsque vous définissez un champ comme clé primaire dans Microsoft Access, tous les enregistrements doivent avoir une entrée unique dans ce champ. Si vous essayez de saisir des doublons dans ce champ, Access renvoie une erreur.

Lors de l'utilisation des Extensions serveur de FrontPage 2000, si vous essayez de soumettre un formulaire à une base de données avec des doublons dans un champ marqué comme clé primaire, le message d'erreur suivant apparaît :
Impossible de mettre à jour la base de données.
Dans FrontPage 2002, la ligne suivante est ajoutée à la fonction FP_DumpError dans le fichier Fpdbform.inc :
On Error Resume Next
Cette ligne de code est ajoutée au fichier afin d'améliorer la prise en charge d'une page de code à l'autre. Elle force FrontPage à ignorer l'erreur renvoyée par Access lorsqu'une page Web tente d'ajouter un enregistrement qui contient des doublons de clé primaire, mais elle autorise l'affichage de la page de confirmation. L'opération semble réussie, mais Access n'autorise pas l'écriture de l'enregistrement qui contient des doublons de clé primaire dans la base de données.

Propriétés

Numéro d'article: 314440 - Dernière mise à jour: lundi 24 février 2014 - Version: 2.1
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft FrontPage 2002 Standard
  • Extensions serveur Microsoft FrontPage 2002
Mots-clés : 
kbnosurvey kbarchive kbbug kbdta kbfix KB314440
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com