In FrontPage 2003 e in FrontPage 2002, verrÓ visualizzato un modulo di conferma, bensý Nessuna informazione viene scritta nel database

Traduzione articoli Traduzione articoli
Identificativo articolo: 314440 - Visualizza i prodotti a cui si riferisce l?articolo.
Questo articolo Ŕ stato archiviato. L?articolo, quindi, viene offerto ?cosý come Ŕ? e non verrÓ pi¨ aggiornato.
Espandi tutto | Chiudi tutto

Sintomi

In Microsoft Office FrontPage 2003 e in Microsoft FrontPage 2002, quando si invia un modulo viene una pagina di conferma visualizzata. Ci˛ consente l'impressione che il modulo Ŕ stato inviato correttamente, ma nessuna informazione viene scritta nel database.

Cause

Questo problema si verifica se si seleziona un campo nel database come chiave primaria e quindi invia un modulo che i dati duplicati in precedenza Ŕ stati inviati in un campo contrassegnati come il campo chiave primaria.

Per ulteriori informazioni, vedere la sezione "Informazioni" pi¨ avanti in questo articolo.

Workaround

Microsoft fornisce esempi di programmazione a scopo puramente illustrativo, senza alcuna garanzia espressa o implicita. Questo include, ma non Ŕ limitato a, le garanzie implicite di commerciabilitÓ o idoneitÓ per uno scopo specifico. Questo articolo si presuppone che conosca il linguaggio di programmazione in questione e gli strumenti utilizzati per creare ed eseguire il debug di procedure. Tecnici del supporto Microsoft possono spiegare la funzionalitÓ di una particolare procedura, ma in nessun sono caso a modificare questi esempi per fornire funzionalitÓ aggiuntive o creare procedure per soddisfare specifiche esigenze. Per aggirare questo problema, attenersi alla seguente procedura:
  1. Aprire il file Fpdbform.inc nella cartella _fpclass.
  2. Individuare la funzione FP_DumpError(strErrorUrl, strMsg).
  3. Rimuovere la riga analogo al seguente.
    On Error Resume Next
    						
  4. Rimuovere la riga analogo al seguente.
    fp_conn.Close
    						
  5. Salvare e chiudere il file.

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a".

Informazioni

Quando si definisce un campo come chiave primaria in Microsoft Access, tutti i record devono includere un'unica voce in tale campo. Se si tenta di immettere i dati duplicati nel campo, Access restituisce un errore.

Quando si utilizza le estensioni del server di FrontPage 2002 o le estensioni 2000 del server di FrontPage, se si tenta di inviare un modulo a un database con i dati duplicati in un campo contrassegnato come chiave primaria, viene visualizzato il seguente messaggio di errore:
Impossibile aggiornare il database.
In FrontPage 2003 e in FrontPage 2002, la riga seguente Ŕ aggiunta alla funzione FP_DumpError nel file Fpdbform.inc:
On Error Resume Next
					
Questa riga di codice viene aggiunta al file per migliorare il supporto tra-tabella codici. Causa FrontPage per ignorare l'errore che viene restituito quando una pagina Web tenta di aggiungere un record contenente dati di chiavi primari duplicati, ma consente la pagina di conferma da visualizzare. L'operazione viene visualizzato esito positivo, ma Access non consente il record che contiene i dati duplicati della chiavi primari devono essere scritti nel database.

ProprietÓ

Identificativo articolo: 314440 - Ultima modifica: lunedý 24 febbraio 2014 - Revisione: 4.1
Le informazioni in questo articolo si applicano a:
  • Microsoft Office FrontPage 2003
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft FrontPage 2002 Server Extensions
Chiavi:á
kbnosurvey kbarchive kbmt kbbug kbfix KB314440 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 314440
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com