Numéro d'article: 314466 - Dernière mise à jour: jeudi 19 octobre 2006 - Version: 3.0

Un écran de démarrage noir s'affiche brièvement et l'ordinateur redémarre continuellement lors du démarrage de Windows XP

Ancien nº de publication de cet article : F314466
IMPORTANT : cet article contient des informations sur la modification du Registre. Avant de modifier le Registre, pensez à le sauvegarder et assurez-vous que vous savez le restaurer en cas de problème. Pour plus d'informations sur la sauvegarde, la restauration et la modification du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
256986  (http://support.microsoft.com/kb/256986/[LN] / ) Description du Registre de Microsoft Windows
Pour vous procurer une version Microsoft Windows 2000 de cet article, reportez-vous à l'article 174630  (http://support.microsoft.com/kb/174630/ ) .

Sommaire

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Symptômes

Lorsque vous tentez de démarrer Windows XP, l'écran de démarrage noir peut s'afficher brièvement et l'ordinateur redémarre continuellement.

Cause

Ce problème peut se produire lorsque les conditions suivantes sont réunies :

  • Une erreur système fatale (erreur STOP) provoque l'arrêt de l'ordinateur.
  • L'option Redémarrer automatiquement est sélectionnée sous Défaillance du système dans la boîte de dialogue Démarrage et récupération des propriétés système.
  • La taille du fichier d'échange de Windows XP est inférieure à la quantité de mémoire physique installée sur votre ordinateur ou l'espace libre sur le disque dur est insuffisant pour écrire le fichier de vidage d'erreur (Memory.dmp).
Windows XP peut rencontrer durant le démarrage un problème qui provoque un message d'erreur STOP. Selon la configuration du système, l'écran bleu peut ne pas s'afficher suffisamment longtemps pour vous permettre de noter les informations concernant l'erreur.

Résolution

Pour contourner ce problème, modifiez le processus de démarrage afin de recueillir les informations nécessaires sur le message d'erreur STOP. Pour cela, appliquez les méthodes suivantes en respectant l'ordre dans lequel elles sont présentées.

REMARQUE : avant d'appliquer les méthodes suivantes, essayez de redémarrer votre ordinateur en mode sans échec. Cela vous permettra peut-être de résoudre le problème provoquant le message d'erreur STOP.

Méthode 1

  1. Essayez de remplacer les ruches du Registre à partir du répertoire de réparation à l'aide de la console de récupération, puis restaurez le système à un état actuel avec la fonctionnalité Restauration du système.

    Pour plus d'informations sur la façon de restaurer le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
    307545  (http://support.microsoft.com/kb/307545/ ) Comment faire pour récupérer un Registre endommagé qui empêche le démarrage de Windows XP

Méthode 2

AVERTISSEMENT : toute mauvaise utilisation de l'Éditeur du Registre peut générer des problèmes sérieux, pouvant vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut garantir que les problèmes résultant d'une mauvaise utilisation de l'Éditeur du Registre puissent être résolus. Vous assumez l'ensemble des risques liés à l'utilisation de cet outil.
  1. Installez Windows XP dans un autre dossier.
  2. Cliquez sur Démarrer, puis sur Exécuter.
  3. Dans la zone Ouvrir, tapez regedit, puis cliquez sur OK.
  4. Accédez à la sous-clé de Registre suivante :
    HKEY_LOCAL_MACHINE
  5. Dans le menu Fichier, cliquez sur Charger la ruche.
  6. Accédez au fichier System dans le dossier d'installation d'origine de Windows XP.

    Par défaut, le fichier System est enregistré à l'emplacement suivant :
    %SystemRoot%\System32\Config\System
  7. Tapez un nom arbitraire lorsque vous êtes invité à entrer un nom de clé dans la boîte de dialogue Chargement de la ruche.

    La ruche HKEY_LOCAL_MACHINE d'origine est chargée en tant que sous-clé de la clé de Registre active.
  8. Dans la clé nom_arbitraire (où nom_arbitraire correspond au nom attribué à la clé de Registre HKEY_LOCAL_MACHINE de l'installation Windows d'origine), accédez à la sous-clé de Registre suivante :
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CrashControl
  9. Dans le volet droit de la fenêtre de l'Éditeur du Registre, double-cliquez sur AutoReboot.
  10. Dans la zone Données de la valeur, tapez 0 (zéro), puis cliquez sur OK.
  11. Cliquez sur le signe moins pour réduire la sous-clé de Registre HKEY_LOCAL_MACHINE.
  12. Dans le menu Fichier, cliquez sur Décharger la ruche.
  13. Dans le menu Fichier, cliquez sur Quitter.
Cela désactive l'option Redémarrer automatiquement dans l'installation d'origine de Windows XP. Une fois ces procédures effectuées, vous serez peut-être en mesure de recueillir des informations sur le message d'erreur STOP et de résoudre le problème qui empêche votre ordinateur de démarrer.

Méthode 3

Une autre procédure de contournement peut s'avérer nécessaire si la taille minimale du fichier d'échange est fix?ee à une valeur inférieure à la quantité de mémoire physique. Windows XP exige la présence sur le disque système d'un fichier d'échange suffisamment grand pour contenir toute la mémoire physique plus 1 mégaoctet (Mo) pour pouvoir y écrire les informations de débogage. Vous pouvez modifier la valeur PagingFiles de l'installation d'origine pour que le fichier de vidage puisse être créé par le message d'erreur STOP. L'espace disponible sur le lecteur système doit être suffisant pour contenir le fichier d'échange.

Pour modifier la valeur PagingFiles du fichier System dans le dossier d'installation d'origine de Windows XP, procédez comme suit :
  1. Cliquez sur Démarrer, puis sur Exécuter.
  2. Dans la zone Ouvrir, tapez regedit, puis cliquez sur OK.
  3. Accédez à la sous-clé de Registre suivante :
    HKEY_LOCAL_MACHINE
  4. Dans le menu Fichier, cliquez sur Charger la ruche.
  5. Accédez au fichier System dans le dossier d'installation d'origine de Windows XP. Par défaut, il se trouve à l'emplacement suivant :
    %SystemRoot%\System32\Config\System
  6. Tapez un nom arbitraire lorsque vous êtes invité à entrer un nom de clé dans la boîte de dialogue Chargement de la ruche.

    La ruche HKEY_LOCAL_MACHINE d'origine est chargée en tant que sous-clé de la clé de Registre active.
  7. Dans la clé nom_arbitraire (où nom_arbitraire correspond au nom attribué à la clé de Registre HKEY_LOCAL_MACHINE de l'installation Windows d'origine), accédez à la sous-clé de Registre suivante :
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Session Manager\Memory Management
  8. Dans le volet droit de la fenêtre de l'Éditeur du Registre, double-cliquez sur PagingFiles.
  9. Dans la zone Données de la valeur, modifiez la première valeur numérique après c:\pagefile.sys (où c: est le lecteur où réside le fichier d'échange) pour la régler sur une valeur supérieure d'au moins 1 Mo à la quantité de mémoire physique de votre ordinateur.

    REMARQUE : ne tapez pas un chiffre supérieur à l'espace disque libre sur votre ordinateur.

    La valeur suivante, par exemple, affiche une taille de fichier d'échange minimale de 130 Mo et une taille de fichier d'échange maximale de 256 Mo.
    c:\pagefile.sys 130 256
  10. Cliquez sur OK.
  11. Accédez à l'emplacement suivant dans la ruche de Registre que vous avez chargée à partir de l'installation d'origine de Windows :
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\CrashControl
  12. Dans le volet droit de l'Éditeur du Registre, double-cliquez sur la valeur CrashDumpEnabled.
  13. Tapez 1 dans la zone Données de la valeur si cette valeur n'est pas encore présente, puis cliquez sur OK.
  14. Cliquez sur le signe moins pour réduire la sous-clé de Registre HKEY_LOCAL_MACHINE.
  15. Dans le menu Fichier, cliquez sur Décharger la ruche.
  16. Dans le menu Fichier, cliquez sur Quitter.
  17. Essayez de démarrer l'installation d'origine de Windows XP. Lorsque l'erreur STOP se produit, les informations sur le vidage mémoire sont enregistrées dans le fichier d'échange.
  18. Redémarrez l'ordinateur et sélectionnez l'installation parallèle de Windows XP. Le fichier de vidage est alors créé et vous pouvez utiliser ces informations pour résoudre le problème qui provoque le message d'erreur STOP dans l'installation d'origine.

    REMARQUE : le fichier de vidage est enregistré dans le fichier %SystemRoot%\Memory.dmp, où %SystemRoot% est le dossier système de l'installation parallèle.
  19. Cliquez sur Démarrer, cliquez avec le bouton droit sur Poste de travail, puis cliquez sur Propriétés.
  20. Cliquez sur l'onglet Avancé, puis sur Paramètres sous Démarrage et récupération.
  21. Désactivez la case à cocher Redémarrer automatiquement, cliquez sur OK, puis à nouveau sur OK.
  22. Redémarrez l'ordinateur. Lorsque vous tentez d'arrêter votre ordinateur, le message exact doit s'afficher.

Méthode 4

Lors du redémarrage, utilisez la nouvelle option de démarrage Désactiver le redémarrage automatique lors d'une défaillance du système. Si cette option est sélectionnée, vous pouvez obtenir les codes d'erreur STOP et poursuivre en conséquence.

Plus d'informations

Pour plus d'informations sur ce problème, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
310396  (http://support.microsoft.com/kb/310396/ ) L'écran d'ouverture de session de Windows XP n'apparaît pas et l'ordinateur redémarre de manière répétée
266465  (http://support.microsoft.com/kb/266465/ ) Comment faire pour effectuer une installation parallèle de Windows 2000 ou de Windows Server 2003
259003  (http://support.microsoft.com/kb/259003/ ) Comment et pourquoi effectuer une installation parallèle de Windows NT 4.0


Pour plus d'informations sur la résolution des messages d'erreur STOP, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft.
123750  (http://support.microsoft.com/kb/123750/ ) Débogage des écrans STOP lors de l'installation de Windows NT
129845  (http://support.microsoft.com/kb/129845/ ) Préparation de l'écran bleu avant de contacter Microsoft


Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows XP Professionnel
  • Microsoft Windows XP Édition familiale
Mots-clés : 
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