[PPT2002] Microsoft PowerPoint プレゼンテーションのメタデータを最小限にする方法

文書翻訳 文書翻訳
文書番号: 314800 - 対象製品
この記事は、以前は次の ID で公開されていました: JP314800
この資料は、アーカイブされました。これは "現状のまま" で提供され、更新されることはありません。
Microsoft PowerPoint 2000 については、次の資料を参照してください。
314797 [PPT2000] Microsoft PowerPoint プレゼンテーションのメタデータを最小限にする方法
すべて展開する | すべて折りたたむ

目次

概要

プレゼンテーションを作成したり、開いたり、保存したりする場合、そのプレゼンテーションを電子的に配布したときに第三者に見られては困る内容がプレゼンテーションに含まれる可能性があります。この情報は "メタデータ" と呼ばれます。メタデータは、Office 文書の編集や表示、保存、検索を強化するために、さまざまな目的で使用されます。

メタデータには、Microsoft PowerPoint のユーザー インターフェイスから簡単にアクセスできるものもありますが、低レベルのバイナリ ファイル エディタでプレゼンテーションを開くなど、特殊な方法を使用しなければアクセスできないものもあります。以下に、プレゼンテーションに格納されるメタデータの例をいくつか示します。
  • 非表示の情報
  • 名前
  • 頭文字
  • 会社名と組織名
  • コンピュータ名
  • プレゼンテーションを保存したネットワーク サーバーまたはハード ディスクの名前
  • その他のプロパティと概要情報
  • 埋め込み OLE オブジェクトの非表示部分
  • テンプレートの情報
  • コメント
この資料では、PowerPoint プレゼンテーションに含まれるメタデータの量を最小限に抑えるためのさまざまな方法について説明します。

詳細

PowerPoint プレゼンテーション内でメタデータが作成される方法は、それぞれ異なります。このため、これらのメタデータを一括してプレゼンテーションから取り除く方法はありません。ここでは、メタデータが PowerPoint プレゼンテーション内に格納される領域について説明します。

Microsoft Office XP Service Pack 1 (SP-1) または最新のアップデートを入手していない場合

Microsoft Office XP Service Pack 1 (SP-1) を使用していない場合、SP-1 を入手してインストールしてください。 SP-1 の入手方法の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
307841 OFFXP: How to Obtain the Latest Office XP Service Pack
また、最新の Microsoft PowerPoint 2002 アップデートがインストールされていることを確認してください。最新の Microsoft PowerPoint 2002 アップデートを入手するには、以下のマイクロソフト Web サイトを参照してください。
http://microsoft.com/japan/office/downloads/

非表示の情報を削除する方法

プレゼンテーションの作成者、コメントや変更履歴に関連付けられた名前など、非表示の情報が誤って配布されないようにするには、以下の手順を実行します。
  1. [ファイル] メニューの [名前を付けて保存] をクリックします。
  2. [名前を付けて保存] ダイアログ ボックスで、[ツール] をクリックし、[セキュリティ オプション] をクリックします。
  3. [セキュリティ] タブで、[保存するときに個人情報をファイルから削除する] チェック ボックスをオンにして、[OK] をクリックします。

プログラムからユーザー名を削除する方法

現在のユーザー名を参照または変更するには、次の手順を実行します
  1. [ツール] メニューの [オプション] をクリックします。[全般] タブをクリックすると、[名前] ボックスと [頭文字] ボックスが表示されます。
  2. これらの情報がプレゼンテーションに表示されないようにするには、自分を特定されない文字列かスペースを該当するボックスに入力し、[OK] をクリックして変更内容を確定します。
新規に作成するプレゼンテーションには、Office を最初にインストールしたときに入力したデフォルト値ではなく、すべてこの情報が含まれます。ただし、既存のプレゼンテーションには、既にインストール時に入力した情報が含まれている可能性があります。

個人の概要情報を削除する方法

Microsoft PowerPoint でプレゼンテーションを作成または保存すると、概要情報がプレゼンテーションに保存される可能性があります。この情報にアクセスするには、次のいずれかの操作を行います。
  • プレゼンテーションを開き、[ファイル] メニューの [プロパティ] をクリックします。[ファイルの概要]、[詳細情報]、[ファイルの構成]、および [ユーザー設定] タブにはすべて、名前、管理者の名前、会社名など、さまざまなプロパティが含まれている可能性があります。
  • Windows エクスプローラでプレゼンテーションを右クリックし、ショートカット メニューの [プロパティ] をクリックします。[プロパティ] ダイアログ ボックス内の各タブに、配布したくない情報が含まれている可能性があります。
  • Microsoft Visual Basic for Applications マクロやその他のプログラム コードを使用して、[プロパティ] ダイアログ ボックスに表示されるプロパティを読み取ります。
既存のプレゼンテーションから概要情報を削除するには、以下の手順を実行します。
  1. プレゼンテーションを開きます。
  2. [ファイル] メニューの [プロパティ] をクリックします。
  3. [ファイルの概要] タブで、[作成者]、[管理者]、[会社名]、および配布したくない情報が入力されているその他のボックスの内容をすべて削除します。
  4. [ユーザー設定] タブで、配布したくない情報が入力されているプロパティをすべて削除します。
  5. 以上の手順が完了した後、[OK] をクリックし、[ファイル] メニューの [上書き保存] をクリックします。
  6. [ファイル] メニューの [閉じる] をクリックします。
上の手順が完了したプレゼンテーションには、概要プロパティは含まれません。

ネットワークに接続したときの個人の概要情報を削除する方法

ネットワークにログオンしている場合、プレゼンテーションを保存すると、[ファイルの概要] タブの [作成者] ボックス、および [詳細情報] タブの [更新者] フィールドにネットワーク ユーザー名が表示されることがあります。その他の個人情報をコンピュータからすべて削除しても、この処理は行われる可能性があります。

ネットワークを利用しているときに、プレゼンテーションから概要情報を削除するには、以下の手順を実行します。
  1. プレゼンテーションがネットワーク サーバーに保管されている場合は、そのプレゼンテーションをローカルのハード ディスクにコピーします。
  2. コンピュータを再起動します。ただし、ネットワークにはログオンしないようにします。ネットワークのログオン ダイアログ ボックスが表示されたら、[キャンセル] をクリックするか Esc キーを押します。

    : Esc キーを押して Windows を起動できない場合 (Windows NT を実行している場合など) は、この手順を続行することはできません。
  3. プレゼンテーションを開きます。
  4. [ファイル] メニューの [プロパティ] をクリックします。
  5. [ファイルの概要] タブで、[作成者]、[管理者]、[会社名]、および配布したくない情報が入力されているその他のボックスの内容をすべて削除します。
  6. [ユーザー設定] タブで、配布したくない情報が入力されているプロパティをすべて削除します。
  7. 以上の手順が完了した後、[OK] をクリックし、[ファイル] メニューの [上書き保存] をクリックします。
  8. [ファイル] メニューの [閉じる] をクリックします。
ネットワークにログオンしている状態では、ファイルを開かないようにします。ファイルを開くと、ネットワーク ユーザー名がファイルに書き込まれる可能性があります。ただし、エクスプローラを使用して、ファイルをネットワーク サーバーまたはフロッピー ディスクにコピーすることはできます。

プレゼンテーション内のコメントを削除する方法

Microsoft PowerPoint には、プレゼンテーションにコメントを挿入する機能があります。通常、コメントには作成者の名前が付加されます。

コメントを削除するには、そのコメントを選択して Del キーを押すか、[チェック/コメント] ツール バーの [コメントの削除] をクリックします。

: Microsoft PowerPoint でコメントを表示するには、[表示] メニューの [変更履歴] をクリックします。

上記の「プログラムからユーザー名を削除する方法」に示されている手順によって [オプション] ダイアログ ボックスからユーザー名を削除すると、以後新しく作成したコメントには名前が含まれません。

ヘッダーとフッターから情報を削除する方法

プレゼンテーションのヘッダーとフッターには、識別情報が含まれていることがあります。ヘッダーとフッターから情報を削除するには、[表示] メニューの [ヘッダーとフッター] をクリックし、ヘッダーまたはフッター、あるいはその両方を変更します。変更が完了したら、[適用] または [すべてに適用] をクリックします。

高速保存をオフにする方法

高速保存機能は、プレゼンテーションに加えられた変更部分のみを保存することにより、プレゼンテーションの保存処理を高速化します。

高速保存機能の仕様により、プレゼンテーションを保存した後でも、削除したテキストがプレゼンテーション内に残る可能性があります。削除したテキストがプレゼンテーション内に残ることを懸念する場合は、以下の手順を実行してください。
  1. [ツール] メニューの [オプション] をクリックします。
  2. [保存] タブで [高速保存] チェック ボックスをオフにして、[OK] をクリックします。

プレゼンテーションからハイパーリンクを削除する方法

プレゼンテーションには、他のドキュメントまたはイントラネットやインターネット上の Web ページへのハイパーリンクが含まれていることがあります。ハイパーリンクは通常、青い下線付きのテキスト文字列として表示されます。

プレゼンテーションから単一のハイパーリンクを手動で削除するには、そのハイパーリンクを右クリックし、ショートカット メニューの [ハイパーリンクの削除] をクリックします。

プレゼンテーションから回覧先情報を削除する方法

回覧先を使用して、プレゼンテーションを電子メールによって送信する場合、ルーティング情報がプレゼンテーションに添付される可能性があります。この情報をプレゼンテーションから削除するには、回覧先情報が保持されない形式でプレゼンテーションを保存する必要があります。

これを行うには、次の手順を実行します。
  1. 高速保存機能をオフにします。操作方法については、この資料の「高速保存をオフにする方法」を参照してください。
  2. [ファイル] メニューの [送信] をポイントし、[ほかの回覧先] をクリックします。
  3. [回覧先] ダイアログ ボックスで、[クリア] をクリックして回覧先を削除してから、[追加] をクリックします。
  4. [ファイル] メニューの [上書き保存] をクリックします。
これにより、回覧先情報が何も含まれない状態でプレゼンテーションが保存されます。

Visual Basic のコードから自分の名前を削除する方法

Microsoft PowerPoint で Visual Basic のマクロを記録する場合、記録されたマクロは、次のようなヘッダーで始まります。
' <マクロ名> Macro
' 記録日 2000/3/11 記録者 <ユーザー名>
記録したすべてのマクロから自分の名前を削除するには、以下の手順を実行します。
  1. マクロが含まれているプレゼンテーションを開きます。
  2. [ツール] メニューの [マクロ] をポイントして [Visual Basic Editor] をクリックします (または Alt + F11 キーを押します)。
  3. プロジェクト ウィンドウで、対象となるマクロが含まれているモジュールをダブルクリックします。
  4. 記録されているマクロ コードから自分の名前を削除します。
名前の削除が完了したら、Alt + Q キーを押してアプリケーションに戻ります。[ファイル] メニューの [上書き保存] をクリックします。

他のファイルに対する Visual Basic の参照設定を削除する方法

Visual Basic Editor では、他のファイルへの参照を作成することが可能です。他のファイルへの参照が含まれているプレゼンテーションを開くと、参照先ファイルの名前が表示されます。

これらの参照を削除するには、以下の手順を実行します。
  1. 参照が含まれるプレゼンテーションを開きます。
  2. [ツール] メニューの [マクロ] をポイントして [Visual Basic Editor] をクリックします (または Alt + F11 キーを押します)。
  3. [ツール] メニューの [参照設定] をクリックします。
  4. 参照されているファイルの横にあるチェック ボックスをオフにします。完了したら、[OK] をクリックして [参照設定 - VBAProject] ダイアログ ボックスを閉じます。
  5. Alt + Q キーを押します。
  6. [ファイル] メニューの [上書き保存] をクリックします。
: 他のファイルへの参照を削除すると、プレゼンテーション内のマクロが正常に機能しなくなる可能性があります。

プレゼンテーションからネットワークやハード ディスクの情報を削除する方法

プレゼンテーションをローカル ハード ディスクまたはネットワーク サーバー上に保存すると、ローカル ハード ディスクやネットワーク サーバーを識別する情報がプレゼンテーションに書き込まれる可能性があります。

プレゼンテーションからこの情報を削除するには、以下の手順を実行します。
  1. プレゼンテーションを開きます。
  2. [ファイル] メニューの [名前を付けて保存] をクリックし、プレゼンテーションをフロッピー ディスク ドライブ (通常は A:) に保存します。
  3. [ファイル] メニューの [閉じる] をクリックします。
  4. フロッピー ディスク ドライブからフロッピー ディスクを取り出します。
これにより、エクスプローラを使用して、フロッピー ディスクから任意のハード ディスクまたはネットワーク サーバーにプレゼンテーション ファイルをコピーすることができます。

: フロッピー ディスクの容量の制限 (通常 1.44 MB まで) のため、プレゼンテーション ファイルのサイズがフロッピー ディスクの空き容量を超えている場合、この方法は使用できません。

プレゼンテーション内の埋め込みオブジェクトにメタデータが含まれることがある

プレゼンテーション内にオブジェクトを埋め込んだ場合、プレゼンテーションにどのような操作を行っても、そのオブジェクト内の独自のプロパティが保持されます。たとえば、Microsoft Word 文書を Microsoft PowerPoint プレゼンテーション内に埋め込んだ場合、文書とプレゼンテーションはそれぞれ独自のプロパティを持ちます。

埋め込みオブジェクトからメタデータを削除するには、オブジェクトをアクティブにし、メタデータを削除して、コンテナ ドキュメント (上の例では PowerPoint プレゼンテーション) を再びアクティブにし、コンテナ ドキュメントを保存します。

: プレゼンテーションの埋め込みオブジェクトをアクティブにする場合、埋め込みオブジェクトの一部のみがプレゼンテーションに表示されます。オブジェクトには、表示されないその他の情報が含まれている可能性があります。埋め込みオブジェクトの実際の内容ではなく、表示されている部分のみがプレゼンテーションに含まれるようにするには、以下の手順を実行します。
  1. オブジェクトを選択し、 [編集] メニューの [切り取り] をクリックします。
  2. [編集] メニューの [形式を指定して貼り付け] をクリックし、図 (拡張メタファイル) 形式を使用してオブジェクトをプレゼンテーションに貼り付けます。
この処理を実行すると、埋め込みオブジェクトの編集はできなくなりますが、メタデータは完全に含まれなくなります。

セキュリティに関する一般的な注意点

ここでは、使用しているコンピュータ環境でセキュリティのレベルを高めるための一般的な注意点について記載します。
  • コンピュータのそばから離れるときは、パスワードで保護されたスクリーン セーバー、システム起動時のパスワード、または Windows NT のロック機能を必ず使用してコンピュータを保護してください。
  • 使用しているコンピュータに共有フォルダがある場合は、必ずパスワードを適用して、権限のあるユーザーだけが共有にアクセスできるようにします。より高いセキュリティを実現するためには、ユーザー レベルのアクセス管理を使用し、コンピュータの共有にアクセスできるユーザーを厳密に制御します。
  • ファイルを削除した後で、すぐにごみ箱を空にします。ファイルを削除するときに、自動的に完全消去または上書きを行うユーティリティの使用を検討することもできます。
  • バックアップしたデータは、 金庫 または鍵付きのキャビネットなどの安全な場所に保管します。
  • 重要な文書はパスワードで保護し、権限のあるユーザー以外は開くことができないようにします。パスワードは、安全な別の場所に保管する必要があります。パスワードを忘れた場合、パスワード保護された文書の内容を取り出す方法はないため、注意が必要です。
  • 電子的な形態で文書を配布しないようにし、代わりに印刷します。独自のフォント、透かし、ロゴ、または特殊な用紙など、自分が特定されるような要素は、(プレゼンテーションなどで) 必要な場合を除いて、使用しないようにします。
  • 電子メールは匿名では処理されません。何らかの方法で文書に自分の識別情報が添付されることを懸念する場合は、文書を電子メールで送信しないでください。
  • HTTP または FTP プロトコルを使用して、インターネット上でドキュメントを送信しないでください。これらのプロトコルを使用して送信される情報は、"クリア テキスト" で送信されます。これは、その内容を盗み見ることが (考えにくいことですが) 技術的に不可能ではないことを意味します。

参考資料

この資料で説明されている内容の詳細については、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
290945 WD2002: How to Minimize Metadata in Microsoft Word Documents
290945 [WD2002] Microsoft Word 文書のメタデータを最小限に抑える方法

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 314800 (最終更新日 2002-06-11) をもとに作成したものです。



プロパティ

文書番号: 314800 - 最終更新日: 2014年2月4日 - リビジョン: 1.0
この資料は以下の製品について記述したものです。
  • Microsoft PowerPoint 2002 Standard Edition
キーワード:?
kbnosurvey kbarchive kbhowto kbui kbdta kbfaq KB314800
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com