Artigo: 314872 - Última revisão: sábado, 1 de Dezembro de 2007 - Revisão: 1.3

Problemas de listas de pesquisa em servidores e clientes incluem mensagens de erro com o ID de evento 8032 e a incapacidade de efectuar pesquisas

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Para obter uma versão deste artigo referente ao Microsoft Windows 2000, consulte 254527  (http://support.microsoft.com/kb/254527/EN-US/ ) .
Expandir tudo | Reduzir tudo

Sintomas

Nas seguintes condições, poderá detectar um ou mais dos seguintes sintomas:
  • Quando faz duplo clique em Os meus locais na rede (My Network Places) no Explorador do Windows (Windows Explorer), é apresentada uma lista de pesquisa incompleta.
  • Os computadores que não têm a partilha de ficheiros e de impressoras activada não são apresentados na lista de pesquisa.
  • Se um controlador de domínio baseado no Windows não tiver a partilha de ficheiros e de impressoras activada, os computadores baseados no Windows que tentem utilizar a lista de pesquisa apresentarão as seguintes informações sobre o ID de evento 8032:
    O serviço de browser falhou na obtenção da lista de secundários demasiadas vezes no transporte \Device\NetBT_Tcpip_{XXXXXXX-9F03-42B2-AB84-12EEEFD572E9}. O browser secundário está a ser parado.

    - ou -

    The browser service has failed to retrieve the backup list too many times on transport \Device\NetBT_Tcpip_{XXXXXXX-9F03-42B2-AB84-12EEEFD572E9}. The backup browser is stopping.
  • Um utilizador cliente baseado no Windows que esteja a tentar efectuar uma pesquisa em Os meus locais na rede (My Network Places) recebe as seguintes informações sobre o ID de evento 8032:
    Tipo de evento: Erro (Error)
    Origem do evento: Browser
    Categoria do evento: Nenhuma (None)
    ID do evento: 8032
    Data: 16-Fev-2000 (16-Feb-2000)
    Hora: 10:22:31
    Utilizador: N/D (N/A)
    Computador: Cliente
    Descrição: O serviço de browser falhou na obtenção da lista de secundários demasiadas vezes no transporte \Device\NetBT_Tcpip_{XXXXXXX-9F03-42B2-AB84-12EEEFD572E9}. O browser secundário está a ser parado.

    - ou -

    The browser service has failed to retrieve the backup list too many times on transport \Device\NetBT_Tcpip_{XXXXXXX-9F03-42B2-AB84-12EEEFD572E9}. The backup browser is stopping.

    Dados: 0000: 0000007a
  • No controlador de domínio baseado no Windows que não tem a partilha de ficheiros e de impressoras activada, são apresentadas as seguintes informações:
    Tipo de evento: Erro (Error)
    Origem do evento: Servidor (Server)
    Categoria do evento: Nenhuma (None)
    ID do evento: 2504
    Data: 16-Fev-2000 (16-Feb-2000)
    Hora: 11:59:22
    Utilizador: N/D (N/A)
    Computador: DC
    Descrição: O servidor não conseguiu ligar-se ao transporte \Device\NetBT_Tcpip_{XXXXXXX-F096-4E5C-A847-F8F095C45053}.

    - ou -

    The server could not bind to the transport \Device\NetBT_Tcpip_{XXXXXXX-F096-4E5C-A847-F8F095C45053}.

    Dados: 0000: aa 05 00 00

    Tipo de evento: Erro (Error)
    Origem do evento: Servidor (Server)
    Categoria do evento: Nenhuma (None)
    ID do evento: 2505
    Data: 16-Fev-2000 (16-Feb-2000)
    Hora: 11:59:31
    Utilizador: N/D (N/A)
    Computador: DC
    Descrição: O servidor não conseguiu efectuar o enlace ao transporte \Device\NetbiosSmb porque existe outro computador na rede com o mesmo nome. O servidor não pode ser iniciado.

    - ou -

    The server could not bind to the transport \Device\NetbiosSmb because another computer on the network has the same name. The server could not start.

    Dados: 0000: 34 00 00 00 4

Causa

Este comportamento pode ocorrer se o componente dos serviços de ficheiros e de impressoras não estiver seleccionado durante a configuração inicial do servidor ou se o componente não estiver seleccionado de todo. Quando esta situação acontece, o serviço de servidor não efectua o enlace à interface NetBIOS. Um computador baseado no Windows que se torne num browser secundário, mas que não tem a partilha de ficheiros e de impressoras activada, não consegue partilhar a lista de pesquisa com clientes. Qualquer computador que não esteja incluído na lista de pesquisa também tem de ter a partilha de ficheiros e de impressoras activada.

Resolução

Para contornar este comportamento, instale ou active a partilha de ficheiros e de impressoras em controladores de domínio baseados no Windows e em qualquer computador que se encontre na lista de pesquisa.

Para instalar ou activar a partilha de ficheiros e de impressoras no Windows XP, siga estes passos:
  1. Clique em Iniciar (Start), clique em Painel de controlo (Control Panel), clique em Ligações de rede e de Internet (Network and Internet Connections) e clique em Ligações de rede (Network Connections).
  2. Clique com o botão direito do rato na ligação de rede que pretende configurar e clique em Propriedades (Properties).
  3. Clique no separador Geral (General) (para uma ligação de área local) ou clique no separador Funcionamento em rede (Networking) (para todos os outros tipos de ligação).
  4. Certifique-se de que Partilha de ficheiros e de impressoras em redes Microsoft (File and Printer Sharing for Microsoft Networks) consta na lista de componentes da ligação.

    NOTA: se a opção Partilha de ficheiros e de impressoras em redes Microsoft (File and Printer Sharing for Microsoft Networks) não constar na lista de componentes da ligação:
    1. Clique em Instalar (Install).
    2. Seleccione a caixa de verificação Serviço (Service) e clique em Adicionar (Add).
    3. Na caixa Fabricantes (Manufacturers), clique em Microsoft.
    4. Na caixa Serviços de rede (Network Services), clique em Partilha de ficheiros e de impressoras em redes Microsoft (File and printer sharing for Microsoft Networks) e clique em OK.
  5. Na lista de componentes da ligação, certifique-se de que a opção Partilha de ficheiros e de impressoras em redes Microsoft (File and Printer Sharing for Microsoft Networks) está seleccionada e clique em Fechar (Close) ou OK.
  6. Clique em Fechar (Close) ou clique em OK.

Ponto Da Situação

A Microsoft confirmou que este problema ocorre nos produtos da Microsoft listados no início deste artigo.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Professional x64 Edition
Palavras-chave: 
kberrmsg kbnetwork kbui kbprb kbbrowse KB314872