"Error 1328. Chyba pri opravovaní súboru <path>\Winword.exe "chybové hlásenie pri použití balíka Office XP Service Pack 1 (SP-1) na pracovnú stanicu</path>

Preklady článku Preklady článku
ID článku: 315063 - Zobraziť produkty, ktorých sa tento článok týka.
Dôležité Tento článok popisuje chybu, ktorá sa vyskytuje v podnikovej prostredie a je určená pre správcov systému v tomto prostredí.

Tento článok nemá nie na vás vzťahujú, ak spĺňate všetky nasledujúce kvalifikácií:
  • Ste nainštalovali vaša verzia balíka Office XP z maloobchodnej CD-ROM (zobrazené s hologramom Office).
  • Ste sa pokúsili aktualizovať svoju verziu balíka Office XP do kancelárie XP Service Pack 1 (SP-1) používaním výrobku aktualizácie webu (http://office.microsoft.com/productupdates).
Ak vaša verzia balíka Office XP nainštalovaný zo siete server alebo CD-ROM, ktorá bola poskytnutá správcom systému, prosím Požiadajte správcu systému o tomto probléme a referenčné tento článok číslo.

Ďalšie informácie o tomto problém, ak ste nainštalovali balík Office z CD-ROM, kliknite na tlačidlo nasledujúci článok číslo zobrazíte článok v databáze Microsoft Knowledge Base:
315152OFFXP: Error 1328, keď použijete balík Office XP Service Pack 1
Rozbaliť všetko | Zbaliť všetko

Priznaky

Keď aplikujete Office XP Service Pack 1 (SP-1), môže sa zobrazí chybové hlásenie podobné nasledovnému:
Chyba 1328. Opravovaní súboru C:\program files\Microsoft chyba Office\Winword.exe. Pravdepodobne bol aktualizovaný iným spôsobom a môže bez viac možné zmeniť touto opravou. Pre viac informácií kontaktujte vášho patch dodávateľa.
Poznámka Všetky klientske aktualizácie pre balík Microsoft Office XP vytvárať súbory denníka v \Temp\OHotfix priečinok. Súbory denníka majú názvy, ktoré sú podobné nasledovnému:
OHotfix () #.log
OHotfix () #_Msi.log
Tieto čísla začínajú na 00001 a sa zvýši za každý následné aktualizácie. Preto, ak spustíte rovnaký aktualizáciu znova, alebo môžete spustiť nová aktualizácia, ďalšiu dvojice súborov denníka je očíslované 00002.

Keď ste Otvorte súbor denníka, môžete vyhľadať text podobný nasledujúcemu:
MSI (s) (D5:80): Executing op:
FileCopy(SourceName=WINWORD.EXE,DestName=WINWORD.EXE,Attributes=1537,FileSize=110578248,
Version=10.0.2930.0,Language=0,InstallMode=58982400,PerTick=32768,IsCompressed=0,,
VerifyMedia=1,,VitalPatches=15,PatchHeaders=Binary00 
MSI (s) (D5:80): File: C:\Program Files\Microsoft Office\Office10\WINWORD.EXE;
Overwrite; Existing file is a lower version
MSI (s) (D5:80): Executing op:
PatchApply(PatchName=WINWORD.EXE,TargetName=C:\Program Files\Microsoft
Office\Office10\WINWORD.EXE,PatchSize=3938618,TargetSize=10578248,PerTick=0,IsCCompressed=1,
FileAttributes=1537,PatchAttributes=0)PatchFiles: File: C:\Program Files\Microsoft 
Office\Office10\WINWORD.EXE, Directory: C:\Program Files\Microsoft 
Office\Office10\, Size:
MSI (s) (D5:80): Note: 1: 2318 2: C:\Config.Msi\PTC8D.tmp
MSI (s) (D5:80): Note: 1: 2302 2: 0  
MSI (s) (D5:80): Note: 1: 1328 2: C:\Program Files\Microsoft
Office\Office10\WINWORD.EXE 3: -1072807676  Error 1328. Error applying patch to 
file C:\Program Files\Microsoft Office\Office10\WINWORD.EXE. It has probably 
been updated by other means, and can no longer be modified by this patch. For more 
information contact your patch vendor. System Error: -1072807676
MSI (s) (D5:80): Product: Microsoft Office XP Professional with FrontPage --Error 1328. 
Error applying patch to file C:\Program Files\Microsoft 
Office\Office10\WINWORD.EXE. It has probably 
been updated by other means, and can no longer be modified by this patch. For more 
information contact your patch vendor. System Error: -1072807676 
				
Ďalšie informácie o používaní denníka súbor, kliknite na nasledovné číslo článku publikovaného v databáze Microsoft Knowledge Base:
308490Riešenie problémov s update Inštalácia pomocou log súborov v balíku Office XP

Pricina

Toto chybové hlásenie sa zobrazí, ak všetky tieto podmienky sú pravdivé:
  • Máte správcovskej inštalácie balíka Office XP ktorý bol aktualizovaný pre-Service Pack 1 správcovskú aktualizáciu.
  • Používate sieť klientskou pracovnou stanicou, ktorá nainštalovaný Úradu zo správcovskej inštalácie.
  • Žiadate SP-1 pre klienta siete Workstation.
Klienta aktualizácie balíka Office použiť binárny metódu aktualizovať súbor. To znamená, že konkrétnych častí súboru aktualizujú. Kvôli tejto metódy, program súboru balíka Office, ktorá bola aktualizovaná na klienta cez celý súbor náhradné (správcovskej inštalácie), ktorá už bola aktualizovaná s ďalšie aktualizácie nie je možné aktualizovať pomocou aktualizácie klienta SP-1. Toto je pretože súbor na obrazu správcovskej inštalácie a súbor na klienta nie sú súbory, ktoré aktualizácie klienta (binárne update) očakáva, že nájsť. To spôsobuje zlyhanie aktualizácie klienta.

V súbore denníka vzorky v "Príznaky" oddiel, oznámenie v riadku, ktorý začína s textom
FileCopy(SourceName=WINWORD.EXE,DestName=WINWORD.EXE,Attributes=1537,FileSize=110578248,
Version=10.0.2930.0
				
Pretože je základná (RTM) verzia Microsoft Word 2002 10.0.2627.0 a Administrátorská inštalácia (SourceName) obsahuje neskoršej verzia, je zrejmé, že správna Inštalácia bola už aktualizovaný post-RTM update. Ďalšie informácie o verzie programu, kliknite na nasledujúce číslo článku publikovaného v databáze Microsoft Knowledge Base:
291331Ako skontrolovať verziu balíka Office XP

Riešenie

Ak potrebujete aktualizovať váš klient na SP-1 bez aktualizácie správneho obrazu, vytvorenie sekundárneho obrazu správcovskej inštalácie, a potom program klienta na RTM úroveň Office XP a platia SP-1 pre klienta. Chcete urobiť, postupujte nasledovne:
  1. Vytvoriť nové administrátorskej inštalácie balíka Office XP, ktorý neobsahuje žiadne aktualizácie alebo opravy.
  2. Spustite nasledujúci príkaz na každého klienta (použite nasadenia Metóda podľa potreby):
    Msiexec.exe/i cesta k novej Admin MSI PREINŠTALOVAŤ = VŠETKY REINSTALLMODE = VM
  3. SP-1 sa vzťahujú na klienta.

dalsie informacie

Ak ste pôvodne nainštalovali balík Office XP na klientskom počítači od Administrátorské umiestnenie, ktorý bol aktualizovaný s Správcovská aktualizácia, musíte použiť nasledovný postup na aktualizáciu všetkých klientov. Ak aktualizujete klient priamo pomocou aktualizácie klienta (koncových používateľov), klienta a administratívne obrázky bude synchronizovaný, ktoré môžu spôsobiť budúce aktualizácie na neúspech.

Ak vaše pracovné stanice klient nainštalovaný Office zo správcovskej inštalácie balíka Office, sa odporúča, aby ste Stiahnuť a nainštalovať správcovskú verziu aktualizácie od Spoločnosti Microsoft Office XP Resource Kit. Ďalšie informácie o nasadenie aktualizácií balíka Office, prejdite na na webovej lokalite spoločnosti Microsoft:
http://www.Microsoft.com/Office/ORK/XP/One/depb11.htm
Po použití správcovskú verziu aktualizácie Office správcovskej inštalácie, budete aktualizovať každý klient workstation podľa spustenie príkazového riadka programu Windows Installer na pracovnej stanici.

Ďalšie informácie o inštalácii aktualizácií k správcovskej inštalácie, kliknite na nasledujúce článok číslo Zobraziť článok v databáze Microsoft Knowledge Base:
301348Ako nainštalovať verejných aktualizovať Správcovské inštalácie balíka Office XP

Vlastnosti

ID článku: 315063 - Posledná kontrola: 19. októbra 2012 - Revízia: 1.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Office XP Professional Edition
  • Microsoft Office XP Small Business Edition
  • Microsoft Office XP Standard Edition
  • Microsoft Office XP Developer Edition
  • Microsoft Access 2002 Standard Edition
  • Microsoft Excel 2002 Standard Edition
  • Microsoft FrontPage 2002 Standard Edition
  • Microsoft Outlook 2002 Standard Edition
  • Microsoft PowerPoint 2002 Standard Edition
  • Microsoft Word 2002 Standard Edition
Kľúčové slová: 
kbtshoot kbpubtypekc kbbug kberrmsg kbprb kbmt KB315063 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok bol preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft, nie prekladateľom. Spoločnosť Microsoft ponúka články preložené prekladateľmi aj strojovo preložené články, vďaka čomu máte možnosť prístupu ku všetkým článkom databázy Knowledge Base vo svojom jazyku. Strojovo preložený článok však nie je vždy perfektný. Môže obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky, podobne ako cudzinec môže robiť chyby, keď rozpráva vašim jazykom. Spoločnosť Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené akýmkoľvek nepresným prekladom obsahu alebo jeho použitím zo strany zákazníkov. Spoločnosť Microsoft softvér na strojový preklad pravidelne aktualizuje.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem: 315063

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com