Komputer nie uruchamia się po zmianie aktywnej partycji przy użyciu narzędzia do zarządzania dyskami

Ten artykuł zawiera rozwiązanie problemu polegającego na tym, że komputer nie uruchamia się po oznaczeniu partycji podstawowej jako aktywnej.

Dotyczy: Windows Server 2012 R2
Oryginalny numer KB: 315261

Symptomy

Po użyciu narzędzia przystawki Zarządzanie dyskami systemu Windows, aby oznaczyć partycję podstawową jako aktywną, komputer może nie zostać uruchomiony i może zostać wyświetlony następujący komunikat o błędzie:

Brak ntldr.

Naciśnij klawisze Ctrl+Alt+Del, aby uruchomić ponownie.

Przyczyna

Takie zachowanie występuje, jeśli partycja oznaczona jako aktywna nie zawiera plików rozruchowych systemu Windows ani plików rozruchowych dla innego systemu operacyjnego. Na komputerach z systemem Intel partycja systemowa musi być partycją podstawową, która została oznaczona jako aktywna do celów uruchamiania. Ta partycja musi znajdować się na dysku, do który komputer uzyskuje dostęp podczas uruchamiania. Jednocześnie może istnieć tylko jedna aktywna partycja systemowa. Jeśli chcesz użyć innego systemu operacyjnego, musisz najpierw oznaczyć jego partycję systemową jako aktywną przed ponownym uruchomieniem komputera.

Rozwiązanie

Ważna

Przed wykonaniem kroków wymienionych poniżej upewnij się, że masz dobrą kopię zapasową krytycznych plików danych.

Aby rozwiązać ten problem, użyj jednej z następujących procedur:

  • Spróbuj zmienić aktywną partycję, uruchamiając dyskietkę, a następnie używając narzędzi dyskowych, aby ręcznie zmienić aktywną partycję:

    1. Uruchom polecenie w wierszu polecenia przy użyciu dyskietki rozruchowej systemu Microsoft Windows 95, Microsoft Windows 98 lub Microsoft Windows Millennium Edition (Me).
    2. W wierszu polecenia wpisz fdisk, a następnie naciśnij klawisz ENTER.
    3. Po wyświetleniu monitu o włączenie obsługi dużych dysków kliknij przycisk Tak.
    4. Kliknij pozycję Ustaw aktywną partycję, naciśnij numer partycji, którą chcesz uaktywnić, a następnie naciśnij klawisz ENTER.
    5. Naciśnij klawisz ESC.
    6. Usuń dyskietkę rozruchu, a następnie uruchom ponownie komputer.
  • Uruchom komputer przy użyciu dysku rozruchowego systemu Windows XP. Aby uzyskać więcej informacji, zobacz Tworzenie dysku naprawy systemu.

  • Jeśli partycja, która została niepoprawnie oznaczona jako aktywna, jest sformatowana w systemie plików FAT, systemie plików FAT32 lub systemie plików NTFS, możesz użyć konsoli odzyskiwania systemu Windows, aby poprawić zachowanie.

Aby uzyskać więcej informacji, zobacz Jakie są opcje odzyskiwania systemu w systemie Windows?.

Uwaga

Partycja systemowa odnosi się do woluminu dysku zawierającego pliki potrzebne do uruchomienia systemu Windows (na przykład Ntldr, Boot.ini i Ntdetect.com). Na komputerach z procesorem Intel x86 partycja systemowa musi być partycją podstawową oznaczoną jako aktywna. Na komputerach intel x86 jest to zawsze dysk 0, dysk, który system BIOS wyszukuje po uruchomieniu systemu operacyjnego.

Za pomocą konsoli odzyskiwania skopiuj plik Ntldr z dysku CD-ROM systemu Windows XP do katalogu głównego bieżącej aktywnej partycji. Wykonaj następujące czynności:

  1. Uruchom komputer przy użyciu dyskietek instalatora systemu Windows XP lub przy użyciu dysku CD-ROM systemu Windows XP.

  2. Na ekranie Witamy w instalatorze naciśnij klawisz F10 lub naciśnij klawisz R, aby naprawić.

  3. Naciśnij klawisz C, aby uruchomić konsolę odzyskiwania.

  4. Skopiuj plik Ntldr z dysku CD-ROM systemu Windows XP do katalogu głównego partycji systemowej, używając następujących poleceń, naciskając klawisz ENTER po każdym poleceniu:

  5. Wpisz cd .. , aby przejść do katalogu głównego dysku C.

    Między d a dwoma okresami (..) znajduje się spacja.

  6. Wpisz literę dysku CD-ROM.

  7. Typ: cd i386.

  8. Typ: Copy ntldr c:.

  9. Typ: Copy ntdetect.com c:.

  10. Typ: Bootcfg /add.

  11. Typ: Exit.

Jeśli partycja nie została sformatowana przy użyciu systemu Windows, może być również konieczne uruchomienie polecenia fixboot konsoli odzyskiwania, aby umożliwić rozruch aktywnej partycji.

Po uruchomieniu w systemie Windows zaleca się użycie przystawki Zarządzanie dyskami systemu Windows w celu zresetowania oryginalnej partycji systemowej jako aktywnej partycji, a następnie ponownego uruchomienia komputera.