« Échec de l'installation. Erreur inconnue (-2147024770) "erreur message lorsque vous tentez d'utiliser Windows Update

Traductions disponibles Traductions disponibles
Numéro d'article: 315297 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Symptômes

Lorsque vous essayez d'utiliser Microsoft Internet Explorer pour mettre à jour Windows à partir du site Windows Update (http://windowsupdate.microsoft.com), le message d'erreur suivant peut s'afficher :
Échec de l'installation. Erreur inconnue (-2147024770)

Cause

Ce problème peut se produire si Internet Explorer a certains fichiers endommagés, ou si le fichier Inseng.dll liens dynamiques (DLL) bibliothèque n'est pas enregistré.

Résolution

Pour résoudre ce problème, appliquez les méthodes suivantes en respectant l'ordre dans lequel présentées.

Méthode 1: Enregistrer le fichier Inseng.dll

  1. Cliquez sur Démarrer , puis cliquez sur Exécuter .
  2. Dans la zone Ouvrir , tapez regsvr32 /u inseng.dll et puis cliquez sur OK .
  3. Lorsque vous recevez le message indiquant que DllUnregisterServer dans Inseng.dll réussi, cliquez sur OK .
  4. Cliquez sur Démarrer , puis cliquez sur Exécuter .
  5. Dans la zone Ouvrir , tapez regsvr32 inseng.dll et puis cliquez sur OK .
  6. Lorsque vous recevez le message indiquant que DllRegisterServer dans Inseng.dll réussi, cliquez sur OK .
  7. Redémarrez l'ordinateur.
Si le problème n'est pas résolu, passez à la méthode 2.

Méthode 2: réparer Internet Explorer

Appliquez l'une des procédures suivantes, selon votre système d'exploitation.

Windows 2000 Service Pack 1 (SP1) ou version ultérieure, Windows Millennium Edition (Me) ou Windows 98

Remarque : où il existe plusieurs versions de Microsoft Windows, les étapes suivantes peuvent être différent sur votre ordinateur. Si tel est le cas, consultez votre documentation pour effectuer ces étapes.
  1. Cliquez sur Démarrer , pointez sur Paramètres , cliquez sur le Panneau de configuration et puis double-cliquez sur Ajout/Suppression de programmes .
  2. Cliquez sur Microsoft Internet Explorer version (où version est la version d'Internet Explorer qui est installé), puis cliquez sur Modifier/Supprimer .
  3. Cliquez sur Réparer Internet Explorer , puis cliquez sur OK .
  4. Cliquez sur Oui pour confirmer l'opération de réparation.
  5. Suivez le à l'écran instructions pour réparer Internet Explorer et redémarrez l'ordinateur lorsque vous êtes invité.

Windows 2000 sans Service Pack 1 ou Service Pack 2 (SP2)

  1. Cliquez sur Démarrer , puis cliquez sur Exécuter .
  2. Dans la zone Ouvrir , tapez rundll32 setupwbv.dll, ie5maintenance , puis cliquez sur OK .

    Remarque : il n'un espace entre « rundll32 » et swtupwbv.dll dans cette commande.
  3. Suivez le à l'écran instructions pour réinstaller Internet Explorer et redémarrez l'ordinateur lorsque vous êtes invité.
Si le problème n'est pas résolu ou si vous ne pouvez pas correctement réparer Internet Explorer, passez à la méthode 3.

Méthode 3: réinstallation d'Internet Explorer

Réinstallez votre version actuelle d'Internet Explorer ou installer la dernière version d'Internet Explorer. Pour obtenir la version plus récente d'Internet Explorer, reportez-vous au site de Web Microsoft suivant :
Mise à jour Internet Explorer
http://www.microsoft.com/windows/products/winfamily/ie/default.mspx

Propriétés

Numéro d'article: 315297 - Dernière mise à jour: mardi 14 septembre 2010 - Version: 4.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Update
  • Microsoft Windows 2000 Professionnel
  • Microsoft Update
Mots-clés : 
kbmt kberrmsg kbprb KB315297 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 315297
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com