"インストールに失敗しました。不明なエラー (-2147024770)「Windows Update を使用しようとするとエラー メッセージ

文書翻訳 文書翻訳
文書番号: 315297
すべて展開する | すべて折りたたむ

目次

現象

Microsoft Internet Explorer を使用して、Windows を更新するのには、Windows Update サイト (からにしようとするとhttp://update.microsoft.com)、次のエラー メッセージが表示されることがあります。
インストールが失敗します。不明なエラー (-2147024770)

原因

この問題は、Internet Explorer いくつかのファイルが破損している場合、または Inseng.dll のダイナミック リンク ライブラリ (DLL) ファイルが登録されていない場合は、発生する可能性があります。

解決方法

この問題を解決するには、以下の方法を記載順に使用します。

方法 1: Inseng.dll ファイルを登録します。

  1. クリックしてください。 開始、し 実行.
  2. で、 ファイルを開く ボックスの種類 regsvr32/u inseng.dll、し [OK].
  3. Inseng.dll DllUnregisterServer が成功したことを示すメッセージが表示されたらをクリックします。 [OK].
  4. クリックしてください。 開始、し 実行.
  5. で、 ファイルを開く ボックスの種類 regsvr32 inseng.dll、し [OK].
  6. Inseng.dll の DllRegisterServer が成功したことを示すメッセージが表示されたらをクリックします。 [OK].
  7. コンピューターを再起動します。
方法 2 を問題が解決しない場合に進みます。

方法 2: Internet Explorer を修復します。

次の手順のいずれかのオペレーティング システムに応じて使用します。

Windows 2000 Service Pack 1 (SP1) または Windows Me ではその後、Edition (Me) または Windows 98

メモ: ためいくつか Microsoft Windows のバージョン、次の手順はコンピューターによって異なる場合があります。場合は、次の手順を完了するのには、製品のマニュアルを参照してください。
  1. クリックしてください。 開始、ポイント 設定をクリックして コントロール パネル、し、をダブルクリック プログラムの追加と削除.
  2. クリックしてください。 Microsoft Internet Explorer バージョン (場所 バージョン インストールされている Internet Explorer のバージョンです)、[ [変更/削除.
  3. クリックしてください。 Internet Explorer の修復、し [OK].
  4. クリックしてください。 [はい] 修復操作を確認するには。
  5. に従って、画面に表示される、Internet Explorer を修復して、確認メッセージが表示されたら、コンピューターを再起動します。

Windows 2000 SP1 または Service Pack 2 (SP2)

  1. クリックしてください。 開始、し 実行.
  2. で、 ファイルを開く ボックスの種類 rundll32 の setupwbv.dll、ie5maintenance、し [OK].

    メモ: は"rundll32"と"swtupwbv.dll"このコマンドの間にスペースです。
  3. に従って、画面に表示される、Internet Explorer を再インストールし、プロンプトが表示されたら、コンピューターを再起動します。
問題が解決しない場合は、Internet Explorer を修復することができない場合は、方法 3 を実行します。

方法 3: Internet Explorer を再インストールします。

現在のバージョンの Internet Explorer を再インストールするか、Internet Explorer の最新バージョンにアップグレードします。Internet Explorer の最新バージョンを入手するのには、次のマイクロソフト Web サイトを参照してください。
Internet Explorer の更新プログラム
http://www.microsoft.com/windows/products/winfamily/ie/default.mspx

プロパティ

文書番号: 315297 - 最終更新日: 2011年7月24日 - リビジョン: 6.0
キーワード:?
kberrmsg kbprb kbmt KB315297 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:315297
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com