Help and Support
 

powered byLive Search

Le message d'erreur « Windows n'a pas pu démarrer car le fichier suivant est manquant ou endommagé : Isapnp.sys » s'affiche au démarrage

Numéro d'article:315311
Dernière mise à jour:jeudi 22 décembre 2005
Version:5.1
Cet article peut contenir des liens vers des informations en langue anglaise (pas encore traduites).
Sommaire

Symptômes

Lorsque vous tentez de démarrer Microsoft Windows XP ou Microsoft Windows 2000, l'un des messages d'erreur suivants peut s'afficher (selon votre système d'exploitation) :

Windows XP
Windows n'a pas pu démarrer car le fichier suivant est manquant ou endommagé :
\windows\System32\Drivers\Isapnp.sys
Windows 2000
Windows n'a pas pu démarrer car le fichier suivant est manquant ou endommagé :
\Winnt\System32\Drivers\Isapnp.sys

Retour au début

Cause

Ce problème peut se produire si le fichier Isapnp.sys est endommagé ou ne se trouve pas à l'emplacement spécifié par le message d'erreur.

Retour au début

Résolution

Pour résoudre ce problème, utilisez la console de récupération pour remplacer le fichier Isapnp.sys.

Retour au début

Windows XP

Pour remplacer le fichier Isapnp.sys dans Windows XP, procédez comme suit :
1.Démarrez l'ordinateur à partir du CD-ROM Windows XP.
2.Sur l'écran Bienvenue, appuyez sur R pour démarrer la console de récupération.
3.Si vous disposez d'un ordinateur à double démarrage ou à démarrage multiple, tapez le chiffre correspondant à l'installation de Windows XP sur laquelle vous souhaitez ouvrir une session lorsque vous y êtes invité, puis appuyez sur ENTRÉE.
4.Lorsque vous êtes invité à entrer le mot de passe administrateur, tapez-le, puis appuyez sur ENTRÉE.

Remarque Si le mot de passe administrateur est vide, appuyez simplement sur ENTRÉE.
5.À l'invite C:\Windows, tapez la commande suivante, puis appuyez sur ENTRÉE :
ren c:\windows\system32\drivers\isapnp.sys isapnp.old
Remarque La procédure décrite dans cet article suppose que vous avez installé Windows XP sur le lecteur C:. Le véritable emplacement de votre installation Windows peut varier.
6.À l'invite C:\Windows, tapez la commande suivante, puis appuyez sur ENTRÉE :
expand lecteur_CD-ROM:\i386\isapnp.sy_ c:\windows\system32\drivers\isapnp.sys
Par exemple, tapez :
expand d:\i386\isapnp.sy_ c:\windows\system32\drivers
7.Une fois le fichier décompressé, tapez exit, puis appuyez sur ENTRÉE pour quitter la console de récupération.
8.Redémarrez l'ordinateur.

Retour au début

Windows 2000

Pour remplacer le fichier Isapnp.sys dans Windows 2000, procédez comme suit :
1.Démarrez l'ordinateur à partir du CD-ROM Windows 2000.
2.Sur l'écran Bienvenue, appuyez sur R pour réparer, puis sur C pour démarrer la console de récupération.
3.À l'invite C:\Winnt, tapez la commande suivante, puis appuyez sur ENTRÉE :
expand lettre_lecteur_CD-ROM:\i386\isapnp.sy_ c:\winnt\system32\drivers\isapnp.sys
Par exemple, tapez :
expand d:\i386\isapnp.sy_ c:\winnt\system32\drivers
Remarque La procédure décrite dans cet article suppose que vous avez installé Windows 2000 sur le lecteur C:. Le véritable emplacement de votre installation Windows peut varier.
4.Une fois le fichier décompressé, tapez exit pour quitter la console de récupération.
5.Redémarrez l'ordinateur.

Retour au début

Plus d'informations

Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
307654 (http://support.microsoft.com/kb/307654/) Comment faire pour installer et utiliser la console de récupération dans Windows XP

Retour au début


Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
?Microsoft Windows XP Édition familiale
?Microsoft Windows XP Professionnel
?Microsoft Windows 2000 Professionel

Retour au début

Mots-clés : 
kbenv kberrmsg kbprb kbsetup KB315311

Retour au début

L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Traductions disponibles

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.