Artigo: 315311 - Última revisão: terça-feira, 29 de Maio de 2007 - Revisão: 5.4

Recebe uma "o Windows não conseguiu iniciar porque o ficheiro seguinte está em falta ou danificado: isapnp.sys" mensagem de erro durante o arranque

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Quando tenta iniciar o Microsoft Windows XP ou Microsoft Windows 2000, poderá receber uma das seguintes mensagens de erro, dependendo do sistema operativo.

Windows XP
O Windows não conseguiu iniciar porque o ficheiro seguinte está em falta ou danificado:
\windows\System32\Drivers\Isapnp.sys
Windows 2000
O Windows não conseguiu iniciar porque o ficheiro seguinte está em falta ou danificado:
\Winnt\System32\Drivers\Isapnp.sys

Causa

Este problema poderá ocorrer se o ficheiro isapnp.sys está danificado ou não está presente no caminho que especifica a mensagem de erro.

Resolução

Para resolver este problema, utilize consola de recuperação para substituir o ficheiro isapnp.sys.

Windows XP

Para substituir o ficheiro isapnp.sys no Windows XP, siga estes passos:
  1. Inicie o computador a partir do CD-ROM do Windows XP.
  2. No ecrã Bem-vindo ao programa de configuração , prima R para iniciar a consola de recuperação.
  3. Se tiver um arranque duplo ou um computador de arranque múltiplo, escreva o número que corresponde à instalação do Windows XP quando lhe for pedido para seleccionar a instalação do Windows para iniciar sessão no e, em seguida, prima ENTER.
  4. Quando lhe for pedido para a palavra-passe de administrador, escreva a palavra-passe e, em seguida, prima ENTER.

    Nota Se a palavra-passe de administrador estiver em branco, basta premir ENTER.
  5. Na linha de comandos C:\Windows, escreva o seguinte comando e, em seguida, prima ENTER:
    ren c:\windows\system32\drivers\isapnp.sys isapnp.old
    Nota Os passos neste artigo assumem instalado o Windows XP para a unidade C:. A localização real da instalação do Windows pode variar.
  6. Na linha de comandos C:\Windows, escreva o seguinte comando e, em seguida, prima ENTER:
    expandir cd-romdrive: \i386\isapnp.sy_ c:\windows\system32\drivers\isapnp.sys
    Por exemplo, escreva:
    expanda d:\i386\isapnp.sy_ c:\windows\system32\drivers
  7. Depois do ficheiro é expandido com êxito, escreva exit e prima ENTER para sair da consola de recuperação.
  8. Reinicie o computador.

Windows 2000

Para substituir o ficheiro isapnp.sys no Windows 2000, siga estes passos:
  1. Inicie o computador a partir do CD-ROM do Windows 2000.
  2. No ecrã Bem-vindo ao programa de configuração , prima R para reparar e, em seguida, prima C para iniciar a consola de recuperação.
  3. Na linha de comandos C:\Winnt, escreva o seguinte comando e, em seguida, prima ENTER:
    expandir cd-romdriveletter: \i386\isapnp.sy_ c:\winnt\system32\drivers\isapnp.sys
    Por exemplo, escreva:
    expanda d:\i386\isapnp.sy_ c:\winnt\system32\drivers
    Nota Os passos neste artigo partem do princípio que instalou o Windows 2000 para a unidade C:. A localização real da instalação do Windows pode variar.
  4. Depois do ficheiro é expandido com êxito, escreva exit para sair da consola de recuperação.
  5. Reinicie o computador.

Mais Informação

Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
307654  (http://support.microsoft.com/kb/307654/ ) Como instalar e utilizar a consola de recuperação no Windows XP

A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows 2000 Professional Edition
Palavras-chave: 
kbmt kbenv kberrmsg kbprb kbsetup KB315311 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 315311  (http://support.microsoft.com/kb/315311/en-us/ )