文書番号: 315338 - 最終更新日: 2010年3月26日 - リビジョン: 2.1

Windows XP へアップグレード後のエラー メッセージ: 次のファイルが存在しないかまたは壊れているため、Windows を起動できませんでした: Windows\System\Vgaoem.fon

お知らせお使いのオペレーティング システムには適用しない情報が含まれている場合があります。
すべて展開する | すべて折りたたむ

現象

Microsoft Windows 98 ベースのコンピューターを Windows XP へアップグレードした場合、セットアップ完了後のコンピューターの再起動時に、次に類似したエラー メッセージが表示されることがあります。
次のファイルが存在しないかまたは壊れているため、Windows を起動できませんでした:\windows\system\vgaoem.fon

オリジナル セットアップ CD-ROM から Windows セットアップを起動して、このファイルを修復できます。修復するには、最初の画面で R キーを押してください。

原因

この現象は、Vgaoem.fon ファイルが存在しないか、壊れている場合に発生する可能性があります。

解決方法

この問題を解決するには、Windows 回復コンソールを使用して Vgaoem.fon ファイルを Windows XP CD からコンピューターのハード ディスク上の Windows\System フォルダーに抽出します。そのためには、次の手順を実行します。
  1. コンピューターを CD-ROM ドライブまたは DVD-ROM ドライブから起動するように設定します。この方法に関する詳細については、コンピューターのマニュアルを参照するか、コンピューターの製造元に問い合わせてください。
  2. Windows XP CD をコンピューターの CD-ROM または DVD-ROM ドライブに挿入し、コンピューターを再起動します。
  3. "Press any key to boot from CD" ダイアログ ボックスが表示されたら、任意のキーを押してコンピューターを Windows XP CD から起動します。
  4. [セットアップの開始] 画面が表示されたら、R キーを押して回復コンソールを起動します。
  5. デュアル ブートまたはマルチ ブート システムの場合は、インストール済みのオペレーティング システムのうち、回復コンソールからのアクセスが必要なシステムを選択します。
  6. Administrator パスワードを要求されたら、パスワードを入力し、Enter キーを押します。
  7. コマンド プロンプトで「map」と入力し、Enter キーを押します。

    Windows XP CD が挿入されている CD-ROM または DVD-ROM ドライブに割り当てられているドライブ文字を書き留めます。次の形式と同様の形式で表示されます。
    D: \Device\CdRom0
  8. 次の行を入力し、Enter キーを押します (CD-ROM drive は Windows XP の CD が挿入されている CD-ROM または DVD-ROM ドライブのドライブ文字、drive は Windows がインストールされているドライブのドライブ文字です)。
    expand CD-ROM drive:\i386\vgaoem.fo_ drive:\windows\system
    たとえば、次のように入力します。
    expand d:\i386\vgaoem.fo_ c:\windows\system
    "Vgaoem.fo" の "o" の後のアンダースコア文字に注意してください。

    次のメッセージが表示されます。
    Vgaoem.fo_
    1 ファイルを展開しました。
    					
  9. exit」と入力します。

    コンピューターを再起動します。
  10. Windows XP CD をコンピューターの CD-ROM または DVD-ROM ドライブから取り出し、通常の方法でコンピューターを起動します。

詳細

回復コンソールの関連情報を参照するには、以下のサポート技術情報番号をクリックしてください。
229716? (http://support.microsoft.com/kb/229716/JA/ ) Windows 2000 回復コンソールについて
307654? (http://support.microsoft.com/kb/307654/JA/ ) Windows XP での回復コンソールのインストールおよび使用方法
Windows XP セットアップの問題をトラブルシューティングする方法の関連情報を参照するには、以下のサポート技術情報番号をクリックしてください。
310064? (http://support.microsoft.com/kb/310064/JA/ ) Windows 98 または Windows Millennium Edition から Windows XP へアップグレードする場合のインストールの問題をトラブルシューティングする方法
Windows XP セットアップの関連情報を参照するには、以下のサポート技術情報番号をクリックしてください。
306824? (http://support.microsoft.com/kb/306824/JA/ ) Home.txt に含まれる Windows XP セットアップのリリース ノート
286463? (http://support.microsoft.com/kb/286463/JA/ ) Pro.txtファイルに含まれるMicrosoft Windows XPセットアップリリースノート
コンピューターの製造元への問い合わせ方法の詳細については、以下のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/gp/vendors (http://support.microsoft.com/gp/vendors)
他社テクニカル サポートのお問い合わせ窓口は、ユーザーの便宜のために提供されているものであり、将来予告なしに変更されることがあります。マイクロソフトは、掲載されている情報に対して、いかなる責任も負わないものとします。

この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
キーワード:?
kberrmsg kbprb KB315338
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"