Identificativo articolo: 315346 - Ultima modifica: mercoledì 28 marzo 2012 - Revisione: 16.0

Messaggio di errore quando si tenta di aggiungere o rimuovere un programma su un computer in cui è in esecuzione Windows XP o Windows Server 2003: "Impossibile accedere al servizio Windows Installer".

Suggerimento di sistemaIl presente articolo fa riferimento a un sistema operativo diverso da quello in uso. Il contenuto dell'articolo che potrebbe non essere relativo al sistema in uso è disabilitato.
Questo articolo è stato precedentemente pubblicato con il codice di riferimento I315346

Per continuare a ricevere gli aggiornamenti della sicurezza per Windows, assicurarsi che sia in esecuzione Windows XP con Service Pack 3 (SP3). Per ulteriori informazioni, fare riferimento alla pagina Web Microsoft riportata di seguito: Per alcune versioni di Windows il servizio di supporto non è più disponibile (http://windows.microsoft.com/it-it/windows/help/end-support-windows-xp-sp2-windows-vista-without-service-packs?os=xp)

Per assistenza relativa a questo problema su Windows 7 e Windows Vista, consultare il seguente articolo sul sito Web Microsoft:

2642495 (http://support.microsoft.com/kb/2642495/it)  Errore "Il servizio Windows Installer non è accessibile" in Windows 7 e Windows Vista

L'articolo è rivolto esclusivamente a utenti avanzati. Se non si ha familiarità con la risoluzione avanzata dei problemi, è consigliabile richiedere assistenza o contattare il supporto tecnico. Per ulteriori informazioni su come contattare il supporto Microsoft, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ln=it#tab0 (http://support.microsoft.com/contactus/?ln=it#tab0)

In questa pagina

Espandi tutto | Chiudi tutto

Sintomi

Quando si tenta di installare un'applicazione software su Windows XP o Windows Server 2003, è possibile che venga visualizzato il seguente messaggio di errore:
Impossibile accedere al servizio Windows Installer. Ciò può verificarsi se si esegue Windows in modalità provvisoria, o se Windows Installer non è installato correttamente. Contattare il personale di assistenza.
Nota Questo problema può verificarsi anche quando si tenta di disinstallare un'applicazione software.

Cause

Questo problema può verificarsi in presenza di una delle seguenti condizioni:
  • I file di Windows Installer sul disco rigido sono danneggiati o mancanti.
  • Si installa o si rimuove un programma che utilizza il file del pacchetto MSI (Microsoft Software Installation) di Windows Installer. Ad esempio, ciò può verificarsi quando si tenta di installare Microsoft Office.

Risoluzione

Per risolvere questo problema, utilizzare i metodi riportati di seguito.

Metodo 1: Nuova registrazione di Windows Installer

Per ripetere la registrazione di Windows Installer, verificare il percorso del file Msiexec.exe sul disco rigido e nel Registro di sistema di Windows, quindi registrare nuovamente Windows Installer. Per eseguire questa operazione, attenersi alla procedura descritta di seguito.

Nota Data l'esistenza di varie versioni di Microsoft Windows, la procedura potrebbe risultare diversa da computer a computer. In questo caso fare riferimento alla documentazione del prodotto per completare la procedura.
  1. Individuare il percorso del file Msiexec.exe sul disco rigido. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic sul pulsante Start, scegliere Esegui, digitare %windir%\system32, quindi scegliere OK.

      Nota questo passaggio consente di aprire la cartella in cui si trova il file Msiexec.exe.
    2. Prendere nota del percorso del file Msiexec.exe. Il percorso del file Msiexec.exe risulterà dalla combinazione del valore contenuto nella casella di testo Indirizzo e il nome Msiexec.exe del file stesso.

      Ad esempio, se la casella di testo Indirizzo contiene un valore di C:\Windows\system32, il percorso del file Msiexec.exe sarà C:\Windows\system32\Msiexec.exe.
  2. Importante In questa sezione, metodo o attività viene illustrato come modificare il Registro di sistema. L'errata modifica del Registro di sistema può causare seri problemi. Attenersi quindi scrupolosamente alla procedura indicata. Per maggiore protezione, eseguire una copia di backup del Registro di sistema prima di modificarlo. In questo modo sarà possibile effettuarne il ripristino in caso di problemi. Per ulteriori informazioni su come eseguire il backup del Registro di sistema e su come ripristinarlo, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
    322756  (http://support.microsoft.com/kb/322756/it/ ) Esecuzione del backup e del ripristino del Registro di sistema in Windows


    Assicurarsi che il percorso del file Msiexec.exe nell'editor del Registro di sistema sia corretto. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic sul pulsante Start, scegliere Esegui, digitare regedit nella casella di testo Apri, quindi scegliere OK.
    2. Espandere HKEY_LOCAL_MACHINE, espandere SYSTEM, espandere CurrentControlSet, espandere Services, quindi fare clic su MSIServer.
    3. Nel riquadro destro fare clic con il pulsante destro del mouse su ImagePath, quindi scegliere Modifica.
    4. Nella casella di testo Dati valore, digitare il percorso del file Msiexec.exe determinato nel passaggio 1, seguito dal valore di /V, quindi scegliere OK.

      Ad esempio, se il percorso del file Msiexec.exe è C:\Windows\system32\Msiexec.exe, digitare il testo riportato di seguito nella casella di testo Dati valore:
      C:\WINDOWS\System32\msiexec.exe /V
    5. Scegliere OK per chiudere la finestra di dialogo Modifica stringa.
    6. Scegliere Esci dal menu File per chiudere l'editor del Registro di sistema.
  3. Avviare il computer in modalità provvisoria e registrare il file Msiexec.exe. Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic sul pulsante Start, quindi scegliere Spegni computer o Arresta il sistema.
    2. Selezionare l'opzione Riavvia, quindi scegliere OK, oppure fare clic su Riavvia.
    3. Premere F8 prima che venga visualizzata la schermata iniziale di Windows.
    4. Nel menu Opzioni avanzate di Windows utilizzare i tasti di direzione per selezionare Modalità provvisoria, quindi premere INVIO.
    5. Nel caso di computer ad avvio multiplo selezionare il sistema operativo appropriato dall'elenco visualizzato, quindi premere INVIO.
    6. Accedere al computer.
    7. Fare clic sul pulsante Start, scegliere Esegui, digitare msiexec /regserver nella casella Apri, quindi scegliere OK.

      Nota per i sistemi operativi a 64 bit è necessario registrare nuovamente anche il programma di installazione MSI a 64 bit. A tale scopo, fare clic sul pulsante Start, scegliere Esegui, digitare %windir%\Syswow64\Msiexec /regserver nella casella di testo Apri, quindi scegliere OK.

      Nelle edizioni a 64 bit del sistema operativo Windows, i file binari a 32 bit si trovano nella cartella %systemroot%\SysWow64. I file binari a 64 bit si trovano nella cartella %systemroot%\System32.
    8. Fare clic sul pulsante Start, quindi scegliere Spegni computer o Arresta il sistema.
    9. Selezionare l'opzione Riavvia, quindi scegliere OK, oppure fare clic su Riavvia.
Se il problema persiste e se viene ancora visualizzato il messaggio di errore precedentemente descritto nella sezione "Sintomi", seguire la procedura descritta nel metodo 2.

Metodo 2: Reinstallazione di Windows Installer

Per reinstallare Windows Installer, rinominare i file danneggiati di Windows Installer, quindi reinstallare il programma. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Fare clic sul pulsante Start, scegliere Esegui, digitare cmd nella casella di testo Apri, quindi fare clic su OK.
  2. Digitare cd %windir%\system32 e premere INVIO.
  3. Digitare attrib -r -s -h dllcache, quindi premere INVIO.
  4. Digitare ren msi.dll msi.old, quindi premere INVIO.
  5. Digitare ren msiexec.exe msiexec.old, quindi premere INVIO.
  6. Digitare ren msihnd.dll msihnd.old, quindi premere INVIO.
  7. Digitare exit, quindi premere INVIO.
  8. Al prompt dei comandi digitare exit e premere INVIO.
  9. Fare clic sul pulsante Start, quindi scegliere Spegni computer o Arresta il sistema.
  10. Selezionare l'opzione Riavvia, quindi scegliere OK, oppure fare clic su Riavvia.
  11. Accedere al computer.
  12. Scaricare e installare la versione più recente di Windows Installer. Per ulteriori informazioni su come ottenere Windows Installer, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
    893803  (http://support.microsoft.com/kb/893803/it/ ) Disponibilità di Windows Installer 3.1 v2 (3.1.4000.2435)
  13. Fare clic sul pulsante Start, quindi scegliere Spegni computer o Arresta il sistema.
  14. Selezionare l'opzione Riavvia, quindi scegliere OK, oppure fare clic su Riavvia.

Informazioni

Windows Installer 4.0 non è disponibile come pacchetto ridistribuibile per Windows Vista. Windows Installer 4.0 viene fornito con il sistema operativo Windows Vista.

Se i metodi descritti in questo articolo non risolvono il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ulteriore assistenza.

Questo problema si verifica anche se la proprietà Tipo di avvio per il servizio Windows Installer è impostato su un valore di disattivazione. Per verificare se il servizio Windows Installer è impostato su un valore di disattivazione, attenersi alla seguente procedura:
  1. Fare clic sul pulsante Start, scegliere Esegui, digitare services.msc nella casella di testo Apri, quindi scegliere OK.
  2. Nell'elenco Servizi (computer locale), fare clic con il pulsante destro del mouse su Windows Installer, quindi scegliere Proprietà.
  3. Se l'elenco a discesa Tipo di avvio è impostato su un valore di disattivazione, selezionare l'opzione Manuale dall'elenco Tipo di avvio, quindi scegliere OK.
  4. Scegliere Esci dal menu File.
Per ulteriori informazioni su Windows Installer, visitare il seguente sito Web Microsoft Developer Network (MSDN):
http://msdn.microsoft.com/it-it/library/aa370566(VS.85).aspx (http://msdn.microsoft.com/it-it/library/aa370566(VS.85).aspx)
Per ulteriori informazioni su come ottenere il modulo di gestione di Windows Installer, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
292539  (http://support.microsoft.com/kb/292539/it/ ) Come ottenere il modulo di gestione di Windows Installer

Le informazioni in questo articolo si applicano a:
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional x64 Edition
Chiavi: 
kbresolve kberrmsg kbprb KB315346
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.