Код статьи: 315346 - Последнее изменение :: 28 марта 2012 г. - Редакция: 3.0

При попытке установить или удалить программу в системе Windows XP либо Windows Server 2003 появляется сообщение об ошибке "Нет доступа к службе установки Windows"

Совет по использованию системыЭта статья относится к операционной системе, отличной от установленной на вашем компьютере. Содержимое, не относящееся к используемой системе, отключено.

Чтобы продолжить получать обновления для системы безопасности Windows, установите пакет обновления 3 (SP3) для Windows XP. Дополнительные сведения см. на следующем веб-сайте корпорации Майкрософт: Заканчивается поддержка некоторых версий Windows (http://windows.microsoft.com/ru-RU/windows/help/end-support?os=xp)

Сведения о данной проблеме в Windows 7 и Windows Vista см. в следующей статье на веб-сайте корпорации Майкрософт:

2642495 (http://support.microsoft.com/kb/2642495/ru)  Ошибка "Не удалось получить доступ к службе установщика Windows" в Windows 7 и Windows Vista

Эта статья предназначена для опытных пользователей. Если дополнительные способы устранения неполадок слишком сложны, можно обратиться за помощью к специалисту или в службу поддержки. Сведения о том, как связаться со службой технической поддержки, см. на веб-сайте корпорации Майкрософт по следующему адресу:
http://support.microsoft.com/contactus (http://support.microsoft.com/contactus/?ln=ru#tab0)

На этой странице

Развернуть все | Свернуть все

Проблема

При попытке установить программу в системе Windows XP или Windows Server 2003 может появиться следующее сообщение об ошибке:
Нет доступа к службе установки Windows. Возможно, система запущена в безопасном режиме или установщик Windows установлен неправильно. Обратитесь в службу поддержки.
Примечание. Эта проблема может также возникнуть при попытке удалить программу.

Причина

Подобное поведение наблюдается в описанных ниже случаях.
  • Повреждены или отсутствуют файлы установщика Windows на жестком диске.
  • Выполняется установка или удаление программы, использующей файл пакета установщика Windows в формате MSI (Windows Installer Microsoft Software Installation). Это может происходить при попытке установить Microsoft Office.

Решение

Для решения этой проблемы воспользуйтесь описанными ниже способами.

Способ 1. Повторная регистрация установщика Windows

Чтобы зарегистрировать установщик Windows повторно, проверьте расположение файла Msiexec.exe на жестком диске и в реестре Windows, затем зарегистрируйте установщик Windows повторно. Для этого выполните указанные ниже действия.

Примечание. Поскольку существует несколько версий Microsoft Windows, следующие действия могут быть различными на разных компьютерах. В этом случае см. инструкции в документации к продукту.
  1. Определите расположение файла Msiexec.exe на жестком диске. Для этого выполните указанные ниже действия.
    1. Выберите в меню Пуск пункт Выполнить, введите команду %windir%\system32 и нажмите кнопку ОК.

      Примечание. Это приведет к открытию папки, в которой расположен файл Msiexec.exe.
    2. Запомните расположение файла Msiexec.exe. Расположение файла Msiexec.exe определяется сочетанием значения в текстовом поле Адрес и названия файла Msiexec.exe.

      Например, если текстовое поле Адрес содержит значение C:\Windows\system32, то расположение файла Msiexec.exeC:\Windows\system32\Msiexec.exe.
  2. Важно! В данный раздел, описание метода или задачи включены сведения об изменении параметров реестра. Однако их неправильное изменение может привести к возникновению серьезных проблем, поэтому при выполнении этих действий строго соблюдайте инструкции. Чтобы обеспечить дополнительную защиту, создайте резервную копию реестра. В этом случае при возникновении неполадок реестр можно будет восстановить. Дополнительные сведения о создании резервной копии и восстановлении реестра см. в следующей статье базы знаний Майкрософт:
    322756  (http://support.microsoft.com/kb/322756/ru/ ) Создание резервной копии и восстановление реестра Windows XP


    Проверьте правильность расположения файла Msiexec.exe в редакторе реестра. Для этого выполните указанные ниже действия.
    1. Выберите в меню Пуск пункт Выполнить, введите в поле Открыть команду regedit и нажмите кнопку ОК.
    2. Последовательно разверните разделы HKEY_LOCAL_MACHINE, SYSTEM, CurrentControlSet, Services и MSIServer.
    3. Щелкните расположенный справа параметр ImagePath правой кнопкой мыши и выберите пункт Изменить.
    4. В текстовом поле Значение введите расположение файла Msiexec.exe, определенное в первом действии, а после него добавьте значение /V и нажмите кнопку ОК.

      Например, если расположение файла Msiexec.exeC:\Windows\system32\Msiexec.exe, введите в текстовом поле Значение следующий текст:
      C:\WINDOWS\System32\msiexec.exe /V
    5. Нажмите кнопку ОК, чтобы закрыть диалоговое окно Изменение строкового параметра.
    6. Откройте меню Файл и выберите пункт Выход, чтобы закрыть редактор реестра.
  3. Запустите компьютер в безопасном режиме и зарегистрируйте файл Msiexec.exe. Для этого выполните указанные ниже действия.
    1. Откройте меню Пуск и выберите пункт Выключение компьютера или Завершение работы.
    2. Выберите вариант Перезагрузка и нажмите кнопку ОК или Перезагрузка.
    3. Перед открытием экрана-заставки Windows нажмите клавишу F8.
    4. В меню Дополнительные параметры Windows с помощью клавиш со стрелками выберите вариант Безопасный режим и нажмите клавишу ВВОД.
    5. Если на компьютере установлено несколько операционных систем, выберите необходимую операционную систему в выведенном на экран списке и нажмите клавишу ВВОД.
    6. Войдите в систему.
    7. Откройте меню Пуск, выберите пункт Выполнить, в текстовом поле Открыть введите команду msiexec /regserver и нажмите кнопку ОК.

      Примечание. В 64-разрядных операционных системах также необходимо зарегистрировать 64-разрядный установщик MSI. Для этого откройте меню Пуск, выберите пункт Выполнить и введите в текстовом поле Открыть команду %windir%\Syswow64\Msiexec /regserver. Нажмите кнопку ОК.

      В 64-разрядных выпусках системы Windows 32-разрядные двоичные файлы находятся в папке %systemroot%\SysWow64. 64-разрядные двоичные файлы находятся в папке %systemroot%\System32.
    8. Откройте меню Пуск и выберите пункт Выключение компьютера или Завершение работы.
    9. Выберите вариант Перезагрузка и нажмите кнопку ОК или Перезагрузка.
Если проблема не устраняется и продолжают появляться сообщения об ошибках, которые перечислены в разделе "Проблема", выполните действия, описанные в способе 2.

Способ 2. Переустановка установщика Windows

Чтобы переустановить установщик Windows, переименуйте поврежденные файлы установщика и заново установите компонент. Для этого выполните указанные ниже действия.
  1. Откройте меню Пуск, выберите пункт Выполнить, в текстовом поле Открыть введите команду cmd и нажмите кнопку ОК.
  2. Введите команду cd %windir%\system32 и нажмите клавишу ВВОД.
  3. Введите команду attrib -r -s -h dllcache и нажмите клавишу ВВОД.
  4. Введите команду ren msi.dll msi.old и нажмите клавишу ВВОД.
  5. Введите команду ren msiexec.exe msiexec.old и нажмите клавишу ВВОД.
  6. Введите команду ren msihnd.dll msihnd.old и нажмите клавишу ВВОД.
  7. Введите команду exit и нажмите клавишу ВВОД.
  8. В командной строке введите exit и нажмите клавишу ВВОД.
  9. Откройте меню Пуск и выберите пункт Выключение компьютера или Завершение работы.
  10. Выберите вариант Перезагрузка и нажмите кнопку ОК или Перезагрузка.
  11. Войдите в систему.
  12. Загрузите и установите последнюю версию установщика Windows. Дополнительные сведения о получении установщика Windows см. в следующей статье базы знаний Майкрософт:
    893803  (http://support.microsoft.com/kb/893803/ru/ ) Доступен установщик Windows 3.1 версии 2 (3.1.4000.2435)
  13. Откройте меню Пуск и выберите пункт Выключение компьютера или Завершение работы.
  14. Выберите вариант Перезагрузка и нажмите кнопку ОК или Перезагрузка.

Дополнительная информация

Установщик Windows версии 4.0 для Windows Vista свободно не распространяется. Он входит в состав операционной системы Windows Vista.

Если способы, описанные в этой статье, не помогают решить проблему, обратитесь за дополнительной помощью в службу поддержки пользователей корпорации Майкрософт.

Эта проблема может также возникнуть в случае, если для параметра "Тип запуска" установщика Windows выбрано значение "Отключено". Чтобы проверить значение этого параметра, выполните указанные ниже действия.
  1. Откройте меню Пуск, выберите пункт Выполнить, в текстовом поле Открыть введите команду services.msc и нажмите кнопку ОК.
  2. В списке Службы (локальные) щелкните правой кнопкой мыши элемент Windows Installer и выберите пункт Свойства.
  3. Если в раскрывающемся списке Тип запуска выбрано значение Отключено, выберите из этого списка вариант Вручную и нажмите кнопку ОК.
  4. В меню Файл выберите пункт Выход.
Дополнительные сведения об установщике Windows см. на следующем веб-сайте MSDN:
http://msdn.microsoft.com/ru-ru/library/aa370566.aspx (http://msdn.microsoft.com/ru-ru/library/aa370566.aspx)
Дополнительные сведения о получении установщика Windows см. в следующей статье базы знаний Майкрософт:
292539  (http://support.microsoft.com/kb/292539/ru/ ) Получение установщика Windows

Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional x64 Edition
Ключевые слова: 
kbresolve kberrmsg kbprb KB315346