Artigo: 315346 - Última revisão: quarta-feira, 28 de Março de 2012 - Revisão: 2.0

Mensagem de erro quando tenta adicionar ou remover um programa num computador com o Windows XP ou Windows Server 2003: "O serviço Windows Installer não pôde ser acedido"

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Para continuar a receber actualizações de segurança do Windows, certifique-se de que está a utilizar o Windows XP com Service Pack 3 (SP3). Para mais informações, consulte esta página Web da Microsoft: Algumas versões do Windows vão deixar de ter suporte (http://windows.microsoft.com/pt-pt/windows/help/end-support-windows-xp-sp2-windows-vista-without-service-packs?os=xp)

Para suporte sobre este problema no Windows 7 e Windows Vista, consulte o seguinte artigo no Web site da Microsoft:

Erro 2642495 (http://support.microsoft.com/kb/2642495/pt) ?O serviço Windows Installer não pôde ser acedido? no Windows 7 e Windows Vista

Este artigo destina-se a utilizadores avançados. Se não estiver familiarizado com operações avançadas de resolução de problemas, poderá pretender contactar alguém para o ajudar ou contactar o suporte técnico. Para mais informações sobre como contactar o suporte da Microsoft, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ln=pt#tab0 (http://support.microsoft.com/contactus/?ln=pt#tab0)

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Quando tenta instalar uma aplicação de software no Windows XP ou Windows Server 2003, poderá receber a seguinte mensagem de erro:
O serviço Windows Installer não pôde ser acedido. Isto pode acontecer caso esteja a executar o Windows em modo seguro ou se o Windows não está instalado correctamente. Contacte o suporte técnico para obter assistência.
Nota Este problema também poderá ocorrer quando tenta desinstalar uma aplicação de software.

Causa

Este problema pode ocorrer caso se verifique uma das seguintes condições:
  • Os ficheiros do Windows Installer existentes no disco rígido estão danificados ou em falta.
  • Está a instalar ou remover um programa que utiliza um ficheiro de pacote (.msi) de instalação de software da Microsoft (MSI, Microsoft Software Installation) do Windows Installer. Por exemplo, isto pode ocorrer quando tenta instalar o Microsoft Office no computador.

Resolução

Para resolver este problema, utilize os seguintes métodos.

Método 1: Registar novamente o Windows Installer

Para registar novamente o Windows Installer, verifique a localização do ficheiro Msiexec.exe no disco rígido e no registo do Windows e, em seguida, registe-o novamente. Para o fazer, siga estes passos.

Nota: uma vez que existem várias versões do Microsoft Windows, os passos que se seguem poderão ser diferentes no seu computador. Se for esse o caso, consulte a documentação do produto para concluir estes passos.
  1. Determine a localização do ficheiro Msiexec.exe no disco rígido. Para tal, siga estes passos:
    1. Clique em Iniciar, clique Executar, escreva %windir%\system32 e clique em OK.

      Nota Este passo abrirá a pasta onde o ficheiro Msiexec.exe está localizado.
    2. Anote a localização do ficheiro Msiexec.exe. A localização do ficheiro Msiexec.exe será uma combinação do valor na caixa de texto Endereço e o próprio nome do ficheiro Msiexec.exe.

      Por exemplo, se a caixa de texto Endereço possuir um valor do C:\Windows\system32, a localização do ficheiro Msiexec.exe file será C:\Windows\system32\Msiexec.exe.
  2. Importante Esta secção, método ou tarefa contém passos que explicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Assim, certifique-se de que segue estes passos cuidadosamente. Para uma maior segurança, efectue uma cópia de segurança do registo antes de o modificar. Deste modo, pode restaurar o registo se ocorrer um problema. Para mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na Base de Dados de Conhecimento Microsoft:
    322756  (http://support.microsoft.com/kb/322756/pt/ ) Como criar uma cópia de segurança e restaurar o registo no Windows


    Certifique-se de que a localização do ficheiro Msiexec.exe no Editor de registo está correcta. Para tal, siga estes passos:
    1. Clique em Iniciar, clique Executar, escreva regedit na caixa de texto Abrir e, em seguida, clique em OK.
    2. Expanda HKEY_LOCAL_MACHINE, expanda SYSTEM, expanda CurrentControlSet, expanda Serviços e, em seguida, clique em MSIServer.
    3. No painel da direita, clique com o botão direito em ImagePath e, em seguida, clique em Modificar.
    4. Na caixa de texto Dados do valor, escreva a localização do ficheiro Msiexec.exe que determinou no passo 1, seguido pelo valor de /V e, em seguida, clique em OK.

      Por exemplo , se a localização do ficheiro Msiexec.exe for C:\Windows\system32\Msiexec.exe, escreva o seguinte valor na caixa de texto Dados de valor:
      C:\WINDOWS\System32\msiexec.exe /V
    5. Clique em OK para encerrar a caixa de diálogo Edit String.
    6. Clique no menu Ficheiro e, em seguida, clique em Sair para encerrar o Editor de Registo.
  3. Inicie o computador em modo de segurança e registe o ficheiro Msiexec.exe. Para tal, siga estes passos:
    1. Clique em Iniciar e, em seguida, clique em Desligar computador ou Encerrar.
    2. Seleccione a opção Reiniciar e, em seguida, clique em OK, ou clique em Reiniciar.
    3. Pressione F8 antes de surgir o ecrã inicial do Windows.
    4. No menu de Opções Avançadas do Windows, utilize as teclas de seta para seleccionar a opção Modo de segurança e, então prima ENTER.
    5. Se utilizar um computador com arranque duplo ou múltiplo, seleccione o sistema operativo adequado na lista apresentada e prima ENTER.
    6. Inicie a sessão no computador.
    7. Clique em Iniciar, clique em Executar, escreva msiexec /regserver caixa de texto Abrir e, em seguida, clique em OK.

      Nota Para sistemas operativos de 64 bits, necessitará também registar novamente o instalador MSI de 64 bits. Para tal, clique em Iniciar, clique em Executar, escreva %windir%\Syswow64\Msiexec /regserver na caixa de texto Abrir e, em seguida, clique em OK.

      Nas edições de 64 bits do sistema operativo Windows, os binários de 32-bits situam-se na pasta %systemroot%\SysWow64. Os binários de 64 bits situam-se na pasta %systemroot%\System32.
    8. Clique em Iniciar e, em seguida, clique em Desligar computador ou Encerrar.
    9. Seleccione a opção Reiniciar e, em seguida, clique em OK, ou clique em Reiniciar.
Se o problema persistir e continuar a receber a mensagem de erro mencionada na secção "Sintomas", siga os passos no Método 2.

Método 2: Reinstalar o Windows Installer

Para reinstalar o Windows Installer, mude o nome dos ficheiros danificados do Windows Installer e reinstale o Windows Installer. Para tal, siga estes passos:
  1. Clique em Iniciar, clique Executar, escreva cmd na caixa de texto Abrir e, em seguida, clique em OK.
  2. Escreva cd %windir%\system32 e, em seguida, prima ENTER.
  3. Escreva attrib -r -s -h dllcache e, em seguida, prima ENTER.
  4. Escreva ren msi.dll msi.old e, em seguida, prima ENTER.
  5. Escreva ren msiexec.exe msiexec.old e, em seguida, prima ENTER.
  6. Escreva ren msihnd.dll msihnd.old e, em seguida, prima ENTER.
  7. Escreva exit e, em seguida, prima ENTER.
  8. Na linha de comandos, escreva exit e prima ENTER.
  9. Clique em Iniciar e, em seguida, clique em Desligar computador ou Encerrar.
  10. Seleccione a opção Reiniciar e, em seguida, clique em OK, ou clique em Reiniciar.
  11. Inicie a sessão no computador.
  12. Transfira e instale a mais recente versão do Windows Installer Para obter mais informações sobre como obter o Windows Installer, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft:
    893803  (http://support.microsoft.com/kb/893803/pt/ ) O Windows Installer 3.1 v2 (3.1.4000.2435) está disponível
  13. Clique em Iniciar e, em seguida, clique em Desligar computador ou Encerrar.
  14. Seleccione a opção Reiniciar e, em seguida, clique em OK, ou clique em Reiniciar.

Mais Informação

O Windows Installer 4.0 não está disponível como um redistribuível para o Windows Vista. O Windows Installer 4.0 está incluído no sistema operativo Windows Vista.

Se os métodos descritos neste artigo não resolverem o problema que é descrito neste artigo, contacte o Suporte Técnico da Microsoft para mais assistência.

Este problema também ocorrerá se a propriedade de Tipo de arranque para o serviço do Windows Installer estiver definido para um valor de Desactivar. Para verificar se o serviço do Windows Installer se encontra definido para um valor de Desactivar, siga estes passos:
  1. Clique em Iniciar, clique Executar, escreva services.msc na caixa de texto Abrir e, em seguida, clique em OK.
  2. Na lista de Serviços (Local) , clique com o botão direito em Windows Installer e, em seguida, clique em Propriedades.
  3. Se a lista pendente Tipo de arranque estiver definida para um valor de Desactivar, seleccione a opção Manual a partir da lista pendente Tipo de arranque e, em seguida, clique em OK.
  4. Clique no menu Ficheiro e, em seguida, clique em Sair.
Para mais informações sobre o Windows Installer, visite o seguinte Web site da Microsoft Developer Network (MSDN):
http://msdn.microsoft.com/pt-pt/library/aa370566.aspx (http://msdn.microsoft.com/pt-pt/library/aa370566.aspx)
Para obter mais informações sobre como obter o motor Windows Installer, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
292539  (http://support.microsoft.com/kb/292539/pt/ ) Como obter o motor Windows Installer

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Professional x64 Edition
Palavras-chave: 
kbresolve kberrmsg kbprb KB315346